Народ валит на NEON... К чему бы?

Изображение пользователя Priestone.

Всё больше сообщений на форуме и в блогах при разборе очередного глюка/костыля заканчивается "перешел на неон", "а вот в неоне свежие... тему можно закрывать" и т.д. Что это? Отток с kubuntu детектед?

0
Mike - 19 Октябрь, 2016 - 11:59
Изображение пользователя Mike.

нет, это сублимация энергии "поравалить"

+2
MacLeod - 19 Октябрь, 2016 - 13:26
Изображение пользователя MacLeod.

1. К желанию получить более новые версии. Так уж совпало, что в текущий момент обновы несут много фич и багфиксов. Вот и воспринимается как благо.
2. Риддел таки мужик, вывел NEON на достойный уровень. Поэтому кеды оттуда уже легко конкурируют с backports по качеству сборки, а по актуальности версий - выигрывают всухую.

З.Ы. Не стоит забывать, что NEON - это лишь репозиторий со свежими Plasma/Frameworks/Qt/etc для той же кубунты, а Maui - по сути, лишь кубунта с подключенным NEON и еще парой сторонних репов.

0
rcry - 19 Октябрь, 2016 - 14:24
Изображение пользователя rcry.

а дайте пожалуйста скрипт для установки neon - в 16.10

+3
MacLeod - 19 Октябрь, 2016 - 14:37
Изображение пользователя MacLeod.

Не дадим. Ибо:
Will there be a version using non LTS Ubuntu releases?

No, we plan only to base on the latest LTS version of Ubuntu, this comes with Linux and graphics stack updates to keep drivers relevant. We will backport other software as needed.
https://neon.kde.org/faq

Будут версии, использующие не LTS релизы?
Нет, мы планируем базироваться только на последней LTS убунты, она поставляется с Линуксом и обновлениями графического стека для поддержания дров в актуальном состоянии. Мы будем бэкпортировать остальной софт по мере необходимости.

Нет, вы можете, конечно, вкорячить в 16.10 репозиторий от 16.04, но я такого советовать не буду.

0
rcry - 19 Октябрь, 2016 - 14:43
Изображение пользователя rcry.

ясно - спасибо

0
Priestone - 2 Ноябрь, 2016 - 18:38
Изображение пользователя Priestone.

Стыдобищаааа... но
Поставил на свой "тестовый" ноут 16.04.1. Покрутил и... добавил реп neon-а, только после этого стал доволен. Заразно это, что ли?

0
kot040188 - 2 Ноябрь, 2016 - 18:46
Изображение пользователя kot040188.

Блин, таким макаром и я неон поставлю. Отпуск как раз…

+2
Priestone - 3 Ноябрь, 2016 - 06:47
Изображение пользователя Priestone.

Так в том-то и дело, что 16.04 вполне сносно работал на этом ноуте. Потом захотелось поменять винт, ведь SSD хорошо, отлично даже, но маловато (120Gb) - в наличии как раз появился HDD на 250Gb и поставил его, но уже с чистой установкой 16.04.1 и... тут появились странные падения плазмы. Обновление из неона до 5.8.2 (а вчера туда упала уже версия 5.8.3) эти падения полечили и всё стало стабильно. Итог: Neon - это действительно лучшая кубунта. ИМХО, конечно же.

0
Гость - 5 Ноябрь, 2016 - 15:29

И не жирная. Хотя спотыкается на установке загрузчика.

+2
mft - 2 Ноябрь, 2016 - 19:57

Перешел на neon месяц назад, абсолютно все устраивает. Из косяков заметил только кривые зависимости qtcreator, но это не проблема.
Да, Риддел и правда крут.

0
dyug - 4 Ноябрь, 2016 - 10:55

Эмм, дамы и господа, помогите больному, что (какой реп) и как подключать к кубунте то?
ибо я вот тут задумался, и нигде нет нормального описания. Есть что угодно, но нет именно описания, какой реп нужно подключить... :-(
или моя болезнь так влияет, или просто описание заныкали так глубоко, что гугл его найти не может/не хочет....

нет, я конечно нашел вот это, нет, я конечно догадываюсь, как это подключить, но все же..
Где, /женщина легкого повеления/, нормальное описание? шо за ерунда?

0
kot040188 - 4 Ноябрь, 2016 - 11:15
Изображение пользователя kot040188.

Я только это нашёл и это. А вообще присоединяюсь к вопросу.

+1
dyug - 4 Ноябрь, 2016 - 11:21

Я конечно продолжал рыться,и таки удалось найти.... На третьей странице поиска, с рассказами как поставить еклипс, и все что угодно, кроме заданного вопроса.
вот оригинал правильного ответа

но первая ссылка кота тоже правильная. другое дело мне ее найти так и не удалось. :-(

0
kot040188 - 4 Ноябрь, 2016 - 11:30
Изображение пользователя kot040188.

Я просто вспомнил откуда пошло обсуждение неона.

0
dyug - 4 Ноябрь, 2016 - 12:57

Краткое содержание:
пока не пнешь с ноги по самые половые органы - ничего не работает!

Последняя строка - это и есть тот самый пинок по тем самым органам. :-)
вроде помогло, но еще не проверял. :-)

ага, и еще раз два раза sudo apt-get dist-upgrade вперемешку с apt-get install -f
и вроде стоит уже... буду ребутиться... :-)

UPD: после ребута. Гмм, виджеты типа есть но их не видно, теперь у меня их по две (якобы) штуки висит...
А так - визуально - неплохо, панель выхода наконец выглядит по человечески, оставляя за мной право передумать не тыкая лишний раз кнопки выбора...

0
Гость - 4 Ноябрь, 2016 - 16:00

И, результат? А то, тоже чешется. И хочется и колется...

0
dyug - 4 Ноябрь, 2016 - 17:52

UPD: после ребута. Гмм, виджеты типа есть но их не видно, теперь у меня их по две (якобы) штуки висит...
А так - визуально - неплохо, панель выхода наконец выглядит по человечески, оставляя за мной право передумать не тыкая лишний раз кнопки выбора...

Больше как бы проблем или особенностей не обнаружено.

0
kot040188 - 5 Ноябрь, 2016 - 15:23
Изображение пользователя kot040188.

Прелестно. Чистая виртуалка:
kot@kot-VirtualBox:~$ sudo apt-get install neon-desktop
Чтение списков пакетов… Готово
Построение дерева зависимостей      
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
neon-desktop : Зависит: kinfocenter но он не будет установлен
                Зависит: plasma-desktop но он не будет установлен
                Зависит: sddm-theme-breeze но он не будет установлен
                Рекомендует: frameworkintegration но он не будет установлен
                Рекомендует: plasma-widgets-addons но он не будет установлен
                Рекомендует: qt5-default но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

0
dyug - 6 Ноябрь, 2016 - 11:10

она только в чистой виртуалке так...
оно и установленной так..

я лично воспользовался синаптиком, который смог решить сии зависимости, но подозреваю, что apt (не apt-get) install neon-desktop возможно решит эту проблему. Но я не проверял.

0
kot040188 - 6 Ноябрь, 2016 - 14:22
Изображение пользователя kot040188.

kot@kot-VirtualBox:~$ sudo apt install neon-desktop
[sudo] пароль для kot:
Чтение списков пакетов… Готово
Построение дерева зависимостей      
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
neon-desktop : Зависит: kinfocenter но он не будет установлен
                Зависит: plasma-desktop но он не будет установлен
                Зависит: sddm-theme-breeze но он не будет установлен
                Рекомендует: frameworkintegration но он не будет установлен
                Рекомендует: plasma-widgets-addons но он не будет

0
kot040188 - 6 Ноябрь, 2016 - 14:48
Изображение пользователя kot040188.

Синаптик говорит, что справится, но после нажатия кнопки "применить":
Не удалось выполнить изменения!
Сначала необходимо исправить ошибки в пакетах.

Ошибочный пакет neon-desktop. Как его исправить фиг знает.
Объясните мне тупому — как другие обновились без проблем? Как разработчики себе представляют это обновление? Это лыжи не едут или я?

+2
ericSAN - 6 Ноябрь, 2016 - 15:36
Изображение пользователя ericSAN.

Ошибочный пакет neon-desktop. Как его исправить фиг знает.Для начала: Synaptic => Правка => Исправить пакеты "с ошибками".

И попробуйте сделать apt-get install для требуемых пакетов. Если и на них будет ругань, то попробуйте установить неустанавливаемые зависимости. Так в конце концов вы доберетесь до пакета, который вам мешает.

0
kot040188 - 6 Ноябрь, 2016 - 15:38
Изображение пользователя kot040188.

Вы попробуйте сделать apt-get install для требуемых пакетов
Видите ли какя штука, они ведь и так стоят. Обновить их нельзя — ругань. Я пробовал удалить пакет kinfocenter, после чего его уже нельзя было установить. Остальные удалятиь не рискнул.

0
kot040188 - 6 Ноябрь, 2016 - 15:39
Изображение пользователя kot040188.

Для начала: Synaptic => Правка => Исправить пакеты "с ошибками".
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
E: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.
E: Невозможно исправить зависимости
E: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.
E: Невозможно исправить зависимости

0
ericSAN - 6 Ноябрь, 2016 - 15:45
Изображение пользователя ericSAN.

По видимому у вас ералаш в /etc/apt/sources.list

0
kot040188 - 6 Ноябрь, 2016 - 15:48
Изображение пользователя kot040188.

Я ещё раз повторяю для глухослепых!!!!!!!!!!!!!!!!!!!!!!! Чиcтая обновлённая до актуального состояния виртeалка kubuntu 16.04!!!!!!!!!!!!!!!!!!!!!!!! Ну может пару приложений установил из офисточника.

+1
Platon - 6 Ноябрь, 2016 - 17:49
Изображение пользователя Platon.

Чистая обовленная до актуального состояния виртуалка

0
kot040188 - 6 Ноябрь, 2016 - 18:00
Изображение пользователя kot040188.

И что? Так лыжи не едут или я?

0
Platon - 6 Ноябрь, 2016 - 18:27
Изображение пользователя Platon.

у виртуалки ограниченные ресурсы, а проводить обновление да еще из стороннего репа - месье знает толк в извращениях.

0
kot040188 - 6 Ноябрь, 2016 - 18:29
Изображение пользователя kot040188.

у виртуалки ограниченные ресурсы
Как это относится к теме?
а проводить обновление да еще из стороннего репа - месье знает толк в извращениях
А тема разве не об этом?

+3
AlexBKost - 6 Ноябрь, 2016 - 20:44

Нет, не об этом. Если-бы было об этом, заглавие выглядело так Народ валит в ВИРТУАЛКИ....

Если тебе мешает лишний раз перезагрузиться без какой-то другой надобности, то и получаешь то что имеешь.

0
kot040188 - 6 Ноябрь, 2016 - 21:16
Изображение пользователя kot040188.

Чем вам помешала моя виртуалка? Откуда такой нездоровый интерес?

+2
AlexBKost - 6 Ноябрь, 2016 - 22:35

Интереса нет никакого, есть простое непонимание стремления запихнуть в виртуалку чего-ни попади, тем самым ограничивая во всем себя же ...

Сколько систем стоит у тебя в виртуалке, и сколько из них показывают достойные результаты в работе?

0
kot040188 - 6 Ноябрь, 2016 - 22:39
Изображение пользователя kot040188.

Какая работа? В виртуалке я провожу эксперименты. На живых людях машинах я не экспериментирую. Вспоминая наши с вами длиннющие беседы ни о чём, я закачиваю эту беседу.

0
dyug - 6 Ноябрь, 2016 - 22:57

Как я уже писал, у меня на реальной системе была идентичная проблема. Правда, я то ее решил...

+5
MacLeod - 7 Ноябрь, 2016 - 04:25
Изображение пользователя MacLeod.

NEON просто для людей, а не для котов =)

+5
MacLeod - 7 Ноябрь, 2016 - 08:32
Изображение пользователя MacLeod.

Во-первых, надоел котосрач, но Кот ведь все равно не угомонится; во-вторых, наверняка тут есть те, кто сидит на 16.04.1 LTS без подключенного репозитория backports, но хочет себе свежую неглючную плазму; в-третьих, наверняка тут есть те, кто не знает третьего (простите за тавтологию) закона логики - закона исключенного третьего и не умеет решать конфликты зависимостей с помощью apt.

Я использовал чистую обновленную виртуалку с 16.04.1 LTS, к которой цеплялся по ssh (это не принципиально).

Итак, мы видим:
neon-desktop : Depends: kinfocenter but it is not going to be installed
                Depends: plasma-desktop but it is not going to be installed
                Depends: sddm-theme-breeze but it is not going to be installed
                Recommends: frameworkintegration but it is not going to be installed
                Recommends: plasma-widgets-addons but it is not going to be installed
                Recommends: qt5-default but it is not going to be installed

Пакет neon-desktop зависит от ряда пакетов, которые не могут быть установлены. Разумное существо видит конкретику - какие именно пакеты "не могут быть установлены". И наверняка захочет узнать подробности почему.

Берем первый из них и пробуем установить:
user@comp:~$ sudo apt-get install kinfocenter
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kinfocenter : Depends: plasma-workspace but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Опаньки, мы выяснили следующую проблемную зависимость, которая еще и совпадает с самим neon-desktop, пробуем ставить ее:

Так, ну и что же мешает пакету установиться теперь?

Пробуем ставить libtaskmanager6:

Классно, libtaskmanager6 ломает libtaskmanager5, старый и ненужный. Пусть ломает. Решение написано белым по черному (или у кого как).

Но наблюдаем конфликт файлов в пакетах. Сносим его к чертям собачьим, он древний как говно мамонта (версия 5.18). В ручном режиме, принудительно:

И пробуем снова починить зависимости:

Обратите внимание, apt сам предложил установить новую версию qml-module-org-kde-activities в автоматическом режиме, зависимости будут девственно верными. К тому же, случилось чудо - plasma-desktop тоже сконфигурилась.

Ставим neon-desktop:

Далее делаем apt-get dist-upgrade, чтобы обновить все остальные пакеты, для которых есть обновы в репе неона. Спотыкается на обработке триггеров systemd kpmcore:
Errors were encountered while processing:
/var/cache/apt/archives/kpmcore_2.2.1-0+16.04+build4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Аналогично, первое что делаем - пытаемся поставить отдельно через apt-get install kpmcore, устанавливается, оставшиеся пакеты конфигурятся, все.
У кого остались опасения, что в триггере kpmcore было что-то значимое, могут сделать:
sudo dpkg-reconfigure kpmcore
Перезагружаемся, радуемся плазме 5.8.3.

P.S. Все вышеописанное не является просто решением, я пытался показать, как решать конфликты.
P.P.S. В реальности нет никакой необходимости подключать реп неона к чистой кубунте, такое только коту в голову могло придти. Проще тогда поставить систему из образа неона. Подобное здраво проделывать если система уже установленная и настроенная.

0
dyug - 7 Ноябрь, 2016 - 11:49

Ты:
Но наблюдаем конфликт файлов в пакетах. Сносим его к чертям собачьим, он древний как говно мамонта (версия 5.18). В ручном режиме, принудительно:
dpkg -P --force-all qml-module-org-kde-activities
Я:
пока не пнешь с ноги по самые половые органы - ничего не работает!
dpkg -i --force-all /var/cache/apt/archives/plasma-desktop_4%3a5.8.3-0neon+16.04+build41_amd64.deb

Почему я использую именно инсталл:
Был у меня случай, когда удаление виновника уронило систему полностью.
а принудительный апгрейд пакета обычно не вызывает желание пакажде менеджера вынести все по обратным зависимостям...

+2
MacLeod - 7 Ноябрь, 2016 - 14:07
Изображение пользователя MacLeod.

Пинки лучше раздавать котам, а не любимой системе =)

Почему я использую именно инсталл
Форсированный инсталл ставит флаг "вручную установленный", а точнее - снимает "автоматически установленный", что ломает первоначальную схему. Удаление старой зависимости - так не делает, о чем я писал выше в комментарии. Ломать или не ломать - личное дело каждого. Я предпочитаю не ломать.

случай, когда удаление виновника уронило систему полностью
Почему я всегда читаю выхлоп apt (случаев, чтобы он грохнул что-то втихаря - не припомню) и пристально слежу за тем, что новые версии будут восстановлены.

желание пакажде менеджера вынести все по обратным зависимостям
Покажете, где тут такое? =)

Повторюсь, выхлоп dpkg я считаю достовернее невероятных приключений, даже пользователя линукса с 98 года =)

0
dyug - 7 Ноябрь, 2016 - 14:31

эмм, я говорил о том, что произошло именно после dpkg, а не apt, или apt-get
вынос пакета, особенно критичного типа libc легко приведет к неработоспособности всей системы, при этом принудительный инсталл сохранит (с заменой конфликтующих файлов) работоспособность.

0
MacLeod - 7 Ноябрь, 2016 - 17:02
Изображение пользователя MacLeod.

В теории - да. Но я бы очень не рекомендовал форсить что-то критичное вообще. Если хелды полезли на уровне libc - это очень хреновый признак.

0
ericSAN - 7 Ноябрь, 2016 - 12:16
Изображение пользователя ericSAN.

Проще тогда поставить систему из образа неонаПлюс очень много!

0
MacLeod - 7 Ноябрь, 2016 - 13:59
Изображение пользователя MacLeod.

Много чего?

0
ericSAN - 7 Ноябрь, 2016 - 17:50
Изображение пользователя ericSAN.

плюсов

0
kot040188 - 7 Ноябрь, 2016 - 14:56
Изображение пользователя kot040188.

Обратите внимание, apt сам предложил установить новую версию qml-module-org-kde-activities
Не сам, а после пинка под жопу. Нахрена он тогда нужен, этот apt, если всё приходится делать лапами? Отдельное спасибо разработчикам неона за этот квест.

0
akal - 7 Ноябрь, 2016 - 15:13
Изображение пользователя akal.

Они на котах не тренировались за неимением оных. Это только у нас один такой есть =)

0
kot040188 - 7 Ноябрь, 2016 - 15:15
Изображение пользователя kot040188.

Тренироваться надо на кошках, а не котах.

0
MacLeod - 7 Ноябрь, 2016 - 18:11
Изображение пользователя MacLeod.

Бестолковый ты комок шерсти. У кубунты нет другого способа обновлений KDE, кроме как:
1) текущие релизы;
2) backports;
3) сборка из исходников.
Первые два способа очень сильно рассинхронизированы с графиком выпуска и анонсами на kde.org.
Третий ты не осилишь по причине низкой тактовой частоты ЦПУ.

И тут появляется халява - бинарные сборки, полностью совместимые с текущим LTS убунты, при подключении которого нужно решить один-два конфликта. Но ты продолжаешь ныть. При новой возможности и поддержке данного сообщества. Нытик.

На причастных к NEON гнать не надо:
Can I turn Kubuntu into KDE neon with a PPA?
We recommend that you install a fresh KDE neon from the provided ISO images. But you can indeed add an APT repository to switch from Kubuntu to KDE neon. This is absolutely not tested or supported. If things take a turn for the worse you are expected to be knowledgable enough to repair your system on your own. A web search should quickly give you relevant information on how to do this.

https://neon.kde.org/faq.php#morph-kubuntu
Я могу подключить Кубунту к KDE neon с помощью PPA?
Мы рекомендуем делать свежую установку KDE neon из представляемых ISO образов. Но вы также можете добавить APT репозиторий чтобы переключить Kubuntu на Neon. Это совершенно не проверено и не поддерживается. Если эти штуки приведут к чему-то плохому, вы должны быть достаточно квалифицированы чтобы восстановить восстановить систему по вашему усмотрению. Гугление должно помочь.

Иными словами или пользуйся или не ной. Даже судя по этому форуму - все кто хотел уже получили свежие кеды и довольны.

0
kot040188 - 7 Ноябрь, 2016 - 18:11
Изображение пользователя kot040188.

Я не ною. Я пытаюсь разобраться. Всем спасибо, беседа ктосрач на эту тему закончена.

0
kot040188 - 7 Ноябрь, 2016 - 15:12
Изображение пользователя kot040188.

В реальности нет никакой необходимости подключать реп неона к чистой кубунте, такое только коту в голову могло придти
У тебя склероз? Да и в этой теме я не первый.
Проще тогда поставить систему из образа неон
В Maui мне не понравился набор приложений по умолчанию. Слишком много вычищать. А как с этим в неона? Как по умолчанию в kubuntu?
Подобное здраво проделывать если система уже установленная и настроенная.
У меня так и есть. Но я сначала тренируюсь на кошках виртуалке.

+2
leisampei - 7 Ноябрь, 2016 - 15:34
Изображение пользователя leisampei.

А как с этим в неона?
Всё по минимуму, почти голая плазма.

0
kot040188 - 7 Ноябрь, 2016 - 17:35
Изображение пользователя kot040188.

Вот блин… Ну тогда тема котосрач по поводу обновления закрыт.
Интересно чем отличается neon-useredition-20161103-1018-amd64.iso от neon-useredition-current.iso?
В этом неоне вообще всё выпилено под корень. Amarok, ktorrent, ocular…

0
ericSAN - 7 Ноябрь, 2016 - 18:23
Изображение пользователя ericSAN.

выпилено под корень. AmarokВот чему чему, а ему дорога в топку (imho)

0
kot040188 - 7 Ноябрь, 2016 - 18:23
Изображение пользователя kot040188.

Это скайпу туда дорога.

0
ericSAN - 7 Ноябрь, 2016 - 17:49
Изображение пользователя ericSAN.

В Maui мне не понравился набор приложений по умолчанию. Слишком много вычищать. А как с этим в неона? Как по умолчанию в kubuntu?Говорите так, словно "вычищать" нужно каждый день. Это же только раз: установил, настроил и пользуйся на здоровье. ;-)

0
kot040188 - 7 Ноябрь, 2016 - 17:58
Изображение пользователя kot040188.

Ну ладно там СПО, но зачем они туда скайп вкорячили я не понимаю…

0
ericSAN - 7 Ноябрь, 2016 - 18:21
Изображение пользователя ericSAN.

Ну ладно там СПО, но зачем они туда скайп вкорячили я не понимаю…Ну, кому как, а мне он таки очень нужен. Как бы то ни было, но на скайпе многое завязано: друзья, работа...

0
kot040188 - 7 Ноябрь, 2016 - 18:22
Изображение пользователя kot040188.

Я считаю, проприетарщину можно и нужно ставить отдельно.

0
dyug - 8 Ноябрь, 2016 - 00:00

Кот, если тебе скайп не нужен, то это не значит, что он никому не нужен.

0
kot040188 - 8 Ноябрь, 2016 - 01:13
Изображение пользователя kot040188.

Может я извращенец, но я люблю, когда мухи отдельно, котлеты отдельно. Те кому нужен скайп, всегда могут его установить. На опеннет в новости про ring пишут, что переводят на него целые конторы (я понимаю, что может и брешут). И на этом же опеннет, мне не верят, когда я говорю, что за каждое упоминание альтернатив скайпу я получаю тапкам по морде… Жизнь линуксоида тяжела. Завтра надо рано встать, буду неона вкорячивать. Дабы не засорять тему, отвечать в этой ветке не буду.

0
MacLeod - 7 Ноябрь, 2016 - 18:13
Изображение пользователя MacLeod.

У тебя склероз? Да и в этой теме я не первый.
У меня нет. Тебе диагнозы ставить не буду. Но отличить
а) подключение неона к установленной и настроенной кубунте
и
б) подключение неона к чистой установке кубунты
ты явно не можешь.

0
kot040188 - 7 Ноябрь, 2016 - 18:25
Изображение пользователя kot040188.

Я смотрю в неоне плимут отключён. Как его включить?

0
ericSAN - 7 Ноябрь, 2016 - 18:38
Изображение пользователя ericSAN.

systemctl start plymouth-start.service
systemctl enable plymouth-start.service
systemctl start plymouth-quit.service
systemctl enable plymouth-quit.service
А вообще сначала нужно глянуть статус данного юнита.

0
kot040188 - 9 Ноябрь, 2016 - 01:16
Изображение пользователя kot040188.

Установил этот неон — шикарно. Графически красивее. Решилось множество проблем с панелями, xneur. Тиринга пока нет. В лисе почему-то опять поменялись роли ЛКМ и СКМ в панели прокрутки, как это связано с неоном понятия не имею. В хранилище виджетов выпилили категории. в параметрах системы нет установщика драйверов. Но не обошлось без ложки дёгтя. У некоторых виджетов слетели настройки и они сбились в кучу, но это мелочи. Не смог установить kphotoalbum calibre qtcurve, проблемы с зависимостями. Не могу открыть редактор источников из muon, пишет "Не удалось выполнить команду « '' --attach 98566149 --dont-update».", в дискавери вообще не нашёл как его окрыть (тут где-то проскакивало про это). Некоторые значки на панелях и в приложениях стали выглядеть хуже (как-будто растянуты). Виджет active window control не хочет работать. Виджеты "комнаты" и "обновления" потеряли иконки. Ksuperkey ведёт себя не совсем адекватно. Вроде ничего не забыл.

0
kot040188 - 9 Ноябрь, 2016 - 01:17
Изображение пользователя kot040188.

qtcurve не устанавливается из-за этого этого. Как быть?

+1
leisampei - 9 Ноябрь, 2016 - 08:37
Изображение пользователя leisampei.


Не могу открыть редактор источников........проскакивало про это

active window control не хочет работать
У меня работает, но можешь скачать и распаковать в ~/.local/share/plasma/plasmoids/org.kde.activeWindowControl/

нет установщика драйверов
sudo apt install kubuntu-driver-manager
только надо ли?..
В хранилище виджетов выпилили категории

если я правильно понял:
0
kot040188 - 9 Ноябрь, 2016 - 16:28
Изображение пользователя kot040188.

проскакивало про это
Спасибо. Сегодня в дискавери догадался нажать на ppa и увидел значок удаления. Так себе интерфейс.
У меня работает, но можешь скачать и распаковать в ~/.local/share/plasma/plasmoids/org.kde.activeWindowControl/
Про это читал. Версии одинаковые.Попробую… Ха, вчера там была версия 1.5.9, сегодня 1.6.0!
только надо ли?..
Просто наблюдение…
если я правильно понял:
А у меня там нет значка! Пустое место!

0
dyug - 9 Ноябрь, 2016 - 10:52

Дамы и господа!
А скажите, у кого то конки есть, и нормально запускается?
ибо у меня почему-то не хочет стартовать при загрузке.

0
ericSAN - 9 Ноябрь, 2016 - 13:06
Изображение пользователя ericSAN.

У меня стало все в норме . Но, к слову сказать, после обновления были подобные проблемы,хотя до обновления ничего подобного не было: conky програмно был в автозагрузке и много-много времени знать не знал об этой проблеме пока не обновился до последней версии кед. Пусть костыльно но решил траблу так:
Первоначально у меня в настройках кед стояло дефолтное "начинать с нового сеанса"(прошу прощения я пишу по памяти с чужого компа до своего доберусь вечером), я переключил на "начинать с предыдущего" и таким образом решил траблу. Понимаю - это пока похоже на подпорку, но работает.

Не знаю пока откуда в этом деле растут ноги, ведь до обновления все работало.

PS: у меня Maui 2 и последнияя версия кед.

0
dyug - 9 Ноябрь, 2016 - 13:43

ага мысль понятна. И картина похожа. Сломали что то?

0
ericSAN - 9 Ноябрь, 2016 - 14:09
Изображение пользователя ericSAN.

Ничего не ломал, просто обновился. apt-get не ругался обновление прошло гладко, но после появилась проблема с коньками (кроме коньков еще в автозагрузке кайро док, но с ним проблем не было подозреваю, что дело в conky-manager'e, но не проверял, не до того решил траблу и ладно ): пару дней не мог включится, что же произошло, но потом сделал как описал выше и ок.

0
dyug - 16 Ноябрь, 2016 - 08:58

В данном случае "Сломали что то?" относится не к вам, а к сборщикам кде. :-)
ибо у меня тоже конки пока еще стартует только ручками..
в автостарте оно не работает.
И я тоже ничего не ломал. :-)

Upd:
После обновления/пересборки конки стартанул нормально из автозагрузки кде

0
kot040188 - 9 Ноябрь, 2016 - 14:36
Изображение пользователя kot040188.

Ещё один минус: Плазма стала запускаться ещё дольше. Уже вся автозагрузка запустилась, а плазмы всё нет.

0
kot040188 - 9 Ноябрь, 2016 - 20:53
Изображение пользователя kot040188.

Thunderbird не хочет запускаться при запуске системы. Удалил из автозапуска, добавил заново — ничего.

0
Pependos - 10 Ноябрь, 2016 - 11:12

У меня на MAUI такое поведение у Thunderbird со времени обновления плазмы до 5.8.0. В дополнение к этому, криво стартует Qbittorrent (с ошибкой), а в Krusader постоянно открывается пустая вкладка с несуществующим адресом. Все это при автостарте, естественно.

0
kot040188 - 10 Ноябрь, 2016 - 21:16
Изображение пользователя kot040188.

Нет, Qbittorrent стартует нормально. А ещё Thunderbird на английском, при этом все пакеты русификации стоят.

0
AlexBKost - 10 Ноябрь, 2016 - 22:25

Проверь Параметры системы => Локализация => Форматы => Регион. Уже сталкивался с таким - при левом регионе некоторые приложения могут не русифицироваться при общей русификации системы.

0
kot040188 - 10 Ноябрь, 2016 - 23:19
Изображение пользователя kot040188.

Как и всегда, Россия.

0
leisampei - 11 Ноябрь, 2016 - 05:54
Изображение пользователя leisampei.

Стоят ли language-pack-gnome-ru, language-pack-kde-ru, kde-l10n-ru?

0
kot040188 - 11 Ноябрь, 2016 - 14:30
Изображение пользователя kot040188.

при этом все пакеты русификации стоят.

+1
DarkneSS - 11 Ноябрь, 2016 - 06:18
Изображение пользователя DarkneSS.

thunderbird-locale-ru?

0
kot040188 - 11 Ноябрь, 2016 - 14:33
Изображение пользователя kot040188.

Заколебаешься так по частям устанавливать… Повыпиливали всё подряд, что надо и что не надо…

0
DarkneSS - 12 Ноябрь, 2016 - 21:26
Изображение пользователя DarkneSS.

Не понял, кто что выпилил. Пакет как минимум с 12.04 существует.

0
kot040188 - 13 Ноябрь, 2016 - 00:10
Изображение пользователя kot040188.

Корреспондент существует и kubuntu при установке тундраптицы сам подтягивается. А в неона нет. Как всегда, лыжи не едут…

0
Richard - 13 Ноябрь, 2016 - 11:05

NEON - предлагает практически чистую Plasma
Слишком много выпилили
Maui предлагает NEON + набор предустановленных программ
Слишком много выпиливать после установки.
Тебе не угодишь...

0
kot040188 - 13 Ноябрь, 2016 - 14:06
Изображение пользователя kot040188.

Котам трудно угодить…

0
Гость - 25 Ноябрь, 2016 - 08:37

почесать за ушками, кстати...

0
dyug - 11 Ноябрь, 2016 - 16:26

стоит и не показывает, и уже и переставлял, на новом пользователе русский есть.
но перетаскивать все, что лежит очень сложно.

0
DarkneSS - 12 Ноябрь, 2016 - 21:28
Изображение пользователя DarkneSS.

Интересно. А если принудительно с LANG=ru_RU.UTF-8 запустить? Если поможет, что в локалях пользователя поломано.

0
dyug - 13 Ноябрь, 2016 - 10:13

Я как бы написал А понял. На новом пользователе тундербирда. а не новом пользователе системы. :-)
то есть локаль не причем. именно глюки профиля.

0
dyug - 11 Ноябрь, 2016 - 16:25

У меня тундра тоже не любит русскую локализацию...

0
Slavyanin - 11 Ноябрь, 2016 - 07:10

Вкорячил, по выражению уважаемого kot040188 , KDE neon. У меня не было проблем, указанных выше

Пришлось один раз запустить dpkg, не устанавливался какой то пакет, типа ...sane, с зависимостями разобрались -f install, dist-upgrade, и аптитуд.
Визуально ничего нового не увидел, в отличии от kot040188 . Здесь я, пожалуй соглашусь с eugenez из форума Ubuntu.Ru.
Проблемы - конечно есть, но я понимаю, что сказал выше уважаемый MacLeod .
Не мог осилить часы. пришлось ставить старую версию tzdata. При выборе UTC + , рядом с цифрами показывает этот самый UTC +. Но мне то он зачем? Но, главная проблема, которую пока я увидел - в дельфине, при открытии корневой папки система тут же виснет. Причем наглухо. Может уважаемый MacLeod что то подскажет по этому поводу. А так придется ждать обновлений.
+1
MacLeod - 25 Ноябрь, 2016 - 00:45
Изображение пользователя MacLeod.

Если у вас обновление прошло не как у большинства или на только установленной системе, в части зависимостей - есть небольшая вероятность, что последние уже были поломаны до этого (последствия обновления с другой версии дистрибутива, неудачных ручных разрешений конфликтов и т.д.).
Про зависание... Как обычно, всегда есть набор вариантов причин, по которым это происходит. От поломанных зависимостей до проблем с железом. Чтобы найти причину, нужно последовательно их исключить. Загрузиться с live neon c той же версией, попробовать проделать обновление на другой машине/виртуалке, проверить диски...

-2
kot040188 - 12 Ноябрь, 2016 - 03:29
Изображение пользователя kot040188.

То, что у виджета обновления нет значка, тундраптица (а заодно qtox) не стартует с системой и я не могу установить qtcurve (и ещё пару приложений), уже начинает бесить!

0
werkty - 12 Ноябрь, 2016 - 08:49

Ну так установите себе ламповую кубунту 16.04, накатите на нее плазму из бэкпортов и радуйтесь тому, что все работает и ничего не нужно допиливать. Ну... почти все работает и почти ничего не нужно допиливать :)

0
kot040188 - 12 Ноябрь, 2016 - 14:48
Изображение пользователя kot040188.

А разве из бэкпортов будет такая же свежая?

0
werkty - 12 Ноябрь, 2016 - 16:33

Конечно нет :) Однако у себя, с плазмой из бэкпортов, я не наблюдаю ваших проблем. Я, честно сказать, тут вообще не наблюдаю никаких проблем, кроме общеизвестных. Самое то для LTS.

0
kot040188 - 12 Ноябрь, 2016 - 16:49
Изображение пользователя kot040188.

То-то и оно. У меня решилось много проблем со свежими кедами. Будет ли также с бэкпортами…

0
rlepish - 13 Ноябрь, 2016 - 00:16

Где скачать iso образ Neon'a?
На https://neon.kde.org/download ссылка не кликается, на http://files.kde.org/neon/images/ - пусто

0
kot040188 - 13 Ноябрь, 2016 - 00:17
Изображение пользователя kot040188.

Народ пишет, что у них там уже несколько дней перебои.

0
leisampei - 13 Ноябрь, 2016 - 12:58
Изображение пользователя leisampei.

Там не перебои, там исчезли все iso-образы. :)

0
kot040188 - 13 Ноябрь, 2016 - 14:08
Изображение пользователя kot040188.

Перебои с поставками iso…

0
Гость - 13 Ноябрь, 2016 - 12:49

Написано же - "приходите завтра" :)

0
Priestone - 14 Ноябрь, 2016 - 09:48
Изображение пользователя Priestone.

Да ладно. Круто же. Шестую плазму готовят, как скомпилят - выложат.

0
kot040188 - 14 Ноябрь, 2016 - 16:03
0
kot040188 - 19 Ноябрь, 2016 - 23:08
Изображение пользователя kot040188.

kot@kot-MS-7930:~$ kdesudo software-properties-kde
sudo: software-properties-kde: команда не найдена

Обновили, блин. Теперь через графику совсем никак ppa не удалить?

0
Гость - 20 Ноябрь, 2016 - 10:57

Теперь через графику совсем никак ppa не удалить?

Да через именно эту "графику"... Быстрее и проще через консоль - вот умеют же такого добиваться :).

0
kot040188 - 20 Ноябрь, 2016 - 12:45
Изображение пользователя kot040188.

А сервер поменять через консоль как? Да много чего можно было через графику в один клик сделать.

0
guide - 20 Ноябрь, 2016 - 23:59
Изображение пользователя guide.

Установлена О.С. Neon пробывал установить software-properties-kde не установилась требует установки двух пакетов.Установил software-properties-gtk все то-же самое плюс графа "Дополнительные драйвера".После обновления все работает нормально и синаптик и консоль и графика.

0
kot040188 - 21 Ноябрь, 2016 - 00:42
Изображение пользователя kot040188.

пробывал
Потому и не получилось ヅ Но вы меня натолкнули на мысль: оказывается он у меня не установлен! Установил, он тянет qapt-batch. Вот тебе и информативная консолька…

+1
Richard - 20 Ноябрь, 2016 - 13:47

Synaptic спасет кота.

+2
ericSAN - 20 Ноябрь, 2016 - 16:34
Изображение пользователя ericSAN.


Обновили, блин.
Вот пример того, когда консоль удобнее, чем графика. Выложить вывод консоли проще, чем тот же самый скриншот. не говорю уже о том, чтбы через мобилу лезть на разные хостинги для просмотра выложенного, чем просто посмотреть вывод бла бла бла/

0
mister.eric - 25 Ноябрь, 2016 - 07:22

Зато самое свежее: кушайте, не обляпайтесь.

+2
ericSAN - 20 Ноябрь, 2016 - 15:31
Изображение пользователя ericSAN.

а много чего можно было через графику в один клик сделать.Было бы просто супер, если бы все можно было делать в один клик в иксах. Реальность же такова, что приходится варьировать между иксами и терминалом.
Synaptic спасетНе всегда, но бывают обстоятельства, когда гуевые приложения - зло, особенно, когда обновляются драйвера графики: в терминале сразу придет ругань, еще на этапе скачивания пакетов в кэш, чего не скажешь о гуёвинах, которые "предупреждают" только после ребута не загражая иксы (был опыт на карточках нвидиа или ати).

+1
Richard - 21 Ноябрь, 2016 - 09:28

тогда, действительно, лучше так: sudo apt-get update  && sudo apt-get dist-upgrade && sudo apt-get install -f  && sudo apt-get autoremove && sudo apt-get autoclean

0
Гость - 23 Ноябрь, 2016 - 17:00

Remove VLC:

0
ericSAN - 24 Ноябрь, 2016 - 05:15
Изображение пользователя ericSAN.

Уууууууууу, главное не нужно ничего читать, а закрыть глаза и ... не удаляя vlc посмотреть, почему удаление плеера сносит пол системы.
Это первый вариант. Второй: удалить все и потом кричать ,что кубунту кривое поделие и да здравствует виндовс и прочая дребедень.

0
Гость - 24 Ноябрь, 2016 - 21:16

С чего бы это смотреть причины выноса системы из-за удаления проигрывателя песенок и кин, имеющего возможность делиться данными по сети. Проще Kubuntu поставить. Windows позволяет для WMP снять галочку присутствия в системе :).

0
ericSAN - 24 Ноябрь, 2016 - 05:20
Изображение пользователя ericSAN.

Каким языком еще говорить народу, что неон для 16.04?

0
kot040188 - 24 Ноябрь, 2016 - 05:43
Изображение пользователя kot040188.

А что, кто-то хочет накатить поверх, как пытался я в виртуалке????

0
ericSAN - 24 Ноябрь, 2016 - 05:47
Изображение пользователя ericSAN.

Плюс вам, милый пушистый.

0
kot040188 - 24 Ноябрь, 2016 - 05:51
Изображение пользователя kot040188.

Нифига не понял, но приятные слова…

0
ericSAN - 24 Ноябрь, 2016 - 09:10
Изображение пользователя ericSAN.

Нифига не понял, но приятные слова…Не поняли суть листинга или того,шо неон для 16.04?

0
kot040188 - 24 Ноябрь, 2016 - 14:22
Изображение пользователя kot040188.

Не понял внезапной лести…

0
Гость - 25 Ноябрь, 2016 - 07:57

просто захотелось почесать котенка за ушами... :-)

0
ericSAN - 24 Ноябрь, 2016 - 06:10
Изображение пользователя ericSAN.

Вопрос просто про то, что описано в топике с больше чем сто комментов. Кстати, выделил бы из них такой:
http://kubuntu.ru/node/13998#comment-170201
http://kubuntu.ru/node/13998#comment-170203
http://kubuntu.ru/node/13998#comment-170208
http://kubuntu.ru/node/13998#comment-170222
Я пока не понял квалификацию пользователя форума MacLeod (на мой взгляд он съел собаку на линукс, говорю это не для жополиза), но к его словам стоит прислушаться, он знает что говорит. Это видно из его сообщений относительно четких решений проблем, не говорю уже о том, что он знает команды, вместо того, чтобы слать скришоты или говорить слишком поверхностно не понимая сути.

ЗЫ.Да, сейчас линукс стал дружелюбнее к юзеру, но, так или иначе, видно пользователей, которые могут помочь и тех, кто просто "кармирует".

+3
MacLeod - 25 Ноябрь, 2016 - 01:31
Изображение пользователя MacLeod.

Эти комментарии, на самом деле, общесистемные и не имеют отношения непосредственно к KDE или самому NEON'у, это лишь частные случаи. Я всегда говорил, что хорошее понимание инструмента под названием пакетный менеджер будет полезным любому юзеру.

пока не понял квалификацию пользователя форума MacLeod
Уровень техлида/техдиректора конкурентоспособной на рынке IT компании, ничего необычного =)
Мне приходится есть собак по пяти операционкам в плане нюансов разработки софта. Что до линукса - у меня это основное средство для содержания высоконагруженных серверов (на проект бывает 20-40 стоечных юнитов на топологию СУБД, 5-10 на бэкенд). Ответственные части серверного кода пишу сам или жестко контролирую, настройки кластеров делаю или за админами издателя проверяю тоже часто лично. На пике популярности проекта простой в течение часа может вылиться в шестизначные убытки.

0
Гость - 25 Ноябрь, 2016 - 08:40

Снимаю шляпу. О сенсей.

0
MacLeod - 26 Ноябрь, 2016 - 10:25
Изображение пользователя MacLeod.

О сенсей.
Не претендую ни разу =)

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры