Аппаратное декодирование видео на картах ATI

Изображение пользователя beginer.

Всем привет!
Собственно проблема такая. Попробовал настроить аппаратное декодирование видео на ATI HD 3650 (драйвер 10.06) используя мануал и ничего не получилось. Вот такой вывод в консоль:

И при запуске фильма:

Поиск на форумах результата не дал. Встретилась только предположение, что это в следствии старой библиотеки xvba-video (хотя была взята последняя версия с сайта). Кто нибудь сталкивался с такой проблемой?
0
skew - 28 Июнь, 2010 - 12:27
Изображение пользователя skew.

У меня всё работает на 10.5, на 10.6 не пашет ускорение :(

0
beginer - 28 Июнь, 2010 - 15:18
Изображение пользователя beginer.

А версии библиотек (libva, xvba-video) какие? Что выдает vainfo?
Просто, если судить по постам, у людей работает на 10.6. Хотелось бы разобраться.

0
skew - 29 Июнь, 2010 - 08:34
Изображение пользователя skew.

vainfo
libva: libva version 0.31.0-sds6
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/va/drivers/fglrx_drv_video.so
libva: va_openDriver() returns 0
vainfo: VA API version: 0.31
vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA API - 0.6.11
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointIDCT
      VAProfileMPEG2Main              : VAEntrypointIDCT
      VAProfileH264High               : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
mplayer-vaapi-20100602;
catalyst-10.5

0
king_diamond - 29 Июнь, 2010 - 19:43

Я сделал так:скачал и установил smplayer и там в настройках вывода видео выбрал xv(0-ATI Radeon AVIVO Video).После этого смотрел видеофайл размером 40Гб без тормозов.Драйвер catalyst-10.6

0
beginer - 30 Июнь, 2010 - 09:46
Изображение пользователя beginer.

Может у вас просто железо мощное? Просто при выборе xv(0-ATI Radeon AVIVO Video) в smplayer у меня начинает тормозить всего то 5 Гб фильм (*.mkv) в разрешении 1280х512.

0
king_diamond - 30 Июнь, 2010 - 15:42

да,железо неслабое,но во всех других испробованных мною плеерах(VLC,Kaffeine,Dragon,KMPlayer)даже с моим железом были жуткие тормоза на видеофайле с блюрей диска в формате m2ts размером 40Гб.

0
skew - 6 Июль, 2010 - 13:56
Изображение пользователя skew.

я заметил интересную фишку, что после обновления ffmpeg, mplaer-vaapi, xvba-video или libva ускорение накрывается медным тазом и помогает переустановка драевера ATI.

Ускорение у меня всё-таки заработало на драйвере 10.6 (как раз после установки/переустановки)

0
beginer - 6 Июль, 2010 - 13:59
Изображение пользователя beginer.

Надо будет попробовать. Спасибо.

0
beginer - 28 Июль, 2010 - 13:01
Изображение пользователя beginer.

На сайте появились новые библиотеки для поддержки аппаратного декодирование видео. С драйвером CATALIST 10.7 все заводится само. Вот только как smplayer как тормозил, так и тормозит. И это при том, что если запускать напрямую mplayer, то все просто великолепно летает. Помогите разобраться - ПОЧЕМУ?

0
skew - 29 Июль, 2010 - 09:36
Изображение пользователя skew.

Настрой smplayer заново по мануалу из первого поста, должно всё работать.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры