установка программы [Решено]

А что неверно здесь?

[email protected]:~$ sudo dpkg -i ya.deb
Выбор ранее не выбранного пакета yandex-disk.
(Чтение базы данных … на данный момент установлено 150516 файлов и каталогов.)
Preparing to unpack ya.deb ...
Unpacking yandex-disk (0.1.5.758) ...
Настраивается пакет yandex-disk (0.1.5.758) …
Using /usr/bin/wget
gpg: не найдено данных формата OpenPGP.
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...

0
DarkneSS - 22 Октябрь, 2014 - 18:53
Изображение пользователя DarkneSS.

OpenPGP установлен?

0
vda1999 - 22 Октябрь, 2014 - 19:00

Наверное нет

0
vda1999 - 22 Октябрь, 2014 - 19:05

Где его взять?

+1
Fierta - 22 Октябрь, 2014 - 19:20
Изображение пользователя Fierta.

Не нужно никаких dpkg, ставь gdebi и с помощью его устанавливай пакеты:
sudo apt-get install gdebi

0
vda1999 - 22 Октябрь, 2014 - 19:46

Как с его помощью устанавливать пакеты?

0
MacLeod - 22 Октябрь, 2014 - 19:59
Изображение пользователя MacLeod.

Все, установился он. А откуда ya.deb был скачен, если не секрет?)

0
vda1999 - 22 Октябрь, 2014 - 20:14

в яндекс программах

0
vda1999 - 22 Октябрь, 2014 - 20:12

ya.deb с Яндекс программ. gdebi - то установился, а что дальше делать?

0
vda1999 - 22 Октябрь, 2014 - 20:05

Что-то я не понял. Он пишет, что программа установлена, но найти и запустить я её не могу.

+2
MacLeod - 22 Октябрь, 2014 - 20:37
Изображение пользователя MacLeod.

Вы бы почитали вот это http://help.yandex.ru/disk/cli-clients.xml, вдумчиво =)

0
vda1999 - 22 Октябрь, 2014 - 20:50

Спасибо. А как установить .tgz или .tar.xz?

+1
MacLeod - 22 Октябрь, 2014 - 21:11
Изображение пользователя MacLeod.

Это архивы, где tar - контейнер, а gz, bz2 и т.д. - тип/алгоритм сжатия. Типа как в винде zip, rar и 7z.

0
vda1999 - 22 Октябрь, 2014 - 22:29

Ну хорошо, тогда как установить python?
https://www.python.org/download

+2
MacLeod - 22 Октябрь, 2014 - 22:37
Изображение пользователя MacLeod.

С помощью пакетного менеджера. Перед этим можно глянуть, что уже установлено, связанное с ним:
dpkg -l | grep python
А устанавливать через:
apt-get install python*
Где вместо звездочки - версия или нужный компонент.
Еще можно через пакетный менеджер Muon или Synaptic.

0
vda1999 - 22 Октябрь, 2014 - 22:54

Питон устанавливается:
[email protected]:~$ apt-get install python 3.4.1
E: Не удалось открыть файл блокировки /var/lib/dpkg/lock - open (13: Отказано в доступе)
E: Не удалось выполнить блокировку управляющего каталога (/var/lib/dpkg/); у вас есть права суперпользователя?
[email protected]:~$ sudo apt-get install python 3.4.1
[sudo] password for dima:
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Заметьте, выбирается «libraw1394-11» для регулярного выражения «3.4.1»
Заметьте, выбирается «libraw1394-11-dbg» для регулярного выражения «3.4.1»
Заметьте, выбирается «libghc-hashed-storage-dev-0.5.10-38491» для регулярного выражения «3.4.1»
Заметьте, выбирается «libghc-hashed-storage-prof-0.5.10-38491» для регулярного выражения «3.4.1»
Заметьте, вместо «libghc-hashed-storage-dev-0.5.10-38491» выбирается «libghc-hashed-storage-dev»
Заметьте, вместо «libghc-hashed-storage-prof-0.5.10-38491» выбирается «libghc-hashed-storage-prof»
Уже установлена самая новая версия libraw1394-11.
Уже установлена самая новая версия python.
Следующие пакеты устанавливались автоматически и больше не требуются:
libglade2-0 libnotify4 libpango1.0-0 libpangox-1.0-0 libxneur libxosd2
python3-tk xneur
Для их удаления используйте «apt-get autoremove».
Будут установлены следующие дополнительные пакеты:
gcc gcc-4.8 ghc ghc-prof libasan0 libatomic1 libbsd-dev libc-dev-bin
libc6-dev libffi-dev libgcc-4.8-dev libghc-dataenc-dev libghc-dataenc-prof
libghc-extensible-exceptions-dev libghc-extensible-exceptions-prof
libghc-mmap-dev libghc-mmap-prof libghc-mtl-dev libghc-mtl-prof
libghc-transformers-dev libghc-transformers-prof libghc-zlib-dev
libghc-zlib-prof libgmp-dev libgmpxx4ldbl libitm1 libquadmath0
libstdc++-4.8-dev linux-libc-dev manpages-dev zlib1g-dev
Предлагаемые пакеты:
gcc-multilib autoconf automake1.9 libtool flex bison gcc-doc
gcc-4.8-multilib gcc-4.8-doc gcc-4.8-locales libgcc1-dbg libgomp1-dbg
libitm1-dbg libatomic1-dbg libasan0-dbg libtsan0-dbg libbacktrace1-dbg
libquadmath0-dbg ghc-doc haskell-doc llvm glibc-doc libghc-dataenc-doc
libghc-extensible-exceptions-doc libghc-hashed-storage-doc libghc-mmap-doc
libghc-mtl-doc libghc-transformers-doc libghc-zlib-doc libgmp10-doc
libmpfr-dev libraw1394-doc libstdc++-4.8-doc
НОВЫЕ пакеты, которые будут установлены:
gcc gcc-4.8 ghc ghc-prof libasan0 libatomic1 libbsd-dev libc-dev-bin
libc6-dev libffi-dev libgcc-4.8-dev libghc-dataenc-dev libghc-dataenc-prof
libghc-extensible-exceptions-dev libghc-extensible-exceptions-prof
libghc-hashed-storage-dev libghc-hashed-storage-prof libghc-mmap-dev
libghc-mmap-prof libghc-mtl-dev libghc-mtl-prof libghc-transformers-dev
libghc-transformers-prof libghc-zlib-dev libghc-zlib-prof libgmp-dev
libgmpxx4ldbl libitm1 libquadmath0 libraw1394-11-dbg libstdc++-4.8-dev
linux-libc-dev manpages-dev zlib1g-dev
обновлено 0, установлено 34 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Необходимо скачать 64,7 MБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 481 MB.
Хотите продолжить? [Д/н] д
Получено:1 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libasan0 i386 4.8.2-19ubuntu1 [64,1 kB]
Получено:2 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libatomic1 i386 4.8.2-19ubuntu1 [8 258 B]
Получено:3 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libgmpxx4ldbl i386 2:5.1.3+dfsg-1ubuntu1 [8 638 B]
Получено:4 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libitm1 i386 4.8.2-19ubuntu1 [28,5 kB]
Получено:5 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libquadmath0 i386 4.8.2-19ubuntu1 [187 kB]
Получено:6 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libgcc-4.8-dev i386 4.8.2-19ubuntu1 [1 736 kB]
Получено:7 http://ru.archive.ubuntu.com/ubuntu/ trusty/main gcc-4.8 i386 4.8.2-19ubuntu1 [4 884 kB]
Получено:8 http://ru.archive.ubuntu.com/ubuntu/ trusty/main gcc i386 4:4.8.2-1ubuntu6 [5 096 B]
Получено:9 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libbsd-dev i386 0.6.0-2ubuntu1 [114 kB]
Получено:10 http://ru.archive.ubuntu.com/ubuntu/ trusty-updates/main libc-dev-bin i386 2.19-0ubuntu6.3 [63,4 kB]
Получено:11 http://ru.archive.ubuntu.com/ubuntu/ trusty-updates/main linux-libc-dev i386 3.13.0-37.64 [800 kB]
Получено:12 http://ru.archive.ubuntu.com/ubuntu/ trusty-updates/main libc6-dev i386 2.19-0ubuntu6.3 [1 555 kB]
Получено:13 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libgmp-dev i386 2:5.1.3+dfsg-1ubuntu1 [294 kB]
Получено:14 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libstdc++-4.8-dev i386 4.8.2-19ubuntu1 [1 058 kB]
Получено:15 http://ru.archive.ubuntu.com/ubuntu/ trusty/main manpages-dev all 3.54-1ubuntu1 [1 820 kB]
Получено:16 http://ru.archive.ubuntu.com/ubuntu/ trusty/main zlib1g-dev i386 1:1.2.8.dfsg-1ubuntu1 [181 kB]
Получено:17 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libffi-dev i386 3.1~rc1+r3.0.13-12 [99,0 kB]
Получено:18 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe ghc i386 7.6.3-10 [25,3 MB]
Получено:19 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe ghc-prof i386 7.6.3-10 [23,7 MB]
Получено:20 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe libghc-dataenc-dev i386 0.14.0.4-2 [203 kB]
Получено:21 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe libghc-dataenc-prof i386 0.14.0.4-2 [198 kB]
Получено:22 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe libghc-extensible-exceptions-dev i386 0.1.1.4-2 [5 288 B]
Получено:23 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe libghc-extensible-exceptions-prof i386 0.1.1.4-2 [4 668 B]
Получено:24 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe libghc-mmap-dev i386 0.5.8-3 [55,8 kB]
Получено:25 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe libghc-transformers-dev i386 0.3.0.0-5 [381 kB]
Получено:26 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe libghc-mtl-dev i386 2.1.2-4 [105 kB]
Получено:27 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe libghc-zlib-dev i386 0.5.4.1-1 [87,5 kB]
Получено:28 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe libghc-hashed-storage-dev i386 0.5.10-4build1 [411 kB]
Получено:29 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe libghc-mmap-prof i386 0.5.8-3 [46,3 kB]
Получено:30 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe libghc-transformers-prof i386 0.3.0.0-5 [459 kB]
Получено:31 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe libghc-mtl-prof i386 2.1.2-4 [125 kB]
Получено:32 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe libghc-zlib-prof i386 0.5.4.1-1 [79,2 kB]
Получено:33 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe libghc-hashed-storage-prof i386 0.5.10-4build1 [511 kB]
Получено:34 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libraw1394-11-dbg i386 2.1.0-1ubuntu1 [81,1 kB]
Получено 64,7 MБ за 2мин 49с (381 kБ/c)
Извлечение шаблонов из пакетов: 100%
Выбор ранее не выбранного пакета libasan0:i386.
(Чтение базы данных … на данный момент установлено 160115 файлов и каталогов.)
Preparing to unpack …/libasan0_4.8.2-19ubuntu1_i386.deb ...
Unpacking libasan0:i386 (4.8.2-19ubuntu1) ...
Выбор ранее не выбранного пакета libatomic1:i386.
Preparing to unpack …/libatomic1_4.8.2-19ubuntu1_i386.deb ...
Unpacking libatomic1:i386 (4.8.2-19ubuntu1) ...
Выбор ранее не выбранного пакета libgmpxx4ldbl:i386.
Preparing to unpack …/libgmpxx4ldbl_2%3a5.1.3+dfsg-1ubuntu1_i386.deb ...
Unpacking libgmpxx4ldbl:i386 (2:5.1.3+dfsg-1ubuntu1) ...
Выбор ранее не выбранного пакета libitm1:i386.
Preparing to unpack …/libitm1_4.8.2-19ubuntu1_i386.deb ...
Unpacking libitm1:i386 (4.8.2-19ubuntu1) ...
Выбор ранее не выбранного пакета libquadmath0:i386.
Preparing to unpack …/libquadmath0_4.8.2-19ubuntu1_i386.deb ...
Unpacking libquadmath0:i386 (4.8.2-19ubuntu1) ...
Выбор ранее не выбранного пакета libgcc-4.8-dev:i386.
Preparing to unpack …/libgcc-4.8-dev_4.8.2-19ubuntu1_i386.deb ...
Unpacking libgcc-4.8-dev:i386 (4.8.2-19ubuntu1) ...
Выбор ранее не выбранного пакета gcc-4.8.
Preparing to unpack …/gcc-4.8_4.8.2-19ubuntu1_i386.deb ...
Unpacking gcc-4.8 (4.8.2-19ubuntu1) ...
Выбор ранее не выбранного пакета gcc.
Preparing to unpack …/gcc_4%3a4.8.2-1ubuntu6_i386.deb ...
Unpacking gcc (4:4.8.2-1ubuntu6) ...
Выбор ранее не выбранного пакета libbsd-dev.
Preparing to unpack …/libbsd-dev_0.6.0-2ubuntu1_i386.deb ...
Unpacking libbsd-dev (0.6.0-2ubuntu1) ...
Выбор ранее не выбранного пакета libc-dev-bin.
Preparing to unpack …/libc-dev-bin_2.19-0ubuntu6.3_i386.deb ...
Unpacking libc-dev-bin (2.19-0ubuntu6.3) ...
Выбор ранее не выбранного пакета linux-libc-dev:i386.
Preparing to unpack …/linux-libc-dev_3.13.0-37.64_i386.deb ...
Unpacking linux-libc-dev:i386 (3.13.0-37.64) ...
Выбор ранее не выбранного пакета libc6-dev:i386.
Preparing to unpack …/libc6-dev_2.19-0ubuntu6.3_i386.deb ...
Unpacking libc6-dev:i386 (2.19-0ubuntu6.3) ...
Выбор ранее не выбранного пакета libgmp-dev:i386.
Preparing to unpack …/libgmp-dev_2%3a5.1.3+dfsg-1ubuntu1_i386.deb ...
Unpacking libgmp-dev:i386 (2:5.1.3+dfsg-1ubuntu1) ...
Выбор ранее не выбранного пакета libstdc++-4.8-dev:i386.
Preparing to unpack …/libstdc++-4.8-dev_4.8.2-19ubuntu1_i386.deb ...
Unpacking libstdc++-4.8-dev:i386 (4.8.2-19ubuntu1) ...
Выбор ранее не выбранного пакета manpages-dev.
Preparing to unpack …/manpages-dev_3.54-1ubuntu1_all.deb ...
Unpacking manpages-dev (3.54-1ubuntu1) ...
Выбор ранее не выбранного пакета zlib1g-dev:i386.
Preparing to unpack …/zlib1g-dev_1%3a1.2.8.dfsg-1ubuntu1_i386.deb ...
Unpacking zlib1g-dev:i386 (1:1.2.8.dfsg-1ubuntu1) ...
Выбор ранее не выбранного пакета libffi-dev:i386.
Preparing to unpack …/libffi-dev_3.1~rc1+r3.0.13-12_i386.deb ...
Unpacking libffi-dev:i386 (3.1~rc1+r3.0.13-12) ...
Выбор ранее не выбранного пакета ghc.
Preparing to unpack …/archives/ghc_7.6.3-10_i386.deb ...
Unpacking ghc (7.6.3-10) ...
Выбор ранее не выбранного пакета ghc-prof.
Preparing to unpack …/ghc-prof_7.6.3-10_i386.deb ...
Unpacking ghc-prof (7.6.3-10) ...
Выбор ранее не выбранного пакета libghc-dataenc-dev.
Preparing to unpack …/libghc-dataenc-dev_0.14.0.4-2_i386.deb ...
Unpacking libghc-dataenc-dev (0.14.0.4-2) ...
Выбор ранее не выбранного пакета libghc-dataenc-prof.
Preparing to unpack …/libghc-dataenc-prof_0.14.0.4-2_i386.deb ...
Unpacking libghc-dataenc-prof (0.14.0.4-2) ...
Выбор ранее не выбранного пакета libghc-extensible-exceptions-dev.
Preparing to unpack …/libghc-extensible-exceptions-dev_0.1.1.4-2_i386.deb ...
Unpacking libghc-extensible-exceptions-dev (0.1.1.4-2) ...
Выбор ранее не выбранного пакета libghc-extensible-exceptions-prof.
Preparing to unpack …/libghc-extensible-exceptions-prof_0.1.1.4-2_i386.deb ...
Unpacking libghc-extensible-exceptions-prof (0.1.1.4-2) ...
Выбор ранее не выбранного пакета libghc-mmap-dev.
Preparing to unpack …/libghc-mmap-dev_0.5.8-3_i386.deb ...
Unpacking libghc-mmap-dev (0.5.8-3) ...
Выбор ранее не выбранного пакета libghc-transformers-dev.
Preparing to unpack …/libghc-transformers-dev_0.3.0.0-5_i386.deb ...
Unpacking libghc-transformers-dev (0.3.0.0-5) ...
Выбор ранее не выбранного пакета libghc-mtl-dev.
Preparing to unpack …/libghc-mtl-dev_2.1.2-4_i386.deb ...
Unpacking libghc-mtl-dev (2.1.2-4) ...
Выбор ранее не выбранного пакета libghc-zlib-dev.
Preparing to unpack …/libghc-zlib-dev_0.5.4.1-1_i386.deb ...
Unpacking libghc-zlib-dev (0.5.4.1-1) ...
Выбор ранее не выбранного пакета libghc-hashed-storage-dev.
Preparing to unpack …/libghc-hashed-storage-dev_0.5.10-4build1_i386.deb ...
Unpacking libghc-hashed-storage-dev (0.5.10-4build1) ...
Выбор ранее не выбранного пакета libghc-mmap-prof.
Preparing to unpack …/libghc-mmap-prof_0.5.8-3_i386.deb ...
Unpacking libghc-mmap-prof (0.5.8-3) ...
Выбор ранее не выбранного пакета libghc-transformers-prof.
Preparing to unpack …/libghc-transformers-prof_0.3.0.0-5_i386.deb ...
Unpacking libghc-transformers-prof (0.3.0.0-5) ...
Выбор ранее не выбранного пакета libghc-mtl-prof.
Preparing to unpack …/libghc-mtl-prof_2.1.2-4_i386.deb ...
Unpacking libghc-mtl-prof (2.1.2-4) ...
Выбор ранее не выбранного пакета libghc-zlib-prof.
Preparing to unpack …/libghc-zlib-prof_0.5.4.1-1_i386.deb ...
Unpacking libghc-zlib-prof (0.5.4.1-1) ...
Выбор ранее не выбранного пакета libghc-hashed-storage-prof.
Preparing to unpack …/libghc-hashed-storage-prof_0.5.10-4build1_i386.deb ...
Unpacking libghc-hashed-storage-prof (0.5.10-4build1) ...
Выбор ранее не выбранного пакета libraw1394-11-dbg:i386.
Preparing to unpack …/libraw1394-11-dbg_2.1.0-1ubuntu1_i386.deb ...
Unpacking libraw1394-11-dbg:i386 (2.1.0-1ubuntu1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for install-info (5.2.0.dfsg.1-2) ...
Настраивается пакет libasan0:i386 (4.8.2-19ubuntu1) …
Настраивается пакет libatomic1:i386 (4.8.2-19ubuntu1) …
Настраивается пакет libgmpxx4ldbl:i386 (2:5.1.3+dfsg-1ubuntu1) …
Настраивается пакет libitm1:i386 (4.8.2-19ubuntu1) …
Настраивается пакет libquadmath0:i386 (4.8.2-19ubuntu1) …
Настраивается пакет libgcc-4.8-dev:i386 (4.8.2-19ubuntu1) …
Настраивается пакет gcc-4.8 (4.8.2-19ubuntu1) …
Настраивается пакет gcc (4:4.8.2-1ubuntu6) …
Настраивается пакет libbsd-dev (0.6.0-2ubuntu1) …
Настраивается пакет libc-dev-bin (2.19-0ubuntu6.3) …
Настраивается пакет linux-libc-dev:i386 (3.13.0-37.64) …
Настраивается пакет libc6-dev:i386 (2.19-0ubuntu6.3) …
Настраивается пакет libgmp-dev:i386 (2:5.1.3+dfsg-1ubuntu1) …
Настраивается пакет libstdc++-4.8-dev:i386 (4.8.2-19ubuntu1) …
Настраивается пакет manpages-dev (3.54-1ubuntu1) …
Настраивается пакет zlib1g-dev:i386 (1:1.2.8.dfsg-1ubuntu1) …
Настраивается пакет libffi-dev:i386 (3.1~rc1+r3.0.13-12) …
Настраивается пакет ghc (7.6.3-10) …
update-alternatives: используется /usr/bin/runghc для предоставления /usr/bin/runhaskell (runhaskell) в автоматический режим
update-alternatives: используется /usr/bin/ghc для предоставления /usr/bin/haskell-compiler (haskell-compiler) в автоматический режим
Настраивается пакет ghc-prof (7.6.3-10) …
Настраивается пакет libghc-dataenc-dev (0.14.0.4-2) …
Настраивается пакет libghc-dataenc-prof (0.14.0.4-2) …
Настраивается пакет libghc-extensible-exceptions-dev (0.1.1.4-2) …
Настраивается пакет libghc-extensible-exceptions-prof (0.1.1.4-2) …
Настраивается пакет libghc-mmap-dev (0.5.8-3) …
Настраивается пакет libghc-transformers-dev (0.3.0.0-5) …
Настраивается пакет libghc-mtl-dev (2.1.2-4) …
Настраивается пакет libghc-zlib-dev (0.5.4.1-1) …
Настраивается пакет libghc-hashed-storage-dev (0.5.10-4build1) …
Настраивается пакет libghc-mmap-prof (0.5.8-3) …
Настраивается пакет libghc-transformers-prof (0.3.0.0-5) …
Настраивается пакет libghc-mtl-prof (2.1.2-4) …
Настраивается пакет libghc-zlib-prof (0.5.4.1-1) …
Настраивается пакет libghc-hashed-storage-prof (0.5.10-4build1) …
Настраивается пакет libraw1394-11-dbg:i386 (2.1.0-1ubuntu1) …
Processing triggers for libc-bin (2.19-0ubuntu6.3) ...

0
vda1999 - 22 Октябрь, 2014 - 22:56

Но запускается всё равно старый Питон:
[email protected]:~$ python
Python 2.7.6 (default, Mar 22 2014, 22:59:38)
[GCC 4.8.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>

0
_qwerty - 22 Октябрь, 2014 - 22:58

python 3.4

0
_qwerty - 22 Октябрь, 2014 - 23:03

тоесть: python3.4

0
vda1999 - 22 Октябрь, 2014 - 23:14

Хорошо, в Konsole Питон 3.4 запускается. А кто нибудь знает, как заставить Wing Ide работать с новым, а не старым?

0
MacLeod - 22 Октябрь, 2014 - 23:31
Изображение пользователя MacLeod.

/usr/bin/python - это ссылка
[email protected]:~$ ls -la /usr/bin/python
lrwxrwxrwx 1 root root 9 дек.  21  2013 /usr/bin/python -> python2.7

Можно сделать ссылку на нужную версию, чтобы применилось для всей системы:
sudo rm /usr/bin/python
sudo ln -s /usr/bin/python3.4 /usr/bin/python

подправить файлик /usr/share/python/debian_defaults.
Или использовать virtualenv...

+2
MacLeod - 22 Октябрь, 2014 - 23:13
Изображение пользователя MacLeod.

Для начала, нужно разобраться, что такое пакетный менеджер, что за пакеты и откуда они берутся.
http://help.ubuntu.ru/wiki/apt
http://help.ubuntu.ru/wiki/установка_программ
В именах пакетов не может быть пробелов, пробелами отделяют в том случае, если устанавливается несколько пакетов.
Нельзя просто указать желаемую версию, можно поставить те пакеты, которые есть в основном репозитории или в подключенных PPA.
Muon в кубунту является графической реализацией и работает с той же базой пакетов в системе и подключенными репозиториями.

0
vda1999 - 22 Октябрь, 2014 - 23:44

Громадное всем спасибо! Без вас бы никогда не справился!

0
nero_aida - 23 Октябрь, 2014 - 00:36
Изображение пользователя nero_aida.

У меня у одного yandex-disk установился после команды dpkg -i 'имя пакета'?

0
BOSS_SAS - 23 Октябрь, 2014 - 05:11

нас как минимум двое

0
pabl0 - 23 Октябрь, 2014 - 19:58

Присоединяюсь

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры