Не работает вебкамера a4tech [Решено]

Изображение пользователя kot040188.

Долгое время не использовал вебку (a4tech, та которая "вставил и работает"), а сейчас guvcview (и не только он) говорит, что не находит её. Нет её и в "Настройка видео и аудио" в раздеде "запись видео", а раньше была. При этом звук с её микрофона записать могу спокойно, в разделе "запись звука" она есть.
Решение

0
dyug - 6 Июнь, 2015 - 11:29

что в логе после ее подключения?

0
kot040188 - 6 Июнь, 2015 - 14:06
Изображение пользователя kot040188.

Где лог?

0
Mike - 6 Июнь, 2015 - 14:30
Изображение пользователя Mike.

в /var/log, это же очевидно!

0
kot040188 - 6 Июнь, 2015 - 14:32
Изображение пользователя kot040188.

Пока не могу глянуть, но там же не один лог. Какой смотреть?

0
Mike - 6 Июнь, 2015 - 14:35
Изображение пользователя Mike.

ну определенно не в логах самбы или апача. Обычно все аппаратные вещи падают в syslog. Можно еще и kern.log помониторить, чтобы наверняка.

0
kot040188 - 6 Июнь, 2015 - 14:53
Изображение пользователя kot040188.

syslog:

kern.log:
0
Mike - 6 Июнь, 2015 - 15:27
Изображение пользователя Mike.

А теперь аккуратненько вбей ошибку в гуголь и внимательно читай, что пишут люди =)

0
kot040188 - 6 Июнь, 2015 - 15:34
Изображение пользователя kot040188.

Решение.
З.Ы. Не ожидал такого от linux… Кажись зимой работало без костылей…

0
Mike - 6 Июнь, 2015 - 15:36
Изображение пользователя Mike.

с вебками - частое явление.

0
kot040188 - 6 Июнь, 2015 - 15:36
Изображение пользователя kot040188.

Не было такого никогда…

0
Mike - 6 Июнь, 2015 - 15:39
Изображение пользователя Mike.

На современном железе с ЮСБ-периферией вечные странности. У меня, к примеру, комп даже не пытается грузиться, когда в него геймпад вставлен. Если его вставить в уже загруженой операционке - работает без проблем.

0
dyug - 6 Июнь, 2015 - 18:16

Если бы это проблема была только с вебкамерами...
когда они полностью блютуз стек випилили, и поставили новый, не поддерживающий старые чипы...
Ах да, рекомендация - использовать прописывать надо в /etc/modprobe.d/123.conf

options uvcvideo quirks=2 trace=65535
это решение, оно более правильное, и более устойчивое к обновлениям.

0
kot040188 - 5 Июль, 2015 - 20:12
Изображение пользователя kot040188.

Так и сделаю. Правда в "запись видео" она так и не появилась. Ну и фиг с ним. Приглашаю всех в соседние мои темы.
Не знаю в чём прикол, но прописывать ничего не пришлось (руки дошли только сейчас, как всегда). После первого ввода команды в консоли, вебка работает нормально…

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры