Новая карта GeForce GTX560Ti - система не грузится [Решено]

Изображение пользователя bodro.

Добрый день!

Проблема такая - у меня установлен Linux Kubuntu 12.04 - обновился только на днях. Материнская плата GA-EG45M-UD2H (-SI). Видеокарта интегрированная от Intel. В PCIExpress-слоте никогда ничего вставлено небыло. Купил себе вчера видеокарту NVidia GeForce GTX560Ti. В BIOS отключил использование интегрированной карты. Стал загружаться - POST-сообщения выводятся - всё хорошо. GRUB начинает грузить ядро, но зависает. Судя по сообщениям, не может то ли загрузить модуль для PCIExpress, то ли с udev какая проблема, то ли ещё с чем. В общем, не могу загрузиться никак - даже в recovery mode.

Пробовал работать с интегриованной картой, но со вставленной в слот GeForce - система так же не грузится, но позволяет загрузиться в recovery mode.

В recovery mode пробовал dpkg --configure -a, dpkg-reconfigure --all - почему-то они ничего не делают. Возможно, что после обновления что-то накрылось, а может в 12.04 изменилась работа с этими утилтами.

В Gentoo проблему решил бы просто - пересобрал ядро и udev, но в Kubuntu очень нехочется делать что-то, минуя системный контроль.
Переустанавливать Linux не хочу - стоит 5 лет, всё настроено и заново настраивать не хочу.

Кто-то встречался с такой проблемой? Буду очень признателен!

0
Mike - 8 Июнь, 2012 - 14:03
Изображение пользователя Mike.

консольно поставить дрова нвидии пробовал?

0
DarkneSS - 8 Июнь, 2012 - 14:49
Изображение пользователя DarkneSS.

Логи бы системы и иксов.

0
bodro - 8 Июнь, 2012 - 18:22
Изображение пользователя bodro.

Я же говорю - не доходит даже да баша - не то что до иксов.

0
rlepish - 8 Июнь, 2012 - 16:41

хз. я в 12.04 работал на интегрированной Интел. в PCІ-е воткнул нвидию 8600ГТ не отключая Интела, загрузилась без проблем. поставил драйвер Нвидии через менеджер драйверов

0
bodro - 8 Июнь, 2012 - 18:25
Изображение пользователя bodro.

Спасибо всем! Проблема решена. Решение описал тут: http://forum.ubuntu.ru/index.php?topic=193963.0

Выложу так же текстом:

Добрый день!

suslikk, спасибо огромнейшее! Помогло, но не совсем. В общем, делал так:

Загрузился без новой карты. В консоли решил посмотреть, а что вообще такое nvidia-current и какие есть пакеты со схожими именами?

[email protected]:~$ apt-cache search nvidia-current
nvidia-current - NVIDIA binary Xorg driver, kernel module and VDPAU library
nvidia-current-updates - NVIDIA binary Xorg driver, kernel module and VDPAU library
nvidia-current-updates-dev - NVIDIA binary Xorg driver development files
nvidia-current-dev - Файлы для разработки двоичного драйвера NVIDIA для Xorg
[email protected]:~$

Увидел что их на самом деле 2 - nvidia-current и nvidia-current-updates. Решил поставить оба, а заодно ещё и пакеты для разработки - мало ли что придётся компилировать.

$ sudo apt-get install nvidia-current nvidia-current-dev nvidia-current-updates nvidia-current-updates-dev

Перезагружаю компьютер, в BI[censored]зываю что надо отключить onboard-карту и использовать PEG (PCIExpress Graphic). Сохраняю, выключаю компьютер, вставляю карту, запускаю.
Наконец-то! Ядро начало грузиться, но потом X-ы упали. Стал смотреть логи и по ним понял что есть какой-то конфликт, как я понял, между модулем ядра и чем-то ещё. стал думать, а как же мне загрузить нужный модуль ядра? Полез в /lib и увидел там два каталога /lib/nvidia-current и /lib/nvidia-current-updates. Стал смотреть и увидел, что они друг друга засунули в блек-лист. Долго не думая, решил что надо удалить nvidia-current:

$ sudo apt-get purge nvidia-current

Затем подключил модуль nvidia-current-updates:

$ sudo modprobe nvidia-current-updates

Запускаю X-ы. Заработало! Всё загрузилось, работает просто великолепно! При максимальном разрешении и при максимальных параметрах [censored]z летает! В Foobilliard работает великолепно! Никаких зубьев - просто великолепно!

Так что, если у кого будет проблема с GTX560Ti - удаляйте, если были до этого установлены, nvidia-current и устанавливайте nvidia-current-updates.

P.S.suslikk большой респект! Очень помог! Я бы ещё долго возился в поисках причины. А так, я хоть загрузился и смог проанализировать логи и понять в чём дело.

0
Vlad_W_1999 - 8 Июнь, 2012 - 18:39

Хорошо у нас антимат работает! Не, ну я понимаю, что компиз это матюк. Согласен. Но BIOS чем такое отношение заслужил?

:-)))

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры