AMD HD5770 не работает OpenGL [Решено]

Пробовал переустанавливать драйвера, как написано в вики. Не работают эффекты, требующие OpenGL, игры тоже. Раньше работали.
[email protected]:~$ glxinfo
name of display: :0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: ATI
server glx version string: 1.4
server glx extensions:
GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGIS_multisample,
GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group
client glx vendor string: ATI
client glx version string: 1.4

[email protected]:~$ fglrxinfo
display: :0 screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 5700 Series
OpenGL version string: 4.2.12002 Compatibility Profile Context 9.012

[email protected]:~$ ldd /usr/bin/glxinfo
linux-vdso.so.1 => (0x00007fffdfdff000)
libGL.so.1 => /usr/lib/fglrx/libGL.so.1 (0x00007f3960499000)
libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f396015f000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f395fd9f000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f395fb82000)
libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f395f970000)
libatiuki.so.1 => /usr/lib/fglrx/libatiuki.so.1 (0x00007f395f855000)
libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f395f637000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f395f433000)
/lib64/ld-linux-x86-64.so.2 (0x00007f39606cc000)
libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f395f22e000)
libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f395f028000)

0
AlexBKost - 25 Март, 2013 - 22:57

... как написано в вики. Каком?
Раньше работали. Когда?
Не находите странным, что приходится переспрашивать?

0
Binque - 26 Март, 2013 - 05:40

В этом вики. Пробовал ставить через "Дополнительные драйверы", из репозитория и вручную. Работать перестало, вероятно, после какого-то обновления драйвера. Точнее не могу сказать, было давно.

0
AlexBKost - 26 Март, 2013 - 15:28

Если бы мне пришлось лечить такую неприятность, я бы корректно удалил все, что устанавливалось/обновлялось, загрузился на свободном, а далее вручную установил последний проприетарный драйвер AMD. И навсегда забыл про него.

0
Binque - 26 Март, 2013 - 16:23

Заработало наконец, большое спасибо. Странно, вроде там написано примерно то же, что и в русском вики.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры