Как увидеть адекватную температуру процессора и пр.?

Поставил виджет Simple CPU Sensor, до этого смотрел температуру проца командой (не помню точно какой), всегда один и тот же результат - температура показывается неверно: конец мая, за окном + 35, в квартире около +20, и температура проца 8 градусов…

в биосе показывает адекватно, около 45-55 градусов.
что может быть не так, и как получить адекватную температуру?

0
DarkneSS - 18 Май, 2013 - 15:42
Изображение пользователя DarkneSS.

Добавьте обычный температурный виджет КДЕ и посмотрите там.

0
ozim - 18 Май, 2013 - 19:40

на скрине он и есть.

0
Almight - 18 Май, 2013 - 16:15
Изображение пользователя Almight.

$ sensors

0
novocat - 18 Май, 2013 - 17:05
Изображение пользователя novocat.

sudo apt-get install psensor
Показывает температуру CPU, /dev/sda, /dev/sdb, NVIDIA, cpu usage
Раньше ставил lm-sensor, но psensor оказался удобнее

0
ozim - 18 Май, 2013 - 19:46

он показывает тоже самое

0
surok - 18 Май, 2013 - 21:58
Изображение пользователя surok.

Спасибо)))Через Мион поставила, теперь значок в Трее стоит, очень удобно.

0
GreatKir - 18 Май, 2013 - 20:34
Изображение пользователя GreatKir.

Модель процессора?
Команда, которой проверяете?

0
ozim - 18 Май, 2013 - 21:48


команда sensors, но результат одинаковый не только под этой командой.

0
Schaman - 18 Май, 2013 - 21:54
Изображение пользователя Schaman.

Узри KInfoCenter. Можно +prtscr.

0
GreatKir - 18 Май, 2013 - 22:00
Изображение пользователя GreatKir.

Лично я так и не увидел вывод команды sensors
Пришлите, пожалуйста, весь вывод

0
ozim - 18 Май, 2013 - 22:06

ну вы же не вывод команды просили, а спрашивали какой командой я вывожу..
Вот вывод

ozim@ozim-kde:~$ sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:        +13.0°C  (crit = +127.0°C)

k10temp-pci-00c3
Adapter: PCI adapter
temp1:        +13.6°C  (high = +70.0°C)
                       (crit = +80.0°C, hyst = +79.0°C)

0
GreatKir - 18 Май, 2013 - 22:09
Изображение пользователя GreatKir.

sudo sensors-detect делали?
Налицо некорректная работа датчика процессора. Но можно брать данные с датчика материнской платы (именно оттуда берет биос)

0
ozim - 18 Май, 2013 - 22:11

да, делал. Дело в том, что биос как раз показывает верно.

0
GreatKir - 18 Май, 2013 - 22:12
Изображение пользователя GreatKir.

Дайте весь вывод (в спойлере) sudo sensors-detect

0
ozim - 18 Май, 2013 - 22:57
0
GreatKir - 19 Май, 2013 - 00:27
Изображение пользователя GreatKir.

Почему в конце отказываетесь от добавления сенсоров в автозагрузку? Добавьте и перезагрузите компьютер.
Do you want to add these lines automatically to /etc/modules? (yes/NO)

Unloading i2c-dev... OK
Unloading cpuid... OK

0
ozim - 19 Май, 2013 - 08:36

сделал.
ozim@ozim-kde:~$ sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:         +6.0°C  (crit = +127.0°C)

k10temp-pci-00c3
Adapter: PCI adapter
temp1:         +6.1°C  (high = +70.0°C)
                       (crit = +80.0°C, hyst = +79.0°C)

0
GreatKir - 19 Май, 2013 - 13:38
Изображение пользователя GreatKir.

Что-то не похоже.
Должен загружаться этот модуль:
Driver `it87':
* ISA bus, address 0xe80
Chip `ITE IT8728F Super IO Sensors' (confidence: 9)

0
ozim - 19 Май, 2013 - 14:33

так что надо сделать то?
на вопрос
"Do you want to add these lines automatically to /etc/modules? (yes/NO)"
я ответил yes, сделал ребут.

0
GreatKir - 19 Май, 2013 - 18:30
Изображение пользователя GreatKir.

http://help.ubuntu.ru/wiki/lm_sensors
попробуйте воспользоваться советом из этой статьи

0
ozim - 19 Май, 2013 - 20:34

Теперь вот такое

0
GreatKir - 19 Май, 2013 - 20:35
Изображение пользователя GreatKir.

Попробуйте нагрузить процессор (например, через prime95) и посмотреть на изменения показателя temp2. Если изменится, значит это температура процессора

0
ozim - 19 Май, 2013 - 20:39

она то изменяется, но неверно показывает, в том и фишка.. Градусов на 30-40 меньше. и в этой куче данных непонятно, где тут вообще температура проца..

0
GreatKir - 19 Май, 2013 - 20:42
Изображение пользователя GreatKir.

temp2, по-моему, дает адекватную температуру. Я не прав? Проверьте через нагрузку процессора

0
ozim - 19 Май, 2013 - 20:52

ну да, более менее похоже.. спасибо. надо запомнить - temp2 =)

0
ozim - 19 Май, 2013 - 21:27

она всегда одинакова.. при нагрузке не меняется. Значит не оно.

0
GreatKir - 19 Май, 2013 - 23:58
Изображение пользователя GreatKir.

В биосе сколько датчиков? У них показания меняются?

0
ozim - 20 Май, 2013 - 08:54
0
ozim - 20 Май, 2013 - 13:25
0
Жюстина - 19 Май, 2013 - 00:57
Изображение пользователя Жюстина.

А у меня та жа проблема, я особо не понимаю, что означают в биосе значения охлаждения "Level 9" - "Level 1", но что в виндовсе, что в линуксе реагируют сенсоры адекватно только когда это значение больше 5.

Лапками кверху, но, у меня так... Материнская плата асрок.

0
surok - 20 Май, 2013 - 12:08
Изображение пользователя surok.

У меня вот такая картинка

Развернуть/свернуть скрытый текст.
. Это номально?
0
DarkneSS - 20 Май, 2013 - 13:11
Изображение пользователя DarkneSS.

Вполне.

0
Mike - 20 Май, 2013 - 13:32
Изображение пользователя Mike.

Топикстартеру: попробовать установить пакет lm-sensors, а потом консольно посмотреть вывод команды sensors.

0
DarkneSS - 20 Май, 2013 - 14:23
0
Mike - 20 Май, 2013 - 14:26
Изображение пользователя Mike.

ой. Как-то этот момент я упустил. Просто видел, что просили выхлоп sensors, но вместо него был дан скриншот виджета.

0
dyug - 20 Май, 2013 - 15:27

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=641429#49
вот по этой ссылке, на мой взгляд есть что то вменяемое.
И еще, мне так помнится, что в году этак 2003-2005 были проблемы с тем, что часть сенсоров выдавала данные в (скажем так) отфонарном формате, который с помощью коэффициентов превращался в нормальные значения.
сайт лмсенсорс лежит, достучаться не могу, ссылку на циферки, разумеется, на память не помню.

0
GreatKir - 20 Май, 2013 - 19:09
Изображение пользователя GreatKir.

Да, копать, вероятно, надо в этом направлении. Мы же не видим исходные данные - sensors выдаёт их в отформатированном виде. А как выдаёт их биос и датчики процессора - хороший вопрос. Проблема с датчиками процессоров k10 в интернете встречается. Можно ещё поискать данные для it8728-isa-0e80

0
GreatKir - 20 Май, 2013 - 19:52
Изображение пользователя GreatKir.

Сюдя по информации в вики https://wiki.archlinux.org/index.php/Lm_sensors, датчик к10 специально отключен, так как может давать неверную информацию на am2+ и F сокетах. Датчик берет информацию из temp1 в данном случае.
Сделайте следующее:
Под рутом выполните команды
# rmmod k10temp
# modprobe k10temp force=1

Если после этого вывод температуры в модуле k10temp-pci-00c3 станет адекватным, добавьте опцию
options k10temp force=1
в файл /etc/modprobe.d/k10temp.conf

0
ozim - 21 Май, 2013 - 06:32

нет, не стал. 4 градуса проц - шоб я так жил))

0
GreatKir - 21 Май, 2013 - 13:34
Изображение пользователя GreatKir.

Покажите, пожалуйста, полный вывод sensors после выполнений этих команд

0
ozim - 21 Май, 2013 - 18:53
0
Гость - 21 Май, 2013 - 21:13


temp3: -80.0°C

Там чтоль градирни с азотной продувкой стоят?.. =)

0
novocat - 22 Май, 2013 - 08:04
Изображение пользователя novocat.

-80.0°C - это фигня. Вы на мой temp3 посмотрите :)

Вот только он - sensor = disabled.
+1
Mike - 22 Май, 2013 - 08:22
Изображение пользователя Mike.

нужно больше охлаждения поддать! на температурах, близких к абсолютному нулю начнут проявляться квантовые эффекти, и тогда комп даже за 5-6 секунд сможет пройти бесконечный цикл полностью!

0
ozim - 22 Май, 2013 - 11:15

смех смехом, но я все еще не вижу адекватной температуры…

0
GreatKir - 22 Май, 2013 - 11:21
Изображение пользователя GreatKir.

Почему-то датчик внутрипроцессорный так и не показывается, по-видимому.
Почему я так думаю? Потому что в процессорах амд есть несколько датчиков. Если бы они показывались, то в k10temp-pci-00c3 было бы 1-2 датчика на каждое ядро. (Сейчас же температура берется из датчика на МП (10 градусов). Почему этот датчик не работает - тоже вопрос.)
Так как они не показываются, можно подумать, что force=1 опция не помогла. Нужно думать в этом направлении

0
ozim - 22 Май, 2013 - 11:28

так что делать то?) главное то, что в биосе верно показывает, а значит датчики работают нормально.

0
Mike - 22 Май, 2013 - 11:36
Изображение пользователя Mike.

я думаю, уже давно очевидно, что вариантов остается всего два: либо забить и начать получать удовольствие от низких значений, либо наконец купить нормальную мамку с нормальными термодатчиками.

0
DarkneSS - 22 Май, 2013 - 11:48
Изображение пользователя DarkneSS.

Или купить термопару, откалиброваться и написать скрипт, пересчитывающий значения :)

0
Mike - 22 Май, 2013 - 11:51
Изображение пользователя Mike.

думаешь, термопара с последующим гемором будет стоить значительно дешевле, нежели новая мать?

0
DarkneSS - 22 Май, 2013 - 11:55
Изображение пользователя DarkneSS.

Не знаю, я бы просто забил :)

0
dyug - 22 Май, 2013 - 12:09

Либо в биосе температура пересчитывается.
Прочтите, наконец, мой пост выше, и сходите, наконец, по ссылке, и попробуйте то предложение.

0
ozim - 23 Май, 2013 - 16:32

там на ненашем языке все, и репорт старый очень, вкратце не подскажете, о чем там?
@Mike а нормальная мамка это какая? Biostar A57A плохая?

0
dyug - 23 Май, 2013 - 17:10

~ # rmmod coretemp
~ # insmod coretemp.ko tjmax=125
~ # sensors

Не на нашем языке все
гуглтранслейт поможет
и репорт старый очень 2011 года? Старый?
вкратце не подскажете, о чем там?
~ # rmmod coretemp
~ # insmod coretemp.ko tjmax=125
~ # sensors

0
ozim - 23 Май, 2013 - 17:13

ozim@ozim-kde:~$ rmmod coretemp
Error: Module coretemp is not currently loaded

что делать?

0
itrch - 23 Май, 2013 - 20:16
Изображение пользователя itrch.

я так понимаю, попробовать следующую команду.

0
ozim - 23 Май, 2013 - 20:56

ozim@ozim-kde:~$ insmod coretemp.ko tjmax=125
Error: could not load module coretemp.ko: No such file or directory

0
dyug - 23 Май, 2013 - 21:29

root@home-dyug:~# modinfo coretemp
filename:       /lib/modules/3.8.0-22-generic/kernel/drivers/hwmon/coretemp.ko
license:        GPL
description:    Intel Core temperature monitor
author:         Rudolf Marek <r.marek@assembler.cz>
srcversion:     74502587A1CAF4729164044
alias:          x86cpu:vendor:0000:family:*:model:*:feature:*00E7*
depends:       
intree:         Y                                                                                                                                                                                         
vermagic:       3.8.0-22-generic SMP mod_unload modversions 686                                                                                                                                           
parm:           tjmax:TjMax value in degrees Celsius (int)

Ну ладно, судя по твоим действиям - увы я не смогу никак помочь.

0
dyug - 23 Май, 2013 - 20:23

тебя не смущает, что в вышеупомянотых командах приглашение рута идет, а не пользователя?
Второе - я бы использовал modinfo для выяснения, какие опции можно задать своим модулям.
И разумеется, погуглил бы.

0
ozim - 23 Май, 2013 - 20:57

под рутом аналогично

0
Mike - 23 Май, 2013 - 20:27
Изображение пользователя Mike.

нуууу, я прям даже и не знаю, что на экзотические сокеты типа FM1 нынче модно.

0
GreatKir - 23 Май, 2013 - 17:24
Изображение пользователя GreatKir.

Та информация относится к процессорам Intel Atom. Там даже модуль ядра другой coretemp

0
Виталий-33 - 5 Ноябрь, 2013 - 11:13
Изображение пользователя Виталий-33.

А может кто подскажет, как теперь убрать Psensor из автозагрузки? Хотелось бы его включать руками, когда нужно.

0
leisampei - 5 Ноябрь, 2013 - 12:48
Изображение пользователя leisampei.

должно быть так:
sudo rm /etc/xdg/autostart/psensor.desktop

0
Виталий-33 - 5 Ноябрь, 2013 - 14:39
Изображение пользователя Виталий-33.

Спасибо, точно тут лежит (вернее уже лежал)

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры