Модем Мегафон M100-1 LTE 4G. Как подключить в Kubuntu?

Купил модем Мегафон M100-1. Как подключить в Kubuntu, чтобы работало 4G?
Как его в принципе подключить? При втыкании в USB ничего не находит (даже встроенный CD-ROM с "дровами" под винду). В Винде же всё работает.

Kubuntu 12.04.

Спасибо за ответы.

+1
lord_i - 27 Май, 2013 - 21:42
Изображение пользователя lord_i.

Some Linux Kernel 3.8.1 changes and improvements:
usb: musb: fix dependency on transceiver driver
USB: usb-storage: unusual_devs update for Super TOP SATA bridge
USB: storage: properly handle the endian issues of idProduct
USB: option: add Huawei "ACM" devices using protocol = vendor
USB: option: add Yota / Megafon M100-1 4g modem
USB: option: add and update Alcatel modems
And more!

+1
DEamON - 27 Май, 2013 - 22:39
Изображение пользователя DEamON.

Перевожу на русский: "Установите новое ядро, там поддержка этого модема добавлена"

0
atlantstar - 27 Май, 2013 - 22:50

Спасибо. Понял. Попробую.
По результатам отпишусь.

0
atlantstar - 28 Май, 2013 - 02:22

Ничего из вышеперечисленного не делал.
Провёл апгрейд системы и программ (с помощью Muon update manager).
Модем действительно сам определился и появился в соединениях (как "Мобильное соединение")
Прописал сделал настройки под Мегафон:
номер *99#
имя пользователя и пароль: gdata
APN: internet
тип: любое соединение

PPP: галки на разрешение всех сжатий.
Ipv4-адрес / Метод: Автоматически (PPP)
Ipv6-адрес / Метод: Отключено

по Speedtest выдал скорость 25Мб/с, что соответствует сетям 4G (LTE)

Теперь вопросы:
1) Модем определяется секунд через 20 после его втыкания в USB. Почему так долго?
2) Посоветуйте программу учёта траффика с напоминанием (у меня 50 мег в день, потом скорость режет).
3) Уровень сигнала постоянно показывает 0%. почему (потому что не WiFi)?
4) Не понятно, какая сеть подключена в данный момент: 2G, 3G, или 4G (LTE). Как узнать? (понятно, что по скорости, но хотелось бы знать заранее)
5) Если в настройках соединения ставлю галку: "системное соединение", то наотрез отказывается подключаться. Почему?
6) если модем вытащить а потом вставить обратно, то он перестаёт определяться. Приходится перезагружать. Как исправить?

+1
rlepish - 28 Май, 2013 - 18:13
+2
kdemon - 29 Май, 2013 - 14:57

1) Модем определяется секунд через 20 после его втыкания в USB. Почему так долго?
При подключении модем определяется как CD-ROM, флэш-накопитель (если имеется) и как собственно модем. Убедиться в этом можно выполнив lsusb до подключения и после подключения модема. Появятся новые устройства типа ttyUSB0, ttyUSB1, ttyUSB2. Поищите в интернете как послать в модем нужную AT-команду, например
AT^U2DIAG=0 (устройство в режиме только модем)
AT^U2DIAG=1 (устройство в режиме модем + CD-ROM)
AT^U2DIAG=255 (устройство в режиме модем + CD-ROM + Card Reader)
AT^U2DIAG=256 (устройство в режиме модем + Card Reader).

2) Посоветуйте программу учёта траффика с напоминанием (у меня 50 мег в день, потом скорость режет).
Modem Manager GUI (не путать с демоном modemmanager)

-1
Michael72 - 29 Май, 2013 - 23:42
Изображение пользователя Michael72.

Поищите в интернете как послать в модем нужную AT-команду, например
AT^U2DIAG=0 (устройство в режиме только модем)
AT^U2DIAG=1 (устройство в режиме модем + CD-ROM)
AT^U2DIAG=255 (устройство в режиме модем + CD-ROM + Card Reader)
AT^U2DIAG=256 (устройство в режиме модем + Card Reader).

Не опасно такие команды посылать?

+1
kdemon - 30 Май, 2013 - 11:20

Не знаю. Одно время экспериментировал. Вроде ничего катастрофического не произошло.

0
Buy - 28 Май, 2013 - 18:41

> 1) Модем определяется секунд через 20 после его втыкания в USB. Почему так долго?

Как ты определяешь что он определился через 20с ? Если по тому что сразу после втыка нет инета, то это не верный способ, модем тратит еще какое-то время на обмен данными с базовой станцией и регистрации в сети LTE (даже если ты еще не жал кнопку connect).

> 2) Посоветуйте программу учёта траффика

Я использую knemo

> 6) если модем вытащить а потом вставить обратно, то он перестаёт определяться. Приходится перезагружать. Как исправить?

У меня так было с 3G модемом, в папке /dev есть ссылки устройств ttyUSB0 ttyUSB1 (в моем случае так было), при втыке они создаются, а при вытаскивании они должны удаляться, но у меня не удалялись, приходилось удалять в ручную. Иначе создавались ttyUSB2 и ttyUSB3 в дополнение к старым и ничего не работало. Проверь как это у тебя: перевоткни модем (можно пару раз), посмотри выводdmesg (только конец естественно!). Будет видно какие устройства создаются и что происходит.
Вообще это проблема драйвера, у меня уже нет этой проблемы.

0
Michael72 - 31 Май, 2013 - 20:38
Изображение пользователя Michael72.

> 2) Посоветуйте программу учёта траффика
Я использую knemo

А у меня за прошедшее время статистику не показывает -
> 6) если модем вытащить а потом вставить обратно, то он перестаёт определяться. Приходится перезагружать. Как исправить?
...
приходилось удалять в ручную.

Я бы порекомендовал указывать вместо /dev/ttyUSBx на точное устройство /dev/serial/by-id/xxxxx или usb-слот /dev/serial/by-path/yyyyy. Например у меня:
$ ls -l /dev/serial/by-id/
итого 0
lrwxrwxrwx 1 root root 13 марта  1 18:13 usb-FTDI_USB__-__Serial-if00-port0 -> ../../ttyUSB0
lrwxrwxrwx 1 root root 13 марта  1 18:13 usb-ZTE__Incorporated_ZTE_CDMA_Tech-if00-port0 -> ../../ttyUSB1                                                                                              
lrwxrwxrwx 1 root root 13 марта  1 18:13 usb-ZTE__Incorporated_ZTE_CDMA_Tech-if01-port0 -> ../../ttyUSB2                                                                                              
lrwxrwxrwx 1 root root 13 марта  1 18:13 usb-ZTE__Incorporated_ZTE_CDMA_Tech-if02-port0 -> ../../ttyUSB3                                                                                              
lrwxrwxrwx 1 root root 13 марта  1 18:13 usb-ZTE__Incorporated_ZTE_CDMA_Tech-if03-port0 -> ../../ttyUSB4                                                                                              
lrwxrwxrwx 1 root root 13 марта  1 18:13 usb-ZTE__Incorporated_ZTE_CDMA_Tech-if04-port0 -> ../../ttyUSB5
В данном случае выбираю /dev/serial/by-id/usb-ZTE__Incorporated_ZTE_CDMA_Tech-if00-port0

0
atlantstar - 30 Май, 2013 - 17:26

Модем определяется секунд через 20 после его втыкания в USB - через 20-25 сек он появляется в "сетевых подключениях" именно как модем.
Как CD не определяется в принципе.
После выдёргивания в "сетевых подключениях" пропадает сразу.
Подключаю к сетям вручную. И-нет появляется секунд через 7-10 (как раз время на обмен данными со станцией).
Всем спасибо. На днях попробую всё проделать, отпишусь о результатах.

+1
Buy - 2 Июнь, 2013 - 18:31

А у меня за прошедшее время статистику не показывает

А у меня показывает за каждый час (за сегодня), сутки, неделю, месяц, год ))) По правой кнопке мыши по значку в трее -> Configure Knemo -> на вкладках правее Statistics ставим галку "активировать". Просмотр статистики: по правой кнопке мыши по значку в трее -> Show statistics.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры