Неудовлетвоенные зависимости при обновлении [Решено]

При обновлении выдает:
Пакеты, имеющие неудовлетворённые зависимости:
kdepimlibs-dbg : Зависит: libakonadi-xml4 (= 4:4.12.0-0ubuntu1~ubuntu13.10~ppa1) но он не установлен
E: Неудовлетворённые зависимости. Попытайтесь использовать -f

sudo apt-get install -f пишет:
Распаковывается пакет libakonadi-xml4 (из файла …/libakonadi-xml4_4%3a4.12.0-0ubuntu1~ubuntu13.10~ppa1_i386.deb) …
dpkg: ошибка при обработке параметра /var/cache/apt/archives/libakonadi-xml4_4%3a4.12.0-0ubuntu1~ubuntu13.10~ppa1_i386.deb (--unpack):
попытка перезаписать «/usr/lib/libakonadi-xml.so.4», который уже имеется в пакете kdepim-runtime 4:4.11.3-0ubuntu0.1~ubuntu13.10~ppa1
При обработке следующих пакетов произошли ошибки:
/var/cache/apt/archives/libakonadi-xml4_4%3a4.12.0-0ubuntu1~ubuntu13.10~ppa1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Как побороть?

+1
DarkneSS - 10 Январь, 2014 - 23:40
Изображение пользователя DarkneSS.

sudo dpkg -r kdepim-runtime
sudo apt-get install -f

+2
a.ozol - 11 Январь, 2014 - 12:27

dpkg: проблемы с зависимостями не позволяют удалить пакет kdepim-runtime:
akonadi-facebook зависит от kdepim-runtime.
libkopete4 зависит от kdepim-runtime.
libkdepim4 зависит от kdepim-runtime (>= 4:4.10.2).
libmailimporter4 зависит от kdepim-runtime (>= 4:4.10.2).
python3-pykde4 зависит от kdepim-runtime, однако:
  Пакет kdepim-runtime будет удалён.
libkdepimdbusinterfaces4 зависит от kdepim-runtime (>= 4:4.10.2).
korganizer зависит от kdepim-runtime (>= 4:4.10.2), однако:
  Пакет kdepim-runtime будет удалён.
kopete зависит от kdepim-runtime, однако:
  Пакет kdepim-runtime будет удалён.
libmessagecore4 зависит от kdepim-runtime (>= 4:4.10.2).
kmail зависит от kdepim-runtime (>= 4:4.10.2), однако:
  Пакет kdepim-runtime будет удалён.
kdepim-strigi-plugins зависит от kdepim-ru
dpkg: ошибка при обработке параметра kdepim-runtime (--remove):
проблемы с зависимостями — не удаляется
При обработке следующих пакетов произошли ошибки:
kdepim-runtime

+2
MacLeod - 11 Январь, 2014 - 16:29
Изображение пользователя MacLeod.

sudo dpkg -r --force-depends kdepim-runtime

+2
a.ozol - 11 Январь, 2014 - 20:12

Помогло.
Удалил так пакет, потом
sudo apt-get install -f
и дообновился:
sudo apt-get dist-upgrade
И все встало на место (пока не дообновился были глюки).

0
dyug - 11 Январь, 2014 - 22:30

Распаковывается пакет libakonadi-xml4 (из файла …/libakonadi-xml4_4%3a4.12.0-0ubuntu1~ubuntu13.10~ppa1_i386.deb) …
dpkg: ошибка при обработке параметра /var/cache/apt/archives/libakonadi-xml4_4%3a4.12.0-0ubuntu1~ubuntu13.10~ppa1_i386.deb (--unpack):
попытка перезаписать «/usr/lib/libakonadi-xml.so.4», который уже имеется в пакете kdepim-runtime 4:4.11.3-0

А вот теперь я в обалдении
обращаю внимание
libakonadi-xml4_4%3a4.12.0
kdepim-runtime 4:4.11.3-0
то есть либаконади от 4.12 ставится на кдепим-рунтайм от 4.11.3?
И заработало???????????????
Ой, глюки будут... :-(

УППППСССС.... виноват, сунулся посмотреть таки да,
aptitude show kde-runtime
Пакет: kde-runtime                              
Состояние: установлен
Автоматически установлен: нет
Версия: 4:4.11.3-0ubuntu0.1

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры