Папка .kde не удаляется через sudo [Решено]

Изображение пользователя krolik.

Всем привет на форуме! У меня такая проблема, на отдельном винчестере, есть такая папка .kde, я её когда то сохранил, теперь она не востребована, так вот она ни как не удаляется через sudo! Ввожу в терминале sudo rm -r .kde, и она зараза не хочет удаляться. Пробовал даже заходить ctr+alt+f1, логниться, и там вводить ту же команду через судо, ничего не помогает. Перелопатил весь инет,не нашёл ответа по данной проблеме. Через лайв-сд так же трабла. Форумчане помогите решить эту задачу!

0
lord_i - 2 Март, 2014 - 12:53
Изображение пользователя lord_i.

покажите ls -al из того места, где лежит .kde
Скорее всего что-то с правами доступа. Но, если не хочется разбираться, поставьте mc, запустите его из под рута и удаляйте все что из коммандной строки не удаляется.

0
krolik - 2 Март, 2014 - 12:52
Изображение пользователя krolik.

[email protected]:~$ cd /media/klon/ФАЙЛЫ
[email protected]:/media/klon/ФАЙЛЫ$ ls -al
итого 16
drwxr-x--T 4 slava slava 4096 Дек 27 15:43 .
drwxr-x--- 7 slava slava 4096 Мар 1 22:51 ..
drwxr-x--T 5 slava slava 4096 Сен 28 2012 build_gimp
drwxr-x--T 7 slava slava 4096 Июл 6 2013 .kde
[email protected]:/media/klon/ФАЙЛЫ$

0
krolik - 2 Март, 2014 - 12:59
Изображение пользователя krolik.

Пробовал даже из mc удалить эту папку, не удаляется к сожалению. Ввожу sudo mc, ввожу пароль, запускается mc, удаляю эту папку и не помогает. пишет пропустить, пропустить всё, и на этом всё заканчивается. Папка заразная так там и остаётся.

0
lord_i - 2 Март, 2014 - 13:36
Изображение пользователя lord_i.

Прежде чем идти дальше - проверьте раздел через fsck, предварительно его отмонтировав. Если найдутся ошибки - надо их исправить (читайте опции fsck). Возможно после этого папка удалится.

0
lord_i - 2 Март, 2014 - 13:48
Изображение пользователя lord_i.

Если с разделом все нормально покажите lsattr из того места, где лежит .kde

0
krolik - 2 Март, 2014 - 14:13
Изображение пользователя krolik.

Вот выдало при вводе комманды fsck

[email protected]:~$ sudo fsck /dev/sda3
[sudo] password for slava:
fsck из util-linux 2.20.1
e2fsck 1.42.8 (20-Jun-2013)
/dev/sda3: clean, 72969/19537920 files, 16148487/78142160 blocks
[email protected]:~$

Далее команда

[email protected]:~$ lsattr /media/klon/ФАЙЛЫ/
-------------e-- /media/klon/ФАЙЛЫ/build_gimp
[email protected]:~$

0
lord_i - 2 Март, 2014 - 14:47
Изображение пользователя lord_i.

Мистика. На вид все хорошо...
Давайте такой финт попробуем.
ls -i получите номер иноды для .kde (слева от названия)
затем
find . -inum номер -exec rm –i {} \;

Стоп. В выводе lsattr я не вижу .kde Надо чтоб оно там было. Надо делать lsattr -a поскольку название файла с точки начинается

0
krolik - 2 Март, 2014 - 15:02
Изображение пользователя krolik.

[email protected]:~$ lsattr -a /media/klon/ФАЙЛЫ/
-------------e-- /media/klon/ФАЙЛЫ/.kde
-------------e-- /media/klon/ФАЙЛЫ/.
-------------e-- /media/klon/ФАЙЛЫ/build_gimp
-------------e-- /media/klon/ФАЙЛЫ/..
[email protected]:~$ lsattr -a /media/klon/ФАЙЛЫ/.kde/
-------------e-- /media/klon/ФАЙЛЫ/.kde/shutdown
lsattr: Неподдерживаемая операция While reading flags on /media/klon/ФАЙЛЫ/.kde/tmp-Mustang
lsattr: Неподдерживаемая операция While reading flags on /media/klon/ФАЙЛЫ/.kde/cache-Mustang
-------------e-- /media/klon/ФАЙЛЫ/.kde/.
-------------e-- /media/klon/ФАЙЛЫ/.kde/.directory
-------------e-- /media/klon/ФАЙЛЫ/.kde/data
-------------e-- /media/klon/ФАЙЛЫ/.kde/share
lsattr: Неподдерживаемая операция While reading flags on /media/klon/ФАЙЛЫ/.kde/socket-Mustang
-------------e-- /media/klon/ФАЙЛЫ/.kde/..
-------------e-- /media/klon/ФАЙЛЫ/.kde/Autostart
-------------e-- /media/klon/ФАЙЛЫ/.kde/env
[email protected]:~$

0
lord_i - 2 Март, 2014 - 15:09
Изображение пользователя lord_i.

Мда ... А вот теперь таки:
Мистика. На вид все хорошо...
Давайте такой финт попробуем.
ls -ai получите номер иноды для .kde (слева от названия)
затем
sudo find . -inum номер -exec rm –i {} \;

0
krolik - 2 Март, 2014 - 15:19
Изображение пользователя krolik.

Всё сделал как вы написали, вот команда

[email protected]:/media/klon/ФАЙЛЫ$ ls -ia
3407873 . 2 .. 3407874 build_gimp 3408313 .kde
[email protected]:/media/klon/ФАЙЛЫ$ find . -inum 3408313 -exec rm –i {} \;
rm: невозможно удалить «–i»: Нет такого файла или каталога
rm: невозможно удалить «./.kde»: Это каталог
[email protected]:/media/klon/ФАЙЛЫ$
Может команду rm с опцией -r писать?

0
krolik - 2 Март, 2014 - 15:33
Изображение пользователя krolik.

Проблема так же появляется когда удаляю папку build_gimp, она как бы удалилась, но при следующем запуске системы, она вновь появляется. Кажется проблемы с правами. Хотя права на эти папки мои.

0
lord_i - 2 Март, 2014 - 15:50
Изображение пользователя lord_i.

Что то тут не то изначально. Как монтируется раздел? покажите df и mount -l (укажите о каком устройстве, например sda2, идет речь)

0
krolik - 2 Март, 2014 - 15:59
Изображение пользователя krolik.

[email protected]:~$ df
Файл.система 1K-блоков Использовано Доступно Использовано% Cмонтировано в
/dev/sdb2 31050732 5391916 24058460 19% /
none 4 0 4 0% /sys/fs/cgroup
udev 1019416 12 1019404 1% /dev
tmpfs 206344 1136 205208 1% /run
none 5120 0 5120 0% /run/lock
none 1031716 808 1030908 1% /run/shm
none 102400 20 102380 1% /run/user
/dev/sdb1 1889480664 62828532 1730649012 4% /home
/dev/sda3 307532728 59558036 247958308 20% /media/klon
[email protected]:~$ mount -l
/dev/sdb2 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/cgroup type tmpfs (rw)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
none on /sys/fs/pstore type pstore (rw)
/dev/sdb1 on /home type ext4 (rw)
systemd on /sys/fs/cgroup/systemd type cgroup (rw,noexec,nosuid,nodev,none,name=systemd)
/dev/sda3 on /media/klon type ext4 (rw)
[email protected]:~$

0
lord_i - 2 Март, 2014 - 16:07
Изображение пользователя lord_i.

У меня больше вариантов нет. :( Примонтирован нормально, атрибуты нормальные. Файловая система без ошибок ... А если создать на этом винте директорий а потом удалить - получится? Покажите какие сообщения выдает система при удалении ./kde . Еще можно глянуть на вывод dmesg tail сразу после попытки удаления. Может аппаратная проблема ...

+1
MacLeod - 2 Март, 2014 - 16:40
Изображение пользователя MacLeod.

sudo chown -R user:user .kde/
sudo chmod -R 777 .kde/

Пробовали перед удалением? Данные операции проходят без ошибок?
Пробовали перенести каталог в другое место, не содержащее в путях кириллицы, через mv?

0
lord_i - 2 Март, 2014 - 16:44
Изображение пользователя lord_i.

так выше же было уже:
[email protected]:~$ cd /media/klon/ФАЙЛЫ
[email protected]:/media/klon/ФАЙЛЫ$ ls -al
итого 16
drwxr-x--T 4 slava slava 4096 Дек 27 15:43 .
drwxr-x--- 7 slava slava 4096 Мар 1 22:51 ..
drwxr-x--T 5 slava slava 4096 Сен 28 2012 build_gimp
drwxr-x--T 7 slava slava 4096 Июл 6 2013 .kde
[email protected]:/media/klon/ФАЙЛЫ$

и удаляет из под рута ...

0
MacLeod - 2 Март, 2014 - 17:01
Изображение пользователя MacLeod.

Интересна была реакция системы, но по последним сообщениям - уже не актуально.

0
krolik - 2 Март, 2014 - 16:44
Изображение пользователя krolik.

Когда создаю папку "Proba", и за тем следом удалить её, всё работает удаляется. Но стоит попробовать создать папку "Proba", а затем удалить папку .kde, начинается косяк, уже не только папку .kde не удалить, но и ту что только что создал. Вот такая вот трабла.

0
lord_i - 2 Март, 2014 - 16:48
Изображение пользователя lord_i.

Очень похоже на аппаратную ошибку винта, после которой все переключается в ридонли. Покажите сразу после отказа удаления вывод dmesg tail

0
krolik - 2 Март, 2014 - 16:55
Изображение пользователя krolik.

У меня в консоли не хватает яко бы места, и часть выхлопа урезает.

+1
lord_i - 2 Март, 2014 - 17:00
Изображение пользователя lord_i.


EXT4-fs error (device sda3): ext4_journal_check_start:56: Detected aborted journal
EXT4-fs (sda3): Remounting filesystem read-only

Жопа винту. В мусорник.
ЗЫ Есть еще вариант что жопа усб-шному карману или усб кабелю. Проверьте путем последовательной замены.

0
krolik - 2 Март, 2014 - 17:00
Изображение пользователя krolik.

Но он же работает, создаются папки, удаляются, и всё такое прочее. Спасибо что помог, пусть доживает свой век!))

+1
lord_i - 2 Март, 2014 - 17:08
Изображение пользователя lord_i.

Та область куда записаны файлы ./kde скорее всего имеет нечитаемые сектора. Когда оттуда идет попытка считывания со множественными ошибками система перемонтирует в ридонли. можно глянуть смарт этого тела через
sudo smartctl -a /dev/sda
тогда будет яснее картина.

0
krolik - 2 Март, 2014 - 17:18
Изображение пользователя krolik.

[email protected]:~$ sudo umount /dev/sda3
[sudo] password for slava:
[email protected]:~$ sudo smartctl -a /dev/sda
sudo: smartctl: команда не найдена
[email protected]:~$

0
lord_i - 2 Март, 2014 - 17:30
Изображение пользователя lord_i.

sudo apt-get install smartmontools

0
alex286 - 2 Март, 2014 - 21:37
Изображение пользователя alex286.

Та область куда записаны файлы ./kde скорее всего имеет нечитаемые сектора. А в самой папке ./kde есть файлы? В мс удалять все последовательно пока не найдешь неудаляемый ("причинный")..Переименовать его в цифру, например "1"... и удалить..

0
krolik - 2 Март, 2014 - 21:57
Изображение пользователя krolik.

Проблема так же появляется когда удаляю папку build_gimp, она как бы удалилась, но при следующем запуске системы, она вновь появляется. Кажется проблемы с правами. Хотя права на эти папки мои.
Они в новь появляются, сколько ни удаляй. Файлов много, и каждый файл по одной удалять, до усрачки можно.

0
MacLeod - 2 Март, 2014 - 17:01
Изображение пользователя MacLeod.

Я бы попробовал отключить/включить журналирование.

0
krolik - 2 Март, 2014 - 17:05
Изображение пользователя krolik.

А какая команда есть для проверки целостности винта? Проверить на наличие битых секторов, на сколько он посыпался, и всё такое.

0
lord_i - 2 Март, 2014 - 17:35
Изображение пользователя lord_i.

sudo badblocks -vs /dev/sda

0
krolik - 2 Март, 2014 - 17:35
Изображение пользователя krolik.
Я не спец в командной среде, вот выложил выхлоп.
+1
lord_i - 2 Март, 2014 - 18:12
Изображение пользователя lord_i.

Как по мне - винт как таковой в порядке. На это косвенно указывает огромное количество Hardware_ECC_Recovered при отсутствии Total_Pending_Sectors и Reallocated_Event_Count (коллеги поправьте если ошибаюсь) Скорее всего проблема может быть
- в усб кармане
- в шнуре усб
- в усб гнезде компа.
Если есть возможность - подцепите винт непосредственно к компу напрямую через сата и попробуйте его в работе.

Я почему-то все время считаю что проблеммный винт внешнй, подключенный через усб. Посмотрел переписку - скорее всего я ошибаюсь.
Проблема может быть в sata кабеле или в sata контроллере на материнке. Можно попробовать переткнуть в другое гнездо, поменять кабель.

0
krolik - 2 Март, 2014 - 18:59
Изображение пользователя krolik.

[email protected]:~$ sudo badblocks -vs /dev/sda
Checking blocks 0 to 312571223
Checking for bad blocks (read-only test): done
Pass completed, 0 bad blocks found. (0/0/0 errors)
[email protected]:~$
Всё чисто! Ну и загадка! С разъёмами сата всё в порядке.

0
lord_i - 2 Март, 2014 - 19:49
Изображение пользователя lord_i.

Вот такие постоянно повторяющиеся ошибки
[ 106.846873] ata3: EH in SWNCQ mode,QC:qc_active 0x7 sactive 0x7
[ 106.846880] ata3: SWNCQ:qc_active 0x2 defer_bits 0x5 last_issue_tag 0x1
[ 106.846880] dhfis 0x2 dmafis 0x2 sdbfis 0x0
[ 106.846884] ata3: ATA_REG 0x41 ERR_REG 0x84
[ 106.846887] ata3: tag : dhfis dmafis sdbfis sactive
[ 106.846890] ata3: tag 0x1: 1 1 0 1
[ 106.846900] ata3.00: exception Emask 0x1 SAct 0x7 SErr 0x400000 action 0x6 frozen
[ 106.846902] ata3.00: Ata error. fis:0x21
[ 106.846906] ata3: SError: { Handshk }
[ 106.846910] ata3.00: failed command: READ FPDMA QUEUED
[ 106.846917] ata3.00: cmd 60/40:00:5f:00:88/00:00:1f:00:00/40 tag 0 ncq 32768 in
[ 106.846917] res 41/84:0c:c7:00:44/84:00:11:00:00/40 Emask 0x10 (ATA bus error)
[ 106.846921] ata3.00: status: { DRDY ERR }
[ 106.846924] ata3.00: error: { ICRC ABRT }
[ 106.846927] ata3.00: failed command: WRITE FPDMA QUEUED
[ 106.846934] ata3.00: cmd 61/f0:08:c7:00:44/00:00:11:00:00/40 tag 1 ncq 122880 out
[ 106.846934] res 41/84:0c:c7:00:44/84:00:11:00:00/40 Emask 0x10 (ATA bus error)
[ 106.846937] ata3.00: status: { DRDY ERR }
[ 106.846940] ata3.00: error: { ICRC ABRT }
[ 106.846943] ata3.00: failed command: READ FPDMA QUEUED
[ 106.846950] ata3.00: cmd 60/80:10:9f:00:88/00:00:1f:00:00/40 tag 2 ncq 65536 in
[ 106.846950] res 41/84:0c:c7:00:44/84:00:11:00:00/40 Emask 0x10 (ATA bus error)
[ 106.846953] ata3.00: status: { DRDY ERR }
[ 106.846956] ata3.00: error: { ICRC ABRT }
[ 106.846961] ata3: hard resetting link

практически однозначно указывают на проблеммы в тракте sata. Откуда они берутся удаленно выяснить весьма сложно. Может южный мост перегревается. Может плохой контакт в кабеле сата или сам кабель плохой ... Копайте. Проблема чисто аппаратная.

ЗЫ тест бэдблокс в том виде как он был запущен тестирует только чтение. Возможно, ошибки при записи вылазят...

0
krolik - 2 Март, 2014 - 20:19
Изображение пользователя krolik.

Я попробую переставить кабеля, на другой разъём сата, но это позже. Отпишусь потом, а по поводу бэдблокс, как его запустить в режиме записи?

0
lord_i - 2 Март, 2014 - 20:36
Изображение пользователя lord_i.

Бэдблокс в режиме записи убъет все данные. На данном этапе, учитывая что чтение не вызывает нареканий, это излишне. Полный расклад по бэдблокс можно получить выполнив
man badblocks или тут

0
Гость - 2 Март, 2014 - 19:36

С LiveCD не пробовали решить эту проблему?

0
krolik - 2 Март, 2014 - 20:17
Изображение пользователя krolik.

Пробовал, увы бесполезно.

0
MacLeod - 2 Март, 2014 - 20:59
Изображение пользователя MacLeod.

Спросил друга-железячника:
"тяни инфу и неси на помойку"
"badblocks показывает 0, потому что винт запихнул беды в G-List, но инфа повредилась. Скорее всего дохнет голова"

0
lord_i - 2 Март, 2014 - 21:05
Изображение пользователя lord_i.

А как-же смарт? С девственными Total_Pending_Sectors и Reallocated_Event_Count ???

0
DarkneSS - 2 Март, 2014 - 21:08
Изображение пользователя DarkneSS.

Насколько я понимаю, смарт мог быть не активен все 100% срока использования винчестера. Кроме того, он не идеален :(

0
lord_i - 2 Март, 2014 - 21:43
Изображение пользователя lord_i.

Как это "неактивен"??? Он же другие параметры вполне себе считает ... То что не идеален - согласен, но при издыхании головы, хоть пару секторов бы попало под Pending_Sectors или Reallocated_Event ...

Не, это на 99% проблемы кабеля или контроллера на матери. Вот тут про ATA bus error, которые у него сыпятся как из рога изобилия, совершенно недвусмысленно сказано:
These are problems with the cables and connections to the drive, both power and data, or the quality of the power supplied. If your errors match one of these, then almost certainly, your drive is completely fine.

и еще:

The presence of BadCRC (которых в смарте уйма) is a pretty good indicator of a poor quality SATA cable. However, if a better cable does not solve the issue, then it is probably a power problem (loose power cable or backplane connection, poor connectors, poor power splitter, overloaded power supply, too many drives on power rail, bad power supply, etc).

Советуют еще обратить внимание на питание. То есть если плохо блоку питания - тоже может быть такая картина.

0
DarkneSS - 2 Март, 2014 - 22:00
Изображение пользователя DarkneSS.

По крайней мере, я помню, что для обоих моих винчестеров его надо было включить. Что я когда-то и сделал.

0
krolik - 2 Март, 2014 - 22:02
Изображение пользователя krolik.

Всем кто откликнулся на мой зов, огромное большое спасибо! Я поступлю проще, я его форматну в Ext4, и посмотрим что из этого выйдет. Думаю проблема с какими то правами.

0
DarkneSS - 2 Март, 2014 - 22:07
Изображение пользователя DarkneSS.

Проблема с правами разрешилась бы через sudo. Или повреждена файловая система, или само железо.

+1
lord_i - 2 Март, 2014 - 22:08
Изображение пользователя lord_i.

Дело ваше, но ничего хорошего из этого не выйдет. Симптомы совершенно однозначно показывают на какую-то из этих проблем
- сата кабель
- сата контроллер
- питание винчестера/всего компьютера

Форматированием такое не поборешь.

0
krolik - 10 Март, 2014 - 12:04
Изображение пользователя krolik.

Всем снова привет! Ещё раз всем спасибо за поддержку! Разобрал я свой компьютер по частям, перевоткнул шлейф на другой сата разъём винчестера, всё протёр, контакты почистил аккуратненько! И всё это я собрал назад, и упс системка не запкскалась, пришлось граб восстанавливать! В целом поставил всё заново! Форматнул тот винчестер. Всё работает, никаких нареканий! Так и не выяснил в чём была проблема. Но главное всё работает!))) (Решено)

0
Chibiko - 10 Март, 2014 - 12:17
Изображение пользователя Chibiko.

Какой-то слишком радикальный метод удаления директории..

0
lord_i - 10 Март, 2014 - 17:54
Изображение пользователя lord_i.

И ATA bus error по dmesg нет?

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры