Слетела русификация KDE. Контекстное меню на английском

Изображение пользователя Priestone.

Вот такая беда. К тому же в К-меню пункты Избранное, Выполнить команду и Выход заменились на Favorites, Run command.. и Leave.

Кто-нибудь сталкивался с таким? Как решали?

0
Priestone - 22 Март, 2014 - 07:05
Изображение пользователя Priestone.

0
primorets - 23 Март, 2014 - 13:26
Изображение пользователя primorets.

Вчера такая же фигня после обновления случилась. Кубунту 14.04. Спокойно жду, когда разработчики исправят.

0
Fierta - 23 Март, 2014 - 14:16
Изображение пользователя Fierta.

В 14.04 точно так же стало после обнов.

0
DarkneSS - 22 Март, 2014 - 10:39
Изображение пользователя DarkneSS.

Проверить приоритеты локализаций в параметрах системы.

0
RexSep - 19 Апрель, 2014 - 14:36

А где искать параметры системы (особенно, если они по-английски)?

0
DarkneSS - 19 Апрель, 2014 - 14:53
Изображение пользователя DarkneSS.

System settings, Locale.

+1
dyug - 22 Март, 2014 - 12:02

Версия? случаем не 14.04?
тогда все в порядке, обрывать руки репозитарщикам.

0
Priestone - 24 Март, 2014 - 19:37
Изображение пользователя Priestone.

Всё верно. Уже и забыл про такие "шутки". Смиренно жду. Как-никак выход скоро. Откатился на 13.10, поставил 14.04 на виртуалку, обновляю регулярно, как выровняется - пойду на неё. Уж больно симпатишно там виджет NM наворотили :-)
Спасибо за напоминалку.

0
dyug - 25 Март, 2014 - 11:31

главное, что они еще туда засунули бету 4.13 бета, она же 4.12.90, а не релиз.
думаю, к релизу файлы русского обновятся нормально.

В конце концов - сейчас стадия тестирования, а не релиз, посему требовать от них, чтоб было ВСЕ хорошо, как то в общем глупо. :-)

Что не отменяет жалоб на глюки, и даже в общем требуется. :-)
/раз уж перешел на версию для тестирования/

+1
dyug - 12 Апрель, 2014 - 11:11

о, сегодня, после очередного обновления, как и ожидалось, все починилось. :-)

0
Platon - 3 Июнь, 2014 - 10:13
Изображение пользователя Platon.

Сегодня у меня слетела русская локаль, обнов не ставил, приоритеты системного языка не менял(стоит русский) страна Казахстан, поменял на страна по-умолчанию Россия, однако 0 эмоций. Локали приложений остались русскими, т.е. слетела именно локаль системы. в период RC и beta-релизов такое логично обкатка системы, но сейчас финальный релиз.
У них вероятно реп упал:
sudo apt-get install aspell-ru kde-l10n-ru language-pack-kde-ru language-pack-kde-ru-base language-pack-ru language-pack-ru-base myspell-ru language-pack-gnome-ru-base language-pack-gnome-ru manpages-ru firefox-locale-ru libreoffice-l10n-ru

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package language-pack-kde-ru-base is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
language-pack-ru-base language-pack-ru language-pack-gnome-ru-base language-pack-gnome-ru
E: Package 'language-pack-kde-ru-base' has no installation candidate
E: Unable to locate package manpages-ru


и это:
http://archive.canonical.com/ubuntu/dists/trusty/Release.gpg Cannot initiate the connection to archive.canonical.com:80 (2001:67c:1360:8c01::16). - connect (101: Network is unreachable) [IP: 2001:67c:1360:8c01::16 80] http://archive.canonical.com/ubuntu/dists/trusty/partner/i18n/Translation-en Cannot initiate the connection to archive.canonical.com:80 (2001:67c:1360:8c01::16). - connect (101: Network is unreachable) [IP: 2001:67c:1360:8c01::16 80] http://archive.canonical.com/ubuntu/dists/trusty/partner/i18n/Translation-ru Cannot initiate the connection to archive.canonical.com:80 (2001:67c:1360:8c01::16). - connect (101: Network is unreachable) [IP: 2001:67c:1360:8c01::16 80] http://archive.canonical.com/ubuntu/dists/trusty/partner/binary-amd64/Packages Cannot initiate the connection to archive.canonical.com:80 (2001:67c:1360:8c01::16). - connect (101: Network is unreachable) [IP: 2001:67c:1360:8c01::16 80] http://archive.canonical.com/ubuntu/dists/trusty/partner/binary-i386/Packages Cannot initiate the connection to archive.canonical.com:80 (2001:67c:1360:8c01::16). - connect (101: Network is unreachable) [IP: 2001:67c:1360:8c01::16 80]
В крусадере файлы имевшие кирилилческое написание преввратились в Крякозябер - при этом не переименовать / не удалить не дает "file not exist" - в долфине все нормально.
После выставления и удаления в списке приоритетов English(U.S.) перезагрузился и русская локаль вернулась, но сервер русской локализации по прежнему не доступен - чудно как-то.

0
dyug - 3 Июнь, 2014 - 10:17

эмм... у вас ipv6 используется?
фраза "connect (101: Network is unreachable)" означает, что именно ваша машина не видит сети.
а "[IP: 2001:67c:1360:8c01::16 80]" говорит о том, что он стремится добраться до указанного адреса по ipv6. Предоставляет ли Ваш провайдер, и обеспечивается ли роутинг ipv6 в Вашей сети - мне не ведомо.
Знаю точно, мой провайдер знает и умеет, но не предоставляет. Ибо пока еще это намного больше проблем, чем преимуществ.

+1
Platon - 3 Июнь, 2014 - 12:00
Изображение пользователя Platon.

с провайдером у меня все аналогично "умеет, но не предоставляет"
в настройках connection editor IPv6 - галки на IPv6 is required for this connection не стоит.
С какого перепугу система запрашивает IPv6 не ясно - я лично её на это не настраивал. Возможно канониклы переводят свое хозяйство на IPv6 (Server Main).
Если поставить галку в IPv6 (Method:Automatic), то NM будет перезагружаться каждые 3 секунды(Connet activated/Connect disactivated), если немного изменить настройку на Method: Automatic(Only addresses), то все нормально - соединение стабильное.

0
rosenrot - 7 Июнь, 2014 - 15:20
Изображение пользователя rosenrot.

Если поставить галку в IPv6 (Method:Automatic), то NM будет перезагружаться каждые 3 секунды(Connet activated/Connect disactivated), если немного изменить настройку на Method: Automatic(Only addresses), то все нормально - соединение стабильное.

Спасибо добрый человек. А я то все голову ломаю, уже который месяц, почему соединение рвется постоянно....не каждые 3 секунды, но частенько.

Теперь и у меня отвалился русский язык. Если в локалях выбрать его, то пишет
You have the language with code 'ru' in your list of languages to use for translation but the localization files for it could not be found. The language has been removed from your configuration. If you want to add it again please install the localization files for it and add the language again.

0
rosenrot - 7 Июнь, 2014 - 15:33
Изображение пользователя rosenrot.

Это все американцы, со своими санкциями. :)

Главное никакой другой язык в локали и не добавить, все откатывается назад. Стоит только американ инглиш.

0
a_l_e_x_e_i - 7 Июнь, 2014 - 15:59
Изображение пользователя a_l_e_x_e_i.

Тоже самое, никакого азыка не поставить кроме английского, это после сегодняшнего обновления )))

0
rosenrot - 8 Июнь, 2014 - 12:26
Изображение пользователя rosenrot.

А после ребута, еще и страна поменялась на америку. Хорошо хоть русская раскладка еще жива.

+4
Лерыч - 8 Июнь, 2014 - 14:40
Изображение пользователя Лерыч.

Обновился буквально этой ночью, никаких проблем с локалью не увидел. Комп после этого перегружал (т.к. среди прочего обновились и ядра). Страна: системная локаль Россия; языки все на месте, предпочитаемым как был, так и остался русский, во всей системе все как было по-русски, так и осталось. Репозитории стандартные, никаких зеркал не добавлял.

Это все американцы, со своими санкциями. :)
Да пох:

:)))
+1
Fierta - 8 Июнь, 2014 - 14:40
Изображение пользователя Fierta.

Весёлая картинка :)))

+4
Лерыч - 8 Июнь, 2014 - 15:25
Изображение пользователя Лерыч.

Еще раз ребутнулся для надежности — нет, все языки на месте, по прежнему все по-русски.

Весёлая картинка :)))
Ага. :))

0
rosenrot - 8 Июнь, 2014 - 15:21
Изображение пользователя rosenrot.

Хехе, это точно)

Однако у меня все слетело, и вроде не у меня одного.

0
a_l_e_x_e_i - 8 Июнь, 2014 - 15:34
Изображение пользователя a_l_e_x_e_i.


и починить пока не удаётся

0
rosenrot - 8 Июнь, 2014 - 16:06
Изображение пользователя rosenrot.

Так точно(
Мало того еще и программы отказываются открывать файлы с кириллическими именами. Видят, но не открывают.

+1
a_l_e_x_e_i - 8 Июнь, 2014 - 16:56
Изображение пользователя a_l_e_x_e_i.

открытие программ я "полечил" так
export LC_ALL=ru_RU.UTF8
sudo update-locale LC_ALL=ru_RU.UTF8
перезагрузка, русский в системе есть, все работает, единственно все меню в системе на английском, жить можно.
Зато какой стимул для изучения языка потенциального неприятеля ))))))
дааааа, давненько я так плотно не сидел за проблемой, обычно последний год 10-15 минут в гугле и готово, а сейчас досих пор нет решения...

0
rosenrot - 8 Июнь, 2014 - 16:57
Изображение пользователя rosenrot.

О,спасибо.

Да уж, хоть английский и не очень хорошо знаю, но пока трудностей не возникает :)

+1
Гость - 10 Июнь, 2014 - 03:23

я просто удалил через ppa-purge реп ppa:kubuntu-ppa/ppa. он вернул старую версию kde-l10n-ru (плюс предыдущие версии некоторых пакетов), удалил из ~/.kde/env/ скрипт и по-новой настроил локаль в параметрах системы.

+4
Гость - 8 Июнь, 2014 - 22:08

Парни, подтвердите баг. Завели. Чем больше народу, тем быстрее фикс.

https://bugs.launchpad.net/kubuntu-ppa/+bug/1327527

0
rosenrot - 8 Июнь, 2014 - 23:25
Изображение пользователя rosenrot.

Подтвердил, на сколько позволяют мои познания языка :)

+3
Fierta - 8 Июнь, 2014 - 23:43
Изображение пользователя Fierta.

Как то странно, никаких косяков с локалью обновы не принесли.Но баг ваш подтвердил.

0
Гость - 10 Июнь, 2014 - 02:15

Как то странно, никаких косяков с локалью обновы не принесли
ppa:kubuntu-ppa/ppa подключен?

0
Platon - 10 Июнь, 2014 - 08:38
Изображение пользователя Platon.

у меня в источниках (KU 14.04 AMD64) этого PPA не подключено, однако, данный инцидент имел место.

0
Fierta - 10 Июнь, 2014 - 15:01
Изображение пользователя Fierta.

Нет, не подключен.

0
rosenrot - 10 Июнь, 2014 - 17:34
Изображение пользователя rosenrot.

У меня подключен.

0
Лерыч - 11 Июнь, 2014 - 01:40
Изображение пользователя Лерыч.

У меня нет.

+2
Гость - 11 Июнь, 2014 - 11:55

восстанови предыдущую версию kde-l10n-ru

0
rosenrot - 11 Июнь, 2014 - 13:32
Изображение пользователя rosenrot.

Сработало, спасибо за подсказку :)
Хотя это не отменяет наличие бага.

+2
Zloy_Ronin - 13 Июнь, 2014 - 01:18

Зашёл в ~/.kde/env/setlocale.sh

поставил:

export LANG=ru_RU.UTF-8
export LANGUAGE=ru:en

Баг ушёл. Может кому поможет.
P.S. В Локали нужно обязательно поставить страну Россия, когда ставлю Беларусь баг возвращается.

0
Fogma - 13 Июнь, 2014 - 22:58
Изображение пользователя Fogma.

не помогает. сбрасывается файл на прежние значения, в языках вылетает таже ошибка.
UPD:вопрос снят. проблема решена очередным обновлением. kubuntu-ppa и backports включены.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры