Снова проблемы с запуском Qualcomm Atheros AR8161 Gigabit Ethernet [1969:1091] (rev 10)

Изображение пользователя primorets.

После очередного обновления К 14.04 перестала запускаться сетевуха. И в этот раз не получается ни-че-го из попыток установить драйвер к ней и выйти в инет. На сайте производителя перепробовал всё, что там предлагается, но, в процессе установки, после команды make, всякий раз консоль выдаёт одно и то же:
[email protected]:~$ cd compat-drivers-2013-03-04-u

Неделю бьюсь, проклинаю то свою тупость, то разработчиков, то советчиков... Ну, это от усталости, скорее всего, такая реакция. Может, глаз уже замылился, прохожу мимо решения и не замечаю.
По-любому, не получается. Начинаю думать, что тот, кто упрекнул меня в том, что полез в незавершёнку, не имея достаточных знаний, был не так уж неправ...
Всё же, что делать? Ноутбук с usb-модемом работает, а вот к оптическому проводу подключиться не могу.
Да, в процессе "битвы" я уже снёс то, что на ноуте стояло, но упрямо записал дистрибутив 14.04 Бета2 на флешку и установил ОС на Тошибу. Как сделать из флешки репозиторий никак не могу вкурить. Бьюсь, короче, как в тесной печурке Лазо...
0
lord_i - 12 Апрель, 2014 - 10:01
Изображение пользователя lord_i.

Может make -i Вам поможет ...

0
primorets - 12 Апрель, 2014 - 10:33
Изображение пользователя primorets.

Сейчас попробую.

0
primorets - 12 Апрель, 2014 - 10:41
Изображение пользователя primorets.

Не, игнорирование нестыковок ничего не даёт, увы. Всё по-прежнему.

0
MacLeod - 12 Апрель, 2014 - 10:32
Изображение пользователя MacLeod.

Не соберется оно с этим ядром... Ядро новое, дровина - старая, в ней куча несовместимых (устаревших) конструкций, судя по вашему выводу.
А с kernel.org пробовали compat-drivers собрать? Если там нет обновленных - полагаю стоит подождать, релиз 14.04 через 5 дней, а там, глядишь, и допилят в ближайшее время.

0
primorets - 12 Апрель, 2014 - 10:33
Изображение пользователя primorets.

Похоже, что остаётся только ждать и надеяться...

0
primorets - 12 Апрель, 2014 - 10:44
Изображение пользователя primorets.

Драйвер compat-drivers-2013-03-04-u анонсирован,как новый, универсальный для всех ядер. Да, гладко было на бумаге...

0
MacLeod - 12 Апрель, 2014 - 11:03
Изображение пользователя MacLeod.

Вообще, оно для всех старых ядер, по идее.

Покажите, на всякий случай, вывод
lspci -nn | grep 'Network\|Ethernet'
и
dmesg | grep Atheros

0
primorets - 12 Апрель, 2014 - 12:22
Изображение пользователя primorets.

[email protected]:~$ dmesg | grep Atheros
[ 1.368089] alx 0000:07:00.0 eth0: Qualcomm Atheros AR816x/AR817x Ethernet [00:26:6c:11:69:c4]
[ 6.621288] ieee80211 phy0: Atheros AR9485 Rev:1 mem=0xffffc90010880000, irq=17
[ 8.988537] usb 1-1.2: Manufacturer: Atheros Communications

А на первую - н7икакой реакции. Т.е., вообще никакой. Может, какую-то поправку в команду следует внести?

0
dyug - 12 Апрель, 2014 - 12:25

оно ж не pci, а usb.
а так -оно в системе есть и должно работать.

0
primorets - 12 Апрель, 2014 - 12:35
Изображение пользователя primorets.

Должно, наверное. Но.....не работает. Сам удивляюся.

0
primorets - 12 Апрель, 2014 - 12:31
Изображение пользователя primorets.

Пардон, проверил - сам, оказывается, напортачил при записи. Одичали, знаете ли, на периферии...

[email protected]:~$ lspci -nn | grep 'Network\|Ethernet'
07:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8161 Gigabit Ethernet [1969:1091] (rev 10)
08:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)

0
MacLeod - 12 Апрель, 2014 - 13:00
Изображение пользователя MacLeod.

Ну, в системе оно, да. Alx, имя eth0, даже MAC-адрес виден.
Вы как интерфейс-то настраиваете? Кабель к роутеру идет? На роутере DHCP?
Покажите вывод
ifconfig

0
primorets - 12 Апрель, 2014 - 13:09
Изображение пользователя primorets.

[email protected]:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:26:6c:11:69:c4
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:16

lo Link encap:Локальная петля (Loopback)
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:1542 errors:0 dropped:0 overruns:0 frame:0
TX packets:1542 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:130554 (130.5 KB) TX bytes:130554 (130.5 KB)

+2
MacLeod - 12 Апрель, 2014 - 13:30
Изображение пользователя MacLeod.

Ну, на месте ваша сетевуха. Интерфейс eth0, только не настроен. Видимо, "на том конце" DHCP не работает или не включен, вот адрес автоматически и не удается получить. Нужно назначить ему IP-адрес, указать маску подсети, шлюз, DNS... Или включить/настроить DHCP на роутере.

0
primorets - 12 Апрель, 2014 - 13:37
Изображение пользователя primorets.

Если мне память не изменяет, настройка eth0 начинается с удаления апплета nm. Я без него не смогу пользоваться usb-модемом. И потом, предыдущие версии Кубунту у меня работали без "оптимизации" интерфейса.
Но буду пробовать. Не сидеть же просто так! К тому же, если честно, и сам бы мог додуматься до этой проверки.
Спасибо! Пошёл настраивать.

+1
MacLeod - 12 Апрель, 2014 - 14:40
Изображение пользователя MacLeod.

Стоп, стоп)))) Не надо удалять менеджер сети, в нем прямо и настройте.

0
Гость - 12 Апрель, 2014 - 14:58

С ним не настраивается. Как говорит вики, иногда приходится nm удалять, когда с ним невозможно отладить. У меня всё заработало именно после удаления nm.

primorets

+1
primorets - 12 Апрель, 2014 - 14:43
Изображение пользователя primorets.

MacLeod, спасибо!
Даже неловко за себя становится: ожидал, что причины отсутствия сети будут такими серьёзными... Оказалось, что сетевуха была настроена с установкой, а причина была простой. Правда, простой она стала после того, как меня в неё ткнули носом. Неловко за своё паникёрство, жалко угробленную неделю(почти).
Спасибо!
Успехов всем.
Пошёл отсыпаться.

0
Гость - 15 Июнь, 2014 - 15:40

Друг можете объяснить что вы конкретно сделали так как у меня похожая проблема.

0
Гость - 15 Июнь, 2014 - 15:47

На всякий случай мой вывод ifconfig
eth0 Link encap:Ethernet HWaddr bc:5f:f4:a8:61:e0
inet6 addr: fe80::be5f:f4ff:fea8:61e0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:143 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:26275 (26.2 KB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:380 errors:0 dropped:0 overruns:0 frame:0
TX packets:380 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:29692 (29.6 KB) TX bytes:29692 (29.6 KB)

0
Гость - 19 Февраль, 2016 - 12:52

In network-manager on tab Ethernet set MTU size to 8192. https://bugzilla.kernel.org/show_bug.cgi?id=70761

0
Гость - 23 Апрель, 2016 - 11:45

Вот спасибо! Помогло на Asus n56vz с Kubuntu 16.04. !

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры