libimobiledevice

Добрый день! Я только сегодня установил Kubuntu, а голову уже сломал себе... подскажите пожалуйста, желательно пошагово, как установить эти драйвера libimobiledevice??? я скачивал архив " libimobiledevice-1.1.6.tar.bz2 (нестабильный) ", а что дальше делать не знаю(( как мне заставить их работать?

+2
AlexBKost - 25 Май, 2014 - 15:40

А чем не подходят те стабилые, что можно установить стандартными средствами системы?

ЗЫ: В архиве имеется файл README - там написано что нужно делать.

0
duman86 - 25 Май, 2014 - 15:53

ну как бы Айфон не хочет определяться.. вот и нужны эти.. да, читал, но ничего не понял(

About
=====

A library to communicate with services of Apple iOS devices using native
protocols.

Requirements
============

Development Packages of:
libgnutls or openssl
libplist
libusbmuxd

Software:
usbmuxd
make
autoheader
automake
autoconf
libtool
pkg-config
gcc

Optional:
cython (Python bindings)
doxygen (Documentation)

Installation
============

To compile run:
./autogen.sh
make
sudo make install

Who/What/Where?
===============

Home:
http://www.libimobiledevice.org/

Code:
git clone http://git.sukimashita.com/libimobiledevice.git

Code (Mirror):
git clone https://github.com/libimobiledevice/libimobiledevice.git

Tickets:
http://github.com/libimobiledevice/libimobiledevice/issues

Mailing List:
http://lists.libimobiledevice.org/mailman/listinfo/libimobiledevice-devel

IRC:
irc://irc.freenode.net#libimobiledevice

Какие выводы я должен из этого сделать?

+1
Гость - 25 Май, 2014 - 16:08

1. Установить пакеты, перечисленные в начале README.
2. Через консоль зайти в папку распакованного архива.
3. Поочередно выполнить там три команды
./autogen.sh
make
sudo make install

0
kot040188 - 25 Май, 2014 - 16:15
Изображение пользователя kot040188.

Installation
============
To compile run:
./autogen.sh
make
sudo make install

Этот текст как бы намекает, что нужно компилять…

0
duman86 - 25 Май, 2014 - 16:21

да, я конечно теперь полезу гуглить че значит "компилять"... я с винды слез и не в курсе пока че да как.. неужели очень сложно просто дать ответ? доступный, что бы я сразу взял и сделал все..

0
kot040188 - 25 Май, 2014 - 16:41
Изображение пользователя kot040188.

Я сам тоже ниразу ещё не комлилял. Советую погуглить и возможно вы откажитесь от этой идеи, или даже откажитесь от linux =) Но если всё-таки не откажитесь, то вышеизложенный текст надо набирать в консоли подставляя к каждой строчке впереди слово sudo и набирая ваш пароль после. Объяснил как мог =) Консоль можно найти в главном меню
З.Ы. Ваше нежелание гуглить может негативно сказаться на использовании linux. Здесь вам не винда, без гугла иногда нельзя. Виндовые привычки здесь лучше не применять

0
duman86 - 25 Май, 2014 - 16:40

да я вот гуглю, но не понимаю как это делать((

0
kot040188 - 25 Май, 2014 - 16:43
Изображение пользователя kot040188.

Так я ж написал примерный сценарий! Я же говорю вы откажитесь…

0
duman86 - 25 Май, 2014 - 16:57

нервы на пределе)) гуглил, делал как на видео, не полчается.. пробую найти нормальное объяснение, пошаговое, в ответ только неработающая хрень...(((

0
kot040188 - 25 Май, 2014 - 17:03
Изображение пользователя kot040188.

Вы консоль нашли? Если да, то пишем в ней примерно так:
cd папка/с/иходниками/
./autogen.sh
make
sudo make install
вашпароль

Возможно я где-то ошибаюсь, но примерно так…

0
kot040188 - 25 Май, 2014 - 17:20
Изображение пользователя kot040188.

нервы на пределе))
Стоит подумать о возвращении на винду… Нервы будут целее…

0
Fierta - 25 Май, 2014 - 17:05
Изображение пользователя Fierta.

Не надо ничего компилировать,эта библа есть в репе,в терминал вставляете данную строку и ставите,всё.
sudo apt-get install libimobiledevice4
На будующее,ставите muon и ищите в нем по названию все что нужно.Как поставить муон? Данный код поможет установить тот самый муон:
sudo apt-get install muon

+1
AlexBKost - 25 Май, 2014 - 17:04

Я ему уже говорил, он нестабильную хочет.

+1
Fierta - 25 Май, 2014 - 17:11
Изображение пользователя Fierta.

Нестабильную хочет? Хочет приключений? Что же его выбор.

0
duman86 - 25 Май, 2014 - 17:12

окей, спасибо. Но в муоне нет такого названия(

0
kot040188 - 25 Май, 2014 - 17:14
Изображение пользователя kot040188.

Есть и она у меня даже установлена. То есть ставится по умолчанию, ибо я её не ставил

0
Fierta - 25 Май, 2014 - 17:15
Изображение пользователя Fierta.

А открыть терминал (konsole) и вставить первый код и нажать ентер?

0
duman86 - 25 Май, 2014 - 17:27

сделал так, установлео! Но это более старая версия, а мне нужна именно эта!
пытался сделать как говорил kot040188, но пишет:
[email protected]:~$ sudo apt-get install usbmuxd make autoheader automake autoconf libtool pkg-config gcc
[sudo] password for duman86:
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
E: Не удалось найти пакет autoheader
[email protected]:~$ cd /home/duman86/Загрузки/libimobiledevice-1.1.6
[email protected]:~/Загрузки/libimobiledevice-1.1.6$ ./autogen.sh
bash: ./autogen.sh: Нет такого файла или каталога
[email protected]:~/Загрузки/libimobiledevice-1.1.6$ ./autogen.sh
bash: ./autogen.sh: Нет такого файла или каталога
[email protected]:~/Загрузки/libimobiledevice-1.1.6$ make
make: *** Не заданы цели и не найден make-файл. Останов.
[email protected]:~/Загрузки/libimobiledevice-1.1.6$ sudo make install
make: *** Нет правила для сборки цели `install'. Останов.
[email protected]:~/Загрузки/libimobiledevice-1.1.6$ ./autogen.sh
bash: ./autogen.sh: Нет такого файла или каталога
[email protected]:~/Загрузки/libimobiledevice-1.1.6$ ^C
[email protected]:~/Загрузки/libimobiledevice-1.1.6$

0
kot040188 - 25 Май, 2014 - 17:32
Изображение пользователя kot040188.

autoheader действительно нет в хрнилищах. Но это не я его советовал…

+2
AlexBKost - 25 Май, 2014 - 17:11

Открыть Терминал/Konsole. Выполнить устаковку инструментов для компиляции:
sudo apt-get install usbmuxd make autoheader automake autoconf libtool pkg-config gcc
Тут же в консоли перейти в папку с распакованным архивом исходников:
cd имя_папки
Последовательно выполнить три команды, которые и есть компиляцией и установкой:
./autogen.sh
make
sudo make install

0
Fierta - 25 Май, 2014 - 17:12
Изображение пользователя Fierta.

sudo make install
Чем это,лучше бы checkinstall.

0
duman86 - 25 Май, 2014 - 17:14

надо сперва разархивировать? правильно я понимаю? файл скачан *.tar.bz2

+1
Fierta - 25 Май, 2014 - 17:25
Изображение пользователя Fierta.

Хотите приключений,тогда разархивировать,перейти в тот каталог и выполнить все вышеозначенные команды,но не выпонять команду sudo make install а сделат следующее: поставить sudo apt-get install checkinstall затем выполнить sudo checkinstall - это создаст более менее вменяемый deb пакет который можно будет легко и безболезненно удалить из системы.

0
Fierta - 25 Май, 2014 - 17:45
Изображение пользователя Fierta.

Вот качайте патченную библу,ставте и не мучайтесь.
Для 64 битной.
libimobiledevice4_1.1.6-64bit

0
duman86 - 25 Май, 2014 - 17:50

0
kot040188 - 25 Май, 2014 - 17:52
Изображение пользователя kot040188.

Очень офигенно всё видно… Кстати не забываем что установщик deb поломан!

0
duman86 - 25 Май, 2014 - 17:54

0
kot040188 - 25 Май, 2014 - 17:56
Изображение пользователя kot040188.

Для начала возможно надо старый пакет удалить… Но возможно что это не поможет…

0
duman86 - 25 Май, 2014 - 18:08

что значит поломан? заново установить нужно?

0
kot040188 - 25 Май, 2014 - 18:13
Изображение пользователя kot040188.

http://kubuntu.ru/node/12219 Ещё не передумали переходить на linux? =)

0
duman86 - 25 Май, 2014 - 18:25

нет, не передумал и ооооочень хочу установить этот пакет! Попробуйте, у вас запустится или нет? установится нормально?

0
kot040188 - 25 Май, 2014 - 18:32
Изображение пользователя kot040188.

Нет конечно. Устанавливать нужно из консоли по ссылке в шапке есть для этого комманда, её и используйте, она работает. А установка в графическом режиме сейчас поломана.

0
duman86 - 25 Май, 2014 - 18:44

[email protected]:/home/duman86/Загрузки# dpkg -i libimobiledevice4_1.1.6-git20140105_amd64.deb
(Чтение базы данных … на данный момент установлено 127995 файлов и каталогов.)
Preparing to unpack libimobiledevice4_1.1.6-git20140105_amd64.deb ...
Unpacking libimobiledevice4 (1.1.6-git20140105) over (1.1.5+git20140313.bafe6a9e-0ubuntu1) ...
dpkg: зависимости пакетов не позволяют настроить пакет libimobiledevice4:
libimobiledevice4 зависит от libtasn1-3 (>= 2.14-0), однако:
Пакет libtasn1-3 не установлен.

dpkg: error processing package libimobiledevice4 (--install):
проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
libimobiledevice4

0
Fierta - 25 Май, 2014 - 18:47
Изображение пользователя Fierta.

Удалите нафиг этот пакет и поставте рабочий и Кота больше не слушайте сейчас он вам насоветует.
Ссылки на 32 и 64 ниже.

0
kot040188 - 25 Май, 2014 - 23:31
Изображение пользователя kot040188.

Тебе не угодишь. Когда я высказывался против консоли, тебя это не устраивало. Сейчас я начал советовать человеку консоль, и тебя опять что-то не утрачивает =) Про сами пакеты я ничего не писал…

0
DarkneSS - 26 Май, 2014 - 06:50
Изображение пользователя DarkneSS.

Вы советуете не консоль, а геморрой. Даже checkinstall не вспомнили.

0
kot040188 - 26 Май, 2014 - 14:32
Изображение пользователя kot040188.

Во первых кроме меня никто вообще не вспомнил, что у человека deb не установится, а он будет ломать голову думая что что-то не так сделал. Ну извините нету у меня таких глубоких знаний как у вас. Что смог вынести из статьи http://kubuntu.ru/node/12219 то и вынес. И кстати прежде чем советовать попробовал у себя - у меня работает. Извините ещё раз.

0
kot040188 - 25 Май, 2014 - 18:49
Изображение пользователя kot040188.

Забыли про sudo перед коммандой. Это вам не винда. Здесь любое изминение системы требует повышения прав.
Но дело скорее всего не в этом. Ниже Fierta ещё что-то предлагает =)

0
Fierta - 25 Май, 2014 - 18:51
Изображение пользователя Fierta.

[email protected]:
ты вот это видишь? он под рутом.

0
kot040188 - 25 Май, 2014 - 18:57
Изображение пользователя kot040188.

Извиняюсь. Но ведь это же не грамотное поведение ;) "Никогда не работай под рутом!" =)

0
duman86 - 25 Май, 2014 - 18:58

он по другому не хотел устанавливать!

0
kot040188 - 25 Май, 2014 - 18:59
Изображение пользователя kot040188.

Кто "он"?

0
duman86 - 25 Май, 2014 - 19:05

терминал! сказал, что суперпользователь нужен
или что-то типо того..

0
kot040188 - 25 Май, 2014 - 23:32
Изображение пользователя kot040188.

Ну фактически он просил sudo…

0
Fierta - 25 Май, 2014 - 18:48
Изображение пользователя Fierta.

А установка в графическом режиме сейчас поломана.
Ты сам то понял что написал?

0
kot040188 - 25 Май, 2014 - 23:32
Изображение пользователя kot040188.

Я понял, а ты? Возможно у кого-то она работает, но я не могу советовать человеку то, что не работает у меня. QApt делает вид что "работает", gdebi крашится при запуске. Такая у меня картина… И что по твоему я должен советовать человеку?

0
DarkneSS - 26 Май, 2014 - 06:51
Изображение пользователя DarkneSS.

dpkg не вариант, тот же gdebi есть и в консольной реализации, он тоже падает?

0
kot040188 - 26 Май, 2014 - 14:42
Изображение пользователя kot040188.

А вот этого не знал. Спасибо, попробую. Заодно проверю графический gdebi, может уже работает...
Проверил графический gdebi: если раньше было видно (по сообщениям) что он крашится, то теперь при клике на deb вообще ничего не происходит…
А QApt по прежнему весело рапортует о безуспешно выполненном задании =)

0
Fierta - 25 Май, 2014 - 18:45
Изображение пользователя Fierta.

Скачайте по этой ссылке,рабочий пакет.
libimobiledevice2_1.1.6+git20140213~ppa1_amd64.deb
Ну и на всякий случай 32 битная.
libimobiledevice2_1.1.6+git20140213~ppa1_i386.deb

0
duman86 - 25 Май, 2014 - 18:51

Установилось, спасибо!!!!
но все-равно чет не работает эта штука(( ничего не понимаю(

0
Fierta - 25 Май, 2014 - 18:57
Изображение пользователя Fierta.

Могу еще посоветовать почитать вот это ветку:
Тема: iPhone iOS7 на Ubuntu
Огрызком не пользуюсь,проверить не могу.И комп перезагрузите навсякий случай.

0
duman86 - 25 Май, 2014 - 19:01

перед тем как поставить Кубунту я поставил Убунту)) Там все работало! Почитав КУЧУ статей, пришел к выводу, что только набор данных пакетов делают радость владельцам "огрызков", но видимо нужно сперва помучаться серьезно!

0
Fierta - 25 Май, 2014 - 19:08
Изображение пользователя Fierta.

Попробуйте еще поставить из ппа:
sudo apt-add-repository ppa:mniess/libimobiledevice
sudo apt-get update
sudo apt-get upgrade
Только перед этим удалите тот пакет.После не забудте ребутнуть комп.

0
Fierta - 25 Май, 2014 - 19:10
Изображение пользователя Fierta.

Еще статья по решению проблемы на англицком,решение ищите в комментах к статье.
How To Fix iPad and iPhone ‘Trust’ Bug On Ubuntu

0
kot040188 - 25 Май, 2014 - 18:58
Изображение пользователя kot040188.

но все-равно чет не работает эта штука
Я почему-то так и думал…

0
duman86 - 25 Май, 2014 - 19:04

почему? типо я совсем рукажопый?)) ну сейчас то установилось и не работает все-равно( быть можт еще че нужно установить.....

0
kot040188 - 25 Май, 2014 - 19:08
Изображение пользователя kot040188.

Боже упаси, вы меня не так поняли. Я просто изначально чувствовал, что эта штука работать не будет. Не знаю почему, но чувствовал =) Я думаю если бы нестабильный пакет заработал, то и стабильный бы работал…

0
duman86 - 25 Май, 2014 - 19:09

на видосах у всех все работает((

0
kot040188 - 25 Май, 2014 - 19:11
Изображение пользователя kot040188.

Ну так есть выход… Сто процентов рабочий… Шучу… =)

0
duman86 - 25 Май, 2014 - 19:35

Не, ну хоть убейте. надо добить! А как autoheader установить? гуглил и по форуму искал, так и не понял как!

0
kot040188 - 25 Май, 2014 - 19:46
Изображение пользователя kot040188.

Не в курсе… Если искать в muon autoheader выдаёт autoconf2.13, причём написано устаревший. Возможно autoheader входит в autoconf2.13, не разбирался…
З.Ы. Убивать не собираюсь =)

0
duman86 - 25 Май, 2014 - 20:28

а как вносить изменения в корневую папку? точнее мне туда файл нужно поместить

0
DarkneSS - 25 Май, 2014 - 20:55
Изображение пользователя DarkneSS.

sudo cp /исходный/путь/файл /куда/поместить

0
kot040188 - 25 Май, 2014 - 21:47
Изображение пользователя kot040188.

А для кого я писал сообщение про изменения в системе и sudo? =)
Если нужен файловый менеджер: kdesu dolphin
Если редактор: kdesu kate

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры