установка программ [Решено]

Здравствуйте,
Как мне установить программу? У меня есть она записанная в файле .deb.

+3
lord_i - 22 Октябрь, 2014 - 16:51
Изображение пользователя lord_i.

Например, так:
sudo dpkg -i имя_файла.deb
Но все-же рекомендую ставить программы из репозиториев, используя apt-get, aptitude и т.д. Это самый безопасный путь.

0
vda1999 - 22 Октябрь, 2014 - 17:40

konsole вывел следующее:
[email protected]:~$ sudo dpkg -i wingide-101-5_5.0.9-1_i386.deb
[sudo] password for dima:
Выбор ранее не выбранного пакета wingide-101-5.
(Чтение базы данных … на данный момент установлен 141521 файл и каталог.)
Preparing to unpack wingide-101-5_5.0.9-1_i386.deb ...
Unpacking wingide-101-5 (5.0.9-1) ...
dpkg: зависимости пакетов не позволяют настроить пакет wingide-101-5:
wingide-101-5 зависит от libqt4-webkit (>= 4.6.2), однако:
Пакет libqt4-webkit не установлен.
wingide-101-5 зависит от libjpeg62, однако:
Пакет libjpeg62 не установлен.

dpkg: error processing package wingide-101-5 (--install):
проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
wingide-101-5
[email protected]:~$

+1
DarkneSS - 22 Октябрь, 2014 - 18:56
Изображение пользователя DarkneSS.

Потому что совет вредный, надо было ставить через gdebi и всё бы подтянулось по зависимостям автоматически. Повезло ещё, что список не большой и вовсе не запутан.

0
MacLeod - 22 Октябрь, 2014 - 19:58
Изображение пользователя MacLeod.

Нормальный совет, просто если dpkg ругнулся на зависимости, их можно поставить следующим шагом, командой
sudo apt-get install -f

0
DarkneSS - 24 Октябрь, 2014 - 18:18
Изображение пользователя DarkneSS.

Для этого сначала надо форсировать сам дпкг, но всё это не имеет смысла, когда есть gdebi.

0
MacLeod - 24 Октябрь, 2014 - 20:40
Изображение пользователя MacLeod.

Да не нужно ничего форсировать, просто до установки зависимостей пакет останется ненастроенным, а после - настроится автоматически.

0
_qwerty - 22 Октябрь, 2014 - 17:50

sudo apt-get install libqt4-webkit libjpeg62

0
vda1999 - 22 Октябрь, 2014 - 17:51

[email protected]:~$ sudo apt-get install libjpeg62 wingide-101-5_5.0.9-1_i386.deb
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
E: Не удалось найти пакет wingide-101-5_5.0.9-1_i386.deb
E: Не удалось найти пакет по регулярному выражению «wingide-101-5_5.0.9-1_i386.deb»

0
kot040188 - 22 Октябрь, 2014 - 17:54
Изображение пользователя kot040188.

Не надо добавлять отсебятины. Команда была дана чёткая…

0
Гость - 22 Октябрь, 2014 - 17:56

сначало:
sudo apt-get install libjpeg62
после:
sudo dpkg -i wingide-101-5_5.0.9-1_i386.deb

0
vda1999 - 22 Октябрь, 2014 - 17:55

Спасибо, установить уже получилось.

0
vda1999 - 22 Октябрь, 2014 - 18:05

А что неверно теперь?

[email protected]:~$ sudo dpkg -i ya.deb
Выбор ранее не выбранного пакета yandex-disk.
(Чтение базы данных … на данный момент установлено 150516 файлов и каталогов.)
Preparing to unpack ya.deb ...
Unpacking yandex-disk (0.1.5.758) ...
Настраивается пакет yandex-disk (0.1.5.758) …
Using /usr/bin/wget
gpg: не найдено данных формата OpenPGP.
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...

0
vda1999 - 22 Октябрь, 2014 - 18:04

И как устанавливать .tgz?

0
DarkneSS - 22 Октябрь, 2014 - 18:55
Изображение пользователя DarkneSS.

Читаем про сборку из исходных кодов.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры