видеокарта r9 280x

у кого есть видеокарта r9 280x и как вы ставите на нее драйвера? обычные определяют ее как hd 7900 (в том числе проприетарные) и работают паршивенько. steam вообще ругается что он мол незнает и не может найти пз для данной видяхи. Какие есть мысли по этому поводу?

0
maximelson - 12 Ноябрь, 2014 - 15:59

У меня есть,msi r9 280,определяется так же.Драйвер стоит fglrx 14.19.
ставил так
cd ~
wget -c --referer='http://support.amd.com/ru-ru/download/desktop?os=Linux+x86' http://www2.ati.com/drivers/linux/amd-catalyst-14-9-linux-x86-x86-64.zip
unzip amd-catalyst-14-9-linux-x86-x86-64.zip
cd fglrx-14.301.1001
sudo sh amd-driver-installer-14.301.1001-x86.x86_64.run --buildandinstallpkg
sudo apt-get -f install
sudo amdconfig --initial -f
sudo reboot

Работает,но в opengl движке kwin и xorg жрут процессор,при сворачивании-разворачивании,и перетаскивание окон,до 100%,xrender поменьше ест.Я бы остался на свободных,с ними порядок,но на них у меня куллеры крутятся в простое на 40%,недавно вышли патчи которые это фиксят,возможно скоро будет в новых ядрах.
Играю в нативный тропико 5,на свободных fps 18-40,на fglrx 60 ниже не опускается.

0
kvius - 20 Ноябрь, 2014 - 17:25

Я играю в портированный warthunder а там на открытых буквы пропадают. ставлю проприетарный, но производительность печалит. Можно там ее как то настроить??
PS. в каталисте все стоит на производительности!

0
Chibiko - 20 Ноябрь, 2014 - 18:15
Изображение пользователя Chibiko.

Поставь галочку на "совместимость со старыми видеокартами"

0
kvius - 21 Ноябрь, 2014 - 19:18

я ее не за тем покупал чтоб потом смотреть на куцую графу!!

0
Гость - 21 Ноябрь, 2014 - 20:24

Вообще каталист производительнее открытых сейчас,по крайней мере открытого radeonsi.
Я уже перестал пытаться играть в Linux,для игр стоит винда,все таки когда отдаешь за видеокарту 10-15 тысяч хочется получать от нее все,а не мериться с падением производительности и другими костылями.

0
kvius - 25 Ноябрь, 2014 - 00:33

(==) Log file: "/var/log/Xorg.1.log", Time: Mon Nov 24 23:22:34 2014
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:0:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:2:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:4:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:5:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:6:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:7:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:10:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:17:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:18:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:18:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:19:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:19:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:20:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:20:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:20:3) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:20:4) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:20:5) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:22:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:22:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:0:1) found

хотелось бы получить ответ на эти ошибки? это выдает при запуске warthunder.

0
Гость - 16 Май, 2015 - 09:15

"Вам-то хорошо у вас только это" Kubuntu драйвера R9 270 вообще не ставит.

0
AlexBKost - 16 Май, 2015 - 14:22

Давай выражайся яснее - какая Kubuntu, какие драйвера, надо понимать на R9 270 откуда и как устанавливались? Что-бы вообще не ставились, так не бывает. Обычно драйвера ставятся, но потом не работают так, как хотелось бы (как у ТС).

0
akal - 16 Май, 2015 - 18:41
Изображение пользователя akal.

Расскажу свою хистори, авось поможет.

Я с Intel HD 3000 мучился. В Стиме игрушки работать отказывались, а система проприетарные драйвера не находила. Intel убрал Driver Installer для 12.04 и 14.04 (прекратил поддержку) и, казалось бы, все.

Потом, когда пробовал 15.04, обнаружил что все работает как надо и без лишних телодвижений. Все-таки ядро.

В общем, сейчас сижу на 14.04, накатив ядро 3.19 и все работает как надо.

0
AlexBKost - 16 Май, 2015 - 19:05

Спасибо, конечно, за ваш бесценный опыт с Intel, но тут обсуждается AMD, потому вы как-бы не туда забрели. Тем более, что сейчас я именно на ядре 3.19 наблюдаю непонятки с проприетарщиной AMD уже на двух системах, тогда как тут еще не встречал от других конкретных описаний. Поэтому призываю владельцев AMD детально отписываться, если есть о чем.

0
akal - 16 Май, 2015 - 19:07
Изображение пользователя akal.

Сожалею что не туда забрел. Просто хотел помочь.

0
kvius - 18 Май, 2015 - 12:48

Сейчас поставил vivid 15.04 накатил проприетарную бету catalyst 15.03-ubuntu4.в контру бегает неплохо (самое интресное что с включенным vsync работает лучше чем без него), в тундре чуть лучше чем раньше, но от идеала далеко! ВСе же надо ждать новый обещаный драйвер amdgpu - может хоть тогда что-то изменится?!

+1
AlexBKost - 18 Май, 2015 - 13:27

Откуда такое адское название бету catalyst 15.03-ubuntu4 ?

0
kvius - 13 Август, 2015 - 09:56

Это бета версия catalyst с ланчпада. До catalyst 15.7 она единственная правильно работала на ядре 3.19

+1
AlexBKost - 13 Август, 2015 - 17:15

Бета с ланчпада, говорите? А разве в то время уже не было этой беты в репозитории? На сколько мне не изменяет память, была, и появилась там она еще в марте, претерпев аж четыре обновления до середины апреля, и сейчас по-прежнему предлагается для установки на VV пакетами fglrx* версии 15.200-0ubuntu4, что особенно странно, в свете выхода Сatalyst 15.7 месяц назад. И в плане правильности работы я совсем не могу вас поддержать — на этой версии пакетов отсутствует, как ни странно, поддержка расширение Xvideo. У вас это никак не проявилось?

А вот на WW, так совпало, что именно сегодня пришло второе обновление пакетов fglrx* версии 15.200.1-0ubuntu3, собранных на Сatalyst 15.7. И я не могу найти другого объяснения, почему этого не происходит на VV до сих пор, кроме как уж очень выраженной промежуточностью релиза VV, и желаю всем не задерживаться на нем, а уже сегодня перебираться на WW, где кроме новых драйверов имеется масса других вкусностей.

0
kvius - 13 Август, 2015 - 17:43

Проявилось! Но fps было побольше.15.7 собирал для себя ручками...

0
AlexBKost - 13 Август, 2015 - 18:12

Так и я тоже собрал ручками 15.7, так собранные пакеты fglrx* получились версии 15.200-0ubuntu1, а в репах версии 15.200-0ubuntu4, собранные из бета-15.3. И теперь все время идет предложение обновить лучшее на худшее, просто смешно. Откуда такое безответственное отношение соответствующих структур к этому вопросу?

0
kvius - 17 Август, 2015 - 13:47

А на ядро 4.1 его получилось у кого-то поставить?

0
AlexBKost - 19 Август, 2015 - 14:38

Одного знаю, у него видимо получилось поставить, потому что он даже инструкцию написал.
С другой стороны, как я отмечал выше, на WW с ядром 4.1.3 в репах имеются готовые пакеты fglrx* версии 15.200.1-0ubuntu3, собранных на Сatalyst 15.7, которые можно установить вручную на другой дист с ядром 4.1.

0
kvius - 19 Август, 2015 - 14:38

я пробовал по ней ставить - все это туфта!

0
kvius - 24 Сентябрь, 2015 - 09:28

перебрался на нее по предложению! Все конечно гуд кроме одного - после установки fglrx 2.15.201 который они собрали для wily система виснет на стадии загрузки. Я уже и ручками deb устанавливал отсюда https://launchpad.net/ubuntu/+source/fglrx-installer/2:15.201-0ubuntu1/+build/7915265 (один хрен). Что можете подсказать?

0
AlexBKost - 24 Сентябрь, 2015 - 15:42

Что можете подсказать? Я сейчас уже не уверен какая у вас версия Кубунту, в любом случае лучше всего, если не ставить драйвер из официального репозитория, то самому собрать вручную скачанный с сайта AMD. Инструкции тут. Не забудьте прежде удалить все установленное ранее.

Сам устанавливал вручную Catalyst 15.9 на Кубунту 15.04 - собирается, устанавливается и работает, подтверждаю.

+1
kvius - 24 Сентябрь, 2015 - 17:01

у меня kubuntu 15.10 (как рекомендовали). ставлю catalyst 15.9 по преведенной мною выше ссылке - и он подвисает (также как и при установке в настройках системы предлагаемого самой системой). После подвисания помогает только переустановка.

0
kvius - 24 Сентябрь, 2015 - 17:04

ваша инсрукция катит только если применять последний коласа патч для ядра 4.2, но я хотел попробовать то, что канониклы наваяли. Если моя ссылка неправильна, дайте мне пожалуйста ту что нужно.

0
AlexBKost - 24 Сентябрь, 2015 - 18:09

у меня kubuntu 15.10 Я уже совсем запутался где, что у кого стоит. Для 15.10 действительно готовы fglrx 15.201 в репах из catalyst 15.9. У меня с ними нет проблем.

Могу порекомендовать только удалить fglrx из recovery mode режима загрузки и установить заново через Synaptic, отследив лог установки на предмет error'ов. Если же их не будет, то и причин для зависания системы на стадии загрузки не должно быть.

0
Гость - 25 Сентябрь, 2015 - 09:09

Спасибо! попробую на досуге!

0
kvius - 25 Сентябрь, 2015 - 21:13

итак sinaptyc не дал результата видимо прийдется всетки ставить ручками с пропатчиванием!

0
AlexBKost - 25 Сентябрь, 2015 - 22:10

прийдется всетки ставить ручками с пропатчиванием! Выше в этой теме по этому поводу вы уже отзывались: я пробовал по ней ставить - все это туфта! А вот на выхлоп Synaptic'a было-бы любопытно взглянуть, иначе расшифруйте подробнее своими словами.

0
Гость - 28 Сентябрь, 2015 - 10:48

самое интересное что в выхлопе synaptic все отлично и без ошибок! кстати я не один такой в багрепорте уже написано насчет фриза во время загрузки.. Так что ждемс пока они поправят!

0
Richard - 24 Сентябрь, 2015 - 10:04

Я на Lenovo G500(если верить спецификациям AMD R5 230M) не могу накатить Catalyst в KUbuntu 14.04, стоит DuaalBoot в Win7 Catalyst карточку опознает как AMD 8500 HD и драйвера встают, правда, индекс производительности Windows не вычисляется - затык на вычислении производительности мультимедия(причем проблема именно в драйвере на дискретную графику, если в BIOS выставить UMA intel HD - индекс вычисляется), а в Linux попытка поставить прооприетарные драйвера оканчивается сообщением, что "графический адаптер AMD не обнаружен или работает не правильно" и черным экраном при перезагрузке...

0
kvius - 24 Сентябрь, 2015 - 15:45

а вы инициализировали после установки командой sudo amdconfig --initial -f ? ДА и кстати там для старых видях еще и последнюю рабочую версию драйвера знать надо!

0
Richard - 25 Сентябрь, 2015 - 08:55

Видеокарта как бы не старая и на сайте AMD рекомендуют 15.9

0
Richard - 25 Сентябрь, 2015 - 11:17

sudo amdconfig --initial -f
Uninitialised file found, configuring.
PowerXpress error: Cannot stat '/usr/lib64/fglrx': No such file or directory
Failed to initialize libglx for discrete GPU
Using /etc/X11/xorg.conf
Saving back-up to /etc/X11/xorg.conf.original-1

и в Catalyst

Попробывал ставить через run скрипт с оф.сайта,
sudo chmod +x AMD-Catalyst-15.9-Linux-installer-15.201.1151-x86.x86_64.run
sudo sh ./AMD-Catalyst-15.9-Linux-installer-15.201.1151-x86.x86_64.run

в usr/share/ati в логе установки:
Supported adapter detected.
Check if system has the tools required for installation.
fglrx installation requires that the system have kernel headers for 3.7 release.  /lib/modules/3.19.0-22-lowlatency/build/include/generated/uapi/linux/version.h cannot be found on this system.
One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
Optionally, run the installer with --force option to install without the tools.
Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.

Поддерживаемый адаптер обнаружен.
НО
fglx требует чтобы система имела заголовки релиза ядра 3.7
Один или несколько инструментов, необходимых для установки не может быть найден в системе. Установите необходимые инструменты перед установкой драйвера fglrx.
При желании, запустите инсталлятор с --force параметр для установки без инструментов.
Принуждение установить будет отключить аппаратное ускорение AMD и может сделать вашу систему неустойчивой.
Ядро 3.19, а драйверу нужны модули 3.7 ...

0
Гость - 25 Сентябрь, 2015 - 09:13

давайте начнем по порядку! какая у вас версия дистрибутива, ее разрядность, какой catalyst ставите и каким методом?

0
kot040188 - 25 Сентябрь, 2015 - 14:10
Изображение пользователя kot040188.
0
kvius - 25 Сентябрь, 2015 - 21:22

это происходит потому что у вас в системе нехватает некоторых пакетов пройдите по этой ссылке http://wiki.cchtml.com/index.php/Ubuntu_Utopic_Installation_Guide и сделайте как по инструкции. Там кстати есть действия и для гибридной графики! Попробуйте и отпишитесь...

0
Richard - 27 Сентябрь, 2015 - 11:46

sudo apt-get install cdbs dh-make dkms execstack dh-modaliases linux-headers-generic libqtgui4 xserver-xorg-dev
Установил благполучно, но пропатчило только стоковое ядро 3.13-63
sudo apt-get install lib32gcc1
Уже установлена самая последняя версия драйвера
sudo chmod +x AMD-Catalyst-15.9-Linux-installer-15.201.1151-x86.x86_64.run
sudo sh ./AMD-Catalyst-15.9-Linux-installer-15.201.1151-x86.x86_64.run

0 - реакции, опять пишит, что недостает компонент
запустил установку из деб-пакета
sudo apt-get -f install
несколько раз в процессе реконфигурации выдавал оповещении о разности версий оболочки установщика
sudo amdconfig --initial -f
adapter not found, reinstall driver

удалил (purge) fglrx, перезагрузился, вновь ставлю со скрипта, а мне пишет:

Загрузился со стоковым ядром(3.13-63) запустил скрипт установки в нем и установка пошла, но
sudo amdconfig --initial -f
amdconfig: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

locate libGL.so.
/usr/lib/i386-linux-gnu/mesa/libGL.so.1
/usr/lib/i386-linux-gnu/mesa/libGL.so.1.2.0
/usr/lib/x86_64-linux-gnu/mesa/libGL.so.1
/usr/lib/x86_64-linux-gnu/mesa/libGL.so.1.2.0

все на месте, пробую перезагрузку в итоге черный экран после перезагрузки
вернул на место открытые дрова сделав sh /usr/share/ati/amd-uninstall.sh из root console режима recovery
сижу курю, поставил ядро 4.0.5 , но оно тоже несовместимо с проприетарными дровами.

0
Гость - 28 Сентябрь, 2015 - 10:53

я вам рекомендую поставить ядро 3.19, ибо для всех которые выше надо применять коласа патч, что кстати может быть в вашем случае... Также попробуйте пока отключить карточку интел в биосе. И розберитесь всетаки на сайте amd по вашей карточке, может быть вам надо ставить более старый драйвер, так как карточка далеко не новая!

0
Richard - 29 Сентябрь, 2015 - 09:59

В BIOS переключение только между UMA Intel HD и Switchable Graphics, т.е. выключить интегрированную графику не вариант, пробывал отключать intel HD в Диспетчере оборудования Windows 7, так при следующей загрузки разрешение низкое, эффектов нет и виндовзный Catalyst рапортует, что драйвер установлен не корректно и требуется деинсталляция и повторная установка. Включаю в диспетчере intel и все восстанавливается.
В KUbuntu у меня сейчас стоят ядра 3.13 , 3.19 и 4.0.5. При этом установка Catalyst стартовала только на 3.13(стоковое ядро lts), поскольку именно его удалось пропатчить по инструкции отсюда

0
kvius - 29 Сентябрь, 2015 - 12:02

стоп-стоп-стоп... во первых - ядрышко желательно, чтоб стояло только одно. во вторых - catalyst 15.9 поддерживает ядро 3.19 из каропки. Мне все же кажется, что вы где-то допускаете ошибку. Вы пробывали запустить просто сам файл *.run? сделайте в свойствах файла его исполняемым и попробуйте запустить! Насчет диспетчера win7 - все что вы там отключаете, отключается лишь для windows 7. Почему в биосе не вариант?

0
Richard - 29 Сентябрь, 2015 - 15:18

хорошо попробую удалить все ядра кроме 3.19 - хотя этих ядер тоже 3(extra, generic и lowlatency)
собственно я так и делал: sudo chmod +x AMD-Catalyst-15.9-Linux-installer-15.201.1151-x86.x86_64.run
дает права на исполнение
sudo sh ./AMD-Catalyst-15.9-Linux-installer-15.201.1151-x86.x86_64.run
выполняет скрипт
В BIOS всего два пункта Intel HD и Switchable Graphics(гибрид intel+AMD) третьего пункта AMD Only нет поэтому, отключить intel можно только программно(из 7-ки).

0
kvius - 29 Сентябрь, 2015 - 17:30

Опять же оно матерится на неудовлетворенные зависимости... Посмотрите лог который оно вам предлагает!

+2
Richard - 30 Сентябрь, 2015 - 05:44

самое смешное в том,что логе никакой конкретики нет:
Supported adapter detected.
Check if system has the tools required for installation.
fglrx installation requires that the system have kernel headers for 3.7 release.  /lib/modules/3.19.0-22-lowlatency/build/include/generated/uapi/linux/version.h cannot be found on this system.
One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
Optionally, run the installer with --force option to install without the tools.
Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.

ни слова о конкретных либах, просто тупо повторение сообщения.
Удалил все ядра, кроме 3.19
sudo apt-get install cdbs dh-make dkms execstack dh-modaliases linux-headers-generic libqtgui4 xserver-xorg-dev-lts-trusty
в процессе ставиться ядро 3.13-65(зависимости на нем)
mkdir catalyst15.9 && cd catalyst15.9
wget --referer='http://support.amd.com/en-us/download/desktop?os=Linux+x86' http://www2.ati.com/drivers/linux/amd-catalyst-15.9-linux-installer-15.201.1151-x86.x86_64.zip
unzip amd-catalyst-15.9-linux-installer-15.201.1151-x86.x86_64.zip

и
chmod a+x AMD-Catalyst-15.9-Linux-installer-15.201.1151-x86.x86_64.run
sudo ./AMD-Catalyst-15.9-Linux-installer-15.201.1151-x86.x86_64.run --buildpkg Ubuntu/trusty
sudo dpkg -i fglrx*.deb

sudo amdconfig --initial -f --adapter=all
все вроде бы работает, но каталиста в меню нет, перезагружаюсь, меня выбрасывает в консоль tty1, логинюсь и делаю startx
лицезрею мат на Xorg segmentation failure
с планшета нахожу рекомендацию сделать замену
sudo cp /etc/X11/xorg.conf.orig /etc/X11/xorg.conf
нет такого файла, что за...
sudo dpgk -r fglrx-dev fglrx-amdcccle fglrx-core fglrx
sudo reboot

и опять те же грабли, снес драйвер, а конфигурация иксов не поменялась.
пришлось грузиться с Live-USB из под Root вычищать содержимое etc/X11 - в частности снес все, что имело в имени xorg.conf(6 файлов), только после этого получилось штатно загрузится.
Чтобы я когда-нибудь имел дело с проприетарными драйверами от AMD - увольте...

0
kot040188 - 30 Сентябрь, 2015 - 06:41
Изображение пользователя kot040188.

Чтобы я когда-нибудь имел дело с AMD - увольте...
Так будет лучше я думаю ヅ

0
AlexBKost - 30 Сентябрь, 2015 - 07:16

Так будет лучше я думаю ヅ А мне подумалось о другом - взять бы этот ноут в руки и довести все до ума, как говорится. Только не судьба. Но ничего, мы же все тут не последний день живем, и Richard'у тоже доведется испытать мгновенный миг ощущения счастья, когда у него таки заведется Catalyst, пусть не в этот раз, а в следующий.

0
kvius - 30 Сентябрь, 2015 - 08:40

1.Почему вы поставили lowlatency а не generic kernel? 2. sudo amdconfig --initial -f --adapter=all применяется лишь в том случае, если у вас 2 адаптера именно ati, так что без --adapter=all. Попробуйте теперь попробовать установку через synaptic. Все же он точно подтянет те зависимости, которые необходимо + плюс убедитесь, что у вас точно полностью удален fglrx.

0
Richard - 30 Сентябрь, 2015 - 10:03

Я удалял lowlatency, оставлял в системе 1 единственное ядрышко, толку никакого...

а просто sudo amdconfig --initial -f ломает линковки на либы
amdconfig: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
как итог все приложения так или иначе завязанные на libGL перестают открываться

0
kvius - 30 Сентябрь, 2015 - 09:55

это все хвосты от открытых драйверов и если ати встает, то там соответственно используются проприетарные библиотеки. Вы кстати до этого случайно не устанавливали открытых драйверов с репов oibaf?

0
Richard - 30 Сентябрь, 2015 - 10:09

нет, сторонних реп не ставил, хотя уже подумываю про xorg-edgers

+6
AlexBKost - 30 Сентябрь, 2015 - 11:42

Еще бывает полезным после удаления прежней проприетарщины переконфигурировать икс-сервер: sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core  xserver-xorg-video-radeon xserver-xorg-video-ati
sudo dpkg-reconfigure xserver-xorg
В любом случае, об этом в этой теме еще никто не упоминал.

0
kvius - 30 Сентябрь, 2015 - 09:15

Чтобы я когда-нибудь имел дело с проприетарными драйверами от AMD - увольте...

Вы думаете, что c Nvidia людям живется проще? Небуду вас огорчать!

0
AlexBKost - 30 Сентябрь, 2015 - 09:30

Вы думаете, что c Nvidia людям живется проще? Сейчас прибежит какой-нибудь Гость и расскажет Кому на Руси жить хорошо (С).

+1
Richard - 30 Сентябрь, 2015 - 09:51

видимо с проприетарными драйверами совсем туго.
RMS прав, закрытый код - зло

0
dyug - 30 Сентябрь, 2015 - 10:57

Вы думаете, что c Nvidia людям живется проще?
Ну в общем - да. По собственному опыту.
По крайней мере в моих условиях.

0
kot040188 - 30 Сентябрь, 2015 - 16:36
Изображение пользователя kot040188.

Вы думаете, что c Nvidia людям живется проще?
Лично мне, да. Только вот скоро переползу на чистый intel. Не знаю чего ожидать, радости или геморроя…

0
MacLeod - 30 Сентябрь, 2015 - 20:21
Изображение пользователя MacLeod.

Кому nvidia, кому amd, а Кот до сих пор кулер выбирает...
Геморра вообще не будет, только подключай через DVI<->DVI, а не HDMI или переходники с ним - были случаи, когда интел терял мониторы до перезагрузки в линуксе на HDMI.

0
kot040188 - 30 Сентябрь, 2015 - 22:17
Изображение пользователя kot040188.

Я зарплату выбираю… У меня монитор не по HDMI подключается…

0
dyug - 30 Сентябрь, 2015 - 10:56

Эмм.. уважаемый пользователь, можно Вам задать вопрос?
Какого того самого известного всем мужского органа Вы используете ядро 3.19.0-22-lowlatency а заголовки ставите от linux-headers-generic а не lowlatency?
Разумеется, у вас известный всем мужской орган что соберется, ибо ядро и его заголовки не совпадают по версиям.
И проблема именно в неправильной установке пакетов

0
Richard - 30 Сентябрь, 2015 - 12:00

headers и на generic, и на lowlatency стояли, поскольку использовались соответствующие мета-пакеты(которые и тянули зависимости)

0
kvius - 30 Сентябрь, 2015 - 09:04

fglx требует чтобы система имела заголовки релиза ядра 3.7

Вы немного неправильно, понимаете, оно имеет ввиду поддержку от ядра 3.7 и выше!

0
Richard - 30 Сентябрь, 2015 - 10:00

изначально стояло 3.13( в любом случае новее 3.7), затем ставил 3.19 и 4.0.5 - и "все не в коня корм"

0
kvius - 30 Сентябрь, 2015 - 11:46

я бы вам все-таки посоветовал начисто переустановить систему и попробовать хотя бы на стоковом ядре впаять fglrx и если все будет норм тогда уже пробывать на другой версии ядра

0
kvius - 24 Сентябрь, 2015 - 15:47

на сайте lenovo по спецификации стоит HD8750... может у вас какая-то модификация этого бука?

0
Richard - 25 Сентябрь, 2015 - 08:07

Lenovo G500 (CPU Pentium 2020M(intel HD)/GPU AMD Radeon HD 8570)

0
dyug - 25 Сентябрь, 2015 - 10:57

господа специалисты по АМД, а скажите пожалуйста как там происходит(должно происходить) переключение на мощную карту в ноутах?
Ибо есть мнение шо грабля в том, что видеокарта по молчанию интел, и разумеется драйвера ругаются...
В нвидии точно помню, что через оптимус нужно, а как с АМД - не в курсе...

0
Richard - 25 Сентябрь, 2015 - 17:11

Поскольку, поставить проприетарный драйвер в Linux не получилось, объясню данную технологию на примере Windows 7, там переключение работает через Catalyst, есть 2 режима:
1) автоматические глобальные настройки - при работе от АКБ задействуется интегрированная графика Intel HD, при питании от сети задействуется дискретная карта AMD.

2) режим ручной установки, в котором пользователь сам назначает какое приложение будет использовать производительный адаптер, а какое будет использовать энерго-экономичный адаптер.

+1
MacLeod - 25 Сентябрь, 2015 - 17:34
Изображение пользователя MacLeod.

Вопрос в том, что осуществлять данное переключение в линухе сможет либо
а) проприетарный драйвер;
б) самопально-костыльное решение типа bumblebee для nvidia.
Как происходит переключение интеграшки на дискретку, думаю, тут всем и так ясно...

0
dyug - 25 Сентябрь, 2015 - 17:35

Я понимаю, как оно может работать в виндовс, меня интересует, как это происходит в линуксе. И возможно, там нужно (как обычно) сделать нетривиальные действия типа включить в биосе, например... :-)

0
Гость - 28 Сентябрь, 2015 - 10:57

в лине с переключением карточек типа ATI/ATi все нормально, а вот в спарке с интелом до сих пор какие-то бока и как я понимаю из-за того что интел не парится насчет своих говновидяшек и не внедряет ничего нового!

+1
dyug - 29 Сентябрь, 2015 - 10:21

Гы, все как обычно, виновата АМД, но обвиним интел. :-)
Если бы была проблема с интелом, то проблемы были бы независимо от другой видеокарты, а как известно(и подтверждается этим гостем), пока есть проблемы с переключением на АМД карту, при нормальной поддержке со стороны Нвидии.

+1
kvius - 29 Сентябрь, 2015 - 11:56

а никто и не обвиняет... Просто есть сам факт - ATI и intel никак не подружатся друг с другом и проблемка как я считаю обоюдная!

0
Priestone - 30 Сентябрь, 2015 - 07:30
Изображение пользователя Priestone.

У меня тоже R9 280x. Поставил на попробовать бету2 kubuntu 15.10, пока на открытых дровах, но... на opennet-ах пишут, что интегрированный в кернель 4.2 AMDGPU поддерживает только от R9 285 и позднее, это получается, что мы в пролете с данной плюшкой?

Цитата с опеннета: "...Задействовано ядро Linux 4.2 с драйвером AMDGPU для новых GPU Radeon..."

0
AlexBKost - 30 Сентябрь, 2015 - 07:39

... что мы в пролете с данной плюшкой? Да, вы в пролете, как и все мы с такими же железками и хуже. Но это никому не мешает поставить закрытые дрова ... хоть на 15.10.

0
Priestone - 30 Сентябрь, 2015 - 08:31
Изображение пользователя Priestone.

Закрытые драйверы, при попытке поставить, повесили систему при загрузке... Ну бета на то она и бета. Для начала, видимо, подожду релиза 15.10 :-) , а там посмотрим

0
kvius - 30 Сентябрь, 2015 - 08:58

это походу у всех у кого r9 280! именно этот баг последним вписан в багтрэкере (так что мы ни одни). по этой инструкции точно собирается catalyst 15.9 для ядра 4.2 (сам проверял и все работает на кубунте 15.4), но собиратся на 15.10, не хочет (пишет что создал, но не находит директорию в которую они должны скидыватся, какой то глюк), а 15.4 для сборки пакетов мне ставить западло...

0
AlexBKost - 30 Сентябрь, 2015 - 09:00

при попытке поставить, повесили систему при загрузке... Да не причем тут бета, не стройте себе иллюзий, что с релизом все наладиться. Я наблюдаю WW со средины мая, в том числе и за изменениями в репозитарных версиях драйверов, а их тоже было немало. Позволю себе предположить, что все дело в модели вашей видеокарты, ибо моя HD 6670 уже признана имеющей определенную несовместимость с Ubuntu, и то с драйверами нет проблем.

0
kvius - 30 Сентябрь, 2015 - 08:43

Работать у нас он тоже будет, так как у нас стоит gcn 1.1, но ощутимый прирост получат видяхи от r9 285 (обидно ибо она говно по сравнению с нашей) и выше!

+1
Priestone - 3 Октябрь, 2015 - 05:57
Изображение пользователя Priestone.

Однако... На открытых драйверах WoT 9.10, установленный с помощью playonlinux, выдал FPS выше, чем на закрытых в 14.04/14.10 ...

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры