Установка из deb

Я нуб
Пытался ставить несколько программ из deb файлов и всегда была одна проблема. Например скайп. Скачав скайп с оф. сайта и установив его я не увидел его в меню. Таким образом у меня возник вопрос он вообще установился или нет и где его искать. Потом поставил из репозитория по инструкции в сети и вуаля всё встало как по маслу и ярлык скайпа появился в меню.

В чем моя ошибка и как правильно ставить програмы их файлов deb?

p/s/ как я понял deb требует ещё каких-то действий , кроме как "кликнуть и готово" как в виндуз

+2
Mike - 16 Декабрь, 2014 - 07:11
Изображение пользователя Mike.

аффтар, почему ты не пользуешься поиском по форуму? что мешает тебе? Я допускаю, что тебя забанили в гугле, но тут то всяко нет!

0
ValeryK - 16 Декабрь, 2014 - 08:34

Да муон то как гнал по установке из кирилических директорий ака Загрузки так и гонит, вот и результат. Я своим знакомым когда ставлю кубунту, всегда устанавливаю sudo apt-get install software-center и установку дебов возлагаю на него, таких вопросов после этого не возникает. Ну согласитесь что муон кривой и ничего не делается в этом направлении.

0
kot040188 - 16 Декабрь, 2014 - 08:52
Изображение пользователя kot040188.

Во первых, muon недавно стал достаточно ровным =) Во вторых, он не занимается установкой deb, этим занимется qapt. Вот он-то и не понимает кириллицу.

0
ValeryK - 16 Декабрь, 2014 - 11:44

хрен редьки. Ставлю убунтовский центр приложений и не парюсь, он еще и блокировки адекватно отрабатывает. А для обычных установок сам всегда пользую apt-get.

0
kot040188 - 16 Декабрь, 2014 - 09:02
Изображение пользователя kot040188.

В чем моя ошибка
В нежелании воспользоваться поиском по форуму прежде чем создавать десять раз разжёванную тему.
Потом поставил из репозитория по инструкции в сети и вуаля всё встало как по маслу и ярлык скайпа появился в меню
Именно поэтому стоит всегда ставить приложения из специально придуманных для этого хранилищ. Это же очень удобно. А главное безопасно (правда скайп это неудачный пример). И только если что-то не устраивает или приложения нет в хранилищах, можно попробовать установить из deb-пакета.

0
ValeryK - 16 Декабрь, 2014 - 11:50

1. Под виндой такой хери нет при установке ехе-шников, и откуда человеку догадаться например что то, что работает например в убунте который год криво пашет в кубунте, да еще настолько нужное. Вспомните сколько времени в кедах лечили переключение раскладки (кот наверно даже и не знает об этом)
2. Такие приложения как скайп , хром, вайбер, Plex, и т.д и т.п. не понаставишься из реп, некоторые старые, а некоторых просто нету. Не путайте новичка, пообвыкнется с косяками и тоже перестанет их замечать.

+1
kot040188 - 16 Декабрь, 2014 - 12:09
Изображение пользователя kot040188.

1. Под виндой много чего нет. Давайте не будем сваливаться в сравнение систем и отклонятся от темы. Если бы автор темы использовал поиск, то вопросов у него было бы меньше.
не путайте новичка
В каком это месте я его путаю?! Или использование хранилищ это теперь дурной тон, и вообще выходит из моды? =D Между прочим автор темы поставил скайп именно из хранилища, что как бы намекает…

0
ValeryK - 16 Декабрь, 2014 - 12:24

Ну спросил, да и то после того как сам решил проблему, давайте его камнями закидаем.
А использование хранилищ при наличии более свежих проприетарных программ - не знаю, я не согласен. У меня всегда самые последние драйвера от AMD и Nvidia, Хром хоть редко пользуюсь, Viber вообще нету в репах. А вот системные, взаимосвязанные, стараюсь не трогать чтобы не нарушать хрупкий баланс.

0
kot040188 - 16 Декабрь, 2014 - 14:27
Изображение пользователя kot040188.

А почему вы думаете, что в хранилищах должны быть обязательно старые версии приложений. Бывает конечно, но не является правилом. Решение вопроса кстати, вполне годное, не знаю, что автору не понравилось.
З.Ы. Через интернет камнями трудно кидать…

0
DarkneSS - 16 Декабрь, 2014 - 22:08
Изображение пользователя DarkneSS.

Дрова не обновляют в рамках релиза мажорно, чтобы исключить вероятность поломки иксов при обновлении внутри релиза.
Не самый новый != плохой # по крайней мере, если видео не принадлежит двум последним поколениям
Кому шашечки, а кому и ехать.

0
nitrofox - 16 Декабрь, 2014 - 08:57
Изображение пользователя nitrofox.

Если вы пользуетесь qapt-deb-installer. Проблема в том что он не понимает русский в пути к файлу.
Можете просто скопировать или сделать силку файл кудато в другое место(допустим в папку /tmp) и от туда запустить.
Я написал скрипт. Принцип такой. Он делает символическую ссылку на deb файл и передает ее программе qapt-deb-installer. Остается только в проводнике указать чтобы deb файлы открывались при помощью скрипта. Вроде даже нормально работает=)

+2
Chibiko - 16 Декабрь, 2014 - 09:44
Изображение пользователя Chibiko.

Что только не напишут, чтобы не юзать gdebi-kde....

0
kot040188 - 16 Декабрь, 2014 - 17:18
Изображение пользователя kot040188.

А он уже работает?! Я не слышал такой новости… Действительно работает, но после успешной установки падает при закрытии =) Правда в отличии от qapt пытается вывести на экран название неудовлетворённой зависимости, но обрывает название на половину. Не подсказывает, что в хранилищах лежит этот же пакет с другой версией. Не показывает подробности пакета, содержащиеся в нём файлы и подробности установки. И на английском. А так работает…

0
Chibiko - 16 Декабрь, 2014 - 17:45
Изображение пользователя Chibiko.

Дарёному коню...
Меня вполне устраивает как он работает.
Если не нравятся его падения в конце установки, используйте консольный вариант.
UPD: Если не нравится, то могу посоветовать немного подучить плюсы, QT и дописать чтобы не падало )

0
kot040188 - 16 Декабрь, 2014 - 18:22
Изображение пользователя kot040188.

Так если бы этого коня раньше подарили. А то ведь совсем недавно, а повод был очень давно…

0
nitrofox - 16 Декабрь, 2014 - 13:09
Изображение пользователя nitrofox.

Ну давно написал скрипт. Не выбрасывать же его? Вот и пользуюсь. Пока что не подводил.. У меня уже собрался целый архив скриптов которые кочуют от одной версии kubuntu к другой..

0
ValeryK - 16 Декабрь, 2014 - 11:59

Ёшкин кот, а не проще создать папку Downloads, затем зайти в "Настройки системы -> Учетная запись -> Пути" и в "Папка загрузок" выбрать путь на нее. Затем будет даже предложено перенести данные со старой папки в новую, и все. Вам обязательно нужна папка с русским названием?

0
nitrofox - 16 Декабрь, 2014 - 13:12
Изображение пользователя nitrofox.

Ну этот вариант более универсальный. Работает с любыми путями.. Один раз написал скрипт и забыл о проблеме.

0
Apanni - 16 Декабрь, 2014 - 11:35

поставь gdebi-kde. у него проблем ни с русским языком, ни с установкой скайпа и прочего софта из deb пакетов

0
kot040188 - 16 Декабрь, 2014 - 14:27
Изображение пользователя kot040188.

Неужели он уже работает?! Пару месяцев назад, он никак не работал! Действительно работает… но не очень…

+1
nero_aida - 16 Декабрь, 2014 - 17:55
Изображение пользователя nero_aida.

Друзья, ну много что уже сказанно про новичков и не новичков. Я пользуюсь linux с 2006 года, а полнстью забросить винду и приложения связанные с ней только в 2010-м. За последнии 2 года я мигрировал с ubuntu на kubuntu, затем на Debian, а потом и вовсе на gentoo. Но я ни разу не создавал новые темы на форумах. Абсолютно на любой мой вопрос я находил разжёванный ответ в гугле. Нужно только не лениться искать эти ответы. При этом вопросы были крайне сложные, по сравнению с установкой пакета deb, про который написано на каждом форуме по 100500 тем. Даже элементарно на оф. сайте Debian написан принцип установки деб через dpkg. Уж если прочесть эту статью, то больше в жизни никогда не понадобятся ни muon, ни убунтовский центр приложений.

0
Chibiko - 16 Декабрь, 2014 - 18:06
Изображение пользователя Chibiko.
+1
ValeryK - 16 Декабрь, 2014 - 18:56

Когда-то, давным давно, хотя наверно и не очень, семь-восемь лет назад, когда я начинал пробовать различные дистры и окружение, поставив лин с KDE пытался настроить клавку, указывал нужное сочетание, нажимал подтвердить и т.п. но она переключалась по своим каким то законам. Спросил у брата, который уже вовсю имел опыт в кедах, на что получил поразивший меня тогда ответ:
А, так это известный старый баг! Надо делать вот так-то...
Я офигел. Старый известный баг, раз все знают можно и не лечить.
Данная ситуация в этом посте в точности повторяет мой тогдашний опыт, это старый баг, все знают что толи муон, толи кьюапт на ставит из кирилической директории, так мало того он еще отчитывается что он молодец и все установлено. Это на самом деле печальная практика.
Как в ХР было, если идет копирование в проводнике и закрыть проводник то без слов ряпалось копирование, а все считали это естествеенным - нельзя закрывать проводник пока копируется! (Как там счас с этим то?) Так вот и рассуждаем: нельзья использовать кьюапт при установке (хоть он и дефолтовый) ведь это же естественно!
P.S. Я тогда облюбовал Гном.

0
kot040188 - 16 Декабрь, 2014 - 19:09
Изображение пользователя kot040188.

Оставьте в покое muon! Он тут совершенно не при чём! Он уже почти торт =) С остальным согласен. Даже предлагают переименовывать директории, только чтобы не исправлять баг.
З.Ы. Не могут кеды без этого, вот вам ещё бородатый баг … =)

0
ValeryK - 16 Декабрь, 2014 - 19:05

Оставьте в покое muon!
Извини, ничего личного. (:-D

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры