DVB SKYSTAR2 EXPRESS HD

Здравствуйте.
Догадываюсь, что буду унижен и послан подальше в гугл, но всё-таки.
Имею несколько карт SKYSTAR2. В данный момент установлена SKYSTAR2 EXPRESS HD. Нужно установить драйверы и настроить возможность просмотра и записи каналов. Спутниковый интернет и граббинг не нужен.
нашел это видео http://www.youtube.com/watch?v=KiSIJF1Y7co, где показано, что карта работает. И ссылку на процесс установки: https://bitbucket.org/CrazyCat/v4l-updatelee. Выполнил все пункты, перезагрузился, попытался подключиться к карте через VLC - не получилось. Так как в гугле нет чёткого описания процесса настройки, вполне возможно, что что-то сделал неправильно. Шаг sudo make deb-pkg выдал несколько ошибок, но процесс дошел до конца. Это заняло около часа.
В выводе LSPCI DVB-карта не обнаруживается. В директории /dev/dvb/ есть поддиректория adapter0, в которой находятся несколько файлов. Какие именно - не помню. Это значит, драйверы карты поставились или нет?
Пробовал в Kubuntu 14.04 x64 и Linux Mint 17 x32

0
AlexBKost - 3 Февраль, 2015 - 11:41

Нужно настроить возможность просмотра и записи каналов. В соседней теме ещё только вчера обсуждалась такая возможность. Не нужно далеко ходить в "гугл".

0
Kubuntovich - 3 Февраль, 2015 - 13:07

Во-первых, там карта далеко не SkyStar. Во-вторых, там обсуждается программа просмотра, а не установка драйверов. А мне сейчас надо именно драйверы на нее поставить, чтобы система ее хоть как-то видела.

0
Гость - 3 Февраль, 2015 - 13:29

Это значит, драйверы карты поставились или нет? Попробуйте средствами, описанными в той теме, и вам станет понятно.

Я только сам не понимаю, вы привели аж две ссылки, по которым карта должна уже работать, а теперь предъявляете мне претензии.

0
AlexBKost - 3 Февраль, 2015 - 14:38

ЗЫ: Пост мой.

0
lord_i - 3 Февраль, 2015 - 12:11
Изображение пользователя lord_i.

У меня давно и успешно работает для таких целей vdr. Очень гибкий сервер с кучей возможностей.
Отрицательнай сторона - надо с ним глубоко разбираться. Все исключительно на конфигах и никакого гуя.
Если решите и будут по нему вопросы - постараюсь помочь.

ЗЫ Если есть директорий /dev/dvb то система карту видит. Какие файлы там есть?
покажите
:/dev/dvb/adapter0# ls -al

0
Kubuntovich - 3 Февраль, 2015 - 13:24

Я ошибся. Директория /dev/dvb/ есть только в Linux Mint. В Kubuntu ее нет. Значит, драйверы не встали? Как их правильно поставить?
на пункте sudo make menuconfig вылезло меню настроек. Я оставил всё по дефолту. Может, нужно было что-то изменить?
Вот содержимое папки /dev/dvb/adapter0/ из Linux Mint 17:
usb@usbhddmint /dev/dvb/adapter0 $ ls
demux0  dvr0  frontend0  net0

но минт установлен на USB-HDD и DVB там не сильно нужно. На кубунте надо.
У меня давно и успешно работает для таких целей vdr. Очень гибкий сервер с кучей возможностей.
Отрицательнай сторона - надо с ним глубоко разбираться. Все исключительно на конфигах и никакого гуя.

А кафеином (Kaffeine) его нельзя заменить? Там же вроде есть кнопка "запись".

0
AlexBKost - 3 Февраль, 2015 - 13:41

Я ошибся. Директория /dev/dvb/ есть только в Linux Mint. в Linux Mint карта работает? Запускайте Kaffeine.

0
Kubuntovich - 3 Февраль, 2015 - 13:57

Я не знаю, работает карта или нет. Есть факт наличия директории /dev/dvb/adapter0 и файлов в ней. Запускаю Kaffeine. Жму кнопку "каналы". Открывается какое-то окно. Наверное, тут нужно выбрать устройство и вбить транспондеры. Но выбор устройства недоступен.
Сейчас сижу в винде, так как не могу залогиниться на этот форум из линукса. По-этому, не помню, как точно называется каждая кнопка в Kaffeine.

0
AlexBKost - 3 Февраль, 2015 - 14:04

...так как не могу залогиниться на этот форум из линукса. У вас сплошные проблемы. Сначала решите эту, ибо одно нерешенное тянет за собой другое, как снежный ком.

0
Kubuntovich - 3 Февраль, 2015 - 15:16

Решил проблему с логином. Я в кубунте. Директории /dev/dvb/ нет. Что делать?

0
AlexBKost - 3 Февраль, 2015 - 15:37

Поищите свою карту тут. Если она там есть, то и на правильные драйвера ссылка будет.

0
Kubuntovich - 3 Февраль, 2015 - 16:25

Там нету SkyStar Express HD. Но по ссылке из первого поста она есть. Написано, что метод установки тестировался на списке карт, включая ее. Почему же тогда не работает?

0
AlexBKost - 3 Февраль, 2015 - 16:43

1. Могли и приврать по списку.
2. Разбирайте ошибки по: Шаг sudo make deb-pkg выдал несколько ошибок, но процесс дошел до конца.

0
Гость - 4 Февраль, 2015 - 08:01

1. и что тогда? там есть похожая, но там в lspci цифры немного отличаются и ревизия 01, а у меня 03.
2. Как же я их разберу? Они убегают быстро, их толком не прочитаешь. А если удается бегло прочитать, то это похоже на ошибки при компиляции исходника С++ с указанием на строчку с ошибкой. И что мне - самому ошибки в коде исправлять?

0
lord_i - 3 Февраль, 2015 - 23:34
Изображение пользователя lord_i.

Вы должны на кубунте добиться такого же содержимого как в минте. В Минте все корректно.
Путь избран правильный (https://bitbucket.org/CrazyCat/v4l-updatelee)именно это и надо ставить.
По поводу кофеина - он очень глючный. Я им поигрался и бросил. VDR - очень стабильная и удобная система, работает как часы, к ней хорошо подключается тетя шура. И вообще - это сервер со всеми вытекающими. Можно смотреть со всех устройств в сети локальной и даже из инета без проблем.

0
AlexBKost - 4 Февраль, 2015 - 00:00

Можно смотреть со всех устройств в сети локальной и даже из инета без проблем. Я тоже полагаю, что сейчас из интернета можно увидеть ВСЁ без разных там DVB-карт. Но если очень хочется, то можно и с ними.

Не счет Kaffeine согласится не могу, хотя и сам предпочитаю ему и всем остальным SMPlayer.

0
lord_i - 4 Февраль, 2015 - 00:26
Изображение пользователя lord_i.


Я тоже полагаю, что сейчас из интернета можно увидеть ВСЁ без разных там DVB-карт. Но если очень хочется, то можно и с ними.

Я имел в виду что используя сервер VDR можно смотреть ТВ со спутника не только на компе, где установлена DVB-карта но и на всех устройствах как в локальной сети так и через интернет. Именно с данной DVB-карты.
Совершенно уверен что и кофеин и смплеер сильно проигрывают в возможностях перед vdr. Их даже сравнивать некорректно, поскольку vdr это сервер а они клиенты по сути.

0
AlexBKost - 4 Февраль, 2015 - 00:42

Да Бог с ними, с кофеин, смплеер и vdr. У ТС вообще ничего не заводится.
Именно с данной DVB-карты. У вас такая же карта? Так почему ТС до сих пор не пометил тему решенной?

0
lord_i - 4 Февраль, 2015 - 00:56
Изображение пользователя lord_i.

Данной - установленной на компе с VDR.
По поводу конкретной карты ТС - если на минте установились дрова Липлянина они и на кубунте должны встать. Там, если я не ошибаюсь, надо не по дефолту меню настроек оставлять, а внимательно по всему пройтись и активировать дрова этой карты.

0
AlexBKost - 4 Февраль, 2015 - 01:26

Насколько я понимаю, информации по DVB-S на этом сайте - ноль. Пардон, близко к нолю, даже учитывая эту тему. А если еще учесть разнообразие DVB-S карт, то даже наши усилия не помогут ТС решить его проблему, если он сам не захочет этого основательно. А мы уже пытались.

ЗЫ: Помните:
Но я не плачу, никогда не плачу,
Есть у меня другие интересы.
И я шучу — я не могу иначе.
Да потому, что я - кто? - родом из Одессы.
(С)

0
Гость - 4 Февраль, 2015 - 08:23

Вы всё правильно подметили. Как можно самому что-то сделать, если информации по вопросу 0?

0
AlexBKost - 4 Февраль, 2015 - 22:16

0 - про на этом сайте только. А на просторах ее хватает.

ЗЫ: тут пишут, что карту таки запустить можно.

0
Kubuntovich - 5 Февраль, 2015 - 08:27

Если не ошибаюсь, там речь идет о ядре версии 2.6

0
Гость - 4 Февраль, 2015 - 08:19

Я поиском набрал skystar и ничего не нашлось. Как еще она может называться?
минт 32бит, кубунта 64бит. По-этому, в минте я в том меню убрал галочку с пункта "64-bit что-то там", а на кубунте ее включил. Но не уверен, что на минте карта работает, несмотря на наличие папки /dev/dvb/

0
Гость - 8 Февраль, 2015 - 10:46

И чё всё заглохло-то? Отправили в гугл, считай помогли?
Опробовал метод CrazyCat на Kubuntu x32. После перезагрузки чёрный экран смерти и всё.

0
akal - 8 Февраль, 2015 - 19:08
Изображение пользователя akal.

И чё всё заглохло-то? Отправили в гугл, считай помогли?

Ну причин почему "заглохло" может быть несколько. Навскидку:

  • Не у всех возникает такая задача. Ну нет у человека такого оборудования и оно ему не нужно.
  • Человек выполняет эту же задачу на другом оборудовании и воспроизвести ошибку не может.
  • Человек выполняет задачу на идентичном оборудовании, у него ничего не работает и помочь ничем не может.
  • Оборудование идентично Вашему, все работает, но его пол-года нет на этом форуме в связи с полной идиллией в жизни.

А если серьезно, уважаемый Гость, чего вы ждали конкретно? Помощи на уровне линии консультаций производителя? Вынужден разочаровать Вас. Это OpenSource и помощь (если помощник знает как помочь) абсолютно бескорыстна и по желанию. Так что директорский тон желательно не применять =).

0
Kubuntovich - 11 Февраль, 2015 - 15:28

А если серьезно, уважаемый Гость, чего вы ждали конкретно? Помощи на уровне линии консультаций производителя? Вынужден разочаровать Вас. Это OpenSource и помощь (если помощник знает как помочь) абсолютно бескорыстна и по желанию.
Так и не поняли. Хорошо, постараюсь предельно в красках обрисовать ситуацию. Речь пойдет о другой карте, но тут без разницы, хрен тот же, просто с другого бока.
Вот допустим, ситуация из жизни: решил купить DVB-карту. Самое дешевое и единственное решение в магазинах города - Technisat SkyStar S2. Гуглю описание - прием DVB-S, DVB-S2, MPEG-2, MPEG-4, SD/HD каналы. Всё норм. Системные требования: bla-bla, windows 95/98/2000/XP/vista/2008/7/Linux. О, LINUX! Радостно воскликаю я. Значит от винды можно отказаться. Ок, гуглим дальше. Гуглим "skystar s2 linux" и видим кучу тем на форумах, где наверное умные люди знают, о чем говорят. Ок, думаю, проблем не будет. Покупаю карту, вставляю ее, ставлю Linux. Пишу lspci и вижу, что карта определилась. Начинаю читать форумы, делать как написано во всевозможных инструкциях и выясняется, что либо ссылки на требуемые файлы сдохли, либо возникают ошибки при сборке, либо не находится какая-то важная директория. Но чаще всего инструкция написана просто под устаревшую версию ядра! Но ты этого ни за что не узнаешь, пока не купишь устройство.
Что делать в таких случаях - ничего не написано. Приходится встать на колени и написать пост с мольбой о помощи на форуме твоей ОС. А тебя посылают в google (люблю это слово. Оно так мерзко звучит, с протяжкой так и ударением на обе Г "ГууГгллл") и пошел ты на второй круг смотреть на даты постов - 2009,2010, 2011 , ну максимум 2013, где всё-равно что-то не патчится по непонятной тебе причине. Хочется спросить у кого-нибудь, но тут вспоминаешь этот чудесный звук, с протяжкой так и ударением на обе Г "ГГгууГгллл".
Мда, вот такая история. И потом, почему бы владельцам DVB карт ни собраться и ни написать бы пошагово как и что ставить? Ах да, никому же это не надо. Даже самому Липлианину это не надо. Даже сайт нормальный себе не смог сделать. Кто-то же пишет эти драйверы. Почему бы не прилагать к ним инструкцию, а не перекладывать это на гугл и форумы?

+4
ValeryK - 11 Февраль, 2015 - 17:04

У меня была карта Skystar II помоему, без S, а может и такая, не помню, было года три - четыре (да какбы не больше!) назад. Работала "с коробки" и шаринг пахал на кафеине, потом забил на шаринг, потом на саттв. И, даже если попытаться найти ту карту в гараже, затем подключить, так мне еще и антенну надо прикрутить и НАСТРОИТЬ, что вообще нетривиальная задача вручную без оборудования, а вызывать пацанчиков и платить за настройку ненужного мне оборудования както сам понимаешь, бессмысленно. ПОТОМУ и помочь ничем не могу, тему вижу, заглядываю даже как видишь, и думаю у большинства так на этом форуме. Не от лени или вселенской личной ненависти, а от отсутствия возможности эмулировния проблемы (довольно таки еще и специфичная тема). Спроси что нибудь другое, как пропатчить КДЕ например.
И посмотри сколько тем с меткой "Решено", т.е. чем смогли помогли?

0
Kubuntovich - 12 Февраль, 2015 - 15:53

Какой хоть дистрибутив-то был?

0
ValeryK - 12 Февраль, 2015 - 18:18

какаято убунта, еще до 3-го гнома, и кофеин версии 0.9.7 вроде , потом 1-й вышел, но в нем плагины все сломали и шаринг не работал, приходилось замораживать версию.
P.S. Нашел свои записи на гуглесайтах, там создавал себе напоминалки, это было 18 янв. 2009 г.

0
AlexBKost - 11 Февраль, 2015 - 17:50

Приходится встать на колени и написать пост с мольбой о помощи на форуме твоей ОС. А тебя посылают в ... Дружище Kubuntovich, вы еще не поняли, что на сайте всего два владельца аналогичной, всего-то, железки — lord_i и ValeryK, Даже я не в счет, потому и в "ГууГгллл" посылают, ибо понимают, что помочь могут моральной поддержкой и только.

0
Kubuntovich - 12 Февраль, 2015 - 15:59

Если у кого-то здесь, как вы говорите, была эта карта и если они были в данной теме, почему бы им ни написать, как минимум, версию дистрибутива, на котором они ее юзали?

0
ValeryK - 12 Февраль, 2015 - 18:01

я не уверен точно какой версии скайстар у меня была. Еще точно помню что шефу ставил Tevii и она тоже из коробки работала.

0
lord_i - 11 Февраль, 2015 - 21:34
Изображение пользователя lord_i.

Другого пути чем правильно скомпилировать драйвера Липлианина, форкнутые и поддерживаемые сейчас человеком с ником CrazyCat (за что ему как минимум огромное спасибо) для данной карточки не существует. Можно стенать и плакать сколько угодно - такова ситуация именно с этой карточкой к сожалению. Кстати, не факт что все заработает даже при удачной установке дров. Эти карточки имеют разные аппаратные реализации и, например в моем случае, так и не заработал S2 :(
По установке - как я выше уже писал - там не надо компилировать по дефолту. Там надо запустить конфигуратор и вдумчиво его настроить на конкретный чип, который на Вашей карточке - это важно. По умолчанию дрова для этой карточки ВЫКЛЮЧЕНЫ. По крайней мере так было когда я этим занимался. Удачи.

0
Kubuntovich - 12 Февраль, 2015 - 16:03

Там надо запустить конфигуратор и вдумчиво его настроить на конкретный чип, который на Вашей карточке - это важно
А как узнать-то, какой там чип?

0
lord_i - 12 Февраль, 2015 - 16:32
Изображение пользователя lord_i.

Вынуть карту из компа и посмотреть.

0
Kubuntovich - 14 Февраль, 2015 - 12:52

У моей SkyStar2 express HD имеется один маленький чипчик, на котором ничего не написано. Там приклеин только QR-код.
lspci определяет карту, как Multimedia controller: Philips Semiconductors SAA7160 (rev 03)
Нашел таки инструкцию:
1. hg clone http://linuxtv.org/hg/~endriss/media_build_experimental
2. cd media_build_experimental
3. make download
4. make untar
5. sudo make
6. sudo make install
7. sudo reboot

На Linux Mint это рботает. Через Kaffeine можно смотреть открытые каналы. Картинка и звук есть.
А на Kubuntu пункт 5 выдает ошибки:
rain@ZX-SPECTRUM:/usr/src/media_build_experimental$ sudo make
make -C /usr/src/media_build_experimental/v4l
make[1]: Вход в каталог `/usr/src/media_build_experimental/v4l'
No version yet, using 3.16.0-30-generic
make[1]: Выход из каталога `/usr/src/media_build_experimental/v4l'
make[1]: Вход в каталог `/usr/src/media_build_experimental/v4l'
scripts/make_makefile.pl
Updating/Creating .config
make[2]: Entering directory `/usr/src/media_build_experimental/linux'
Applying patches for kernel 3.16.0-30-generic
patch -s -f -N -p1 -i ../backports/api_version.patch
patch -s -f -N -p1 -i ../backports/pr_fmt.patch
patch -s -f -N -p1 -i ../backports/debug.patch
patch -s -f -N -p1 -i ../backports/drx39xxj.patch
patch -s -f -N -p1 -i ../backports/v3.16_netdev.patch
patch -s -f -N -p1 -i ../backports/v3.16_wait_on_bit.patch
patch -s -f -N -p1 -i ../backports/v3.16_void_gpiochip_remove.patch
Patched drivers/media/dvb-core/dvbdev.c
Patched drivers/media/v4l2-core/v4l2-dev.c
Patched drivers/media/rc/rc-main.c
make[2]: Leaving directory `/usr/src/media_build_experimental/linux'
Preparing to compile for kernel version 3.16.0
File not found: /lib/modules/3.16.0-30-generic/build/.config at ./scripts/make_kconfig.pl line 34, <IN> line 4.
make[2]: Entering directory `/usr/src/media_build_experimental/linux'
Patches for 3.16.0-30-generic already applied.
make[2]: Leaving directory `/usr/src/media_build_experimental/linux'
./scripts/make_kconfig.pl /lib/modules/3.16.0-30-generic/build /lib/modules/3.16.0-30-generic/build
Preparing to compile for kernel version 3.16.0
File not found: /lib/modules/3.16.0-30-generic/build/.config at ./scripts/make_kconfig.pl line 34, <IN> line 4.
make[1]: Выход из каталога `/usr/src/media_build_experimental/v4l'
make[1]: Вход в каталог `/usr/src/media_build_experimental/v4l'
Updating/Creating .config
make[2]: Entering directory `/usr/src/media_build_experimental/linux'
Patches for 3.16.0-30-generic already applied.
make[2]: Leaving directory `/usr/src/media_build_experimental/linux'
Preparing to compile for kernel version 3.16.0
File not found: /lib/modules/3.16.0-30-generic/build/.config at ./scripts/make_kconfig.pl line 34, <IN> line 4.
make[2]: Entering directory `/usr/src/media_build_experimental/linux'
Patches for 3.16.0-30-generic already applied.
make[2]: Leaving directory `/usr/src/media_build_experimental/linux'
./scripts/make_kconfig.pl /lib/modules/3.16.0-30-generic/build /lib/modules/3.16.0-30-generic/build
Preparing to compile for kernel version 3.16.0
File not found: /lib/modules/3.16.0-30-generic/build/.config at ./scripts/make_kconfig.pl line 34, <IN> line 4.
make[1]: *** Нет правила для сборки цели `.myconfig', требуемой для `config-compat.h'.  Останов.
make[1]: Выход из каталога `/usr/src/media_build_experimental/v4l'
make: *** [all] Ошибка 2

Как будто заголовочники ядра не находит. Помогите, что с этим делать?
Содержимое /boot:
rain@ZX-SPECTRUM:/boot$ ls -a
.                         config-3.16.0-30-generic      lost+found                    System.map-3.19.0-rc6+
..                        config-3.19.0-rc6+            memtest86+.bin                vmlinuz-3.13.0-24-generic
abi-3.13.0-24-generic     grub                          memtest86+.elf                vmlinuz-3.16.0-29-generic
abi-3.16.0-29-generic     initrd.img-3.13.0-24-generic  memtest86+_multiboot.bin      vmlinuz-3.16.0-30-generic
abi-3.16.0-30-generic     initrd.img-3.16.0-29-generic  System.map-3.13.0-24-generic  vmlinuz-3.19.0-rc6+
config-3.13.0-24-generic  initrd.img-3.16.0-30-generic  System.map-3.16.0-29-generic
config-3.16.0-29-generic  initrd.img-3.19.0-rc6+        System.map-3.16.0-30-generic

0
ValeryK - 14 Февраль, 2015 - 14:43

а sudo apt-get inыефдд build-essential linux-headers-generic установлен?

0
Kubuntovich - 14 Февраль, 2015 - 15:26

Да, я проверял, они установлены, но это не помогало. Я установил sudo apt-get install linux-headers-3.16.0.30-generic и начало собираться. Но теперь на пункте sudo make install почти в самом конце выдает это:
depmod: WARNING: could not open /lib/modules/3.16.0-30-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/3.16.0-30-generic/modules.builtin: No such file or directory

а после перезагрузки чёрный экран.

0
ValeryK - 14 Февраль, 2015 - 15:59

apt-get install linux-generic ?

0
Kubuntovich - 15 Февраль, 2015 - 08:42

пишет, что уже установлена самая новая версия.

0
Chibiko - 14 Февраль, 2015 - 17:59
Изображение пользователя Chibiko.

на минте сделай вместо 6 пункта:
sudo checkinstall -D --install=no
перенеси собранный пакет на кубунту и попробуй установить ) Главное чтобы разрядность систем одинаковыми были.

0
Kubuntovich - 15 Февраль, 2015 - 08:38

Зайти в директорию media_build_experimental и сделать sudo checkinstall -D --install=no?
Или сначала всё удалить и проделать заново до 5 пункта?

0
Chibiko - 16 Февраль, 2015 - 16:13
Изображение пользователя Chibiko.

Пробовал в Kubuntu 14.04 x64 и Linux Mint 17 x32
Тебе не поможет =\ Не взлетит =\ Разрядность разная. Попроси кого-нибудь у кого x86_64 тебе пакет собрать.

0
Гость - 16 Февраль, 2015 - 16:53

я уже переустановил kubuntu на х32

0
Chibiko - 16 Февраль, 2015 - 18:42
Изображение пользователя Chibiko.

Ок. Тогда всё проще пареной репы. Инструкция:
1. cd ~
2. rm -rf ./media_build_experimental
3. hg clone http://linuxtv.org/hg/~endriss/media_build_experimental
4. cd media_build_experimental
5. make download
6. make untar
7. make
8. sudo checkinstall -D --install=no

в директории media_build_experimental появится пакет. Его перенести на kubuntu и установить.

0
Гость - 24 Февраль, 2015 - 10:38

При попытке установить полученный пакет на Kubuntu x32, ругается:
rain@ZX-SPECTRUM:~$ sudo dpkg -i media-build-experimental_20150224-1_i386.deb              
(Чтение базы данных … на данный момент установлено 190544 файла и каталога.)                
Preparing to unpack media-build-experimental_20150224-1_i386.deb ...                           
Unpacking media-build-experimental (20150224-1) ...                                             
dpkg: error processing archive media-build-experimental_20150224-1_i386.deb (--install):          
попытка перезаписать «/lib/firmware/cpia2/stv0672_vp4.bin», который уже имеется в пакете linux-firmware 1.127.11
dpkg-deb: ошибка: подпроцесс вставка уничтожен по сигналу (Обрыв канала)                               
При обработке следующих пакетов произошли ошибки:
media-build-experimental_20150224-1_i386.deb
rain@ZX-SPECTRUM:~$

0
Chibiko - 24 Февраль, 2015 - 13:31
Изображение пользователя Chibiko.

Ну получается что checkinstall собрал с файлом из пакета linux-firmware
sudo apt-get purge linux-firmware media-build-experimental
sudo dpkg -i media-build-experimental_20150224-1_i386.deb

И надеятся что всё ок встанет.

0
dyug - 24 Февраль, 2015 - 14:35

В вашем варианте проще всего допустить замену файла.
команда выглядит так
dpkg --force-overwrite -i имя_пакета.deb
данная команда позволит заменить файл на, возможно, более новую версию.

В данном случае мой комментарий касается только работы dpkg и не более.
часто бывает, что при постановке из ппа появляются файлы, которые нужно заменить для нормальной работы нового пакета.

0
Chibiko - 24 Февраль, 2015 - 16:51
Изображение пользователя Chibiko.

Ммм... не рекомендовал бы так делать, но да, один из выходов из этой ситуации.

0
dyug - 24 Февраль, 2015 - 16:54

в данном случае замена - на мой взгляд - правильное решение.
/вспоминая дебильную 3ком сетевуху, в которой для работы влана требовалось заливать измененную прошивку, а в ядре и модуле была старая/

0
Kubuntovich - 16 Март, 2015 - 15:39

Извините за задержку, бухал :)
Теперь после sudo make install он пишет:
...
install zr364xx.ko -> /lib/modules/3.16.0-30-generic/updates/media/
strip --strip-debug /lib/modules/3.16.0-30-generic/updates/media/*.ko
/sbin/depmod -a 3.16.0-30-generic
depmod: WARNING: could not open /lib/modules/3.16.0-30-generic/modules.order: No such file or directory
depmod: WARNING: could not open /lib/modules/3.16.0-30-generic/modules.builtin: No such file or directory
make[1]: Выход из каталога `/usr/src/media_build_experimental/v4l'
rain@ZX-SPECTRUM:/usr/src/media_build_experimental$

и при загрузке ядра несколько раз подряд что-то про /lib/modules/3.16.0-30-generic/modules.builtin

0
kot040188 - 16 Март, 2015 - 16:13
Изображение пользователя kot040188.

бухал :)
На этом форуме это неуважительная причина =)

0
Kubuntovich - 17 Март, 2015 - 08:14

а c чувством юмора тут всё в порядке?

+2
ValeryK - 17 Март, 2015 - 11:09

да когда как

0
kot040188 - 17 Март, 2015 - 13:36
Изображение пользователя kot040188.

В порядке! Разве нет? =)

0
Kubuntovich - 23 Март, 2015 - 10:40

итак, что делать?

0
Гость - 13 Апрель, 2015 - 18:53

друг, поставил драйвер то?

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры