Проблема с зависимостями - не устанавливается ни один пакет

Здравствуйте.
Недавно пытался установить эмулятор Sony Playstation 1 ePCSXe. Потребовалось установить пакет libsdl-ttf2.0-0_2.0.11-3_i386.deb. Эмулятор так и не запустился, но теперь появилась проблема с зависимостями. Не устанавливается ни один пакет.
sudo apt-get install /любой пакет/
выдaёт это:
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
libsdl-ttf2.0-0 : Ломает: libsdl-ttf2.0-0:i386 (!= 2.0.11-3) но 2.0.11-2 будет установлен
libsdl-ttf2.0-0:i386 : Ломает: libsdl-ttf2.0-0 (!= 2.0.11-2) но 2.0.11-3 будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).

sudo apt-get -f install выдаёт это:
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  libsdl-ttf2.0-0:i386
Пакеты, которые будут обновлены:
  libsdl-ttf2.0-0:i386
обновлено 1, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 46 пакетов не обновлено.
не установлено до конца или удалено 2 пакетов.
Необходимо скачать 0 B/14,9 kB архивов.
После данной операции, объём занятого дискового пространства уменьшится на 2 048 B.
Хотите продолжить? [Д/н] y
(Чтение базы данных … на данный момент установлено 310823 файла и каталога.)
Preparing to unpack …/libsdl-ttf2.0-0_2.0.11-3_i386.deb ...
Unpacking libsdl-ttf2.0-0:i386 (2.0.11-3) over (2.0.11-2) ...
dpkg: error processing archive /var/cache/apt/archives/libsdl-ttf2.0-0_2.0.11-3_i386.deb (--unpack):
попытка перезаписать общий «/usr/share/doc/libsdl-ttf2.0-0/changelog.Debian.gz», который отличается от других экземпляров пакета libsdl-ttf2.0-0:i386
При обработке следующих пакетов произошли ошибки:
/var/cache/apt/archives/libsdl-ttf2.0-0_2.0.11-3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo dpkg --configure -a выдаёт это:
dpkg: error processing package libsdl-ttf2.0-0:amd64 (--configure):
пакет libsdl-ttf2.0-0:amd64 2.0.11-3 не может быть настроен, так как libsdl-ttf2.0-0:i386 другой версии (2.0.11-2)
dpkg: error processing package libsdl-ttf2.0-0:i386 (--configure):
пакет libsdl-ttf2.0-0:i386 2.0.11-2 не может быть настроен, так как libsdl-ttf2.0-0:amd64 другой версии (2.0.11-3)
При обработке следующих пакетов произошли ошибки:
libsdl-ttf2.0-0:amd64
libsdl-ttf2.0-0:i386

Система: Kubuntu 14.04 x64

0
Chibiko - 23 Март, 2015 - 10:41
Изображение пользователя Chibiko.

Не пробовали удалить libsdl-ttf2.0-0_2.0.11-3_i386.deb ?
ePCSXe есть в стандартных репах. Называется pcsxr

0
Kubuntovich - 24 Март, 2015 - 07:37

kub@I5:~$ sudo apt-get purge libsdl-ttf2*
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Заметьте, выбирается «libsdl-ttf-gst» для регулярного выражения «libsdl-ttf2*»
Заметьте, выбирается «libsdl-ttf2.0-0» для регулярного выражения «libsdl-ttf2*»
Заметьте, выбирается «libsdl-ttf2.0-dev» для регулярного выражения «libsdl-ttf2*»
Package 'libsdl-ttf-gst' is not installed, so not removed
Package 'libsdl-ttf2.0-dev' is not installed, so not removed
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
hedgewars : Зависит: libsdl-ttf2.0-0 но он не будет установлен
tuxpaint : Зависит: libsdl-ttf2.0-0 но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).

+2
Chibiko - 24 Март, 2015 - 12:03
Изображение пользователя Chibiko.

удалите. просто. libsdl-ttf2.0-0. Тот который 32-битный поставили. без. звёздочек. один. пакет. через. aptitude. и да, он снесёт пару приложений. но. зато. восстановите. целостность. системы.
Потом просто надо будет сделать apt-get update && apt-get clean && apt-get install hedgewars tuxpaint pcsxr

И ещё. НЕ. Посторяю: НЕ! НЕ ставьте пакеты из непроверенных источников!!! НЕ ставьте пакеты от других версий дистрибутива. НЕ ставьте пакеты от других дистрибутивов.
Чревато последствиями. Особенно если не знаете что такое зависимости и как их решать.

0
Kubuntovich - 24 Март, 2015 - 12:19

Спасибо, работает.

0
dyug - 24 Март, 2015 - 11:54

libsdl-ttf2.0-0 :
Ломает: libsdl-ttf2.0-0:i386 (!= 2.0.11-3) но 2.0.11-2 будет установлен
libsdl-ttf2.0-0:i386 : Ломает: libsdl-ttf2.0-0 (!= 2.0.11-2)
но 2.0.11-3 будет установлен

КАК? могут поставиться ДВЕ разные версии?
это КАК надо было не обновляться, чтоб получить такую старую версию?
sdl-ttf2.0 (2.0.11-3) unstable; urgency=medium

  * Bump Policy Standards-Version to 3.9.5 (no changes needed)
  * Remove field "DM-Upload-Allowed: yes", obsolete
  * Change maintainer address to @debian.org
  * Regenerate with dh_autoreconf without using upstream's autogen.sh

-- Manuel A. Fernandez Montecelo <mafm@debian.org>  Fri, 20 Dec 2013 15:46:53 +0000

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры