Два монитора с различными расширениями

Всем привет,

до недавнего времени у меня стояло 2 монитора с одинаковыми расширениями по 1280x1024 и не было проблем. Приобрёл себе FULL HD монитор, дабы идти в ногу со временем и иметь большую рабочую область. Сначала хотел подключить сразу все три, широкоформатный по центру, а маленьние по бокам. Так как третьего кабеля не было под рукой, подсоединил только два: широкоформатный (1920x1080) и один из старых (1280х1024). Вот тут и начались проблемы.

Широкоформатный выдает 1919x1080 и растягивает сеё изображение на нативное 1920x1080, в итоге картинка получается размытая в большинстве случаев.

Пробывал менять разширение через xrand, ставил нужное, но толку нет. Если подключать лишь один широкоформатный, то проблема исчезает.

P.S. Конфиги (Xorg.conf)

Использующийся драйвер

Видеокарта: HD 5870
Оба монитора подсоединены по DVI

0
AlexBKost - 25 Май, 2015 - 22:05

Начинаю читать новую интересную тему. Вижу метку xorg.conf, а самого xorg.conf так и не увидел, дочитав до самого конца, лишь впечатляющую комбинацию цифр "всего 1919x1080". Определенно могу сказать только одно - при таком отношении к вопросу, даже при наличии третьего кабеля, не получилось бы ничего путного.

0
FewG - 25 Май, 2015 - 22:21

Xorg.conf

Как видно настройки все стандартные.

0
Гость - 25 Май, 2015 - 23:52

Знаешь, я как своей Ж почувствовал, что в этой теме пойдет речь про карту AMD, в чем у меня имеется личный интерес, потому и начал завуалированно допытываться подробностей, когда их еще не было в основном тексте.
А теперь что мы все видим - в xorg.conf прописан драйвер проприетарный fglrx, а на картинке используемого драйвера - свободный xserver-xorg-xideo-ati. Вопрос: как это можно совместить?

0
AlexBKost - 26 Май, 2015 - 00:02

Пост мой, поспешно переключался между 15.04 и 14.04 и не заметил отсутствия аутентификации.

+1
Vern - 26 Май, 2015 - 11:14

Добрый день!
У меня была похожая ситуация с двумя мониторами VGA. Один сразу установил нужное разрешение, второй только на 1024х768. Менял местами -- теперь второй монитор работал 1024х768. Оказалось, на втором канале видеокарты не видится модель монитора. После долгих ковыряний на форумах Ubuntu нашел, как в xorg принудительно поставить разрешение стандартному монитору по умолчанию. После этого проблема исчезла.
Извиняюсь, что не дал рецепта, но хоть направление поиска, думаю...

+1
Sabalt - 25 Май, 2015 - 23:25
Изображение пользователя Sabalt.

А почему с xrandr не получилось?
xrandr --newmode "1366x768"   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync
xrandr --addmode VGA1 "1366x768"
xrandr --output VGA1 --mode "1366x768" --left-of LVDS1  --primary
xrandr --output LVDS1 --mode "1024x600" --right-of VGA1
Я вот таким образом подключался.

0
dyug - 26 Май, 2015 - 10:29

что то меня сильно смущает что по мнению Хорга монитры включены по ВГАкабелю Identifier "0-CRT2"
и как мне кажется, оно как то пытается работать через ВГА режимы...
Это мое мнение, и я стараюсь не использовать видеокарты АМД. :-)

А вообще, более интерсно было бы глянуть лог хорга
обычно он лежит в
[email protected]:~$ ls -l /var/log/Xorg.0.log
-rw-r--r-- 1 root root 52325 Май 26 10:14 /var/log/Xorg.0.log

0
FewG - 26 Май, 2015 - 15:33

Конфиг, как мне кажется, почему-то не влияет на работу, ибо пробывал все три варианта дров (скрин выше), а содержание файла не менялось.

Хотя xrandr говорит о DVI подсоединениях:

Содержание Xorg.0.log

Устанавливал проприетарные дрова с амд-сайта. После кучи смены расширений в CCC (Catalyst Control Center) и прочих рандомных кликах на всякие кнопочки и настройки, был получен желанный результьтат, но экрана рендерился рывками, как будто, и дров никаких не устанавливал.

+1
AlexBKost - 26 Май, 2015 - 16:36

Судя по приведенному Xorg.0.log, сейчас работает свободный драйвер РАДЕОН, но тогда в системе не должно быть такого xorg.conf, как в шапке темы.
пробывал все три варианта дров (скрин выше), а содержание файла не менялось. он сам не меняется, а генерируется командой sudo amdconfig --initial -f и может быть изменен через Catalyst Control Center. А сейчас в системе какая-то каша - неграмотно устанавливать другой драйвер, предварительно корректно не удалив предыдущий.
Предлагаю следующий вариант действий:
1. Через Synaptic проверить, наличие оставшихся хвостов от FGLRX и удалить их.
2. Удалить файл xorg.conf.
3. Перезагрузиться.
4. Установить проприетарный драйвер AMD по инструкции по пункту Installing Catalyst Manually, там же как настраивать.
5. Перезагрузиться, наслаждаться правильной работой.

0
FewG - 26 Май, 2015 - 17:35

Как писал уже выше, проприетарные драйвера решают проблему с расширением, но создают новую, работать невозможно, ибо экран рывками отрисовывается и вентилятор карты уходит на взлёт. Хоть переходи обратно на два по 1280x1024 монитора.

P.S. Видимо поэтому и Xorg Server указан как рекомендуемый драйвер для системы.

0
Гость - 26 Май, 2015 - 17:55

Проприетарный FGLRX, предлагаемый устанавливать из офрепов, имеет версию 15.200. Не знаю кто как и из чего его собирает, но я тоже не доволен его работой, но в другом плане.
Если установить вручную с сайта AMD, то получается совсем другой результат, как по работе, так и по версии (14.501).
Я никого не уговариваю ничего делать, просто имею опыт работы с этой проприетарщиной и методами установки на четырех системах.

0
AlexBKost - 26 Май, 2015 - 21:29

Это я опять промахнулся.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры