Ubuntu 14.04.3 LTS и libegl1-mesa-drivers-lts-vivid» не найден кандидат...

Обновляюсь с Lubuntu 14.04.2, для перевода уже существующих установок на новые версии ядра и графического стека следует выполнить команду, но пишет ошибку:

[email protected]:~$ sudo apt-get install linux-generic-lts-vivid xserver-xorg-lts-vivid libegl1-mesa-drivers-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid
password for luba:      
Чтение списков пакетов… Готово
Построение дерева зависимостей      
Чтение информации о состоянии… Готово
Пакет libegl1-mesa-drivers-lts-vivid недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета «libegl1-mesa-drivers-lts-vivid» не найден кандидат на установку

+5
AlexBKost - 7 Август, 2015 - 14:15

Откуда вы выциганили эту команду для обновления? Здесь пишут, что следует так обновляться:
sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-core-lts-vivid xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid libwayland-egl1-mesa-lts-vivid Сам не пробовал, поэтому ничего гарантировать не могу.

UPD: Добрался таки до Kubuntu 14.04 - обновление возможно:

UPD2: Обновление проверялось на сборке Fierta, большой ему привет и наилучшие пожелания. Сборка просто ничем не убиваемая, даже такими "сомнительными" обновлениями. Ждем новую сборку на 16.04.

+2
Fierta - 7 Август, 2015 - 21:38
Изображение пользователя Fierta.

большой ему привет и наилучшие пожелания.
И Вам всего самого доброго и наилучшего :)

0
Aleksandru71 - 8 Август, 2015 - 19:46
Изображение пользователя Aleksandru71.

А у меня почему то по вашей строчке нет пакетов:

0
AlexBKost - 8 Август, 2015 - 20:01

А у меня почему то по вашей строчке нет пакетов: такое тоже может быть, но эта строчка не моя, а из офф-вики. Вам для начала нужно было еще выполнить sudo apt-get update

0
Aleksandru71 - 8 Август, 2015 - 20:17
Изображение пользователя Aleksandru71.

Естественно выполнял, не помогло.

0
AlexBKost - 8 Август, 2015 - 20:48

Получается, что виноват ваш репозиторий, указанный в source.list. У меня репозиторий другой. точнее его зеркало.

0
Aleksandru71 - 9 Август, 2015 - 00:20
Изображение пользователя Aleksandru71.

А разве не в оффрепах обновление?

0
AlexBKost - 9 Август, 2015 - 11:31

Естественно, так никто и не предлагал добавлять специальные репы. Первый упомянутый у вас недоступный пакет xserver-xorg-core-lts-vivi в моем случае находится по пути

Проверьте его наличие в своем репе (я же не знаю какой он), если он там таки есть, значит у вас проблемы с source.list - это может означать, что источник для загрузки пакета не упомянут в sources.list
0
Aleksandru71 - 9 Август, 2015 - 19:31
Изображение пользователя Aleksandru71.

Теперь мне вот такое выдает:

0
Fierta - 9 Август, 2015 - 20:09
Изображение пользователя Fierta.

Попробуйте основной сервер или другие зеркала. В ru.archive.ubuntu.com, пусто.

0
Aleksandru71 - 9 Август, 2015 - 20:42
Изображение пользователя Aleksandru71.

Эти пакеты у меня есть, у меня с зависимостями проблема.
Если через синаптик пытаюсь поставить например этот пакет: xserver-xorg-lts-vivid, то предлагается снести больше половины кед.

0
AlexBKost - 9 Август, 2015 - 22:39

Можете попробовать удаление этих двух файлов:
/var/cache/apt/pkgcache.bin
/var/cache/apt/srcpkgcache.bin,
а затем снова выполнить sudo apt-get update.
Если с репозиторием и sources.list порядок, должно помочь.

0
Aleksandru71 - 9 Август, 2015 - 23:20
Изображение пользователя Aleksandru71.

Не помогло, да и чем могло помочь.
Пакеты есть, что то с зависимостями.
На всякий случай, вот мой sources.list:

0
AlexBKost - 10 Август, 2015 - 11:33

Пакеты есть, что то с зависимостями. Я просто вынужден снять шляпу перед серьезностью вашего sources.list, но в тоже время пожурить вас за то, что не опубликовали его в своем первом посте. Как по мне всему бедой Xorg Edgers PPA http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu и ваш OFFICIAL UBUNTU REPOS

0
Aleksandru71 - 10 Август, 2015 - 17:20
Изображение пользователя Aleksandru71.

Удалось обновится с горем пополам по третьему варианту, вот отсюда: http://forum.ubuntu.ru/index.php?topic=264079.0
Правда после кеды пришлось до устанавливать.
Косяки с зависимостями были, разрулил. Сейчас вроде бы все в порядке.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры