Неудовлетворённые зависимости [Решено]

Изображение пользователя kot040188.

Пытаюсь установить andyetitmoves_1.2.2-1_amd64.deb двойным кликом. Пишет об неудовлетворённых зависимостях. Но не признаётся, что ему надо. Как узнать чего оно хочет?

-1
Гость - 6 Февраль, 2016 - 19:57

sudo dpkg -i пакет.deb в консоли

0
kot040188 - 6 Февраль, 2016 - 20:37
Изображение пользователя kot040188.

Так это же установка без учёта зависимостей. Вопрос совсем другой…

0
dyug - 6 Февраль, 2016 - 20:52

котико, ты упорен, как орущий кот сидящий на собственных яйцах.
sudo apt-get install -f ты явно не хочешь вспомнить...

0
kot040188 - 6 Февраль, 2016 - 22:19
Изображение пользователя kot040188.

Специально для местных дедушек уточняю вопрос (по-моему и так понятно): как узнать какие зависимости нужны для установки deb перед установкой, а не после? Может я не смогу их удовлетворить, приложение не будет работать, так нафига мне его устанавливать?

+2
MacLeod - 6 Февраль, 2016 - 22:58
Изображение пользователя MacLeod.

А почему дедушки обязаны гуглить за здорового упитанного балбеса?)
dpkg -I пакет.deb

Может я не смогу их удовлетворить
Значит -f install его снесет.

0
kot040188 - 7 Февраль, 2016 - 00:36
Изображение пользователя kot040188.

Да не надо мне его устанавливать! Я наверное не по-русски пишу… Мне заранее надо узнать зависимости! Я всегда гуглю перед созданием темы. Кто следующий предложит эту команду?

+1
nitrofox - 7 Февраль, 2016 - 00:51
Изображение пользователя nitrofox.

$dpkg -I opera-stable_35.0.2066.37_amd64.deb

новый пакет debian, версия 2.0.
размер 45350606 байт(а): управляющий архив длиной 15845 байт(а).
391 байт(а), 18 строк * config #!/bin/sh
1381 байт(а), 18 строк control
26407 байт(а), 258 строк md5sums
8509 байт(а), 176 строк * postinst #!/bin/sh
615 байт(а), 28 строк * postrm #!/bin/sh
216 байт(а), 12 строк * prerm #!/bin/sh
567 байт(а), 11 строк templates
Package: opera-stable
Version: 35.0.2066.37
Architecture: amd64
Maintainer: Opera Packaging Team
Installed-Size: 160437
Pre-Depends: apt-transport-https
Depends: gconf-service, libasound2 (>= 1.0.16), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.11), libcairo2 (>= 1.6.0), libcups2 (>= 1.4.0), libcurl3 (>= 7.16.2), libdbus-1-3 (>= 1.2.14), libexpat1 (>= 2.0.1), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.4.2), libgcc1 (>= 1:4.1.1), libgconf-2-4 (>= 2.31.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.31.8), libgtk2.0-0 (>= 2.24.0), libnotify4 (>= 0.7.0), libpango1.0-0 (>= 1.14.0), libstdc++6 (>= 4.6), libx11-6 (>= 2:1.4.99.1), libxcomposite1 (>= 1:0.3-1), libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxi6 (>= 2:1.2.99.4), libxrandr2 (>= 2:1.2.99.2), libxrender1, libxss1, libxtst6, debconf (>= 0.5) | debconf-2.0, libudev0 (>= 147) | libudev1 (>= 183), libnspr4 (>= 1.8.0.10), libnss3 (>= 3.14.3)
Recommends: pepperflashplugin-nonfree, chromium-codecs-ffmpeg-extra
Conflicts: opera
Replaces: opera
Provides: www-browser
Section: non-free/web
Priority: optional
Homepage: http://www.opera.com/browser/
Description: Fast and secure web browser
Opera is a fast, secure, and user-friendly web browser.
It includes web developer tools, news aggregation, and the ability
to compress data via Opera Turbo on congested networks.

0
kot040188 - 7 Февраль, 2016 - 01:09
Изображение пользователя kot040188.

Так вот оно что… А в wiki об этом ни слова. И учитывая, что он игнорирует зависимости, я думал он их и не показывает.

0
nitrofox - 7 Февраль, 2016 - 01:21
Изображение пользователя nitrofox.

Дак команда которую вам посоветовал MacLeod выводит информацию о пакете.

Показать информацию о пакете:
dpkg -I filename [control-file]

Установка одного пакета:
dpkg -i <.deb file name>

0
kot040188 - 7 Февраль, 2016 - 01:57
Изображение пользователя kot040188.

Голова моя содовая. Извиняюсь перед всеми. Надо больше спать. Спутал i и I. Пойду спать.

-1
MacLeod - 7 Февраль, 2016 - 15:04
Изображение пользователя MacLeod.

А в wiki об этом ни слова.
Какой нахрен вики?

man dpkg
или гуглишь манпейдж, чтобы было удобнее читать в браузере.

0
kot040188 - 7 Февраль, 2016 - 15:21
Изображение пользователя kot040188.

Согласен, что-то я не то делаю…

0
kot040188 - 7 Февраль, 2016 - 22:15
Изображение пользователя kot040188.

А как узнать какие зависимости есть а каких нет? Вручную вбивать в пакетном менеджере как-то неудобно.

0
Chibiko - 8 Февраль, 2016 - 00:46
Изображение пользователя Chibiko.

apt-cache show pkgname
Или ещё круче:
apt-cache showpkg pkgname

Или я не понял вопроса?
Кот, тогда задавай правильно.
Правильно сформулированный вопрос - уже половина ответа 8)

0
kot040188 - 8 Февраль, 2016 - 01:27
Изображение пользователя kot040188.

Я его уже два раза формулировал. Специально для тебя третий раз: для установки deb чего-то не хватает. Как узнать чего? Вроде по русски написал. Командой которую дали выше можно узнать чего он требует, а вот как узнать что из этого списка отсутствует или верится не та. Ручками при большом списке муторно. apt install вываливпет список чего не хватает для установки. Qapt такого списка не выдаёт. Типа сам догадайся чего ему нужно. Как получить такой список для deb? Не знаю как ещё сформулировать…

0
AlexBKost - 8 Февраль, 2016 - 15:55

Qapt такого списка не выдаёт. Типа сам догадайся чего ему нужно. Ты ничего не путаешь? QApt как раз и дает количество и список пакетов, которые необходимо изменить для установки желаемой deb-ки, если такие изменения требуются - появляется кнопка Подробности..., не вкладка.

0
kot040188 - 8 Февраль, 2016 - 16:31
Изображение пользователя kot040188.

Ткните носом в кнопку!

0
AlexBKost - 8 Февраль, 2016 - 16:52

При таком фатальном исходе её и быть не может. Но и обобщать не следует. Я не знаю, чё это за плеер, только у меня на 16.04 тоже один плеер был удален при очередном обновлении и теперь так же не желает устанавливаться, как у тебя. Скорее найти аналог, чем порешать зависимости - это невозможно (либо уже, либо ещё).

0
kot040188 - 8 Февраль, 2016 - 17:03
Изображение пользователя kot040188.

Что ж вы сразу в кусты? ヅ Я не знаю, что тут обобщать, но кнопки нет. Это не плеер, а игра, там есть описание. Аналогов нет.

0
AlexBKost - 8 Февраль, 2016 - 17:18

Тогда придется о ней забыть, или подзабыть периодически проверяя.

Хотя, у меня есть одна идейка, если дашь мне кликабельную сылку на загрузку этой игры, только 32-bit, гарантирую её проверить.

0
kot040188 - 8 Февраль, 2016 - 18:20
Изображение пользователя kot040188.

На 14.04 устанавливалась без проблем. 32 не держу за ненадобностью.

0
nitrofox - 8 Февраль, 2016 - 20:09
Изображение пользователя nitrofox.

Игра платная =) https://apps.ubuntu.com/cat/applications/andyetitmoves/

0
kot040188 - 8 Февраль, 2016 - 21:50
Изображение пользователя kot040188.

Она ещё и проприетарная…

-1
MacLeod - 8 Февраль, 2016 - 18:51
Изображение пользователя MacLeod.

Аналогов нет.
Ну так возьми и пересобери пакет, подправив зависимости...

0
kot040188 - 8 Февраль, 2016 - 18:56
Изображение пользователя kot040188.

Если ей чего-то не хватает, где я это возьму? Знать бы чего…

0
MacLeod - 8 Февраль, 2016 - 19:17
Изображение пользователя MacLeod.

Поставь через dpkg -i, узнаешь чего. Напишешь тут.
Сначала нужно узнать, чего конерктно - потом думать, где взять. Последовательность, помнишь? =)

0
kot040188 - 8 Февраль, 2016 - 21:39
Изображение пользователя kot040188.

Сначала нужно узнать, чего конерктно
Вот это как раз и не получится до установки…

0
nitrofox - 8 Февраль, 2016 - 21:51
Изображение пользователя nitrofox.

Вроде у dpkg есть ключ --no-act | --dry-run | --simulate
Делать всё, что необходимо, но не записывать на диск изменения. Он используется для того, чтобы посмотреть, что произошло бы при выполнении указанного действия, но при этом ничего не меняется.

0
kot040188 - 8 Февраль, 2016 - 21:52
Изображение пользователя kot040188.

Поздно я уже установил…

0
nitrofox - 8 Февраль, 2016 - 19:23
Изображение пользователя nitrofox.

Деб пакет это просто архив. А если ее просто распаковать и попробовать запустить?
Или натравить на исполняемый файл ldd

0
kot040188 - 8 Февраль, 2016 - 21:39
Изображение пользователя kot040188.

        не является динамическим исполняемым файлом

0
nitrofox - 8 Февраль, 2016 - 21:55
Изображение пользователя nitrofox.

Ну я скачал игру из источника чье имя не говорят вслух.. Там в архиве будет /opt/AndYetItMoves/lib/AndYetItMoves. Он как раз нужен. Так как /opt/AndYetItMoves/AndYetItMoves является простым скритом.

0
kot040188 - 8 Февраль, 2016 - 21:56
Изображение пользователя kot040188.

Я думал это к deb надо применять…

0
kot040188 - 7 Февраль, 2016 - 01:12
Изображение пользователя kot040188.

за здорового
Я бы с радостью, но увы. Ближайший год не ждите…

0
buggy - 7 Февраль, 2016 - 14:53
Изображение пользователя buggy.

Чой-то? (C) Доктор Быков

0
kot040188 - 7 Февраль, 2016 - 15:19
Изображение пользователя kot040188.

Так сложилось. Вот ещё одну операцию сделаю…

+1
buggy - 8 Февраль, 2016 - 01:49
Изображение пользователя buggy.

Искренне желаю полного и скорейшего выздоровления! Ты, пожалуйста, поправляйся, не надо болеть!

0
kot040188 - 8 Февраль, 2016 - 03:17
Изображение пользователя kot040188.

Спасибо, постараюсь.

0
MacLeod - 7 Февраль, 2016 - 15:06
Изображение пользователя MacLeod.

Смотри, какая фигня получается... Любой дедушка тебе фору даст что ли? =)

0
kot040188 - 7 Февраль, 2016 - 15:18
Изображение пользователя kot040188.

Пока да.

0
kot040188 - 8 Февраль, 2016 - 21:48
Изображение пользователя kot040188.

[email protected]:~$ sudo dpkg -i /home/kot/bin/install/andyetitmoves_1.2.2-1_amd64.deb[sudo] пароль для kot:
Выбор ранее не выбранного пакета andyetitmoves.
(Чтение базы данных … на данный момент установлено 352566 файлов и каталогов.)
Подготовка к распаковке …/andyetitmoves_1.2.2-1_amd64.deb …
Распаковывается andyetitmoves (1.2.2) …
Настраивается пакет andyetitmoves (1.2.2) …
Обрабатываются триггеры для hicolor-icon-theme (0.15-0ubuntu1) …
Обрабатываются триггеры для desktop-file-utils (0.22-1ubuntu3) …
Обрабатываются триггеры для mime-support (3.58ubuntu1) …
[email protected]:~$ sudo apt-get install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей      
Чтение информации о состоянии… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

Чего-то я не понял прикола… Игра запускается. Что от меня хотел qapt?

0
nitrofox - 8 Февраль, 2016 - 22:02
Изображение пользователя nitrofox.

Смешно.. 2 дня мучений.... А помогла команда с первого поста

0
kot040188 - 8 Февраль, 2016 - 22:25
Изображение пользователя kot040188.

Как сказать. Вопрос, что от меня хотел qapt, остаётся открытым…

+1
dyug - 9 Февраль, 2016 - 16:18

вот нет, чтоб забить на эти куапты и пользоваться правоверной/православной/выбрать_нужное командной строкой, нет обязательно нужно походить по граблям пару дней, устроить "тему на пару экранов" на сайте, и в итоге установить ее с полпинка с командной строки..... :-)
При том, что УЖЕ не один раз говорили пользуйтесь основными средствами, а не надстройками кривописанными....

И именно коту это говорилось уже не один раз...

0
kot040188 - 9 Февраль, 2016 - 16:20
Изображение пользователя kot040188.

Я не настолько православен…

0
dyug - 9 Февраль, 2016 - 17:13

Я же написал - нужное выбрать.
Разумеется, если не желаешь на каждый свой чих нарываться на кривые надстройки над работающими приложениями.

0
kot040188 - 9 Февраль, 2016 - 18:31
Изображение пользователя kot040188.

Вас послушать, так только консоль не кривая и только ею надо пользоваться, остальное всё ерунда и недостойно настоящего линуксоида…

0
dyug - 9 Февраль, 2016 - 18:52

Котико, ты опять начинаешь времена твоего прихода на сайт? :-)
Бредишь, опять приписываешь мне свои мысли.
Хотя в 1998 году, когда я поставил свою первую слакварь - это было истиной.

0
kot040188 - 9 Февраль, 2016 - 20:07
Изображение пользователя kot040188.

Котико, ты опять начинаешь времена твоего прихода на сайт? :-)
Я их и не заканчивал. Не хотите говорить на эту тему - игнорируйте меня ヅ Чтобы никого не смущать, прописал тег…

0
kot040188 - 8 Июль, 2016 - 17:00
Изображение пользователя kot040188.

Похоже на глюк qapt - уже несколько раз он отказывался ставить пакет, ссылаясь на неудовлетворённые зависимости. На самом деле зависимости были удовлетворены.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры