Сканер Canon Lide210 перестал работать на Kubuntu 16.04

Изображение пользователя Vidgar.

Не работает сканер Ошибка устройства ввода-вывода. Пробовал программы Xsanе, Simplescan (с него раньше сканировал на кубунте 15...Работал без проблем) Scanlite

0
fox4 - 16 Август, 2016 - 18:15
Изображение пользователя fox4.

Попробовать в консольке
sudo sane-find-scanner
Если не определяется почитать статью
и попробовать выполнить пункты с 5 по 7 потом снова попробовать
sudo sane-find-scanner
В пятом пункте используется команда
sudo lsusb

0
Vidgar - 17 Август, 2016 - 16:25
Изображение пользователя Vidgar.

Сканер видит без проблем. Все программы определяют верно.
# sane-find-scanner will now attempt to detect your scanner. If the
# result is different from what you expected, first make sure your
# scanner is powered up and properly connected to your computer.

# No SCSI scanners found. If you expected something different, make sure that
# you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9 [Canon], product=0x190a [CanoScan], chip=GL124) at libusb:002:005
found USB scanner (vendor=0x03f0 [Hewlett-Packard], product=0x0a2a [HP LaserJet Professional P1606dn]) at libusb:002:004
could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
# Your USB scanner was (probably) detected. It may or may not be supported by
# SANE. Try scanimage -L and read the backend's manpage.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports
# can't be detected by this program.
[email protected]:~$

0
fox4 - 17 Август, 2016 - 18:03
Изображение пользователя fox4.

Открываем на редактирование файл 40-libsane.rules:
sudo kate /lib/udev/rules.d/40-libsane.rules
Находим в нём строку # The following rule will disable ... и выше неё дописываем:

# Canon Lide 210
ATTRS{idVendor}=="04a9",ATTRS{idProduct}=="190a", ENV{libsane_matched}="yes"
# The following rule will disable

Сохраняем изменения, перегружаем компьютер и проверяем сканирование.

0
Vidgar - 26 Октябрь, 2016 - 10:02
Изображение пользователя Vidgar.

Извините, что долго не отвечал. Изменение 40-libsane.rules не помогла. Так же выскакивает ошибка ввода-вывода. Сканируется только программа vuescan. Но она платная. И рисует водные линии(

0
Priestone - 26 Октябрь, 2016 - 11:13
Изображение пользователя Priestone.

Напомнило отсюда: HOWTO Настройка сканера...
Возможно есть и для топикстартера похожее решение (сам тоже нечто похожее делал, но давно - пару лет назад в одной из подопечных контор, так там работает до сих пор, а вот что конкретно делал и модель сканера там - уже не подскажу, не помню)

0
Vidgar - 31 Октябрь, 2016 - 15:12
Изображение пользователя Vidgar.

К сожалению там разбирают сканер epson и прилагают к нему бинарник. К Canon ответа нет(

0
Priestone - 1 Ноябрь, 2016 - 07:12
Изображение пользователя Priestone.

А чем не устроила информация отсюда?
SANE Supported Devices

CanoScan LiDE 210 USB 0x04a9/0x190a Complete GL124 based, resolution from 75 to 4800 dpi genesys(1.0-63) sane-genesys

0
Vidgar - 1 Ноябрь, 2016 - 14:30
Изображение пользователя Vidgar.

+1
dyug - 1 Ноябрь, 2016 - 14:54

Простите, а пользователь точно включен в группу сканирования?
Ибо была у меня такая грабля...

0
Vidgar - 3 Ноябрь, 2016 - 11:31
Изображение пользователя Vidgar.

Где это проверить?
Если под рутом запустить xsane, то тоже не сканирует. Та же ошибка

0
dyug - 3 Ноябрь, 2016 - 14:09

проверить:
от пользователя запустить id и для полноты картины groups от него же.
описание исправления проблемы:взято здесь по словам "sane от пользователя"

насчет группы я точно не помню, нужно смотреть как точно ее зовут в /etc/group

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры