Muon, менеджер обновлений и synaptic не запрашивают пароль [Решено]

Изображение пользователя kot040188.

Пару дней назад работали. А сегодня при любом действии не запрашивают пароль, а выдают:

Выполнение этого действия без соответствующего полномочия невозможно
У вас нет прав на выполнения этого действия

0
Priestone - 25 Декабрь, 2016 - 09:27
Изображение пользователя Priestone.

Уже было: ссылка

Вкратце. Должно помочь:
sudo apt-get install --reinstall polkit-kde-1

0
kot040188 - 25 Декабрь, 2016 - 15:00
Изображение пользователя kot040188.

Не помогло.

0
kot040188 - 26 Декабрь, 2016 - 19:34
Изображение пользователя kot040188.

Я даже обновления поставить не могу.

0
AlexBKost - 26 Декабрь, 2016 - 23:40

Так в чем проблема - обновиться через консоль - даст Бог Muon и менеджер обновлений начнут пароль запрашивать после.

А вообще, на форуме при каждом удобном случае умные люди предлагают всем завести на хозяйстве Synaptic. Я тоже могу присоединиться к этим пожеланиям - давеча лишний раз убедился в его всемогуществе. Конечно, им ещё нужно будет научится пользоваться в критических ситуациях, а он может.

0
kot040188 - 26 Декабрь, 2016 - 23:48
Изображение пользователя kot040188.

Ну так когда предложит обновить muon может и исправится что-нибудь. А пока только браузер хочет обновиться. А синаптик не заменит менеджер обновлений. И в решении данной темы он тоже бессилен. Обладал интернет и ничего похожего не нашёл…

0
AlexBKost - 27 Декабрь, 2016 - 00:36

Хорошо, давай неспешно обсудим действительность на твоей системе 16.04. Я так понимаю, плазма там 5.8.4 из неона. Так вот, озвучь, плиз, какие пакеты отвечают за Muon и Менеджер обновлений соответственно?

0
kot040188 - 27 Декабрь, 2016 - 06:47
Изображение пользователя kot040188.

Я не в курсе.

+1
AlexBKost - 27 Декабрь, 2016 - 18:01

Плохо, очень плохо, что не в курсе.

А раз ты даже не хочешь облегчить свою участь, установив Synaptic, а я уже ввязался в это обсуждение (скорее всего последний раз для тем твоего авторства), то постараюсь вразумить.

Еще на 16.04 с плазмой 5.5.5 от Muon (v. 5.6.0), как такового, отказались вообще, заменив его Диспетчером обновлений (пакет plasma-discover-updater v.5.6.2), который на плазме 5.8.4 заменен Центром программ (пакет plasma-discover соответственной версии). А ты этот Muon до сих пор тягаешь по всем плазмам, зачем он тебе вообще понадобился?

Надеюсь, ты понял, что нужно делать.

0
kot040188 - 27 Декабрь, 2016 - 19:10
Изображение пользователя kot040188.

plasma-discover/менеджер обновлений тоже не выдаёт запрос. Об этом написано в заголовке.
А ты этот Muon до сих пор тягаешь по всем плазмам
А что нельзя?

0
AlexBKost - 27 Декабрь, 2016 - 19:27

А что нельзя? Еще раз, зачем он тебе вообще понадобился? Не надо вопросом отвечать на вопрос.

0
kot040188 - 27 Декабрь, 2016 - 19:18
Изображение пользователя kot040188.

Для установки пакетов. Я гвозди им не забиваю. Использую по назначению, вроде бы…

+4
AlexBKost - 27 Декабрь, 2016 - 19:56

Для установки и обновления пакетов plasma-discover абсолютно не требуется помощь от muon, тем более что в плазме 5.8.4 его нет, совсем. Muon, как скрипач не нужен (С).

Нет, если тебе нравится на людях играть дурачка, давай продолжай.

+1
Priestone - 27 Декабрь, 2016 - 06:44
Изображение пользователя Priestone.

А что мешает в терминале выполнить:
sudo su
apt update
apt upgrade
?

0
ericSAN - 27 Декабрь, 2016 - 09:57
Изображение пользователя ericSAN.

Тогда уж лучше:
sudo apt-get update
sudo apt-get dist-upgrade

0
Priestone - 27 Декабрь, 2016 - 11:42
Изображение пользователя Priestone.

update - Обновить информацию о пакетах, содержащихся в репозиториях.
upgrade - Обновление пакетов, для которых в репозитории доступны новые версии.
dist-upgrade - Обновление пакетов, требующих разрешения зависимостей (установка дополнительных или удаление конфликтующих пакетов)

0
kot040188 - 27 Декабрь, 2016 - 19:09
Изображение пользователя kot040188.

Вы хотите поговорить об этом? Я — нет.

0
kot040188 - 30 Декабрь, 2016 - 19:06
Изображение пользователя kot040188.

Synaptic также не запрашивает пароль!
[email protected]:~$ synaptic-pkexec
==== AUTHENTICATING FOR com.ubuntu.pkexec.synaptic ===
Authentication is required to run the Synaptic Package Manager
Authenticating as: kot
Password:
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
==== AUTHENTICATION FAILED ===
Error executing command as another user: Not authorized

This incident has been reported.

+1
Priestone - 1 Январь, 2017 - 09:04
Изображение пользователя Priestone.

Совет остаётся всё тем же, что и был в самом начале: чините PolicyKit.

Переустановите пакеты:

libpolkit-agent-1-0
libpolkit-backend-1-0
libpolkit-gobject-1-0
libpolkit-qt-1-1
libpolkit-qt5-1-1
polkit-kde-agent-1

0
kot040188 - 1 Январь, 2017 - 15:52
Изображение пользователя kot040188.

Не помогло.

0
kot040188 - 2 Январь, 2017 - 15:07
Изображение пользователя kot040188.

Оказывается надо было перезагрузиться послек переустановки.

0
kot040188 - 1 Январь, 2017 - 14:09
Изображение пользователя kot040188.

gdebi тоже не выдаёт запрос. Но qapt выдаёт.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры