Глюки видеодрайвера на парных видеокартах Nvidia

Ситуация такая:
есть настольный комп, в нём 2 видеокарты Nvidia GTX 750Ti.
Вставляем LiveCD Kubuntu 16.04 и запускаем в любом режиме (хоть сразу устанавливать, хоть попользоваться перед установкой) и операционка видит две видеокарты, на два монитора выводит изображение. Ничего не лагает и не глючит.
Ставим операционку. Начинаются глюки. Сначала в форме жутких лагов (переустановка 16.04 не помогает). Сделал обновление сначала до 16.10, потом до 17.04. На 17.04 всё начинает работать. Не идеально, но терпимо. Однако, после установки ряда программ касающихся KDE вторая видеокарта отрубилась и работать не хочет.

Теперь вопрос:
какой видеодрайвер использует LiveCD от Kubuntu и как сделать так, чтобы вместо включённого после установки системы работал он? А то меня честно говоря как-то не радует сек* во всех позах камасутры с настройкой драйвера, работающего на 17.04 или 16.04.

Вывод по команде sudo lshw -C video

Развернуть/свернуть скрытый текст.
  *-display               
       description: VGA compatible controller
       product: GM107 [GeForce GTX 750 Ti]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: [email protected]:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:38 memory:fa000000-faffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:c0000-dffff
  *-display
       description: VGA compatible controller
       product: GM107 [GeForce GTX 750 Ti]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: [email protected]:02:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:39 memory:f8000000-f8ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:d000(size=128) memory:f9000000-f907ffff
0
jzyken - 8 Май, 2017 - 23:36
Изображение пользователя jzyken.

Использует nouveau - свободный драйвер.
А у вас стоит проприетарный nvidia.

0
kutuzov-san - 8 Май, 2017 - 23:49

То-то и оно. Не ставил и не активировал проприетарных дров.

+1
AlexBKost - 9 Май, 2017 - 00:08

Покажите лучше вывод по команде:
lspci -k | grep -EA3 'VGA|3D|Display'

0
kutuzov-san - 9 Май, 2017 - 00:46

01:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)
Subsystem: ASUSTeK Computer Inc. GM107 [GeForce GTX 750 Ti]
Kernel driver in use: nvidia
Kernel modules: nvidiafb, nouveau
--
02:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)
Subsystem: ASUSTeK Computer Inc. GM107 [GeForce GTX 750 Ti]
Kernel driver in use: nvidia
Kernel modules: nvidiafb, nouveau

Так же сообщаю, что обновление драйверов nouveau по инструкции с http://help.ubuntu.ru/wiki/%D1%81%D0%B2%D0%BE%D0%B1%D0%BE%D0%B4%D0%BD%D1%8B%D0%B9_%D0%B4%D1%80%D0%B0%D0%B9%D0%B2%D0%B5%D1%80_%D0%B2%D0%B8%D0%B4%D0%B5%D0%BE%D0%BA%D0%B0%D1%80%D1%82_nvidia не помогла.

0
jzyken - 9 Май, 2017 - 02:25
Изображение пользователя jzyken.

Не ставил и не активировал проприетарных дров.
Странно...
Так же сообщаю, что обновление драйверов nouveau по инструкции не помогла.
Так вам не nouveau нужно обновить, а nvidia-3.. удалить.
sudo aptitude purge ~invidia-3

+1
MacLeod - 9 Май, 2017 - 06:41
Изображение пользователя MacLeod.

А у вас стоит проприетарный nvidia.
Забавно. lshw парсит мнение ядра (https://github.com/lyonel/lshw/blob/master/src/core/pci.cc, константы в строках 21-22 и методы ниже. Кстати, над организацией кода я местами ржал аки конь, но это тема для отдельной дискуссии) и выводит в некоем структурированном виде, пытаясь иногда разбавлять собственными соответствиями айдишников...
В общем, в ветке выше ТС показывал еще вывод lspci, где видны задействованные модули ядра nvidiafb и nouveau, отсылок к модулям вида nvidia_xxx или nvidia_xxx_drm нет, но ядро почему-то считает, что используемый драйвер - "nvidia", хотя ранее так называли именно проприетарные, если ничего не путаю.

Забавная ситуация с новым железом:

а вот
хотя

В общем, lshw что-то пропало желание использовать.

З.Ы. ТСу рекомендую все с точностью до наоборот - поставить проприетарные дрова, например nvidia-361, т.к. фризят и вешают обычно именно открытые.

0
kutuzov-san - 9 Май, 2017 - 10:37

Всё интересней и интересней:
1. установка дров проблему не решила;
2. удаление дров тоже не помогло;

И потому у меня тут пара выводов сформировалась:
1. нужно уточнить процесс загрузки систему: у меня на компе винда и кубунту (сейчас уже 17.04). Выбираю я при загрузке кубунту, она грузится и в момент когда высвечивает логотип включает второй монитор подключённый ко второй видеокарте. После перехода к другому (последующему) экрану загрузки на котором изображены точки второй монитор отрубается и больше не врубается.
2. как видно из вывода команд вторую видяху система видит, а раз видит и нет сигнала - значит с самим драйвером может быть всё в порядке. А вот не в порядке может быть с настройками по которым этот драйвер работает. Ведь, если у нас на LiveCD и установленной кубунту используется один и тот же драйвер, то проблема не в драйвере, а в тех файлах-настройках, которые меняются после установки системы.
3. проблемы ведь начались после установки пакетов программ, а последними номерами я ставил не имеющие отношения к видеодрайверам компоненты кде вроде рабочего стола и обоев с прочим артом (проприетарных дров не ставил на тот момент).

Отсюда вопрос: где сии файлы-настройки видеодрайвера, видеокарты и монитора найти и как их проверить? Можно ли их вытащить из LiveCD и поставить в систему?

0
MacLeod - 9 Май, 2017 - 14:44
Изображение пользователя MacLeod.

второй монитор подключённый ко второй видеокарте
Зачем? К одной оба подключите. Поставьте проприетарные дрова и проверьте настройки дислеев в KDE.

0
kutuzov-san - 9 Май, 2017 - 22:15

На этот вопрос уже есть у меня ответ. Я ведь две карты ставлю из-за того, что моя старая Nvidia накрылась. На ней было 3 выхода (из которых реально работать могли только 2) и там проблемы с подключением второго монитора проблемы не было. Но сейчас задача - подключить обе видяхи. Мне очень хочется сидеть даже не за двумя, а за тремя мониторами =) Только вот надо третий купить...

И кстати, глюк, который сейчас обсуждаем ведь возникает только на 17.04 (на более ранних версиях - простые тормоза графики).

0
MacLeod - 11 Май, 2017 - 02:37
Изображение пользователя MacLeod.

Я ведь две карты ставлю из-за того, что моя старая Nvidia накрылась. На ней было 3 выхода (из которых реально работать могли только 2) и там проблемы с подключением второго монитора проблемы не было. Но сейчас задача - подключить обе видяхи.
Все равно не вижу логики, на одной GTX750Ti есть как минимум DVI-D + HDMI, к которым можно прицепить два монитора... Переходники часто помогают.
Но если уже выбрали путь изврата:
Матчасть с историей
https://unix.stackexchange.com/questions/123862/how-can-i-get-xrandr-to-detect-both-nvidia-cards-2-x-gtx480-triple-head
https://www.martineve.com/2014/04/15/enabling-a-triple-head-3-monitor-setup-on-linux-mint-16-petra-with-two-nvidia-cards/
Т.е. на проприетарщине суть, видимо, в Mosaic + правильный конфиг, а на свободных можно до посинения играться с xrandr...

Мне очень хочется сидеть даже не за двумя, а за тремя мониторами =) Только вот надо третий купить...

К слову, не зря говорят: "третий - лишний". Было у меня до этого три FullHD'шных под nvidia surround... Но работать на трех - это свернуть или, как минимум, утомить себе шею.
Недавно взял себе эти два с 4к матрицами - когда попробовал, в очередной раз думал, какого лешего раньше не перешел. Шрифты как на айпаде, ну, или на лазерном принтере напечатанные. В моих картах по три DisplayPort + HDMI, но пихать больше двух основных не тянет как-то уже, третий (старичок с s-ips, все не могу заставить себя выбросить) теперь только для каких-нибудь тестов вида "а как оно будет выглядеть на low DPI?"
0
dyug - 11 Май, 2017 - 10:34

ТЫ очень и очень нехороший человек. :-(

+1
lord_i - 11 Май, 2017 - 11:10
Изображение пользователя lord_i.

А по-моему - радоваться надо за человека. :)
А себе ставить более высокие планки :))))

0
jzyken - 9 Май, 2017 - 19:33
Изображение пользователя jzyken.

Да, действительно. nvidia - ещё не показатель. Не знал, спасибо!

0
kutuzov-san - 9 Май, 2017 - 22:18

В итоге решил переставить систему с нуля и просто не лезть к пакетам kde. Может быть хоть метод тыка поможет...

Однако, вопрос остаётся. Если кто знает ответ - буду рад ему.

По результатам установки системы с 0: всё работает. Но очень быстро слетает после установки пакетов (проприетарные драйвера не ставятся).

0
kutuzov-san - 19 Май, 2017 - 12:36

Собственно докладываю по результатам переустановки и длительного тестирования:
1. Поскольку диск в Kubuntu 17.04 я 2 раза перекачивал и перезаписывал и оба раза он не хотел работать я поставил сначала 16.04 и начал повышать уровень системы. В процессе программ не ставил.
2. После повышения по цепочке 16.04-16.10-17.04 обе видяхи виделись и работали.
3. Поставил часть программ, которые мне нужны и в этот раз не трогал пакеты с меткой KDE (арты, комплекты программ и т.д.). Удивительно, но факт - всё работает. Глюки у второй видяхи в настоящий момент связаны с ограничением обработки изображения и тем, что не может воспроизводить видео.

Таким образом, делаю вывод, что всё летит к чёрту и монитор перестаёт видится в одном из двух случаев:
1. Установка проприетарных дров (но требует проверки с которой я не хочу копаться)
2. Установка некоторых пакетов, идущих в комплекте KDE. Что они там задевают и изменяют не понимаю, но факт, как говорится, на лицо: не ставил дров и пакетов KDE - всё пашет (хоть и с глюками).

Кстати, 750Ti имеет несколько модификаций, отличающихся по охлаждению и доступным видеовыходам. Кроме того, уже достаточно давно жалуются, что нельзя подключить 3 монитора к 1 видяхе из-за недостатка ресурсов питания. Как говорится "Если на корабль с 8 пушками запихнуть 10, стрелять будет 6".

Спасибо всем кто участвовал. япрочту все поступившие ссылки и после сохранения системы акронисом займусь экспериментами.

0
AlexBKost - 19 Май, 2017 - 15:30

1. Поскольку диск в Kubuntu 17.04 я 2 раза перекачивал и перезаписывал и оба раза он не хотел работать я поставил сначала 16.04 и начал повышать уровень системы. Все это очень подозрительно и трудно объяснимо. У вас самого есть хоть какие-нибудь предположения о произошедшем?

0
kutuzov-san - 20 Май, 2017 - 12:48

Нет. Нету.
Если подробней, то диск грузился до того момента где должно появиться окно выбора способа работы (тест системы/её установка) и на этом моменте подвисал. Но поскольку я обошел этот момент через грейд системы, мне он не слишком помешал. И если говорить честно, я думаю что в последние месяцы разрабы что-то накосячили в репозиториях и скорее всего в пакетах системы т.к. был ещё интересный случай: ко мне обратился сосед с просьбой поставить убунту, чтобы избавиться от вирусни (которая то денег требовала, то на порносайты отправляла). Я форматнул диск в 0, сделал разбивку разделов на 2 части (корень и home), поставил ubuntu 16.04, обновил пакеты из репозиториев, поставил стандартный пакет мультимедиа, архиваторов и пару расширений под лису. (естественно пароль админа соседу не сказал дабы не накосячил). Всё вроде работает. Комп отдал соседу. Через день звонит сосед и говорит, что после пары перезапусков система перестала грузиться. Я в непонятках прошу принести комп. Система действительно не грузится. Ладно, решил переустановить. Решено - сделано. Всё работает. Я снова выполняю процедуру обновления и установки программ, перезагружаюсь ииии.... Шишь! Не работает! И вот тут у меня начались непонятки совсем невменяемые т.к. эту процедуру я на своём компе делал раз 20-30. Я ещё раз переустановил систему и только поставил пакеты мультимедиа с пакетами архиваторов, ну и лису обновил. Больше никаких пакетов не обновлял. Вуаля: всё работает! Причём после многократных перезагрузок. Я не знаю что там случилось с обновлениями, но вот столкнулся.

0
werkty - 20 Май, 2017 - 13:00

Это у вас какая-то магия :) так не бывает в реальной жизни. По крайней мере, я, скольким людям не устанавливал кубунты/убунты/ксубунты, никогда такого не наблюдал. А вот что наблюдал, так это одного моего знакомого, который за какой комп не возьмется везде, на самых разных машинках, обязательно проявится один и тот же баг. Я так думаю, что вы что-то делаете, вносите какое-то изменение, и чисто на автомате везде его повторяете, бессознательно так сказать :) и оно вылезает в виде того, в виде чего вылезает:)

0
Гость - 23 Май, 2017 - 20:12

Может быть и так, только вот порядок установки у меня настолько стандартен, что я повторяя его и на своём ноуте или компе должен был бы получить такой глюк. Причем гораздо раньше (напоминаю, я переставлял линукс раз 30 из-за своих кривых рук и экспериментов). А ведь его не было. Да и неработоспособность последнего LiveDVD это никак не объясняет... В общем, что-то тут не так. А вот что - вопрос. Если надо могу скинуть данные по железу своего компа, ноута и попробовать достать данные по компу соседа (ибо он явно не полезет разбирать системный блок).

0
kutuzov-san - 23 Май, 2017 - 20:18

Кстати, я в постах выше упоминал про лаги при отображении видео на мониторе подключенном ко второй видеокарте. В последние дни случайно нашел инфу для важного уточнения: лагают только внешние проигрыватели (VLC и прочие, а так же графика рабочего стола). Однако, видеохостинги запущенные через браузер НЕ лагают. Точно так же, если окно видеопроигрывателя открыть на мониторе, подключённом к первой видеокарте и затем частично (не больше половины окна) перенести на монитор, подключённый ко второй видеокарте, лагов нет. А вот если включить видеопроигрыватель чисто на мониторе, подключённом ко второй видяхе, будут лаги. Вот такая вот бодяга...

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры