Подключение сканера BenQ 5160C [Решено]

Изображение пользователя DmitriyK.

Сканер BenQ 5160C

Устанавливал так:
Создал каталог snapscan в /usr/share/sane
Скопировал в него файл 2331v013.bin
Подправил файл /etc/sane.d/snapscan.conf
# firmware upload is needed by the scanner
# firmware /usr/share/sane/snapscan/your-firmwarefile.bin
firmware /usr/share/sane/snapscan/2331v013.bin
Сохранил и перезагрузился

В итоге вот что получилось:
:~$ lsusb
Bus 003 Device 007: ID 04a5:2331 Acer Peripherals Inc. (now BenQ Corp.)
Bus 003 Device 002: ID 04b8:0007 Seiko Epson Corp.
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

:~$ sudo scanimage -L
device `snapscan:libusb:003:007' is a Acer FlatbedScanner50 flatbed scanner

:~$ sane-find-scanner -v
checking /dev/usbscanner15... failed to open (Invalid argument)
found USB scanner (vendor=0x04a5, product=0x2331) at libusb:003:007

:~$ scanimage -L
No scanners were identified.

:~$ SANE
сканер программой не определяется

:~$ sudo xsane
Невозможно открыть устройство snapscan:libusb:003:007, Ошибка во время ввода-вывода с устройством

Подскажите что делать дальше?

На этой странице http://www.cltb.net/en/articles/scanner.html описано как подключить BenQ 5000, но я разобраться не смог.

0
DmitriyK - 20 Август, 2008 - 15:55
Изображение пользователя DmitriyK.

Добавил себя в группу сканеры и пользователи
Вывод:
$ scanimage -L
device `snapscan:libusb:003:003' is a Acer FlatbedScanner50 flatbed scanner
$ sane-find-scanner

found USB scanner (vendor=0x04a5 [Color], product=0x2331 [ FlatbedScanner 50]) at libusb:003:003
# Your USB scanner was (probably) detected. It may or may not be supported by
# SANE. Try scanimage -L and read the backend's manpage.

запустил коку предложила выбрать сканер и умерла выдав ошибку что нет сани

сани выдает ошибку ввода ввывода

0
DmitriyK - 19 Август, 2008 - 19:27
Изображение пользователя DmitriyK.

Видать без виртуалки не обойтись!

0
polkan - 22 Август, 2008 - 05:26
Изображение пользователя polkan.

bash# chown root:scanner /dev/bus/usb/005/006 /proc/bus/usb/005/006
bash# chmod 664 /dev/bus/usb/005/006 /proc/bus/usb/005/006

это делал?

далее файл подобный такому

/etc/udev/rules.d/45-libsane.rules

должен содержать подобное

SYSFS{idVendor}=="04a5", SYSFS{idProduct}=="20f8", MODE="664", GROUP="scanner"

Удачи в донастройке

0
DmitriyK - 8 Март, 2009 - 15:02
Изображение пользователя DmitriyK.

Выдержка
[email protected]:~$ dmesg

[73.075202] usb 1-1: new full speed USB device using ohci_hcd and address 7
[ 73.258907] usb 1-1: device descriptor read/64, error -62
[ 73.546449] usb 1-1: device descriptor read/64, error -62
[ 73.825967] usb 1-1: new full speed USB device using ohci_hcd and address 8
[ 74.005694] usb 1-1: device descriptor read/64, error -62
[ 74.289193] usb 1-1: device descriptor read/64, error -62
[ 74.568734] usb 1-1: new full speed USB device using ohci_hcd and address 9
[ 74.976061] usb 1-1: device not accepting address 9, error -62
[ 75.151775] usb 1-1: new full speed USB device using ohci_hcd and address
10
[ 75.559107] usb 1-1: device not accepting address 10, error -62

как подсказало сообщество - проблема в контроллере usb на материнской плате (скорее всего по питанию).

0
Chibiko - 14 Октябрь, 2009 - 15:41
Изображение пользователя Chibiko.

Блин.. а у меня вот такая трабла - вроде всё нормально, когда загрузишся утром в винду..... Выйдешь в кубунту - запускаешь Xsane - всё норм сканит.

Если с утра не заходить в винду и врубать в только что загруженной кубУнте Xsane - он начинает страшно щёлкать и говорить это:
Невозможно открыть устройство snapscan:libusb:003:007, Ошибка во время ввода-вывода с устройством

А по утрам я редко в винду лазию.... а в течении дня иногда приходится посканить что-то...
Как - то гиморно лазить туда - сюда, ибо мне больше нравится и привычнее в кубунте сидеть....

Не подскажет как бы вылечить и навсегда избавится на работе от винды?

Ах, да, совсем забыл:
Kubuntu 9.04
Сканер BenQ 5000U "Scan to Web"
драйвер юзаю u254v042.bin

0
polkan - 26 Октябрь, 2009 - 10:05
Изображение пользователя polkan.

подозреваю что ты включаешь всю аппаратуру одновременно (пилотом) и saned запускается раньше чем пройдет самоинициализация сканера... попробуй перезапустить saned и попробовать сканировать, если поможет, то задай таймаут в скрипте запуска saned - как это сделать не знаю, но это возможно... предположительный алгоритм - переместить запуск saned в самый конец (переименовать цифирки перед saned в /etc/init.d? а также переобозвать линки в /etc/rc*.d/) и в тело скрипта задать параметр типа sleep=10sec

0
Chibiko - 26 Октябрь, 2009 - 11:42
Изображение пользователя Chibiko.

/etc/init.d# ./saned stop
saned disabled; edit /etc/default/saned

Увы, saned оказывается вообще не запущен, и:
/etc/init.d/saned start
saned disabled; edit /etc/default/saned

Никаких результатов не даёт =\

0
Xenomorph - 26 Октябрь, 2009 - 16:15
Изображение пользователя Xenomorph.

Отредактируй файл /etc/default/saned, переписав строку
RUN=no на RUN=yes. Потом запусти /etc/init.d/saned заново. Должно заработать.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры