Weather Plasmoid

Решил себе сегодня поставить Weather Plasmoid. Начал собирать как описано автором и на команде
# cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` ..
мне вывалился ответ
Программа 'cmake' на данный момент не установлена.  Вы можете установить ее, напечатав:
sudo apt-get install cmake
bash: cmake: команда не найдена

установил... на туже команду новый ответ
-- The C compiler identification is GNU
-- The CXX compiler identification is unknown
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: CMAKE_CXX_COMPILER-NOTFOUND
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
CMake Error: Internal CMake error, TryCompile configure of cmake failed
-- Check for working CXX compiler: CMAKE_CXX_COMPILER-NOTFOUND -- broken
CMake Error at /usr/share/cmake-2.6/Modules/CMakeTestCXXCompiler.cmake:25 (MESSAGE):
  The C++ compiler "CMAKE_CXX_COMPILER-NOTFOUND" is not able to compile a
  simple test program.

  It fails with the following output:





  CMake will not be able to correctly generate this project.
Call Stack (most recent call first):
  CMakeLists.txt:2 (project)


CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
CMake Warning (dev) in CMakeLists.txt:
  No cmake_minimum_required command is present.  A line of code such as

    cmake_minimum_required(VERSION 2.6)

  should be added at the top of the file.  The version specified may be lower
  if you wish to support older CMake versions for this project.  For more
  information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring done

выполнив команду
sudo aptitude install lsb-cxx openc++
и установив компилятор С++ вот какой получил ответ на туже команду
-- The CXX compiler identification is GNU
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at /usr/share/cmake-2.6/Modules/FindKDE4.cmake:72 (MESSAGE):
  ERROR: cmake/modules/FindKDE4Internal.cmake not found in
  /home/ibergard/.kde4/share/apps;/usr/lib/kde4/share/kde4/apps
Call Stack (most recent call first):
  CMakeLists.txt:7 (find_package)


CMake Warning (dev) in CMakeLists.txt:
  No cmake_minimum_required command is present.  A line of code such as

    cmake_minimum_required(VERSION 2.6)

  should be added at the top of the file.  The version specified may be lower
  if you wish to support older CMake versions for this project.  For more
  information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring done

Чего же еще этому зверю не хватает?

Комментарии (10)

0
Ibergard - 3 Август, 2008 - 20:22

на случай если кому понадобится... решилось установкой пакетов
kde4-devel libplasma-dev
и устранением их зависимостей.
дальше все прошло как по маслу... и теперь я наслаждаюсь погодным плазмоидом у себя на верхней панели.

0
Гость - 18 Сентябрь, 2008 - 22:30

во, спасибо, помогло

0
pioner14 - 10 Декабрь, 2008 - 11:19
Изображение пользователя pioner14.

Спасибо!!!!!!!!!!!!!!!!

0
magzcheg - 2 Сентябрь, 2009 - 13:15
Изображение пользователя magzcheg.

У меня все равно ругается, говорит :
[email protected]:~$ sudo aptitude install kde4-devel libplasma-dev
Чтение списков пакетов... Готово                                       
Построение дерева зависимостей                                         
Чтение информации о состоянии... Готово                                
Чтение информации о расширенных состояниях                             
Инициализация состояний пакетов... Готово                              
Не удалось найти пакеты, содержащих «kde4-devel» в своём имени или описании
Не удалось найти пакеты, содержащих «kde4-devel» в своём имени или описании
Следующие пакеты С ОШИБКАМИ:                                              
  libplasma-dev                                                           
Следующие НОВЫЕ пакеты будут установлены:                                 
  comerr-dev{a} libaudio-dev{a} libglib2.0-dev{a} libjpeg62-dev{a} libkadm55{a}
  libkrb5-dev{a} liblcms1-dev{a} libmng-dev{a} libpng12-dev{a} libpq-dev{a}    
  libqt4-dev{a} libqt4-opengl-dev{a} libsqlite0{a} libsqlite0-dev{a} libssl-dev{a}
  qt4-qmake{a}                                                                    
0 пакетов обновлено, 17 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.                                                                        
Необходимо получить 9077kБ архивов. После распаковки 48,3MБ будет занято.             
Следующие пакеты имеют неудовлетворённые зависимости:
  libplasma-dev: Зависит: libplasma3 (= 4:4.2.4-0ubuntu1~jaunty1~ppa2) но установлен 4:4.3.1-0ubuntu1~jaunty1~ppa1.
                 Зависит: kdelibs5-dev (= 4:4.2.4-0ubuntu1~jaunty1~ppa2) но его невозможно установить
Следующие действия разрешат зависимости:

Оставить для следующих пакетов их текущие версии:
libplasma-dev [Не установлен]

Счёт -9881

Принять данное решение? [Y/n/q/?]

что делать? как удовлетворить зависимости? :(

+1
senser - 7 Август, 2008 - 21:56
Изображение пользователя senser.

У меня стоит Forecastfox ( http://forecastfox.mozdev.org/index.html ) - расширение для Firefox. Очень хорошая штуковина, много настроек, рекомендую.

0
Ibergard - 8 Август, 2008 - 03:59

Хех... так то конечно удобно, но пользуюсь я Оперой.

0
SeaJey - 19 Сентябрь, 2008 - 11:42
Изображение пользователя SeaJey.

Ещё можно было из интерпида deb-src потырить и пересобрать для харди.

0
Гость - 28 Сентябрь, 2008 - 00:01

не подскажите где это пакет найти для дебиана ?

0
Ibergard - 28 Сентябрь, 2008 - 13:19

интересно... а чем плазмоид для кде4 в кубунту отличается от плазмоида для кде4 в дебиане?:)

0
vbifyz - 28 Сентябрь, 2008 - 16:33

Кроме подписи в пакете и информации о зависимостях теоретически нечем

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры