Установка rpm-5.1.0

Изображение пользователя Val Rubis.

Ставил rpm-5.1.0
[email protected]:/home/user/rpm-5.1.0# ./configure
Configuring RPM Package Manager (RPM), Version 5.1.0

Инициализация прошла успешно, но вот дальше дело не пошло.

=== TOOL-CHAIN CHECKS ===
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.
[email protected]:/home/user/rpm-5.1.0#

На одном из сайтов посоветовали
$ sudo apt-get install build-essential
но у меня нет инета под Линуксом.
Кстате это не первая прога которая на этой ошибке не ставица дальше.

0
polkan - 5 Август, 2008 - 08:07
Изображение пользователя polkan.

юзай гномий менеджер пакетов, тама выбирай буилды, которые советовали, и вместо кнопки "установить" найди кнопку "создать сценарий загрузки"

оно создаст текстовый файл с урлами для вгета

уносишь туда, где есть инет и качаешь все

возвращаешься со скачанным, и устанавливаешь в систему

потом возвращаешься к установке рпм

0
Val Rubis - 5 Август, 2008 - 23:13
Изображение пользователя Val Rubis.

В продолжении темы.
Обновил библиотеки gcc, все что нашел на диске с Кубунту.
Но теперь другая проблема:
THIRD-PARTY LIBRARIES (2/2)
checking popt.h usability... no
checking popt.h presence... no
checking for popt.h... no
checking for poptGetContext in -lpopt... no
checking whether to build with POPT library... no
configure: error: mandatory POPT library not found
[email protected]:/home/user/rpm-5.1.0#
Поиск на компе и диске с Кубунту не дал результатов.
Что это такое и где его брать?

0
sawa - 6 Август, 2008 - 00:04
Изображение пользователя sawa.

ИМХО - полноценно Кубунту/Убунту можно пользовать если есть интернет. Если его нет, то бери машину и топай к ближайшему источнику чтобы правильно накатить пакеты. Адепт сам разберется что с чем связано.

0
Val Rubis - 6 Август, 2008 - 01:53
Изображение пользователя Val Rubis.

Интернет у мну есть. Вот тока модем не обнаружился. Модем внутренний PCI SoftV92.
Начал ставить POPT.
Снова ошибка:
checking for /usr/ucblib in LIBS... no
checking for GNU xgettext... configure: error:
*** GNU gettext is required. The latest version
*** is always available from ftp://ftp.gnu.org/gnu/gettext/.

Когда же это закончица???

0
Val Rubis - 9 Август, 2008 - 00:01
Изображение пользователя Val Rubis.

Скачал последнюю версию POPT.
Все р авно выходит то же сообщение, что якобы надо устаноить свежую версию...

0
Robotex - 9 Август, 2008 - 00:20

Сначала инет настроить нужно, а потом уж все остальное. Че за модем? Че за инет? ADSL?

0
Val Rubis - 9 Август, 2008 - 01:06
Изображение пользователя Val Rubis.

Инет только что настроил, за что огромное спасибо.
Вся загвоздка была в настройке инета.
Сча качаю обновки.
А модем встроеныйй Конексант, посему диалап.
И Конкверерр не лезет в инет, тока через Оперу.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры