непонятная проблема со звуком

Во-первых, скажу, что я совсем новичок :)
У меня две звуковухи в системе (интегрированная и revo 5.1) А проблема такая: после установки kubuntu звук при входе в систему проигрыался, но до середины где-то, потом обрывался и, например, при попытке проиграть мп3 или запустить кино - его не было. При выходе из системы звук выхода проигрывался нормально полностью. Погуглив решил проблему перетаскиванием вверх в списке звуковых карт моей revo 5.1(которую и использую обычно). Все ок, при запуске звук стал проигрываться нормально и в остальных местах он тоже есть. Но сейчас при запуске какого-нибудь видео файла открывается dragon player, нормально его проигрыает, но если закрыть его и опять открыть этот же файл - все, хоть 100 раз открывай-закрывай - звука нет. Любой другой файл запустить - звук работает, но только для первого раза :) Поставил кофеин - врод нет этой проблемы, но сегодня кофеин вообще звук не проигрывает. Помогите разобраться.

0
terrrible - 3 Апрель, 2009 - 11:12

Совсем уж экзотическая проблема? :) Помогите новичку! Тут еще вопрос о таскбаре: почему иконки на ней периодически не прорисовываются, а висят прозрачными?

0
balamutick - 3 Апрель, 2009 - 11:37
Изображение пользователя balamutick.

Реально, первый раз вообще в интернете с такой проблемой столкнулись.

А серъёзно, пока будешь ждать, что тебе ответят, почитай подобные же проблемы(их реально много раз поднимали и решали), обычно не всё так сложно и делается элементарными телодвижениями.

0
skew - 3 Апрель, 2009 - 12:02
Изображение пользователя skew.

У меня нечто похожее было на версиях КДЕ 4,0 (и 4,1 кажется тоже). Какая стоит? Используются обе звуковухи?
в файл /etc/modprobe.d/alsa (может alsa-base, alsa-base.conf)
впиши строку указывающую твою модель:options snd-ice1724 model=revo51отсюда. Что напишет:lspci | grep Audio

0
terrrible - 3 Апрель, 2009 - 12:05

Спасибо, попробую. В линуксе одна используется, под виндой обе.
А как можно узнать версию КДЕ? Ну судя по эффектам с окнами и на раб. столе у меня все-таки 4.2

0
Ockonal - 3 Апрель, 2009 - 16:29
Изображение пользователя Ockonal.

kwin -v
Укажет тебе =)
Вот мой вывод:
[email protected]:~$ kwin -v
Qt: 4.5.0
KDE: 4.2.2 (KDE 4.2.2)
KWin: 4.2.2 (KDE 4.2.2)

0
Lang - 3 Апрель, 2009 - 16:56
Изображение пользователя Lang.

Погуглив решил проблему перетаскиванием вверх в списке звуковых карт моей revo 5.1(которую и использую обычно).
Это в phonon'е как я понял, а что до этого стояло PulseAudio? Если разобраться, то ты перевел микширование с звукого сервера на звуковую карту? Прочитай это, может не идеально написано, но даст какое-то базовое понимание, как работает звуковая система

Но сейчас при запуске какого-нибудь видео файла открывается dragon player, нормально его проигрыает, но если закрыть его и опять открыть этот же файл - все, хоть 100 раз открывай-закрывай - звука нет. Любой другой файл запустить - звук работает, но только для первого раза :)

Попробуй в phonon'е (Параметры системы -> Мультимедия) поставить галочку "Показать дополнительные устройства" и по экспериментировать. А вообще у тебя может одновременно проигрываться звук из разных приложениях? Может у тебя карточка не поддерживает смешивание нескольких одновременно звучащих сигналов

0
terrrible - 3 Апрель, 2009 - 22:17

Lang, спасибо, попробую как только смогу). Определил что у меня кде 4.1 и обновился. Но теперь грузит только командную строку, я так понял что-то лишнее снес, когда плазмоиды старые удалял. Помогите вернуться к графическому виду :)

0
Lang - 3 Апрель, 2009 - 22:47
Изображение пользователя Lang.

Если в консоли есть интернет, то сделай sudo apt-get --reinstall install kde

0
terrrible - 3 Апрель, 2009 - 23:12

ну до обновления был инет, значит должен быть, но при исполнении этой команды он выодит что-то, не могу прочесть что, т.к. половина букв русских, остальные символы пропущены, прочитать невозможно. Выводит список каких-то компонент кде и все %)

0
Nesmero - 4 Апрель, 2009 - 07:46
Изображение пользователя Nesmero.

export LANG=C

0
Lang - 3 Апрель, 2009 - 23:32
Изображение пользователя Lang.

Это все пакеты которые входят в состав kde нажимай Y и enter, хотя в этом случае он много лишнего поставить. Если не устраивает, то вспоминай чего удалял тогда и ставь заново

0
terrrible - 4 Апрель, 2009 - 00:21

Так в том-то и дело, он не предлагает нажать "да" и продолжить, он что-то нам пишет и опять возвращается в режим ввода в командную строку
Изображение с кодом 568677 - savepic.ru — сервис хранения изображений
PS: перед обновлением удалял все пакеты, в названии которых было слово plasma

0
Ockonal - 4 Апрель, 2009 - 01:01
Изображение пользователя Ockonal.

Поставьте себе 9,04 бету.. Во-первых, не будет "крякозябр" в консоли, во-вторых, может будет звук :-D

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры