Проблема с Network Manager в Kubuntu 9.04

Проблема следующая - когда открываю NM активны только вкладки Wireled и VPN, а DSL, Wireless и Mobile Broadcom неактивны (соответственно соединение добавить нельзя). Что делать?

0
AlexU - 25 Апрель, 2009 - 13:39

Решил написать сюда, т.к. тема подходит.
Mobile Broadcom становиться активной после подключения модема, но после ввода настроек, к инету не подключается. (AnyData ADU-300A, SkyLink).
К тому же локальную сеть смог поднять только с ifup, все попытки настроить с помощью NM ни к чему не привели.
В 8.10 завелось все без проблем - и модем, и локалка.

0
labaman - 25 Апрель, 2009 - 17:18

Вообщем почитал комментарии на kubuntu.org по аналогичному вопросу - говорят что это чисто глюк KDE, и что скорее всего его поправят только к выходу KDE 4.3.1. Лично я не готов столько ждать (к тому же пока еще подоспеет релиз Ubuntu с KDE 4.3.1 на борту не известно). В общем откатился на Ubuntu ибо в нем Gnome NM работает прекрасно.
P.S. Кстати на kubuntu.org изложено много альтернатив для тех, кто верен KDE до смерти, в частности одна из них это выкачать аплет Gnome NM (с доброй половиной самого GNOME) и использовать его, добавив в автостарт.
P.S.S. Забавно получается в kubuntu 8.10 предлагали прикрутить аплет gnome-bluez, чтобы нормально пользоваться Bluetooth, и вот теперь в 9.04 предлагают прикрутить аплет Gnome NM, чтобы нормально работать с сетевыми устройствами. Весело...

+1
jogan - 26 Апрель, 2009 - 08:55
Изображение пользователя jogan.

Да забейте Вы на этот вистанутый-виджитовый интерфейс версии 4 - ставим 3.5 и радуемся жизни. У меня в 3.5 и WiFi И BT работают на ура - ставил ось что называется "из коробки" - сразу всё нашлось.

0
Vlad_W_1999 - 2 Май, 2009 - 14:49

У меня с 8.10 прикручен гномий апплет. Иначе не настраивался wi-fi. А вот в 9.04 вылез какой-то непонятный глюк. Теперь думаю: а не из-за этого ли?

0
dimak08 - 25 Апрель, 2009 - 17:18

Немного поковырялся в этом нэтворк менеджере, оказывается слетает маска подсети сразуже после нажатия "ОК"
Из-за этого не возможно подключится ни к одной сети

0
labaman - 25 Апрель, 2009 - 17:20

здесь не просто невозможно подключиться - здесь вообще нельзя по средствам NM создать какое-либо соединение кроме Ethenet и VPN.

0
dimak08 - 25 Апрель, 2009 - 17:45

можете помоч настроить локальную сеть и интернет средствами конслоли??
мои настройки: IP: 192.168.216.21
Netmask: 255.255.255.0
Gateway: 192.168.216.1
DNS: 192.168.200.1

и так чтобы не слетали при каждой перезгрузки

Заранее спасибо.

0
Гал - 25 Апрель, 2009 - 19:43
Изображение пользователя Гал.

Dimak08, ты считай сам все уже настроил. Тока это все запиши в /etc/network/interfaces
sudo nano /etc/network/interfaces,
там пишешь это
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.216.21
netmask 255.255.255.0
gateway 192.168.216.1

по поводу днс точно не скажу. В 8.10 его надо писать в /etc/resolv.conf а вот в 9.04 он у меня сам прописался в файле с интерфейсами. Так что наличие файла resolv.conf не гарантирую, так как в 9.04 особо еще не разбирался. И к сожалению не подскажу как правильно прописать в файле с интерфейсами но на всякий случай попробуй как обычно
nameserver 192.168.200.1
а затем вот это
sudo /etc/init.d/networking restart

0
Neksi - 25 Апрель, 2009 - 18:03

Не смог подключить при установке с CD, а вот с DVD схватило автоматом

0
mss - 25 Апрель, 2009 - 19:31
Изображение пользователя mss.

Данную проблему решил хотя и кружным (как говорят в Евпатории:через Саки на Мойнаки) но верным способом.
После установки 9.04 загрузился с диском 7.10 и настроил сеть. Скопировал папку /etc.
Загрузился в 9.04.
Удалил нетворк менеджер.
Скопировал папку /etc/resolvconf/run из "сохранённого" /etc в /etc/resolvconf 9.04 (главное там-файл resolf.conf, где прописаны DNS)
Скопировал файл interfaces из "сохранённого" /etc/network в такую же папку 9.04
Запустил в терминале
sudo /etc/init.d/networking restart
И всё заработало.
Наверняка есть более простой способ. Пусть знатоки подскажут. Лучше всего- как настроить сеть в терминале.

0
dimak08 - 25 Апрель, 2009 - 19:50

Зы :) я тоже с Евпатории :)

/etc/network/interfaces:

auto lo
iface lo inet loopback
auto eth0
iface eth0 inet static
address 192.168.216.21
netmask 255.255.255.0
gateway 192.168.216.1

/etc/resolv.conf:

nameserver 192.168.200.1

и sudo /etc/init.d/networking restart выдаёт:
* Reconfiguring network interfaces...
Don't seem to be have alt the variables for eth0/inet
Failed to dring up eth0. [OK]

0
mss - 25 Апрель, 2009 - 23:09
Изображение пользователя mss.

Хе-хе!А я с Новоозёрного!
Не /etc/resolv.conf!
Сделай, как я писал, по пунктам. У меня настроилось за две минуты (не считая времени настройки "шаблонной" 7.10
Файл resolv.conf с настройками должен лежать в папке /etc/resolvconf/run
Если её нет, создать.

0
jogan - 25 Апрель, 2009 - 20:30
Изображение пользователя jogan.

Да вообще полная лажа и с кедами 4-ми(как от этого виджитного гумна избавится, ума не преложу)и с 9.04, касательно bradcom-овских WiFi дров. Мне после установки вообще в безапелляционной форме было заявлено - "Проприетарные дрова более не поддерживаются..." и нах. Вот обясните мне - почему в 8.10 они(дрова) поддерживались, а в 9.04 уже нет? Хорошо backup всей системы перед обновлением сделал - теперь обратно откатил и радуюсь жизни. Вообщем KDE 4 + ОС 9.04 = Windows Vista

0
Гал - 25 Апрель, 2009 - 21:32
Изображение пользователя Гал.

Вот именно поэтому я и не спешил с обновлением до 9.04. А так, на соседний винт поставил. :) Решения однозначно есть, но их видимо пока не нашли.

0
dimak08 - 25 Апрель, 2009 - 22:55

у меня просто проблема... кубунта 8-ая не хочет запускать инсталятор даже в текстовом варианте.

всё таки выхода нет с настройкой сети??

0
Гал - 26 Апрель, 2009 - 04:29
Изображение пользователя Гал.

А в файле в интерфейсами не пробовал писать? Дело в том, что я ставил серверную версию. У меня комп получает настройки с ДХЦП, вот он во время установки их автоматом получил. А когда я заглянул в /etc/network/interfaces то обнаружил там помимо всего что должно быть еще и строку с днс. Дома буду посмотрю и точно напишу. :)

0
dimak08 - 26 Апрель, 2009 - 08:58

я уже выше писал что происходит если записать в файл с интерфейсами.

0
Гость - 26 Апрель, 2009 - 02:53

сделай скрипт типа :
#!/bin/bash

ifconfig 192.168.0.1 broadcast 192.168.0.255 netmask 255.255.255.0
route add default <ваш шлюз>
echo "nameserver <ваш первый днс>" > /etc/resolv.conf
echo "nameserver <ваш первый днс>" >> /etc/resolv.conf

и ставь его в автозагрузку - но олько после запуска network manager .... - или убрать network manager совсем + скрипт в автозагрузку через init.d

0
jogan - 26 Апрель, 2009 - 08:48
Изображение пользователя jogan.

Выход найден(отдельная благодарность знающим людям): Kubuntu 9.04+KDE3.5 Intrepid+Jauntly LiveCD Images Сам пока не пробовал - качаю. На данный момент откатил систему(с помощью Backup-а созданного Acronis-ом)до 8.10 и через пень колоду установил Open Office 3.0.1 - из-за него собственно и стал замарачиваться обновлением. По непроверенным данным - и с проприетарными дровами там всё в порядке :)

0
dimak08 - 26 Апрель, 2009 - 09:28

немного поковырялся на kubuntuforums.net и сделал мануальчик:

sudo su
ifconfig eth0 ваш_айпи netmask маска_подсети
route add -net 0.0.0.0 gw ваш_шлюз
echo nameserver адрес_днс_сервера > /etc/resolv.conf
/etc/init.d/networking restart

вот образец:
[email protected]:/home/ubuntu# ifconfig eth0 192.168.216.21 netmask 255.255.255.0
[email protected]:/home/ubuntu# route add -net 0.0.0.0 gw 192.168.216.1
[email protected]:/home/ubuntu# echo nameserver 192.168.200.1 > /etc/resolvconf/run/resolv.conf
bash: /etc/resolvconf/run/resolv.conf: No such file or directory
[email protected]:/home/ubuntu# /etc/init.d/networking restart
* Reconfiguring network interfaces... [ OK ]
[email protected]:/home/ubuntu# ping 192.168.200.1
PING 192.168.200.1 (192.168.200.1) 56(84) bytes of data.
64 bytes from 192.168.200.1: icmp_seq=1 ttl=63 time=6.35 ms
64 bytes from 192.168.200.1: icmp_seq=2 ttl=63 time=0.846 ms
^C
--- 192.168.200.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 0.846/3.601/6.356/2.755 ms
[email protected]:/home/ubuntu# ping ya.ru
ping: unknown host ya.ru
[email protected]:/home/ubuntu# echo nameserver 192.168.200.1 > /etc/resolv.conf
[email protected]:/home/ubuntu# /etc/init.d/networking restart
* Reconfiguring network interfaces... [ OK ]
[email protected]:/home/ubuntu# ping ya.ru
PING ya.ru (213.180.204.8) 56(84) bytes of data.
64 bytes from ya.ru (213.180.204.8): icmp_seq=1 ttl=52 time=43.9 ms
64 bytes from ya.ru (213.180.204.8): icmp_seq=2 ttl=52 time=45.0 ms
64 bytes from ya.ru (213.180.204.8): icmp_seq=3 ttl=52 time=43.3 ms
64 bytes from ya.ru (213.180.204.8): icmp_seq=4 ttl=52 time=44.0 ms
64 bytes from ya.ru (213.180.204.8): icmp_seq=5 ttl=52 time=44.2 ms
^C
--- ya.ru ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4004ms
rtt min/avg/max/mdev = 43.333/44.115/45.013/0.588 ms
[email protected]:/home/ubuntu#

прошу заметить, что файл с ДНСом лежит /etc/resolv.conf, а не /etc/resolvconf/run/resolv.conf, как писалось выше

0
kik - 9 Октябрь, 2009 - 02:57
Изображение пользователя kik.

А если ДНС сервера два?.. =\

0
Xenomorph - 9 Октябрь, 2009 - 03:16
Изображение пользователя Xenomorph.

Хоть три(как у меня)! Тогда добавляешь в /etc/network/interfaces строчку dns-nameservers xx.xxx.xxx.xxx yy.yyy.yyy.yyy zz.zzz.zzz.zzz
где xx.xxx.xxx.xxx, yy.yyy.yyy.yyy, zz.zzz.zzz.zzz - твои DNS-серверы.
Или, если выдача IP идет через DHCP, проще прописать в /etc/dhcp3/dhclient.conf prepend domain-name-servers xx.xxx.xxx.xxx, yy.yyy.yyy.yyy, zz.zzz.zzz.zzz , что, кажись, то же самое, но не уверен.

0
kik - 9 Октябрь, 2009 - 07:07
Изображение пользователя kik.

спасибо :)

0
Гал - 26 Апрель, 2009 - 09:36
Изображение пользователя Гал.

я же говорил решение есть))

0
Гость - 26 Апрель, 2009 - 13:12

a networkmanager удалять надо?

0
AlexU - 26 Апрель, 2009 - 14:22

Есть еще один вариант -- wicd.
На одном из форумов наткнулся на фразу, что будет включен в следующий релиз КДЕ.
Не уверен, что это правда, т.к. wicd на GTK.
Попробую... отпишусь.

0
dimak08 - 26 Апрель, 2009 - 15:12

установил его после сноса нетворк менеджера :)

0
SeaJey - 2 Май, 2009 - 13:22
Изображение пользователя SeaJey.

Не конкретно сам wicd, а SOLID-бэкенд к нему.

0
labaman - 28 Апрель, 2009 - 15:11

вообще-то у меня aptitude сам снес NM пред установкой wicd. В wicid есть один недостаток - нет поддержки DSL. Конечно можно и по-старинке через pppoeconf, но тут уже для меня скорее дело принципа.

0
sergey.vinakov - 2 Май, 2009 - 09:47
Изображение пользователя sergey.vinakov.

Читаю и удивляюсь - почему у меня все работает... ADSL модем настроен роутером, SSID не скрытый, правда без шифрования пока, только фильтр по мак-адресам. 9.04 у меня если что.

0
lohmat - 2 Май, 2009 - 10:58
Изображение пользователя lohmat.

Вот-вот, не скрытая потому-что :)
А вообще, wicd мне больше понравилась. Удобнее и все сразу завелось скрытая сеть+шифрование, но это ИМХО.

0
SeaJey - 2 Май, 2009 - 13:24
Изображение пользователя SeaJey.

Проблема именно со скрытыми ssid'ами. И некоторыми достаточно редкоиспользуемыми типами шифрования.

0
lohmat - 2 Май, 2009 - 13:47
Изображение пользователя lohmat.

С редкими типами я не пробовал, у меня просто скрытая сеть с WEP 64bit и ключ в hex...

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры