KTorrent плохо сидирует (РЕШЕНО)

Изображение пользователя nick_sniper2.

Суть проблемы: закачан весь файл, либо его часть. КТорент начинает раздавать (тем у кого меньше закачано). Через какое-то время у личера "Счет" опускается к -1, потом к -50 и раздача для него останавливается. Потом сброс счета, опять короткая раздача, опять -50 и стоп.

Нет никаких ограничений (ни скорости, ни соотношений, ничего). Настройки менял на самые разные. Форумы смотрел - не вижу решения.

Подскажите, а то сам не могу понять. Как можно нормально в КТоррент сидировать? Я не хочу в данный момент ничего закачивать. Хочу только посидировать, чтобы поднабраться рейтинга. А КТоррент то что можно раздать за час, раздает за 3 суток.

0
nick_sniper2 - 29 Июнь, 2009 - 23:47
Изображение пользователя nick_sniper2.

Разве ни у кого нет подобных проблем?

0
wherecat - 30 Июнь, 2009 - 09:02
Изображение пользователя wherecat.

В свое время колупался с портами, после настройки активно засосали.
У вас собссно инет через что?

0
nick_sniper2 - 30 Июнь, 2009 - 19:37
Изображение пользователя nick_sniper2.

Стоит Кубунта 9.04, дальше ВайФай (54М), потом DSL-модем к провайдеру (теоретических 38М). Теоретически провайдер никаких портов закрывать не должен. Единственное ограничение - 500К на upload. Но не думаю, что ограничение скорости сильно влияет. Да, у меня был включен файрвол (ufw) - остановил. Разницы не вижу.

В самом КТоррент стоят настройки:
Порт: 6881
Порт трекера UDP: 4444

Где еще могут быть проблемы с портами? Как проверить?

Хотя я не совсем уверен, что это порты. Складывается впечатление, что это КТоррент для 4-х Кед недоработан. Еще раз повторюсь: при закачке файла идет и раздача. Довольно неплохо. При сидировании раздача тоже бывает. Но уж очень вяло. В большинстве случаев простаивает (хотя личеров достаточно и мог бы раздавать). Более подробно я описывал в 1-м посте.

Спасибо за ответ.

+1
picaro - 30 Июнь, 2009 - 22:06
Изображение пользователя picaro.

У тебя нормальный ip? У меня примерно такая же схема. Так aDSL модем является роутером, на котором поднят NAT, которому надо было обьяснить, что порт надо пробрасывать.
Проверь порт на открытость из мира.

0
nick_sniper2 - 1 Июль, 2009 - 00:31
Изображение пользователя nick_sniper2.

Да... Кто бы мог подумать.

Проблема оказалась не в модеме, а в ВайФай роутере. От небезызвестной компании D-Link. Надо было покопаться в настройках. Только у них это почему-то называется не как у людей (NAT, либо port mapping), а Virtual server (я и не обращал на него внимания, отключен да и отключен).

Проброс портов сделал. Проверил с помощью whatsmyip.org - теперь порты открыты из Интернета.

Наконец-то все нормально заработало! Спасибо за помощь. А то я уже не один месяц мучался.

0
wherecat - 1 Июль, 2009 - 08:02
Изображение пользователя wherecat.

Хых, ещё на hdtracker рекомендуют умолчальные настройки 6881/4444 менять нафих. Ибо провайдер палит и чинит диавольские козни. Порт на DHT не забудьте открыть ;)

0
Гость - 6 Ноябрь, 2009 - 11:11

Наверное, вы путаете Cable modem с xDSL... Cable: Upstream 512k, downstream 32 Mbit
xDSL (Max) 8/8

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры