Blocked updates. (Пакеты, которые будут оставлены в неизменном виде:) (РЕШЕНО)

Изображение пользователя vap.

В трее висит менеджер обновлений

жму apply он типа чтото делает и опять выдает тоже самое, попробовал в командной строке выдало вот:
# sudo apt-get upgradeЧтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Пакеты, которые будут оставлены в неизменном виде:
  linux-generic linux-headers-generic linux-image-generic
  linux-restricted-modules-generic
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 4 пакетов не обновлено.

Комментарии (13)

+1
Ockonal - 21 Июнь, 2009 - 22:53
Изображение пользователя Ockonal.

sudo aptitude update
sudo aptitude dist-upgrade
sudo aptitude update
sudo aptitude -f install
sudo reboot

Такая комбинация Вас точно спасет.
P.S. Всё заключается во 2й строке :D

+1
nemon - 22 Июнь, 2009 - 02:57

Меня от заблокированных апдейтов спасает бональное: sudo aptitude upgrade Которое, кстати, помогло с точно такими же заблокированными апдейтами сегодня.

0
vap - 22 Июнь, 2009 - 05:44
Изображение пользователя vap.

спасибо помогло.

+2
balamutick - 22 Июнь, 2009 - 10:52
Изображение пользователя balamutick.

Давайте нормальные названия темам.
Даже если они на вашем блоге. Сами потом искать задолбаетесь, пожалейте логику !

Переименовал принудительно (подло пользуясь властью):
из "boken" (или что-то подобное, невнятное было написано)
В
"Blocked updates. (Пакеты, которые будут оставлены в неизменном виде:) (РЕШЕНО)"

p.s. boken - вообще не вариант.

0
dude_sam - 24 Июнь, 2009 - 20:34
Изображение пользователя dude_sam.

У меня сегодня заблокированные апдейты ядра и амарока победлись командой
sudo aptitude safe-upgrade

0
nemon - 25 Июнь, 2009 - 04:22

Ну это в принципе равноценно запуску с параметром апгрей. Т.к. при запуске с параметром апгрейд в консоли видно The "upgrade" command is deprecated; use "safe-upgrade" instead. что означает использования сейф-апгрейда :)

0
Гость - 13 Январь, 2010 - 14:27

Вот еще что помогает
sudo aptitude full-upgrade

0
kot040188 - 19 Январь, 2016 - 03:06
Изображение пользователя kot040188.

А есть какая-то разница между apt-get и aptitude? sudo apt-get dist-upgrade мне не помогло.

0
dyug - 19 Январь, 2016 - 17:10

да есть.
в разнице оболочек. :-)
то, что делает apt-get dist-upgrade делает aptitude upgrade только предварительно предложив поставить новые пакеты. apt-get upgrade никогда не ставит новые пакеты, только обновляет уже установленные. И если вдруг при обновлении нужно установить какой то дополнительный пакет - то данный пакет(насколько мне не изменяет мой склероз) будет оставлен в неизменном виде, до выполнения apt-get dist-upgrade

0
kot040188 - 19 Январь, 2016 - 17:21
Изображение пользователя kot040188.

А aptitude dist-upgrade что делает? (ヅ)
Вот такая петрушка:

Вот что делать?
0
dyug - 19 Январь, 2016 - 17:24

[email protected]:~# aptitude --help
aptitude 0.7.3
Использование: aptitude [-S имя файла] [-u|-i]
aptitude [параметры] <действие> …
Действия (если не заданы, aptitude запускается в диалоговом режиме):

install - Установить/обновить пакеты.
remove - Удалить пакеты.
purge - Удалить пакеты и их файлы настройки.
пропущено
forbid-version - Запретить aptitude обновлять определённую версию пакета.
update - Скачать список новых/обновлённых пакетов.
safe-upgrade - Выполнить безопасное обновление.
full-upgrade - Выполнить обновление, возможна установка и удаление пакетов.

что еще нужно для обьяснения?
лень команду набрать, да?

0
dyug - 19 Январь, 2016 - 17:31

странно, но есть мнение что гсс ты ставишь не из родного репа. :-)

Я бы оставил без обновления. Ибо это число пакетов и их названия (которые входят в ключевые зависимости работоспособности) удалять НЕЛЬЗЯ категорически.
А минорное изменение гсс на работоспособность и сборку явно не повлияет.
А если для тебя влияет, то наверняка ты уже в курсе как правильно собирать исполняемые файлы и библиотеки. :-)
Всего навсего нужно будет пересобрать примерно половину базы убунты, как на мой взгляд, хотя я могу и ошибаться, и пересобирать придется всю убунту, вместе с кубунтой. :-)

0
kot040188 - 19 Январь, 2016 - 17:43
Изображение пользователя kot040188.

странно, но есть мнение что гсс ты ставишь не из родного репа. :-)
Я его вообще не ставил, накой он мне? Может это из какого-то ppa…
наверняка ты уже в курсе как правильно собирать исполняемые файлы и библиотеки. :-)
Чур меня…

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры