Verlihub

Сколько не перечитал мануалов разных нечего не получается. Хочу собрать Verlihub
установил зависящие пакеты gcc, g++, binutils, geoip-bin, libgeoip-dev, libpcre3-dev, liblua50-dev, liblualib50-dev, make, libmysqlclient-dev хочу собрать верлик а он мне пишет
./configure
***-desktop:~/Документы/verlihub$ ./configure
-bash: ./configure: Permission denied

смотрю траблу
configure: error: "Please install mysql-devel package"
я и libmysql++-dev уже поставил и все перепробовал что делать?

0
Гость - 10 Сентябрь, 2009 - 23:09

Либо из под рута собирай, либо права выставь верные на каталог с исходником (рекурсивно)

0
Mike - 11 Сентябрь, 2009 - 06:19
Изображение пользователя Mike.

вот эта строка
-bash: ./configure: Permission denied
кагбе намекает нам, что для конфигурирования пользовательских прав недостаточно, и запускать конфигуратор надо командой
sudo ./configure
Кроме того я даже больше скажу: то же самое тебе придется сделать и с командами make и make install

0
ktchv - 11 Сентябрь, 2009 - 07:45
Изображение пользователя ktchv.

как раз по-моему эта строка нам как бэ намекает, что надо сделать chmod +x configure на фс, где нет флага noexec.

0
Mike - 11 Сентябрь, 2009 - 07:51
Изображение пользователя Mike.

вот эта строка
***-desktop:~/Документы/verlihub$ ./configure
кагбэ намекает на то, что топикстартер пытается делать все в своем родном хоуме, где у него должны быть права на выполнение программ.

0
LIZARD666 - 11 Сентябрь, 2009 - 08:10

sudo: ./configure: command not found
[email protected]:~/Документы/verlihub$

делал неполучается

Спасибо
sudo chmod +x configure
помогло, но во время инсталляции пишет все равно
configure: error: "Please install mysql-devel package"

0
ktchv - 11 Сентябрь, 2009 - 08:55
Изображение пользователя ktchv.

sudo перед chmod не нужно.

проверьте, точно ли установлен libmysqlclient-dev.

0
LIZARD666 - 11 Сентябрь, 2009 - 08:58

стоит он в том то и дело(((
i A libmysqlclient15-dev            - MySQL database development files

0
ktchv - 11 Сентябрь, 2009 - 08:59
Изображение пользователя ktchv.

а mysql-server и mysql-client ?

0
LIZARD666 - 11 Сентябрь, 2009 - 09:15

[email protected]:~/Документы/verlihub$ sudo make install

Вывод тут: http://paste.ubuntu.com/269123/

и по пакетам
i
i A mysql-client-5.0 - MySQL database client binaries
i A mysql-server-5.0 - MySQL database server binaries

*Balamutick: для больших сообщений, тем более в узкой колонке ответа, используйте сервиc paste.ubuntu.com для размещения журналов(логов) и выводов консоли. Ваше сообщение подправил.

0
ktchv - 11 Сентябрь, 2009 - 09:22
Изображение пользователя ktchv.

configure и make не выдали ошибок?

сносим всё и делаем по инструкции и правильно конфигурим

0
LIZARD666 - 11 Сентябрь, 2009 - 09:47

попробывал тоже самое dev ошибка мускуля я по этой инструкции делал ВОТ

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры