Kubuntu 9.10 и nvidia [Решено]

Дистрибутив: Kubuntu 9.10
Видеоката: Geforce 7100 GS 512 Мб
Монитор: Китайский noname, подключен через VGA.
Драйвера nvidia версии: NVIDIA-Linux-x86-190.42-pkg1.run

Ставились таким образом:

Ctrl+Alt+F3, логин потом:
sudo /etc/init.d./kdm stop
sudo sh /home/andrey/NVIDIA-Linux-x86-190.42-pkg1.run
sudo /etc/init.d./kdm start

Поставились без ошибок.

Но разрешение монитора 640x480. Это поломка глаз.
В винде нормальное разрешение 1280х1024.

Как можно полечить и сделать нормальное разрешение?

P.S. Извините за орфографию.

0
Vlad_W_1999 - 30 Октябрь, 2009 - 20:51

С драйверами от Nvidia действительно фиг знает что происходит. Я сносил все дрова, какие были, грузился в текстовом режиме, ставил эти же 190... Результат очень странный: работают эффекты, но система уверена, что идёт на свободном драйвере... Как бороться пока не понял.

0
wherecat - 30 Октябрь, 2009 - 22:42
Изображение пользователя wherecat.

Отлились кошке мышкины слезки?

ATi-кун :)

0
Vlad_W_1999 - 31 Октябрь, 2009 - 00:08

Спокуха! Уже сказано, что 190.42 появятся в репах через пару дней. Подождём.

Кстати, что-то я не помню, что бы здесь злорадствовали, когда у атишников были траблы...

0
kubuser - 31 Октябрь, 2009 - 11:36
Изображение пользователя kubuser.

А можно ссылочку?

0
Vlad_W_1999 - 31 Октябрь, 2009 - 15:05

А вот со ссылочкой засада: прочитал на каком-то баг-репорте. Ссылку сейчас просто не найду. Но вроде как на форуме у коллег уже обсуждается как прикрутить репы PPA... Скажем, вот.

0
DarkneSS - 30 Октябрь, 2009 - 22:44
Изображение пользователя DarkneSS.

Можно прописать моделайны в хорг...
Мои страдания

0
Viktor - 31 Октябрь, 2009 - 14:31

Может действительно заглянуть в файл xorg.conf и там прописать нужное разрешение, кажись эта тема уже где то здесь обсуждалась надо просто поискать.

0
Goodboy3012 - 31 Октябрь, 2009 - 17:42

Спасибо.

modeline делал вот этим - http://www.arachnoid.com/modelines/index.html

Вот итоговый xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Tue Oct 20 21:00:15 PDT 2009

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Tue Oct 20 21:00:15 PDT 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-1"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 60.0
    ModeLine    "640x480@60.00" 23.86 640 656 720 800 480 481 484 497 -HSync +Vsync
    ModeLine    "800x600@60.00" 38.22 800 832 912 1024 600 601 604 622 -HSync +Vsync
    ModeLine       "1024x768@60.00" 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync
    ModeLine       "1280x1024@60.00" 108.88 1280 1360 1496 1712 1024 1025 1028 1060 -HSync +Vsync
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7100 GS"
    Option         "UseDisplayDevice" "CRT-0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "TwinView" "0"
    Option         "metamodes" "1280x1024_60 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

+1
al1971 - 2 Ноябрь, 2009 - 15:07

В убунту 9.10 решил проблему проще, запустил конфигурационную утилиту nvidia - settings из под рута. Настроил все что надо было и сохранил в xorg.conf.
Все работает!!

0
Гость - 5 Ноябрь, 2009 - 19:49

Goodboy3012 ОГРОМНОЕ спасибо, а то уже неделю парился, просто скопировал конфиг и вуаля всё заработало )))

0
Гость - 7 Ноябрь, 2009 - 20:05

из всего этого имеют смысл только правильные значения HorizSync VertRefresh
и тогда на их основе система определит правильный список разрешений.
значения эти у современных мониторов по большей части совпадают(при одинаковой геометрии).

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры