Помогите расставить приоритеты репазиториев

Изображение пользователя null56.

У меня два репазитория, стабильный и нет
deb ftp://mirror.yandex.ru/debian/ stable main contrib non-free
deb ftp://mirror.yandex.ru/debian/ unstable main contrib non-free

Подскажите пожалуйста, как мне расставить приоритет между ними, чтобы сначала использовался стабильный приоритет

Заранее благодарен за помощь

0
Lang - 2 Декабрь, 2009 - 23:08
Изображение пользователя Lang.

По-любому будет качаться пакет у которого больше версия

0
null56 - 3 Декабрь, 2009 - 00:00
Изображение пользователя null56.

кое что нашел, но не знаю на сколько это актуально

cat /etc/apt/preferances

Package: *
Pin: release a=stable
Pin-Priority: 600
Package: *
Pin: release a=lenny-backports
Pin-Priority: 500
Package: *
Pin: release a=testing
Pin-Priority: 450
Package: *
Pin: release a=unstable
Pin-Priority: 400

0
null56 - 3 Декабрь, 2009 - 00:00
Изображение пользователя null56.

вот с маном бы по этому поводу кто бы подсказал

0
DarkneSS - 3 Декабрь, 2009 - 01:00
Изображение пользователя DarkneSS.

Зачем вам нестабильный реп, если хотите стабильные версии пакетов?

0
null56 - 3 Декабрь, 2009 - 01:14
Изображение пользователя null56.

Я использую из нестабильных ветвей только некоторые пакеты, которые мне действительно нужны, например qt. Но из - за смешения ветвей не могу установить некоторые пакеты, такие как
apt-get install qmmp
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
  qmmp: Зависит: libqmmp-misc (>= 0.3.1-1) но он не будет установлен
E: Сломанные пакеты

если есть выход альтернативный, то подскажите пожалуйста

0
Lang - 3 Декабрь, 2009 - 11:25
Изображение пользователя Lang.

Подумай про зависимость программ и библиотек

0
Гость - 31 Март, 2010 - 18:46

Я какбе рекомендую вместо unstable использовать вот это:
deb http://mirror.yandex.ru/backports.org/ lenny-backports main contrib non-free

Пакеты там скомпилированны так, чтобы не зависеть от новых библиотек, например.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры