Встроенный звук via HD 1708s работает на половину

Изображение пользователя QcK.

via HD 1708s
Не могу заставить выводить звук на колонки 5.1 выход наушников работает.

0
Жюстина - 22 Декабрь, 2009 - 13:05
Изображение пользователя Жюстина.

А что уже пробовалось то?

Сначала в KMix установить значения Surround Jack Mode - Shared и Channel Mode - 6.

Жёсткая настройка ALSA

После этого настроить ALSA для работы с шестиканальным звуком. Если хочется использовать только ALSA и она автоматически не настраивается на вывод звука 5.1, то нужно отредактировать файл ~/.asoundrc у меня работало с такой настройкой.

Это моя неумелая настройка, так что ведёт она себя плоховато. ALSA будет разводить стерео на все каналы, но KMix отдельно каналы у меня отказывался регулировать при такой настройке, и фильмы в которых уже записан звук 5.1 звучали плохо, другого решения для себя у меня не нашлось.

Настройка pulseaudio и ALSA

C pulseaudio всё и проще и сложнее, сначала её надо установить, если не установлена.

После этого опять нужно редактировать файл ~/.asoundrc но уже по-другому:

А в файле /etc/pulse/daemon.conf найти строку default-sample-channels и поставить значение 6, если стоит какое-то другое, и убрать точку с запятой в начале этой строки. Ещё можно поиграться со значением disable-lfe-remixing или enable-lfe-remixing значения yes или no.

Сейчас у меня всё настроено именно так, и всё работает очень хорошо. Стереозвук разводится на все каналы, а 5.1 канальный звук выводится как и должен.

После всей этой настройки, консольно: sudo alsa force-reload И не помешает в плеерах поставить модуль вывода на pulseaudio.

0
andrymax - 6 Январь, 2010 - 08:07
Изображение пользователя andrymax.

"Сначала в KMix установить значения Surround Jack Mode - Shared и Channel Mode" - где это? По всем пунктам меню KMIX посмотрел .... Версия 3.5 Сама система - Kubuntu 9.10 KDE 4.3.2

0
Жюстина - 6 Январь, 2010 - 10:12
Изображение пользователя Жюстина.

Настройка > Настройка каналов > выбрать нужные

0
andrymax - 6 Январь, 2010 - 20:27
Изображение пользователя andrymax.

Скрин можно? Surround есть и включен, вот остального нет. Не понимаю я вас ...

0
andrymax - 7 Январь, 2010 - 07:12
Изображение пользователя andrymax.

Действительно ... Вот мой

0
andrymax - 7 Январь, 2010 - 09:31
Изображение пользователя andrymax.

Tакая тема: добавил строчку в /etc/pulse/daemon.conf - disable-center-remixing = yes
Фрагмент файла:
.................
resample-method = src-linear
disable-remixing = yes
disable-lfe-remixing = yes
disable-center-remixing = yes
..........
Без нее была мешанина в каналах. Строки disable-remixing = yes disable-lfe-remixing = yes (строка для смешения сигнала на саб) пробовал в разных комбинация раскоментировать и наоборот - не помогало - центра небыло.
Теперь VLC с видео mkv со звуком DTS 5.1 позволяет включать каналы звука (5.1) - все ОК! Ваще все работает, но...
на команду:

[email protected]:~$ speaker-test -D surround51 -c6 -t wav

speaker-test 1.0.20

Устройство для проигрывания - surround51
Параметры потока - 48000Гц, S16_LE, 6 каналов
WAV файл(ы)
E: conf-parser.c: [/etc/pulse/daemon.conf:52] Unknown lvalue 'disable-center-remixing' in section 'n/a'.
Установленна частота в 48000Гц (запрошено 48000Гц)
Размер буфера от 64 до 5440
Размер периода от 32 до 2720
Используется максимальный размер буфера 5440
Периоды = 4
был установлен period_size = 1088
был установлен buffer_size = 5440
0 - Передний левый
4 - Центральный
1 - Передний правый
и т.д. ругается (видно в строке c E ), но все исправно по каналам проговаривает. :)

да, эабыл добавить: В "Параметры системы - Мультимедиа-Приоритет устройства вывода для ...." - что Pulseaudio наверху, что HDA ATI SB (ALS883) - без разницы, как на звук, так и на видео и всю систему. Непонятно мне...

0
andrymax - 11 Январь, 2010 - 16:02
Изображение пользователя andrymax.

Решил проблемму со звуком 5.1: Полностью переустановил Pulseaudio с удалением всего, что с ней связано в профиле.
Спасибо за помощь! Осталось хороший Media Center нарыть, чтоб с пульта можно было управлять, не вcтавая с дивана. Или просто поставить MythTV :)

0
andrymax - 22 Январь, 2010 - 04:24
Изображение пользователя andrymax.

Ветка форума превращается в мой блог.... :) Ну да ладно - может кому поможет.
После попытки установки системного эквалайзера (http://forum.ubuntu.ru/index.php?topic=17787.msg613858#msg613858) проблеммы - он не заработал - т.е. даже ни разу не запустился.
Когда удалил - настройки звука нормальные пропали (5.1) Восстановил, но теперь почти сразу на фильмах, ни с того, ни с сего, звук заикается - зар в 1,5-2 сек прерывается на доли секунды...
Удалил тупо Pulseaudiо, и еще подчистил пакеты после того. И все работает на ALSA. Все 5.1!

0
andrymax - 18 Апрель, 2012 - 13:15
Изображение пользователя andrymax.

Добавлю, это спустя 2 с лишним года (сейчас апрель 2012, 17-ое) - все это хрень полная, т.к. это просто тыканье без понятия сути. Хочу сказать, что и сейчас, спустя время, инет забит такими же вопросами и еще более тупыми на них ответами, из коих понятно, что почти никто не разбирается в этой трабле, а городит, как получиться. Сам тоже не понял - сейчас, когда осталось меньше 10 дней до выхода 12.04, я опять поставил Mint 10 на старом добром Gnome 2 (это на основе Ubuntu 10.10) и имею те же проблемы с 5-ти канальным звуком :) Ественно, оно легко относительно настраивается, и благодаря посту выше, но все таки опять "то работает, то не работает" без видимых на то причин...

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры