Нечеткая заставка при загрузке системы(РЕШЕНО)

Изображение пользователя Firemies.

Добрый день,
Подскажите где копать, установил Кубунту 10.04, потом установил дрова Нвидии 195.26.15 и после этого окно Кубунту при старте и выключении в непонятном разрешении, это не критично но если можно исправить подскажите как. Спасибо

0
Flameflower - 25 Апрель, 2010 - 19:42
Изображение пользователя Flameflower.

Поможет удаление драйверов. :)
Честно говоря сам с подобной проблемой, вроде не критично, а глаза мозолит.
Грешу на драйвера нвидии..

0
DeathMoroz - 25 Апрель, 2010 - 19:55

думаю тут надо плясать с режимами фреймбуфера(где-то в грубе)

0
Firemies - 25 Апрель, 2010 - 20:41
Изображение пользователя Firemies.

Согласен что не критично, просто как то не правильно))),уже читал DeathMoroz твой комментарий насчет фреймбуфера ,подскажи где , а то правил в /etc/default/grub разрешение но не помогло, думаю с вашими подсказками решим вопрос и другим поможем))

0
DeathMoroz - 25 Апрель, 2010 - 21:22

я пока не хочу возиться :) выйдет релиз, если там проблема будет то буду разбираться. Вообще я фреймбуфер настраивал последний раз года 2 назад в генте.

0
Firemies - 25 Апрель, 2010 - 21:42
Изображение пользователя Firemies.

Если не будет сложно после релиза подскажи где фреймбуфер настраивать))

0
SEVA - 26 Апрель, 2010 - 00:10
Изображение пользователя SEVA.

попробуй /boot/grub/grub.cfg
set gfxmode=разрешение

0
Flameflower - 26 Апрель, 2010 - 09:31
Изображение пользователя Flameflower.

А частоту горизонатальной\вертикальной развертки не надо указывать?

0
Firemies - 30 Апрель, 2010 - 12:27
Изображение пользователя Firemies.

Спасибо за новость то я уже и grub.cfg редактировал, и использовал fbset ничего не помогает , ждем обновление))

+9
Lang - 30 Апрель, 2010 - 20:04
Изображение пользователя Lang.

Нашёл как поправить!

1) Ставим hwinfo
sudo apt-get install v86d hwinfo

Смотрим доступные режимы
sudo hwinfo --framebuffer

2)Выбираем из всех подходящее, в моём случае
Mode 0x0365: 1440x900 (+5760), 24 bits

3)Идём править /etc/default/grub
sudo kate /etc/default/grub
Ищем строку GRUB_CMDLINE_LINUX_DEFAULT
И приводим её к виду:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1440x900-24,mtrr=3,scroll=ywrap"

4)Правим /etc/initramfs-tools/modules
sudo kate /etc/initramfs-tools/modules
И добавляем
uvesafb mode_option=1440x900-24 mtrr=3 scroll=ywrap

5)echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash

6)Обновляем граб
sudo update-grub2
sudo update-initramfs -u

Всё, должно работать нормально

0
Linus - 30 Апрель, 2010 - 20:50
Изображение пользователя Linus.

Спасибо огромное! Всё заработало в родном разрешение... совет помог

0
Firemies - 30 Апрель, 2010 - 20:59
Изображение пользователя Firemies.

Спасибо все помогло!!!

0
Lang - 30 Апрель, 2010 - 21:10
Изображение пользователя Lang.

Поправь пожалуйста для других заголовок, что решено

+1
kolodyazhnyj - 9 Сентябрь, 2010 - 19:04

Уже наверно поздно про это писать, но я нашел более простой способ. В терминале:
sudo kate etc/default/grub
И добавляем в этой файл стрчку:
GRUB_GFXPAYLOAD_LINUX=1280x1024
где 1280x1024 разрешение вашего экрана.

+2
Foxy - 9 Сентябрь, 2010 - 20:44
Изображение пользователя Foxy.

/etc/default/grub

+1
DarkneSS - 9 Сентябрь, 2010 - 21:00
Изображение пользователя DarkneSS.

Прикольно: без слеша создаёт в /home/%username%/etc/default/grub

0
kolodyazhnyj - 10 Сентябрь, 2010 - 22:51

Прикольно: не знает, что не в /home/username, а в текущем каталоге

P.S. извиняюсь за ошибку, но она не настолько серьезная, чтобы выпендриваться. К тому же ее уже исправил Foxy.

+1
DarkneSS - 10 Сентябрь, 2010 - 23:11
Изображение пользователя DarkneSS.

o_0
Я вообще-то тоже этого не знал, пока не попробовал. Какой уж тут выпендрёж?

0
kolodyazhnyj - 14 Сентябрь, 2010 - 09:48

:) Прости, не так тебя понял.

0
KRoman - 27 Май, 2012 - 09:30
Изображение пользователя KRoman.

И для меня это оказалось полезным! Что значит отсутствие "/" .

0
DarkneSS - 27 Май, 2012 - 09:47
Изображение пользователя DarkneSS.

В общем, без начального слеша играет от текущей папки (домашний каталогпо умолчанию), а не от корня. Такие дела =)

0
Voyageur - 14 Сентябрь, 2010 - 10:30
Изображение пользователя Voyageur.

Во! Это тема, мне помогло))

0
Nochnoi - 31 Октябрь, 2011 - 21:01

Сделал сегодня всё по этой инструкции...
Раньше получилось с первого раза, а сейчас болт.
Надписи "KUBUNTU" вообще нет. Один синий фон.
После запуска системы, обнаружилось что слетели драйвера видеокарты NVIDIA.
Разрешение стало 1024x768.
Устанавливаю драйвера для карты заново и после перезагрузки системы появляется чёрный экран, то есть консоль..
"ubuntu 11.04 INTELekt tty2
INTELekt login"

Как теперь всё исправить то?

0
Firemies - 30 Апрель, 2010 - 20:39
Изображение пользователя Firemies.

Извини за тупой вопрос как выбрать Mode 0x0365: 1440x900 (+5760), 24 bits или это просто посмотреть какое разрешение выставить))

0
DeathMoroz - 30 Апрель, 2010 - 20:48

посмотерть на шаге и 1 и вписать

0
DeathMoroz - 30 Апрель, 2010 - 20:49

после обновления ядра не отвалится?

0
Firemies - 30 Апрель, 2010 - 21:00
Изображение пользователя Firemies.

Вопрос мой выше и впрям был тупой, все работает и если что после обновления ядра можно и повторить наверно))

+1
Lang - 30 Апрель, 2010 - 21:09
Изображение пользователя Lang.

Косяк, как я понял, в проприетарных дровах, если ATI с Nvidia не поправят, то возможно придётся повторить процедуру

0
Гость - 4 Май, 2010 - 13:19

Спасибо! Все заработало!

+1
Firemies - 5 Май, 2010 - 12:28
Изображение пользователя Firemies.

вышло обновление, теперь заставка будет и без данной процедуры работать,но все равно спасибо за более раннее и правильное решение

0
Rindroid - 8 Май, 2010 - 19:09

Мне обновление не помогает, надпись остается размытой (

0
Firemies - 8 Май, 2010 - 19:43
Изображение пользователя Firemies.

Если после обновления надпись расмытая- сделай как сказал Lang,появится заставка но с логотипом Убунту, переустанови plymouth-theme-kubuntu-logo и будет все окей, хотя после баг фикса и так должно быть усе окей))

+1
Rindroid - 9 Май, 2010 - 10:14

Сделал я по инструкции Lang.. после чего система отказалась загружаться! Заново устанавливал всё.

0
Firemies - 9 Май, 2010 - 10:35
Изображение пользователя Firemies.

Ты при выборе разрешения после команды sudo hwinfo --framebuffer наверно ошибся с разрешением, но сейчас обновишься и заставка после баг фикса будет ок

0
Rindroid - 11 Май, 2010 - 07:32

Не помогает обновление, говорю. Как было, так и осталось!

0
Firemies - 11 Май, 2010 - 07:49
Изображение пользователя Firemies.

Какая карта у тебя?

0
Rindroid - 11 Май, 2010 - 09:11

Geforce 9300m GS (ноутбук)

+1
zipfer - 14 Май, 2010 - 00:01

У меня тоже самое, не помогает обновление, точнее немного помогает, заставка не полностью размыта, но она гигантская, и появляется только на неск секунд, а до этого просто мигающий курсор.
Вот чесн слово через одно место сделана заставка

0
DeathMoroz - 14 Май, 2010 - 05:47

что значит гигантская?
Дело в том что без дров нвидиа заставки выводится с бОльшим разрешением и цветностью и выглядит лучше, чем с дровами нвидиа

0
Voyageur - 14 Май, 2010 - 13:31
Изображение пользователя Voyageur.

То есть, после обновления вышеописанные танцы с грубом лучше все равно проделать?

0
Firemies - 14 Май, 2010 - 13:52
Изображение пользователя Firemies.

Нет после обновления танцев не надо, просто как сказано выше splash будет несколько больше чем на свободных дровах )))

0
Voyageur - 14 Май, 2010 - 15:07
Изображение пользователя Voyageur.

Он у меня наверное немного больше. Но при этом он все равно нечеткий! Детализация плохая! Такое ощущение, что разрешение картинки низкое.

0
Гость - 15 Май, 2010 - 13:40

Та фиг они там что исправили. Они просто заменили картинку на более простинькую, типа 16 бит и разрешение маленькое. Вот и все что они сделали. А родное разрешение с нормальной заставкой как не было так и нет.

0
Hunger - 15 Май, 2010 - 14:13

Зделал как советовали. Да, картинка стала четкой, но все равно, сама картинка некрасивая. Я же помню, когда ставил кубунту, по умолчанию подхватились открытые драйвера и вот на них была очень красивая заставка. Теперь походу, они просто заменили на какуюто попроще. Переставлял тему плимута, пофигу, всеравно таже некрасивая картинка. Кому-нибудь удалось вернуть красивую взад?

0
Firemies - 15 Май, 2010 - 14:25
Изображение пользователя Firemies.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1440x900-24,mtrr=3,scroll=ywrap"
Главная строчка - выставляешь то разрешение какое хочешь и какое поддерживает твоя карта, и будет тебе четкий splash

0
Hunger - 15 Май, 2010 - 17:41

Да нет же. Я так и сделал. Картинка четкая. Она просто некрасивая ))) Не потому что разрешеыние кривое, а потому что просто некрасивая. По жизне. Я точно помню что при инсталяции была картинка красивее. Судя по всему, просто поменяли тему на более простинькую.

0
DeathMoroz - 15 Май, 2010 - 19:01

вроде на менее цветастую

0
DeathMoroz - 15 Май, 2010 - 16:28

я этот сплэш вижу около 1 секунды :) и не парюсь какой он там

0
zipfer - 16 Май, 2010 - 01:00

во во, я забил, не люблю когда через жопу делают, а главное, я уверен, что решить данную проблему разрабам, раз-плюнуть, однако выпустили какой то полубагфикс.
Короче, если уж очень хотите ставьте burg
deb http://ppa.launchpad.net/bean123ch/burg/ubuntu/ lucid main
потом в /etc/default/burg просто проставьте ваше разрешение, ну и соответственно sudo update-burg и не нужно писать кучу строчек.
Однако мне даже такой вариант не нравится, должно работать само, ну или хоть после апдейтов

0
Hunger - 16 Май, 2010 - 18:00

Я себе поставил из стандартных, plymouth solar, а также для Grub похожую заставку, в целом получилось недурственно

0
Hunger - 18 Май, 2010 - 12:16

А вобще конечно, фигня этот плимут. Его ж задумывали как раз для того, чтобы не было рывков и резких переходов между разными этапами загрузки. Толи в кубунте не умеют его готовить, толи он такой кривущий, но как дергалось и металось на экране до этого, так и сейчас, принципиальной разницы со старым сплешем я не заметил.

0
DarkneSS - 20 Май, 2010 - 00:03
Изображение пользователя DarkneSS.

Дублирую вопрос из топика о релизе: возможно ли, чтобы plymouth при загрузке показывал текстовую информацию, как делал это усплеш после удаления опции quit из конфига загрузчика?

0
Xenomorph - 20 Май, 2010 - 10:40
Изображение пользователя Xenomorph.

Эээ... Нажать Escape при загрузке?

0
DarkneSS - 20 Май, 2010 - 10:56
Изображение пользователя DarkneSS.

Спасибо, проверю. Сейчас попробую проиллюстрировать свои запросы =)
Вот так по умолчанию в версиях 9.10 и 10.04:

А вот так можно было сделать в 9.10 и более ранних:

Можно ли так (ну или не совсем так, но похоже) сделать в 10.04?

+1
Xenomorph - 20 Май, 2010 - 11:17
Изображение пользователя Xenomorph.

Я дурак!Я тебя неправильно понял сначала) Сейчас поискаем инфу.

0
DarkneSS - 20 Май, 2010 - 11:20
Изображение пользователя DarkneSS.

Извиняюсь на мутное изложение))

0
Xenomorph - 20 Май, 2010 - 12:43
Изображение пользователя Xenomorph.

Я, наверное,нашел решение - нужно самому лезть в /lib/plymouth/themes/kubuntu-logo и редактировать kubuntu-logo.script.
Единственная проблема - я там что-то наредактировал, теперь у меня система грузится настолько быстро, что сплэш появляется на пару секунд и тут же вырубается, загрузив kdm.

0
Firemies - 20 Май, 2010 - 12:51
Изображение пользователя Firemies.

подскажи что правил,очень интересно))

0
tigris - 20 Май, 2010 - 13:13
Изображение пользователя tigris.

тоже так хочу, что правил?

0
DeathMoroz - 20 Май, 2010 - 13:39

у меня и на пару секунд не появляется может на 1 и появляется. я ничего не менял :)

0
DarkneSS - 22 Май, 2010 - 20:15
Изображение пользователя DarkneSS.

Так есть ли решение? ;-)

0
Xenomorph - 20 Май, 2010 - 13:47
Изображение пользователя Xenomorph.

sudo aptitude show plymouth-theme-script
Пакет: plymouth-theme-script
Состояние: установлен
Автоматически установлен: нет
Версия: 0.8.2-2ubuntu2
Приоритет: необязательный
Раздел: universe/x11
Сопровождающий: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Размер в распакованном виде: 106k
Зависимости: plymouth, plymouth-label
Заменяет: plymouth (< 0.8.1-1~)
Предоставляет: plymouth-theme
Описание: graphical boot animation and logger - script theme
Plymouth is an application that runs very early in the boot process (even before the root filesystem is mounted!) that provides a graphical boot animation while
the boot process happens in the background.

This package contains the example script theme, useful for theme developers.

These theme may not correctly display messages from filesystem decryption, checking or error handling.

Это как вариант для создания своей темы.

0
DarkneSS - 20 Май, 2010 - 14:25
Изображение пользователя DarkneSS.

А можно вариант от Xenomorph? ;-)

0
PostaL - 5 Июнь, 2010 - 00:54
Изображение пользователя PostaL.

Lang большое спасибо сделал отображает как надо.

0
sergshulya - 30 Август, 2010 - 23:21

Люди подскажите пожалуйсто что делать если у меня, когда я пишу Mode 0x0369: 1680x1050 (+6720), 24 bits и жму enter оно выдает: bash: ошибка синтаксиса около неожиданной лексемы `('

и еще. если я нажимаю sudo kate etc/default/grub оно выдаёт : sudo: kate: command not found
Пожалуйсто Подкажите =)

0
nemon - 31 Август, 2010 - 01:18

Второй вопрос оффтопный, но на просто kate в консоли, что отвечает?

0
Xenomorph - 31 Август, 2010 - 01:28
Изображение пользователя Xenomorph.

Ответит: Программа 'kate' на данный момент не установлена. Вы можете установить её, выполнив:
apt-get install kate

в Ubuntu нет kate.

0
Гость - 28 Ноябрь, 2010 - 08:55

Может, лучше nano или mcedit или vim, что бы было независимо от десктопа вообще?

0
Xenomorph - 31 Август, 2010 - 01:25
Изображение пользователя Xenomorph.

Желтый здесь -> ЖЁЛТЫЙ!

0
Xenomorph - 31 Август, 2010 - 01:30
Изображение пользователя Xenomorph.

Mode 0x0369: 1680x1050 (+6720) ГДЕ В ТРЕДЕ СКАЗАНО, ЧТО НУЖНО ЭТО ВВОДИТЬ????
Kate не запустится, у тебя же УГГном, там Kate отсутствует, ибо не нужен, воистину, да будет так!

0
Fatalist - 31 Август, 2010 - 12:41
Изображение пользователя Fatalist.

sudo kate etc/default/grub
может всё-таки /etc/... ?

ну и sudo aptitude install kate, если уж очень хочется.

0
wherecat - 31 Август, 2010 - 12:45
Изображение пользователя wherecat.

gedit ?

Дедушка Оккам негодуэ.

0
rossomaha - 31 Август, 2010 - 22:28
Изображение пользователя rossomaha.

посоле установки дров разрешение в консоли упало с 1280*1024 на 600*800 - как это исправить? Или решение для заставки сработает и тут?

0
Fatalist - 1 Сентябрь, 2010 - 05:55
Изображение пользователя Fatalist.

У Grub'а в menu.lst дописан параметр "vga=0x0365" для моего 1440х900. Смена дров, апдейты и прочее никак не влияет на разрешение консоли.

0
rossomaha - 1 Сентябрь, 2010 - 08:50
Изображение пользователя rossomaha.

В том то и дело что изменилось после установки дров - спасибо за подсказку!

0
Irshad - 18 Январь, 2011 - 19:22
Изображение пользователя Irshad.

После выполнения совета Lang все исправилось, но появилось второе Меню Запуска Приложений))
Не подскажете как убрать одно из них?
Все, разобрался))))))))))))))

0
picaro - 18 Январь, 2011 - 19:29
Изображение пользователя picaro.

Все, разобрался))))))))))))))
теперь расскажи как ты это сделал

0
DarkneSS - 18 Январь, 2011 - 20:28
Изображение пользователя DarkneSS.

Телепатирую: пкм, удалить.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры