Проблема с эффектами рабочего стола и спящим режимом

После долгих мучений с xorg.conf настроил нужное разрешение экрана. Но теперь при уходе в спящий режим (suspend to ram) система не возращается обратно. Сначала появляются какие-то куски окон,а потом черный экран.
Также толком не работают эффекты рабочего стола - вернее - дико тормозят.
Юзаю Kubuntu 10.04, вот xorg.conf. Помогите, может с ним что не так?
Заранее спасибо

Развернуть/свернуть скрытый текст.
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 ([email protected]) Sun Nov 8 21:50:38 PST 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
# HorizSync 30.0 - 110.0
# VertRefresh 60.0 - 160.0
Option "DPMS"
#1024x768 @ 75.00 Hz (GTF) hsync: 60.15 kHz; pclk: 81.80 MHzModeline "1024x768_75.00" 81.80 1024 1080 1192 1360 768 769 772 802 -HSync +Vsync
HorizSync 28.0-83.0
Option "PreferredMode" "1024x768 at 75.0"
VertRefresh 51.0-75.0
modeline "[email protected]" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "[email protected]" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline "[email protected]" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline "[email protected]" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "[email protected]" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "[email protected]" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "[email protected]" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "[email protected]" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
modeline "[email protected]" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
modeline "[email protected]" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
Gamma 1.0
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV34 [GeForce FX 5200]"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "NVIDIA Corporation NV34 [GeForce FX 5200]"
Monitor "Monitor0"
DefaultDepth 16
Subsection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection

0
trubadur4ik - 15 Май, 2010 - 11:41
Изображение пользователя trubadur4ik.

У меня вообще ни спящий, ни ждущий не работает. :'(

0
Firemies - 15 Май, 2010 - 12:06
Изображение пользователя Firemies.

А у вас swap раздел случайно имеется- обычно он отвечает за это, у меня есть и никаких проблем ) и спит и ждет

0
trubadur4ik - 16 Май, 2010 - 02:10
Изображение пользователя trubadur4ik.

Канешн, имееца. :-)

+1
Firemies - 15 Май, 2010 - 12:06
Изображение пользователя Firemies.

А ты как драйвера устанавливал до того как xorg.conf начал мучать))

0
Ashen - 16 Май, 2010 - 13:08

дрова поставил стандартным способом - через меню, и дальше в "приоприетарные драйверы". Вот только после этого у меня разрешение было 640x480, поэтому дальше xorg.conf правил сам. И 3D ускорение, как сказала playonlunux у меня не включено. Драйвер кривой что ли?

А до установки дров спящий режим работал замечательно

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры