Не воспроизводятся видео- и аудиофайлы в медиаплеерах

Изображение пользователя alexandr-makukhin.

Здравствуйте, уважаемые кубунтоводы!

Я в Kubuntu 10.04 установил медиаплееры
Amarok,
Kmplayer,
Totem,
Smplayer,
Kaffeine.

Из всех вышеперечисленных медиаплееров, только Kaffeine воспроизводить видео без звука, а Amarok воспроизводить всего единственный альбом "Gorod.312.Vne.zonw.dostupa.2006.APE.CUE.Lossless".

В браузере Mozilla Firefox, Adobe Flash Player исправно работает.

В Kubuntu 10.04, также, как и в Kubuntu 9.04 установлен Драйвер ускоренной графики NYIDIA (версия 173) (Рекомендуемый), только с одним отличием: в Kubuntu 9.10 медиаплееры работают, а в Kubuntu 10.04 - не работают.

Movie player выдаёт сообщение:
"An erro occurred. The playback of this movie requires a MPEG-1 Layer 3 (MP3) decoder plugin which is not installed.".

Вопрос: Какие требуется загрузить плагины для воспроизведения медиаплеерами видео- и аудиофайлов:
"Zakritii.pokaz.obsujdenie.vse.urut.ya.ostanus.(16.01.2010).2010.DivX.SATRip-RiperAM.avi",
"Vse.umrut.a.ya.ostanus.2008.DivX.DVDRip.Kinozal.TV.avi",
"Gordon_Kihot-18_Nikita_Mihalkov-14.05.10.avi",
"Gorod.312.Live.2009.MP3.320kbps".

+1
DeathMoroz - 30 Май, 2010 - 12:32

sudo aptitude install kubuntu-restricted-extras

0
alexandr-makukhin - 30 Май, 2010 - 13:15
Изображение пользователя alexandr-makukhin.

Никакого эффекта не последовало после установки kubuntu-restricted-extras
. Всё осталось по прежнему, даже после перезагрузки компьютера, Movie player выдаёт тоже-самое сообщение:
"An erro occurred. The playback of this movie requires a MPEG-1 Layer 3 (MP3) decoder plugin which is not installed.".

0
Firemies - 30 Май, 2010 - 14:56
Изображение пользователя Firemies.

У меня со звуком проблемы в кубунту решаются с помощью alsamixer
в консоли
alsamixer подвигать ползунки и все должно помочь, если нет установи vlc из репов - он у меня все хорошо проигрывает и кроссплатформленный

s

0
alexandr-makukhin - 31 Май, 2010 - 09:49
Изображение пользователя alexandr-makukhin.

VLC воспроизводить видео без звука.

Звуковая схема Kubuntu 10.04 работает, и воспроизводиться звук в Adobe Flash Player.

0
Гость - 31 Май, 2010 - 10:33

У меня после установки звук был и в Амороке и в Драгоне, а вот во флэше не было. VLC после установки звук воспроизводить не захотел. Поставил PulseAudio звук появился везде))).

0
Mike - 31 Май, 2010 - 09:54
Изображение пользователя Mike.

в микшере ползунок PCM нужно выставить в максимальное положение. По дефолту он может быть на минимуме.

0
Firemies - 31 Май, 2010 - 12:30
Изображение пользователя Firemies.

Вот здесьнадо ползунки подвигать и все должно быть окей,

0
dyug - 30 Май, 2010 - 15:53

я так полагаю, что это Вам не подойдет http://medibuntu.org/
Medibuntu (Multimedia, Entertainment & Distractions In Ubuntu) is a repository of packages that cannot be included into the Ubuntu distribution for legal reasons (copyright, license, patent, etc).
Все остальное есть по ссылке, научитесь задавать правильно вопросы поисковику.

0
dyug - 31 Май, 2010 - 14:39

как я понял, проблема воспроизведения видео относится к проблеме регулировки микшера? :-)
Ну что же, давайте, давайте, воспроизводите.
пока не дойдет, что нужно поставить протеитарные кодеки - так и будет "проблема с микшером" :-)

0
Firemies - 31 Май, 2010 - 14:45
Изображение пользователя Firemies.

У меня не было проблем с воспроизведением аудио и видео никогда за время пользования Кубунту, были в убунту но я поставил pulse server и там все появилось, дополнительные кодеки никогда не грузил, поскольку vlc у меня все воспроизводит((

0
dyug - 31 Май, 2010 - 18:12

у меня есть пару файлов, которые без w32codecs с медибунту не проигрываются.
в том числе и влс

посему проще поставить один раз раз кодеки чем две недели будоражить форум и лечить видео через аудиомикшер.

0
Firemies - 3 Июнь, 2010 - 13:54
Изображение пользователя Firemies.

подскажи пожалуйста какой формат vlc не проигрывает без кодеков w32codecs- для повышения знаний в этой области, спасибо

0
alexandr-makukhin - 31 Май, 2010 - 14:51
Изображение пользователя alexandr-makukhin.

как я понял, проблема воспроизведения видео относится к проблеме регулировки микшера? :-)
Я тоже не пойму причём тут микшер. Считаю, в Kubuntu 10.04 не установлены кодеки для медиаплееров.

0
knuckles - 31 Май, 2010 - 17:50
Изображение пользователя knuckles.

А если их снести, а потом снова поставить?
sudo aptitude -fr --purge-unused purge kubuntu-restricted-extras
sudo aptitude -fr install kubuntu-restricted-extras

0
alexandr-makukhin - 1 Июнь, 2010 - 14:22
Изображение пользователя alexandr-makukhin.

Это не помогло - http://paste.ubuntu.com/442740/

0
dyug - 31 Май, 2010 - 18:10

вот и я не пойму.
Я предложил все же решение, подключить меибунту и поставить протеитарные кодеки для системы - Вы его проигнорировали. я увы не могу ничем вам помочь более.

0
alexandr-makukhin - 1 Июнь, 2010 - 14:11
Изображение пользователя alexandr-makukhin.

alexander@moscovia:~$ sudo apt-get install w32codecs
[sudo] password for alexander:
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Пакет w32codecs недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list
E: Для пакета w32codecs не найдены кандидаты на установку

0
dyug - 1 Июнь, 2010 - 14:48

увы, я понял.
Нет, я НЕ БУДУ 125 раз разжевывать что нужно СНАЧАЛА прочитать сообщение выше, и подключить репрозитарий медибунту.

ибо если после 5 рекомендаций продолжается непонимай - я не не буду это обсуждать.
Ибо, на мой лично взгляд - просто бесполезно.

P.S. в последний раз:
Необходимо подключить репозитарий медибунту - ссылка на сайт есть в моем посте, потом обновить, потом ставить.
Если ЭТО непонятно - то извините, вам линух просто противопоказан.

0
knuckles - 3 Июнь, 2010 - 08:20
0
dyug - 3 Июнь, 2010 - 11:56

да, переливание из пустого в порожнее меня бесит.
я слишком много времени за свои 48 лет потратил не на работу а на совещания о том как надо работать.
Мне это НАДОЕЛО.

+1
alexandr-makukhin - 1 Июнь, 2010 - 16:37
Изображение пользователя alexandr-makukhin.

Также, не помогло и это:

1. sudo wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update

2.sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 2EBC26B60C5A2783

3. sudo apt-get --yes install app-install-data-medibuntu apport-hooks-medibuntu

4. sudo apt-get install w32codecs

5. Перезагруа

Всё как и прежде: отсутствует звук во-всех медиаплеерах и не во-всех медиаплеерах воспроизводиться видео.

0
alexandr-makukhin - 1 Июнь, 2010 - 17:14
Изображение пользователя alexandr-makukhin.

Не помогло:
1. sudo apt-get remove w32codecs
2. sudo apt-get install w32codecs
3. sudo aptitude -fr --purge-unused purge kubuntu-restricted-extras
4. sudo aptitude -fr install kubuntu-restricted-extras5.перезагрузка

0
alexandr-makukhin - 3 Июнь, 2010 - 12:38
Изображение пользователя alexandr-makukhin.

Появился звук в медиаплеерах после переустановки Kubuntu на переформатированный раздел диска.
Оказалось надо-было установить alsamixer, чтобы появился звук в VLC, жаль, другие медиаплееры не работают.

0
Гость - 8 Ноябрь, 2010 - 01:23

чё паритесь.
Поставь KMPlayer. Не нужны никакие кодеки. Читает всё.

0
alexandr-makukhin - 8 Ноябрь, 2010 - 15:52
Изображение пользователя alexandr-makukhin.

KMPlayer не работает в Kubuntu 9.10, 10.04, 10.10.

0
DarkneSS - 8 Ноябрь, 2010 - 17:17
Изображение пользователя DarkneSS.

Он не нужен. Smplayer - наше всё!

+1
sawa - 8 Ноябрь, 2010 - 20:28
Изображение пользователя sawa.

В моём 10.10 работает.
DarkneSS прав насчет устройств вывода. Боимся экспериментов? Там их как кот наплакал. Меняй и пробуй, на каком начнёт воспроизводить на том и остановись.

0
alexandr-makukhin - 8 Ноябрь, 2010 - 17:30
Изображение пользователя alexandr-makukhin.

DarkneSS, что Вы делали для того, чтобы у Вас заработал Smplayer ?

0
DarkneSS - 8 Ноябрь, 2010 - 17:52
Изображение пользователя DarkneSS.

Установил, запустил, в настройках выбрал модуль вывода видео XVideo, аудио - PulseAudio. Всё.

0
alexandr-makukhin - 8 Ноябрь, 2010 - 19:03
Изображение пользователя alexandr-makukhin.

Удивительно!
DarkneSS. Вас совет помог.
Я в SMPlayer --> Настройки --> Основные --> Видео, выставил в пункте Устройство вывода: xv (0 - NV17 Video Texture),и SMPlayer начал воспроизводить видео.
KMPlayer тоже заработал, только при воспроизведение MKV не выводить видеодорожку, а только аудио. И при этом, через одну-две минуты наглухо зависает процесс KMPlayer.

0
DarkneSS - 8 Ноябрь, 2010 - 19:49
Изображение пользователя DarkneSS.

Тоже устройство вывода поменяйте. Я в своё время не поленился справку smplayer почитать. Там рекомендуется выбирать Xvideo.

0
Жюстина - 8 Ноябрь, 2010 - 20:33
Изображение пользователя Жюстина.

Ну так не раз же уже мимоходом говорили посмотреть про вывод видео...

0
Lexxa - 8 Ноябрь, 2010 - 21:34

Раз уж речь пошла про SMplayer, тоже спрошу.
Он у меня регулярно тупит с аудиокодеком. На шестиканальную дорожку выбирает какой-то стереокодек. Или вообще ничего. Приходится ручками указывать ему на ffac3.
mpayer с терминала опознает правильно (собственно откуда я название кодека вычислил). Никто не встречался?

0
Жюстина - 8 Ноябрь, 2010 - 23:22
Изображение пользователя Жюстина.

А по умолчанию какое количество каналов в SMplayer?

Само понятие стереокодека очень забавно, кстати...

0
Lexxa - 9 Ноябрь, 2010 - 00:47

Ну, как я понял, разные кодеки тянут разное количество каналов. А количество кодеков там неимоверное.
По умолчанию 5.1 стоит.

0
alexandr-makukhin - 9 Ноябрь, 2010 - 19:25
Изображение пользователя alexandr-makukhin.

Там рекомендуется выбирать Xvideo.
Кодека Xvideo нет.
Xvidix воспроизводить только аудио без видео.

0
DarkneSS - 9 Ноябрь, 2010 - 19:57
Изображение пользователя DarkneSS.

Это не кодек. Это модуль вывода видео!

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры