ошибка при поиске программ в kPackage. пишет "There are broken dependies on your system.Use advanced package manager"

0
Chibiko - 27 Июнь, 2010 - 23:40
Изображение пользователя Chibiko.

Попробуйте в консоли:

sudo aptitude -f install

Соостветственно если не решит проблему - вывод информации сюда 8)
Будем решать коллективным разумом 8)

0
Flameflower - 27 Июнь, 2010 - 23:40
Изображение пользователя Flameflower.

А что ставить пытался?
Проблема не в kPackage, а в поломанных зависимостях.
Попробуй из терминала установить нужный пакет так:
sudo aptitude install *****
Где вместо ***** - твой пакет.
Посмотри, на что будет ругаться.

0
pashulka - 27 Июнь, 2010 - 23:45

Вообще как я помню,сломался после того,как я хотел запустить фильм,он предложил скачать кодеки для Dragon,я скачал,установил.Запускаю,опять предлагает их установить.Опять установил,перезагрузил,снова требует установить кодеки.Забил,хотел скачать другой плеер,потипу kplayer,написал в поиске,а он мне эту ошибку...
вспомнил,я ещё pidgin пытался установить...Вот что мне терминал выкинул

fly@fly-laptop:~$ sudo aptitude -f install
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Инициализация состояний пакетов... Готово
Запись информации расширенных состояний... Готово
Следующие пакеты С ОШИБКАМИ:
blender g++-4.2 libavdevice52 libavformat52 libk3b6-extracodecs libstdc++6-4.2-dbg libstdc++6-4.2-dev libswscale0 pidgin-ppa
Следующие пакеты будут УДАЛЕНЫ:
liboil0.3{u} libschroedinger-1.0-0{u} linux-headers-2.6.32-21{u} linux-headers-2.6.32-21-generic{u}
0 пакетов обновлено, 0 установлено новых, 4 пакетов отмечено для удаления, и 2 пакетов не обновлено.
Необходимо получить 0Б архивов. После распаковки освободится 86,4MБ.
Следующие пакеты имеют неудовлетворённые зависимости:
libswscale0: Зависит: libavutil49 (>= 4:0.5.1-1ubuntu1) но его невозможно установить или
libavutil-extra-49 (>= 4:0.5.1-1ubuntu1) но его невозможно установить
Зависит: libavutil49 (< 4:0.5.1-99) но его невозможно установить или
libavutil-extra-49 (< 4:0.5.1-99) но его невозможно установить
g++-4.2: Зависит: gcc-4.2 (= 4.2.4-1ubuntu4) который является виртуальным пакетом.
Зависит: gcc-4.2-base (= 4.2.4-1ubuntu4) который является виртуальным пакетом.
libavformat52: Зависит: libavcodec52 (>= 4:0.5.1-1ubuntu1) но его невозможно установить или
libavcodec-extra-52 (>= 4:0.5.1-1ubuntu1) но его невозможно установить
Зависит: libavcodec52 (< 4:0.5.1-99) но его невозможно установить или
libavcodec-extra-52 (< 4:0.5.1-99) но его невозможно установить
Зависит: libavutil49 (>= 4:0.5.1-1ubuntu1) но его невозможно установить или
libavutil-extra-49 (>= 4:0.5.1-1ubuntu1) но его невозможно установить
Зависит: libavutil49 (< 4:0.5.1-99) но его невозможно установить или
libavutil-extra-49 (< 4:0.5.1-99) но его невозможно установить
libstdc++6-4.2-dbg: Зависит: gcc-4.2-base (= 4.2.4-1ubuntu4) который является виртуальным пакетом.
Зависит: libgcc1-dbg но его невозможно установить
libstdc++6-4.2-dev: Зависит: gcc-4.2-base (= 4.2.4-1ubuntu4) который является виртуальным пакетом.
Зависит: libc6-dev (>= 2.5) но его невозможно установить
blender: Зависит: libavcodec52 (>= 4:0.5+svn20090706-3) но его невозможно установить или
libavcodec-extra-52 (>= 4:0.5+svn20090706-3) но его невозможно установить
Зависит: libavutil49 (>= 4:0.5+svn20090706-3) но его невозможно установить или
libavutil-extra-49 (>= 4:0.5+svn20090706-3) но его невозможно установить
libk3b6-extracodecs: Зависит: libavcodec52 (>= 4:0.5.1-1) но его невозможно установить или
libavcodec-extra-52 (>= 4:0.5.1-1) но его невозможно установить
Зависит: libavutil49 (>= 4:0.5.1-1) но его невозможно установить или
libavutil-extra-49 (>= 4:0.5.1-1) но его невозможно установить
pidgin-ppa: Зависит: pidgin но его невозможно установить или
finch но его невозможно установить
libavdevice52: Зависит: libavcodec52 (>= 4:0.5.1-1ubuntu1) но его невозможно установить или
libavcodec-extra-52 (>= 4:0.5.1-1ubuntu1) но его невозможно установить
Зависит: libavcodec52 (< 4:0.5.1-99) но его невозможно установить или
libavcodec-extra-52 (< 4:0.5.1-99) но его невозможно установить
Зависит: libavutil49 (>= 4:0.5.1-1ubuntu1) но его невозможно установить или
libavutil-extra-49 (>= 4:0.5.1-1ubuntu1) но его невозможно установить
Зависит: libavutil49 (< 4:0.5.1-99) но его невозможно установить или
libavutil-extra-49 (< 4:0.5.1-99) но его невозможно установить
E: Не удалось обнаружить файл пакета pidgin-ppa. Это может означать, что вам придётся вручную исправить этот пакет.
Следующие действия разрешат зависимости:

Удалить следующие пакеты:
g++-4.2
libstdc++6-4.2-dbg
libstdc++6-4.2-dev
pidgin-ppa

Установить следующие пакеты:
libavcodec52 [4:0.5.1-1ubuntu1 (lucid, now)]
libavutil49 [4:0.5.1-1ubuntu1 (lucid, now)]

Оставить для следующих пакетов их текущие версии:
liboil0.3 [0.3.16-1ubuntu2 (lucid, now)]
libschroedinger-1.0-0 [1.0.9.is.1.0.8-0ubuntu1 (lucid, now)]

Счёт 454

Принять данное решение? [Y/n/q/?] y
Следующие НОВЫЕ пакеты будут установлены:
libavcodec52{a} libavutil49{a}
Следующие пакеты будут УДАЛЕНЫ:
g++-4.2{a} libstdc++6-4.2-dbg{a} libstdc++6-4.2-dev{a} linux-headers-2.6.32-21{u} linux-headers-2.6.32-21-generic{u} pidgin-ppa{a}
0 пакетов обновлено, 2 установлено новых, 6 пакетов отмечено для удаления, и 2 пакетов не обновлено.
Необходимо получить 0Б/4 091kБ архивов. После распаковки освободится 103MБ.
Хотите продолжить? [Y/n/?] y
Запись информации расширенных состояний... Готово
(Чтение базы данных ... на данный момент установлено 114282 файлов и каталогов.)
Удаляется пакет g++-4.2 ...
Удаляется пакет libstdc++6-4.2-dev ...
Удаляется пакет libstdc++6-4.2-dbg ...
Удаляется пакет pidgin-ppa ...
gpg: ключ "67265EB522BDD6B1C69E66ED7FB8BEE0A1F196A8" не найден: eof
gpg: 67265EB522BDD6B1C69E66ED7FB8BEE0A1F196A8: delete key failed: eof
dpkg: не удалось обработать параметр pidgin-ppa (--remove):
подпроцесс установлен сценарий post-removal возвратил код ошибки 2
Удаляется пакет linux-headers-2.6.32-21-generic ...
Удаляется пакет linux-headers-2.6.32-21 ...
Обрабатываются триггеры для man-db ...
Обрабатываются триггеры для ureadahead ...
ureadahead will be reprofiled on next reboot
При обработке следующих пакетов произошли ошибки:
pidgin-ppa
E: Sub-process /usr/bin/dpkg returned an error code (1)
Не удалось установить пакет. Попытка восстановить:
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях
Инициализация состояний пакетов... Готово
Запись информации расширенных состояний... Готово

Текущее состояние: 6 сломано [-3].

До этого сообщения пытался исправить проблему по этому методу
https://bugs.launchpad.net/ubuntu/+source/build-essential/+bug/360550

0
knuckles - 28 Июнь, 2010 - 13:01
Изображение пользователя knuckles.

/etc/apt/sources.list в студию! :-)
и еще содержимое всех файлов из /etc/apt/sources.list.d, пожалуйста.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры