Intel Fortran и libstdc++.so.5

Собственно, сабж.
Скачал с интелловского сайта установщик для Intel Fortran Compiler, но установить его не смог, потому что он жалуется на:
"missing system commands" и отсутствие 32 файлов. Оказалось, что все дело в libstdc++.so.5
Я его скачал для x86 и amd64 поклал в /usr/lib32/ и /usr/lib соответственно. После этого установщик перестал жаловаться на отсутствие 32 версии, но все еще орет про "missing system commands".
Я не понимаю, что ему нужно, ведь все уже есть.

Есть идеи?

-1
xo4y-ifc - 7 Июль, 2010 - 11:57

мертвый форум

+1
Vlad_W_1999 - 7 Июль, 2010 - 13:45

Скачал с интелловского сайта установщик для Intel Fortran Compiler

И весь форум кинулся выкачивать вышеозначенный инсталлятор. Ага? Вероятно, крайне неплохо было бы указать, что данный инсталлятор имеет формат install.exe, или install.sh, или install.bin, или install.deb. Ну, хотя бы для того, чтобы можно было понять, что ставится. По секрету скажу, что Fortran не является самым популярным языком и потому люди могут просто не знать, что из себя представляет его инсталлятор.

но установить его не смог

Не смог как? Если устанавливалось из консоли, то неплохо бы прикрепить к посту файлик с выводом в консоль процесса инсталляции. Вероятно, тогда бы можно было что-то посоветовать.

"missing system commands" и отсутствие 32 файлов

Прочитал как "отсутствие тридцати двух файлов". Сразу же возникла мысль: если их не хватает, то необходимо доустановить. Однако, перечитав несколько раз в контексте понял, что это "не хватает тридцать вторых файлов". Однако, очень хорошо написано! Вопрос поставлен так прозрачно, что прямо хочется на него ответить!

Оказалось, что все дело в libstdc++.so.5

Сейчас буду материться! Каким образом "оказалось"? Ветром надуло? Насоветовал кто? Вычитал где? Оказалось у него, блин...

Я его скачал для x86 и amd64 поклал в /usr/lib32/ и /usr/lib соответственно.

Ладно, а для 64-битных систем зачем? Шоб було? :-)

но все еще орет про "missing system commands"

Орёт, опять же, где? Если в графике, то картинку, если в консоли, то весь текст. Иначе тебе ничем никто помочь не сможет. Ставить из-за тебя компилятор мёртвого языка никто не будет.

мертвый форум

Форум как раз очень даже живой. Вопросы надо задавать так, чтобы на них хотелось отвечать. Это нужно тебе, а не нам. Так что потрудись сформулировать как положено.

-1
xo4y-ifc - 7 Июль, 2010 - 21:59

>Vlad_W_1999

1999 - этот год рождения?

0
Vlad_W_1999 - 8 Июль, 2010 - 13:28

О, да! Именно так! :-)))

Будешь хамить -- помощи не получишь. Будешь правильно формулировать вопросы -- будешь получать исчерпывающие ответы.

0
Vlad_W_1999 - 8 Июль, 2010 - 13:38

Ладно, не смотря на твоё хамство таки сходил на сайт. Там говорят, что необходимо скачать 400 метров. Это не пугает. Но для скачивания необходим какой-то IBM-ID. А этого у меня нету и получать не хочется.

Так шо не выкаблучивайся и подробно описывай всё, что я сказал раньше.

0
staff - 8 Июль, 2010 - 13:46

http://gardarea51.wordpress.com/2009/11/30/x-lite-ubuntu-9-10/ просмотри должно помочь

0
Жюстина - 8 Июль, 2010 - 14:53
Изображение пользователя Жюстина.

Интересно и что скачан был один файл libstdc++.so.5 ???? ))))) ну смешно же...

Особенно если посмотреть на такой вывод:

Развернуть/свернуть скрытый текст.
[email protected]:~$ locate libstdc++
/usr/lib/libstdc++.so.6
/usr/lib/libstdc++.so.6.0.13
/usr/lib/gcc/i486-linux-gnu/4.4/libstdc++.a
/usr/lib/gcc/i486-linux-gnu/4.4/libstdc++.so
/usr/share/doc/libstdc++6
/usr/share/doc/libstdc++6-4.4-dev
/usr/share/doc/gcc-4.4-base/C++/README.libstdc++-baseline
/usr/share/doc/gcc-4.4-base/C++/changelog.libstdc++.gz
/usr/share/doc/gcc-4.4-base/C++/libstdc++_symbols.txt
/usr/share/doc/gcc-4.4-base/test-summaries/libstdc++.sum.gz
/usr/share/locale-langpack/en_GB/LC_MESSAGES/libstdc++.mo
/usr/share/locale-langpack/ru/LC_MESSAGES/libstdc++.mo
/var/lib/dpkg/info/libstdc++6-4.4-dev.list
/var/lib/dpkg/info/libstdc++6-4.4-dev.md5sums
/var/lib/dpkg/info/libstdc++6.list
/var/lib/dpkg/info/libstdc++6.md5sums
/var/lib/dpkg/info/libstdc++6.postinst
/var/lib/dpkg/info/libstdc++6.postrm
/var/lib/dpkg/info/libstdc++6.shlibs
/var/lib/dpkg/info/libstdc++6.symbols

Невооружённым глазом заметно, что версия которая там нужна устарела, и кажется очень давно. Для таких библиотек разница между 5 и 6 версией это наверняка годы...

И вообще это только один файлик из всей кучи стандартных библиотек, так что одного файлика точно будет не достаточно.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры