Проблема с WiFi в Kubuntu 10.04 на MSI PR200

В ноутбуке стоит WiFi карточка Intel Pro/Wireless 3945ABG. Драйвер стоит нужный вроде как iwl3945. При подключении к точке доступа, ноутбук проходит проверку пароля, получает и IP, и DNS, и шлюз. Можно попасть в веб конфигуратор точки. НО!! Пинг не идет ни до точки, ни до модема, к которому эта точка подключена. Интернета соответственно тоже нема. Пробовал пинговать известный IP адрес, тоже пусто. В чем может быть проблема? Подскажите пожалуйста.

Вот что выдает мне на консоли:
[email protected]:~$ sudo ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1d:92:50:c9:9f 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:83462 errors:0 dropped:0 overruns:0 frame:0
          TX packets:95247 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:64266733 (64.2 MB)  TX bytes:67565961 (67.5 MB)
          Interrupt:27 Base address:0x8000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:219 errors:0 dropped:0 overruns:0 frame:0
          TX packets:219 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:14816 (14.8 KB)  TX bytes:14816 (14.8 KB)

wlan0     Link encap:Ethernet  HWaddr 00:1c:bf:b0:0b:94 
          inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::21c:bfff:feb0:b94/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1282 (1.2 KB)  TX bytes:1168 (1.1 KB)

[email protected]:~$ sudo iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"home-network" 
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:26:5A:A5:D2:6C  
          Bit Rate=1 Mb/s   Tx-Power=15 dBm  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:ACDB-9577-6DD1-1440-9AB5-4323-C6
          Power Management:off
          Link Quality=70/70  Signal level=-30 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

pan0      no wireless extensions

[email protected]:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE Controller (rev 03)
01:04.0 FLASH memory: ENE Technology Inc ENE PCI Memory Stick Card Reader Controller
01:04.1 SD Host controller: ENE Technology Inc ENE PCI SmartMedia / xD Card Reader Controller
01:04.2 FLASH memory: ENE Technology Inc Memory Stick Card Reader Controller
01:04.3 FLASH memory: ENE Technology Inc ENE PCI Secure Digital / MMC Card Reader Controller
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)

[email protected]:~$ lsusb
Bus 007 Device 003: ID 09da:000a A4 Tech Co., Ltd Port Mouse
Bus 007 Device 002: ID 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 004: ID 0db0:a97a Micro Star International Bluetooth EDR Device
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 004: ID 0c76:0005 JMTek, LLC. Transcend Flash disk
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     2      0        0 wlan0
link-local      *               255.255.0.0     U     1000   0        0 wlan0

вот.

0
DUBLb - 10 Июль, 2010 - 11:02

И вот еще что интересно. Подключил по вайфаю дома еще один комп на винде (на нем интернет есть и все в порядке), там сделал пару расшаренных папок. Так вот этот комп я могу пинговать, и папки на нем по тому же вайфаю смотреть могу. То есть получается что проблема у меня именно в отправлении пакетов за точку доступа, потому что когда делаешь пинг модема, на точке мигает лампочка вайфай подключение, но не мигает лампочка кабеля который к модему подключен, и на модеме не мигает лампочка сетевухи.

0
dyug - 11 Июль, 2010 - 22:07

гмм, забавно, забавно...
судя по ивконфигу - линк установлен.
какой ип получила виндявочная машина?

а пинговать саму точку доступа - можно?
а адреса модема, точки доступа и выдаваемые адреса точно в одной сети?
На модеме или точке доступа точно нет никаких фильтров?

Это так - что пришло в голову...
П.С.Сам сижу на вифи сейчас дома, как видишь - работает...
да, ноут другой.

0
dyug - 10 Июль, 2010 - 14:29

И где собственно шлюз то?
я его НЕ ВИЖУ в упор.
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     2      0        0 wlan0
link-local      *               255.255.0.0     U     1000   0        0 wlan0

вот здесь его точно нету.

0
Xenomorph - 10 Июль, 2010 - 14:40
Изображение пользователя Xenomorph.

sudo ip route add default via 192.168.1.1 dev wlan0 попробуй это, вдруг поможет

0
DUBLb - 10 Июль, 2010 - 15:24

Как говориться до и после:
[email protected]:~$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     2      0        0 wlan0
link-local      *               255.255.0.0     U     1000   0        0 wlan0
[email protected]:~$ sudo ip route add default via 192.168.1.1 dev wlan0
[email protected]:~$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     2      0        0 wlan0
link-local      *               255.255.0.0     U     1000   0        0 wlan0
default         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
[email protected]:~$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
^C
--- 192.168.1.1 ping statistics ---
5 packets transmitted, 0 received, 100% packet loss, time 4032ms

Причем во второй раз последняя строчка появляется примерно через минуту ожидания

0
DUBLb - 12 Июль, 2010 - 12:16

2 dyug.
У меня привязка по маку на точке, мой бук получает 1.4 и с винды и с kubuntы, а вторая машина получает ip 1.5.
Точка не пингуется ни с винды ни с linuxa.
Адреса: модем - 192.168.1.1, точка - 192.168.1.2, бук когда по сетевухе - 192.168.1.3, бук когда по wifi - 192.168.1.4, второй (виндовый комп) когда по wifi - 192.168.1.5
Да фильтров нету, тем более, что им то (и точке и модему) наверное все равно с чего я им отправляю, а на буке с винды все ок работает.

default 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0
меня вот эта строчка смущает, она появляется как то долго.

0
dyug - 12 Июль, 2010 - 12:26

понятно, как оно должно по идее работать.

Долго? она должна появляться сразу.
значит где-то что то не так, что именно увы, сказать не смогу.
А если подключается по сетевухе - все нормально выдается и пингуется?

кстати, если модем у тебя и роутер (я так понимаю) то почему не поднять на нем дхцп, и использовать его?
Еще можно попробовать прописать статик настройку, и посмотреть что там происходит...
на линухе никаких фаерволов не настраивал?

0
DUBLb - 12 Июль, 2010 - 12:42

)) Ну у меня считай и есть dhcp, только для моих компов зарезервированы адреса, когда ко мне еще ктото приходит они получают адреса после 1.5.
По сетевухе все ок, iptables говорит что там везде accept.

То что посоветовал Xenomorph одни раз помогло )) я сидел по кабелю, потом выполнил эту строчку, ответ был no such process вроде бы, вынул кабель, а по вай фай все работало. Перезагрузился и все перестало работать и когда я решил повторить фокус работать тоже не захотело. Теперь пишет все время file exists. Какой файл? Может его удалить и снова заработает?

0
Xenomorph - 12 Июль, 2010 - 12:52
Изображение пользователя Xenomorph.

sudo ip route del default
sudo ip route add default via 192.168.1.1 dev wlan0

Точка не пингуется ни с винды ни с linuxa.ололошечки:D

0
dyug - 12 Июль, 2010 - 14:11

да, у тебя дхцп на точке доступа, как я понял.
я и выдал предложение перенести его на модем-роутер...
может быть поможет.
И стоило бы еще написать модель модема, модель точки доступа, тип используемого шифрования.

0
DUBLb - 12 Июль, 2010 - 18:31

Не )) dhcp именно на модеме-роутере, точка исключительно как беспроводной свитч используется, на ней единственные настройки какие есть это настройки вай фая.
Модем ZyXel p-600 series, точка доступа D-link DIR320, шифрование WPA2 Personal. Но оно походу не причем, ведь он к точке подключается, и локалку тоже видит.

0
dyug - 12 Июль, 2010 - 19:14

так, нескромный вопрос - точка доступа которая 320 дир - она включена именно в режиме точки доступа?
то есть функции роутинга маскарадинга отключены?

вопрос важный..
про тип шифрования я понял, просто были прецеденты, потому и спросил

Ну не знаю я, не знаю..
может если бы мог посмотреть что то и увидел... :-(

0
DUBLb - 13 Июль, 2010 - 08:56

Могу выложить куда нить скрины с точки и с модема ))

0
dyug - 13 Июль, 2010 - 10:40

ну выложи, куда либо...
главное урл не забудь указать потом, чтобы можно было увидеть. :-)

0
DUBLb - 12 Июль, 2010 - 13:06

И усе равно не работает

0
dyug - 12 Июль, 2010 - 14:09

Единственное, что я могу посоветовать, так как не вижу проблем исходя из описания, попробуй поменять тип шифрования на точке.
может есть какая то трабла в в этом.. НЕ ЗНАЮ Я, в чем у тебя проблема.

0
DUBLb - 12 Июль, 2010 - 18:32

Тип шифрования менял и вообще убирал ))

0
DUBLb - 14 Июль, 2010 - 15:18

Настройки точки и модема
Вот ссылочка. Настройки сбросил на всякий случай. С венды или пл сетевухе все работает. По вайфаю по прежнему нет.
Мне еще посоветовали отключить SElinux. Как проверить включен ли он вообще? А то методы отключения selinux эти методы не работают у меня, потому что тех папок и файлов, которые тут описаны у меня нет

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры