Пропадает курсор при выходе из ждущего режима

Всем привет! Установлена Kubuntu 10.04 на ноутбуке ASUS F8S. При закрытии крышки ноутбука система переходит в ждущий режим, а при восстановлении производиться блокировка экрана. Когда меня это начало доставать, снял галку "Заблокировать экран при восстановлении" в "Управлении питанием". Экран перестал блокироваться при выходе из ждущего режима. Вот только при этом пропадает курсор мыши с экрана. Опытные перцы могут что-нибудь подсказать, как избавиться от этого бага? Я хоть и печатаю быстро и вслепую, но все-таки надоело по 20 раз на дню вводить пароль при разблокировании экрана...

0
DarkneSS - 29 Июль, 2010 - 15:22
Изображение пользователя DarkneSS.

Когда у меня пропадает курсор (правда, я не понимаю почему), я веду мышкой к К-меню, открываю его и вожу вверх-вниз... и курсор появляется =)

0
John - 29 Июль, 2010 - 17:05

Не помогает. Может имеет смысл обновить КДЕ до 4.4.4? Сейчас у меня стоит 4.4.2. Если да, то какой репозитарий надо подключить? Или КДЕ тут не причем?

0
DarkneSS - 29 Июль, 2010 - 23:04
Изображение пользователя DarkneSS.

Для обновлений этот. Может помочь, но не факт...

0
John - 30 Июль, 2010 - 09:59

За ссылочку благодарствую. Вот только действительно не помогло...

0
knuckles - 30 Июль, 2010 - 10:21
Изображение пользователя knuckles.

Открой /etc/X11/xorg.conf и после следующих строк (у тебя могут отличаться):
Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"

попробуй добавить параметр
Option "HWCursor" "off"
сохрани файл и перестартуй иксы.
Если не поможет, попробуй эту опцию (предыдущую удали):
Option "SWCursor" "on"
снова сохрани файл и перестартуй иксы.
Если и это не поможет, то вместо предыдущих двух вариантов попробуй в секции Device (там, где видеокарта описана) опции
Option "hw_cursor" "false"
или
Option "sw_cursor" "true"

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры