Проблема с phpmyadmin?

Здравия желаю товарищи комрады, возможно я не оригинален и проблема моя весьма тупа, но разьве так должен выглядить phpmyadmin?

Тока поставил 9.10. Впервые право.

apt-get install делал на всё вродебы, всё стоит, никто не ругается.

Единственное что - может быть сия радость дань Konqueror? Но это я сейчас постараюсь упредить.

Подсобите советом люди добрые!.)

0
Жюстина - 19 Август, 2010 - 04:19
Изображение пользователя Жюстина.

Konqueror тут не при чём, советую для надёжности скачать phpmyadmin отдельно, а не из репозиториев, и распаковать его в каталог сервера, так у меня всегда работаеть. А вот если посмотреть на список файлов, то это где-то на пути вот таком должно быть http://127.0.0.1/phpMyAdmin/setup/

А config-db.php запускался?

+1
Sapphire - 18 Август, 2010 - 21:52
Изображение пользователя Sapphire.

нет поддержки php апачем. при установке мускуля выберите апач и будет Вам счастье.
ЗЫ: все прекрасно ставится из реп. Не нужно качать отдельно.
ЗЫ2: под веб-сервер рекомендую дебиан. бубунты хороши только как рабочие станции и все. не более. сугубо мое мнение

0
Жюстина - 19 Август, 2010 - 04:14
Изображение пользователя Жюстина.

Меня почему-то смутило отсутствие index.php (и каталогов со всяким другим интересным) или подобного чего-то, когда пакетом устанавливается оно начинает как то оригинальнее работать?

0
Sapphire - 19 Август, 2010 - 08:03
Изображение пользователя Sapphire.

работает оно точно также. просто ставить удобнее
--------------------
вот так точно работает

Установка апача:
sudo apt-get install apache2
Настроить можно в файле конфига: sudo gedit /etc/apache2/sites-available/default
(Лучше всего создать папку www в /home/юзер/ и в /etc/apache2/sites-available/default указать путь, так будет проще работать)
Установка мускуля:
sudo apt-get install mysql-server
Вместе сним ставятся автоматически и клиент и при установке попросить ввести пароль для рута. Еще можно phpmyadmin поставить (по желанию)
sudo apt-get install phpmyadmin
Установка php:
sudo apt-get install php5
Настраивать ненужно.

0
Жюстина - 19 Август, 2010 - 08:08
Изображение пользователя Жюстина.

Ну тогда вот просто смотрим на список файлов, который показан нам, и пытаемся догадаться какой из php файлов апача должен запустить, и вообще где phpmyadmin там???

0
Sapphire - 19 Август, 2010 - 08:18
Изображение пользователя Sapphire.

ну походу нет его;) потому что так он выглядеть не должен

скриншот с фряхи, но смысл пхпмайадмин от этого е изменился

0
Жюстина - 19 Август, 2010 - 08:20
Изображение пользователя Жюстина.

Собсна об этом я и кричу во все буквы!!!

0
Sapphire - 19 Август, 2010 - 08:23
Изображение пользователя Sapphire.

буквы маленькие - поэтому и не видно)))) 100% рабочий ман по установке выложен мною выше. если после этого ничего не заработает, то уж извините...

0
Жюстина - 19 Август, 2010 - 08:37
Изображение пользователя Жюстина.

Ой да мне то шо? У меня такута: sudo tasksel install lamp-server

А потом просто копирую phpmyadmin куда надо... И ведь тожа 100% работат.

0
tigris - 19 Август, 2010 - 00:31
Изображение пользователя tigris.

Я делал вот по этому, все работает великолепно.

0
vi1987 - 19 Август, 2010 - 07:24

а разве phpmyadmin не тянет за собою и apache со всеми необходимыми модулями и php??
насколько я знаю он тянет все пакеты от которых зависит. разве что mysql не тянет сам (((

0
Sapphire - 19 Август, 2010 - 08:06
Изображение пользователя Sapphire.

не тянет. пакет php5 как раз для этого и ставится

0
vi1987 - 19 Август, 2010 - 09:46

попробуй выполни на чистой системе sudo apt-get install phpmyadmin и посмотри что система тебе предложит поставить ;)

0
Sapphire - 19 Август, 2010 - 15:30
Изображение пользователя Sapphire.

php5 он за собой не потянет

0
vi1987 - 19 Август, 2010 - 18:04

тогда скажи почему у меня все поставилось??

0
Жюстина - 19 Август, 2010 - 18:21
Изображение пользователя Жюстина.

Хотела сказать что вспышки на солнце были наверное, НО чтоб убедиться сделала во шо:
com@com:~$ aptitude show phpmyadmin
Пакет: phpmyadmin
Новый: да
Состояние: не установлен
Версия: 4:3.3.2-1
Приоритет: дополнительный
Раздел: universe/web
Сопровождающий: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Размер в распакованном виде: 17,4M
Зависимости: libapache2-mod-php5 | php5-cgi | php5, php5-mysql | php5-mysqli, php5-mcrypt, perl, debconf (>= 0.5) | debconf-2.0, dbconfig-common, ucf (>= 0.28), libjs-mootools (>=
                        1.2.4.0~debian1-1)
Рекомендует: apache2 | lighttpd | httpd, php5-gd, mysql-client
Предлагает: mysql-server

0
Sapphire - 19 Август, 2010 - 23:04
Изображение пользователя Sapphire.

anton@HP:~$ sudo aptitude install phpmyadmin
[sudo] password for anton:
Чтение списков пакетов... Готово
Построение дерева зависимостей      
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях     
Инициализация состояний пакетов... Готово         
Запись информации расширенных состояний... Готово
Следующие НОВЫЕ пакеты будут установлены:
  apache2-mpm-prefork{a} apache2-utils{a} apache2.2-bin{a} apache2.2-common{a} dbconfig-common{a} javascript-common{a} libapache2-mod-php5{a} libapr1{a} libaprutil1{a}
  libaprutil1-dbd-sqlite3{a} libaprutil1-ldap{a} libdbd-mysql-perl{a} libdbi-perl{a} libjs-mootools{a} libmcrypt4{a} libnet-daemon-perl{a} libplrpc-perl{a} libt1-5{a}
  mysql-client{a} mysql-client-5.1{a} php5-common{a} php5-gd{a} php5-mcrypt{a} php5-mysql{a} phpmyadmin wwwconfig-common{a}
0 пакетов обновлено, 26 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 21,3MБ архивов. После распаковки 63,5MБ будет занято.
Хотите продолжить? [Y/n/?] ^C

php5 c phpmyadmin не тянется

0
dyug - 13 Февраль, 2011 - 11:23

libapache2-mod-php5{a} а что такое это по твоему?
Не путать поддержку пхп в апаче, и пхп5-сли - команд лине интерфейс.

0
uicraor - 20 Август, 2010 - 09:12
Изображение пользователя uicraor.

srv@srv:~$ wajig install phpmyadmin
[sudo] password for srv:
Чтение списков пакетов... Готово
Построение дерева зависимостей      
Чтение информации о состоянии... Готово
Будут установлены следующие дополнительные пакеты:
  apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common dbconfig-common javascript-common libapache2-mod-php5 libapr1 libaprutil1 libaprutil1-dbd-sqlite3
  libaprutil1-ldap libdbd-mysql-perl libdbi-perl libgd2-xpm libjs-mootools libmcrypt4 libnet-daemon-perl libplrpc-perl libt1-5 mysql-client mysql-client-5.1 php5-common php5-gd
  php5-mcrypt php5-mysql wwwconfig-common
Предлагаемые пакеты:
  apache2-doc apache2-suexec apache2-suexec-custom apache2 httpd php-pear dbishell libgd-tools libmcrypt-dev mcrypt php5-suhosin mysql-server postgresql-client apache apache-ssl
НОВЫЕ пакеты, которые будут установлены:
  apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common dbconfig-common javascript-common libapache2-mod-php5 libapr1 libaprutil1 libaprutil1-dbd-sqlite3
  libaprutil1-ldap libdbd-mysql-perl libdbi-perl libgd2-xpm libjs-mootools libmcrypt4 libnet-daemon-perl libplrpc-perl libt1-5 mysql-client mysql-client-5.1 php5-common php5-gd
  php5-mcrypt php5-mysql phpmyadmin wwwconfig-common
обновлено 0, установлено 27 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Необходимо скачать 21,5MБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 64,2MB.
Хотите продолжить [Д/н]?

чет мне много букаф не осилить предложил... ><

0
Condor - 19 Август, 2010 - 08:34
Изображение пользователя Condor.

phpmyadmin не устанавливается в корень веб сервера.
Он устанавливается в /etc/phpmyadmin вроде как, а при установке, он просто прописывает в настройки апача алиас к себе.
При установке phpmyadmin спрашивает, куда прописаться, в апач или лайт серверы.
Можно ставить из реп, всё работает.
И, как правильно уже было замечено, надо поставить пакет php5, ну и mysql-server-5.1, если он ещё не поставлен.

0
Sapphire - 19 Август, 2010 - 08:36
Изображение пользователя Sapphire.

у меня скриншот с freebsd. там он как раз в корень и ставится))

0
Condor - 19 Август, 2010 - 10:17
Изображение пользователя Condor.

Бывает и такое...
В убунте он не в корне сервера.
На фряхе серваки держал года два-три назад, потом переехал на ubuntu-srver.
Заморочек меньше, производительность и стойкость ни сколько не хуже.

0
SerhioLopes - 12 Февраль, 2011 - 23:45
Изображение пользователя SerhioLopes.

делаю все как вы все пишите, а в locahost/phpmyadmin не заходит

0
Жюстина - 13 Февраль, 2011 - 02:31
Изображение пользователя Жюстина.

sudo tasksel install lamp-server

потом качаш phpmyadmin с сайта, и разархивируешь в каталог /var/www

проверяешь: http://127.0.0.1/phpmyadmin

Если не работает то нужен вывод ls /var/www

0
yurmax - 13 Февраль, 2011 - 06:58
Изображение пользователя yurmax.

да, странная ситуация конечно.
какогото модуля не хватает.
чтоб наверняка, сделаем так.
проинсталим из репа вебмин, он хорошо вытягивает все зависимости до мелочей.
после этого можно сносить вебмин и ставить phpmyadmin.

0
SerhioLopes - 16 Февраль, 2011 - 16:54
Изображение пользователя SerhioLopes.

Всем спасибо. Я забывал включить модуль пхп

0
Faustlogger - 11 Апрель, 2012 - 15:21

Проблема та же, что и в сабже.
Выполнив
pavel@pavel-M51Kr:~$ aptitude show phpmyadmin
Получил
Package: phpmyadmin                 
State: installed
Automatically installed: no
Version: 4:3.4.5-1
Priority: дополнительный
Section: universe/web
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Uncompressed Size: 18,1 M
Depends: libapache2-mod-php5 | libapache2-mod-php5filter | php5-cgi | php5-fpm | php5, php5-mysql | php5-mysqli,
         php5-mcrypt, perl, debconf (>= 0.5) | debconf-2.0, dbconfig-common, ttf-dejavu-core, ucf (>= 0.28)
Recommends: apache2 | lighttpd | httpd, php5-gd, mysql-client
Suggests: mysql-server, www-browser
Description: инструмент Web-админиcтрирования MySQL

Но что-то мне это не очень помогло в решении моей проблемы. Надеюсь на помощь гуру

0
dyug - 11 Апрель, 2012 - 18:50

а aptitude install phpmyadmin, вместо aptitude show phpmyadmin не пробовал сделать?
говорят, помогает. Во всяком случае мне так точно помогло. :-)

0
Гость - 29 Июнь, 2012 - 00:35

блин все просто можно не phpmyadmin
sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf.d
sudo /etc/init.d/apache2 restart

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры