Grub2 - "Error: out of disk"

Всем привет. Поставил кубунту на несколько компьютеров, включая свой ноутбук. Да этого момента проблем не возникало.
Возникла необходимость установить 10.4 на старый комп примерно с такой конфой:

pentium 3 700 MHz
SDRAM 512
asus ku4vx
HDD 320 WD IDE

Диск форматирую и разбиваю стандартными средствами, пробовал и в ext3 u B ext4 - разницы никакой.
Восстанавливал grub2 как указано здесь: http://ubuntologia.ru/grub2-recovery тоже не помогает.

Память, винт потестил, все в порядке, кроме того на этой конфе пашет 2000 винда без глюков.

Установка проходит нормально но при загрузке ОС выдает:
error: out of disk
grub rescue>

Что можно сделать?

0
Lik - 24 Сентябрь, 2010 - 13:21

Первые три страницы гугла не помогли. forum.ubuntu.ru - перечитал все что связано с этой ошибкой.
Такое впечатление что дело совсем не в грубе.

0
DarkneSS - 24 Сентябрь, 2010 - 13:28
Изображение пользователя DarkneSS.

В багрепортах на ланчпаде нет решения?..

0
knuckles - 24 Сентябрь, 2010 - 13:38
Изображение пользователя knuckles.

Ты с LiveCD можешь загрузиться?

Загрузись и примонтируй хард (будем считать, что хард называется sda, и ты его примонтируешь в /mnt/hard):
sudo mount /dev/sda /mnt/hard
Далее приложи сюда содержимое файла /mnt/hard/boot/grub/grub.cfg и результат выполнения команд
ls -l /dev/disk/by-uuid/
и
ls -l /dev/disk/by-id/

0
Lik - 24 Сентябрь, 2010 - 13:42

На ланчападе ничего универсального. Мусолят каждый случай пока ТС не перестанет постить.

Сейчас ставлю систему на другой жесткий (по старше), если проблема не в шдд, то отпишусь по результатам)

0
Lik - 24 Сентябрь, 2010 - 14:45

Проблема была в ШДД, на другом все ок.
Два возможных вывода:
1. если старая конфигурация то и винт должен быть старый, возможно не дружит с новым.
2. возможно винт был глючный, но все тесты прошел)

Спасибо за помощь)

Да, кстати, кому интересно, на таком проце плазма подтормаживает, так что если совсем старье то мб лучше DEBIAN ставить, ну если все дрова прикрутятся конечно)

0
Voyageur - 25 Сентябрь, 2010 - 10:18
Изображение пользователя Voyageur.

Вряд ли плазма тормозит из-за проца, тем более 3,7 GHz!

0
uicraor - 25 Сентябрь, 2010 - 10:50
Изображение пользователя uicraor.

Он вроде написал что комп старый! PentiumIII 700MHz :D

0
Voyageur - 25 Сентябрь, 2010 - 12:35
Изображение пользователя Voyageur.

Блин, тупанул)))

0
Гость - 12 Январь, 2011 - 14:09

У меня такая же ерунда. На ноуте винт посыпался IDE. Купил новый, тоже WD 320 Gb. Савил винду пашет норм. А вот с линуксоксом чрез раз дружит.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры