Подключение C-Motech CNU-680 на Kubuntu 10.04 x64 [Решено]

Изображение пользователя Shrine.

После установки просто подключиться к интернету у меня нет возможности, едиснтвенный вариант - модем из заголовка. Добрая компания Skylink "вшила" дрова в модем, поэтому сначала он подключается как внешний носитель, а не как модем. Но в папке для линукса есть лишь файлик RDEVCHG и его исходник, а так же execute.sh, которые после последовательного использования должны были заставлять модем работать. Но, конечно, это не работает. Я знаю, что для 32-битных есть UI почти как в Windows, который сам все делает и модем прекрасно работает, но на amd64 она не запускается. Поэтому нужно искать другие решения. Так как через модем - мое единственное подключение, доступа к интернету с кубунты у меня нет, но скачивать с винды зависимости и потом их там ставить по одной - дело неблагородное. Поэтому я установил в качестве репозитория установочный диск (спасибо сайту debian.org):

После можно установить все, что было досутпно с диска, например, драйвер для видеокарты, чтобы включить различные приятные свистелки-перделки в оформлении, а так же нужные пакеты для установки usb-modeswitch, это libusb-dev (по-моему у меня на диске его не было, и я его скачивал отдельно с винды), и, насколько помню, gcc.
После устанавливаем usb-modeswitch, инструкция по установке есть в самом архиве.
В разных мануалах написано, что нужно менять некоторые параметры в usb_modeswitch, чтобы модем переключался и в /dev появлялось устройство ttyACM*, но я так и не смог добиться такого результата, модем у меня так и остался на ttyUSB0. Вот команда, которая по словам одного мануала, сработала: usb_modeswitch -v 0x16d8 -p 0x6803 -m 0x07 -M 5553424308e0408524000000800008ff524445564348470000000000000000
modprobe option && echo -n "0x16d8 0x6803" > /sys/bus/usb-serial/drivers/option1/new_id

Однако, я уверен, что именно из-за usb-modeswitch у меня модем стал реагировать на мои действия, хоть и с ttyUSB0.
Перепробовав практически все способы, что описаны в интернете, я почти отчаялся, пока не нашел небольшую инструкцию, где говорилось о последовательности - RDEVCHG и pppconfig. Как я уже говорил раньше, RDEVCHG не работает, но вот pppconfig меня заинтересовало, и после нескольких минут стучания по клавиатуре я соединился с интернетом. Итак:

Теперь можно пользоваться интернетом. Быть может, этот мануал поможет кому-то, кто попал в подобную ситуацию с этим модемом.
А теперь вопрос, а можно ли как-то запустить подключение на kppp? У меня так и не получилось.
Что я делал: Модем на ttyUSB0, опрашивается, реагирует на команды в мини-терминале. Соединение: Номер #777, имя - mobile, пароль - internet. Если так и оставить по дефолту, то соединение останавливается еще на инициализации. В настройках соединения сделал скрипт с "ATZ, ATDT#777",где ATZ - команда инициализации, а ATDT#777 собственно дозвон, модем инициализируется, пишет CONNECT, мигает красный светоид, kppp пишет, что есть соединение, но интернет не работает. Страницы не открываются, пакеты с нета не ставятся. Быть может что-то пропустил/недоглядел/ступил, или есть какая-нибудь маленькая хитрость? Буду благодарен за помощь.
0
Жюстина - 3 Октябрь, 2010 - 20:45
Изображение пользователя Жюстина.

А я тожа билась с kppp правда только для простого gprs, оно так и не захотело работать, вообще зависало...

Я только чистой настройкой ppp пользовалась и всё, так работало хорошо.

0
Shrine - 3 Октябрь, 2010 - 23:16
Изображение пользователя Shrine.

Ну я еще буду возиться с kppp, там во много раз удобнее было бы, скорость, принятые\переданные байты, время подключения. Может еще кто подскажет что-то. Ну если нет, так нет, буду с консоли подключаться, все же лучше, чем ничего.

0
rlepish - 3 Октябрь, 2010 - 23:32

скорость, принятые\переданные байты, время подключения
Knemo

0
freeman1407 - 4 Октябрь, 2010 - 00:42

Может это поможет.

0
Shrine - 4 Октябрь, 2010 - 15:43
Изображение пользователя Shrine.

Спасибо, но уже все решилось. Проблема была в DNS серверах, страницы не открывались по символьным адресам из-за этого. kppp почему-то не хочет позволять ставить галочку "автоматически".

+1
rlepish - 3 Октябрь, 2010 - 23:31

kppp пишет, что есть соединение, но интернет не работает. Страницы не открываются

В Kppp в настройке соединения вкладка DNS стоит автоматическое или ручное?
У меня такое было, при автоматическом проблем не было, но КППП переключалось в ручное и страницы не открывались. Добавил в настройках DNS и проблема пропала.
Правда, как установить ДНС в Авто так и не нашел

0
Shrine - 4 Октябрь, 2010 - 15:40
Изображение пользователя Shrine.

Наверно в этом и дело... Потому что подключение вроде без проблем прошло, скрипт подключения брал из лога официальной UI проги. Сейчас с ноута, но по памяти, вроде стоит вручную, а автоматом кнопка деревянная.

Да, дело было в DNS, в настройках стоит "ручная", после подключения ввел ip-адрес Яндекса, все открылось без проблем. Ввел адреса DNS вручную, и вуаля, все работает. Большое спасибо за наводку!

0
MRNV - 28 Июнь, 2012 - 10:19

В общем то те же проблемы с подключением. Модем Е173 Мегафон, если подробнее о всех этапах подключения то вот:
-Модем видит,
-Не подключено Мегафон-Россия
При щелчке в настройках зависает минуты на три
-Ожидание авторизации
-Уровень сигнала 80%
-Способ доступа GSM/EDGE
и в итоге
-Не подключено
Далее пробую Изменить Соединение
-Добавить
-Настройка мобильного соединения
ставлю галочку напротив
-Подключаться автоматически
-Точка доступа APN internet
В основных параметрах номер оставляю по умолчанию, а также логин и пароль
-*99#
-gdata
-*****
-PIN не требуется
На этом этапе получаю уведомление
-Получение сетевого адреса
и далее снова
-Не подключено
Может что нибудь не так делаю? Возня с РРРоЕ тоже ничего не дала, пробовал так же minicom и wvdial, в итоге только менялись тип соединения между GSM/EDGE и GSM/UMTS и систеное время на MTU, это вообще странно. Может ноут не подходит, где то читал что это железо заточено строго под Windows, а именно Dell Precision M2600.

0
Shrine - 18 Июль, 2012 - 20:23
Изображение пользователя Shrine.

Странно, что у вас через штатный нетворк манагер не подключается. У меня тоже есть такой модем, но подключается все с пол пинка. Быть может это из-за большого пинга в 2G, у меня тоже такое бывало, что он висел на подключении минутами, пытаясь достучаться, но в конце-концов все равно подключался. Кроме того, если у вас есть даже слабый сигнал 3G, лучше подключаться через него. У меня там даже при слабом сигнлае все отлично подключается.

Кроме того, зачем вам PPPoE? Вам нужно просто PPP.

Насчет ноута - это все глупости. У меня не было ни одного знакомого, у которого бы не получилось полностью и без проблем отучить ноут от винды.

0
Гость - 16 Ноябрь, 2013 - 03:34

у меня при подключении пишет
[email protected]:~$ sudo pon skylink
/usr/sbin/pppd: In file /etc/ppp/peers/skylink: unrecognized option '/dev/ttyUSB0'

что делать ? помогите :(

0
DarkneSS - 16 Ноябрь, 2013 - 15:56
Изображение пользователя DarkneSS.

ls /dev/ttyUSB* при подключенном устройстве.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры