Network Manadger не включает ... (что мне не нравится в нетворк менеджере)

Изображение пользователя lord_i.

Всем привет.
На железе HP ProBook 4310s НМ не включает 1000 Мб/с на eth0

~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
02:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
85:00.0 Ethernet controller: Marvell Technology Group Ltd. Device 436c (rev 10)

Хотя вроде как включено:
ethtool eth0
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  Not reported
        Link partner advertised pause frame use: No
        Link partner advertised auto-negotiation: No
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: Unknown
        Supports Wake-on: pg
        Wake-on: d
        Current message level: 0x000000ff (255)
        Link detected: yes

Но в свойствах соединения пишется 100 Мб/с и реальная скорость соответствует 100Мб/с
Нотик соединен с 1000 Мб свичем, индикатор показывает содинение 1000 Мб/с... Фигня какая-то, не могу понять где копать... Может кто поможет?

0
knuckles - 5 Октябрь, 2010 - 07:48
Изображение пользователя knuckles.

Может, сама сетевуха гигабит не поддерживает? Модель какая?

0
lord_i - 5 Октябрь, 2010 - 08:07
Изображение пользователя lord_i.

Поддерживает. Под виндой работает.
-PCI Devices-
Ethernet controller : Marvell Technology Group Ltd. Device 436c (rev 10)

0
knuckles - 5 Октябрь, 2010 - 08:14
Изображение пользователя knuckles.

Ну, мне это ни о чем не говорит :-) Device 436c - это и есть модель? Я у них что-то не нашел такого...

0
lord_i - 5 Октябрь, 2010 - 22:38
Изображение пользователя lord_i.

Странно, что Вам это ни о чем не говорит ... Потому как:
vendor: 11ab ("Marvell Technology Group Ltd."), device: 436c ("88E8072 PCI-E Gigabit Ethernet Controller")

0
knuckles - 6 Октябрь, 2010 - 06:52
Изображение пользователя knuckles.

Странно, что Вам это ни о чем не говорит ...
Ну, глупый я, что тут скажешь :-)

0
lord_i - 5 Октябрь, 2010 - 23:09
Изображение пользователя lord_i.

Глюк сам собой рассосался ... Странно все это ... Теперь включаю - НМ бодро пишет про 1000Мб/с и скорость нормальная ... Мда ... IMHO НМ в кубунту самое глючное место.

0
balamutick - 6 Октябрь, 2010 - 17:13
Изображение пользователя balamutick.

Глюк сам собой рассосался ... Значит не зря я бил в бубен

0
xsudo - 5 Октябрь, 2010 - 23:17
Изображение пользователя xsudo.

А что нужно?

У тебя:
Speed: 1000Mb/s
Duplex: Full

А Network Manadger можешь выкинуть и не пользоваться. Лучше вобще его выпилить.

А так можешь попробовать:
sudo ethtool -s eth0 autoneg on

Ну или понизить:
sudo ethtool -s eth0 autoneg off speed 100 duplex full
sudo ethtool -s eth0 autoneg off speed 10 duplex full

Логи смотрел? Всё нормально?

реальная скорость соответствует 100Мб/с
Чем проверял?

З.Ы.
Про тестирование можешь почитать вот это:
Почитать про iperf

0
lord_i - 6 Октябрь, 2010 - 08:40
Изображение пользователя lord_i.

Спасибо за советы. iperf обязательно попробую. Скорость мерял крузадером. По поводу ethtool я знаю, и все это делал в первую очередь. Вчера под вечер НМ показал вообще 0 скорость соединения - то есть понятно что ему веры нет.
По поводу - выпилить. Из альтернатив я пробовал wicd и менеджер от гнома. Возможно я не очень вдумчиво их настраивал, но как то они меня не впечатлили ... Надо будет еще раз попробовать... Вообще непонятно - почему столь важный функционально узел как НМ в таком глючно-запущеном состоянии.

0
xsudo - 6 Октябрь, 2010 - 11:51
Изображение пользователя xsudo.

Я пользуюсь ifconfig )
Не глючно) удобно в настройке )
wicd пользовался только один раз, и то из-за то го, что лень было с настройками вафли возиться.

0
lord_i - 6 Октябрь, 2010 - 20:03
Изображение пользователя lord_i.

Насколько я понимаю - ifconfig удобно использовать при каком-то одном, максимум двух подключениях. У меня бывает три сетки вайфая часто меняются, езернет изредка и часто мобилка в машине если в поле надо в инет выйти. Причем мобилки две - цдма и жсм ... Короче, все это конфигурять ручками как то откровенно харит. Тем более НМ все это подхватывает в итоге, но, сцуко с бубном ... Особенно вайфай последнее время как то тяжело находит. Приходится НМ останавливать а потом стартовать... Короче - мелкий гемор. И все-же повторю свою мысль - чего народ не занимается полировкой НМ под КДЕ? Ведь всем известно что оно глючное.Причем, обнновления КДЕ происходят а НМ не меняли уже наверное с полгода если не ошибаюсь... Идея то хорошая, красиво сделано ... Не понимаю ...

0
balamutick - 6 Октябрь, 2010 - 23:03
Изображение пользователя balamutick.

Короче, все это конфигурять ручками как то откровенно харит. Наивный человек.
Если какая-то вещь может настраиваться ручками через консоль, значит эту вещь в большинстве случаев можно автоматизировать для настройки в один клик.

Просто один раз придётся написать скрипт для задания настроек, после только щёлкать мышкой на запуск нужного.
Виндузятникам: на вашей винде такое тоже возможно, можно написать пакетный файл для настроек сети. ЧТобы не топтать мышку и клавиатуру на работе\дома\кофе и т.п.
НМ не меняли уже наверное с полгода если не ошибаюсь... Это да. Мне интересно, им никто Жук-отчётов не шлёт или им так пофиг на пользователей ?

+2
lord_i - 7 Октябрь, 2010 - 08:32
Изображение пользователя lord_i.

По поводу пакетников. Я прекрасно понимаю что можно написать какой угодно сложности скрипт. И даже сам пишу там где без этого не обойтись. Например, на сервере, где просто нет графической среды. Но, в кубунте - графическая среда с интегрированным НМ, который является весьма важной частью системы. НЕХОЧУ запускать никаких скриптов. ХОЧУ чтоб важная часть графического интерфейса работала так как должна в полностью автоматическом режиме. Кстати, в винде нет необходимости писать какие-то пакетные файлы. там сеть поднимается в автомате прекрасно без единого глюка на этом же железе. Еще кстати - в убунту таких боков тоже не встречается (по отзывам)... Собственно я об этом ... :)

0
knuckles - 7 Октябрь, 2010 - 09:50
Изображение пользователя knuckles.

Важно помнить что такое "мэйнстрим" :-) И если что-то к нему не относится (а Кубунту как раз не относится: во-первых, потому что не Windows, а во-вторых, потому что в Debian/Ubuntu сновное DE - Gnome), то там всегда проблем больше.

0
lord_i - 7 Октябрь, 2010 - 19:57
Изображение пользователя lord_i.

Так то оно так ... Только, насколько я понимаю - КДЕ само по себе "мэйнстрим", с позволения сказать... :) И глючит в нем НМ не только под кубунту...

+1
balamutick - 7 Октябрь, 2010 - 20:37
Изображение пользователя balamutick.

КДЕ это наше всё. Только так позволяется говорить %-)

0
lord_i - 7 Октябрь, 2010 - 22:01
Изображение пользователя lord_i.

Дык кто спорит? Наше всё. Наше глючное любимое всё. "Здесь сынок, наша родина" (с) анекдот.

ЗЫ Не с того не с сего отвалился вайфай и просит пароль... Пароль правильный а он еще просит ... Выключил вайфай воткнул эзер ... жопа какая-то ... :(

0
balamutick - 8 Октябрь, 2010 - 13:52
Изображение пользователя balamutick.

Наше глючное любимое всё. "Здесь сынок, наша родина" (с) не знаю не знаю, ЛТС ка стоит и достаточно стабильно, а вот то, что какой-то ******* решил что NM - нам нужен, это конечно ******во.

0
knuckles - 8 Октябрь, 2010 - 07:14
Изображение пользователя knuckles.

КДЕ само по себе "мэйнстрим"
Само по себе все - мэйнстрим.

Что касается NM, то уже не раз здесь говорилось: изначально он писался исключительно под openSUSE. Разработчики не учитывали и не собирались учитывать особенности других дистрибутивов. Однако, потом он понравился мэйнтэйнерам, и его стали включать в KDE в разных дистрибутивах - так он стал стандартом дэ-факто.
Что касается проекта Убунту. Когда там что-то меняют в недрах системы, ничего на совместимость с KDE и NM, в том числе, не тестят - это задача так называемой KDE team, которая относительно малочисленная, и потому просто не в состоянии все проверить.
Я тоже люблю KDE, но KDE на базе Убунту (Кубунту) и NM на базе Убунту - это не мэйнстрим.

0
lord_i - 8 Октябрь, 2010 - 17:24
Изображение пользователя lord_i.

Огромное спасибо за посвящение в тонкости мейнстримов. Теперь, в светской беседе, не примену ввернуть. Правда, правда :)

0
knuckles - 8 Октябрь, 2010 - 17:37
Изображение пользователя knuckles.

=)

0
balamutick - 7 Октябрь, 2010 - 15:49
Изображение пользователя balamutick.

Например, на сервере, где просто нет графической среды. Но, в кубунте - графическая среда с интегрированным НМ, который является весьма важной частью системы. НЕХОЧУ запускать никаких скриптов. Я не на русском языке пишу ?
Në GJUHËN kakm unë shkruaj për t'u kuptuar?

Ладно, будем на уровне плинтуса объяснять.

В винде мы как дусты настраиваем адрес мышкой из гуя. А можно настраивать батником. ГДЕ она автоматически настраиват ? Откуда она знает, какой адрес я использую для дома, для работы, для друзей ?

Подсказка: в винде есть штука, как альтернативная конфигурация если автоматом не цепанулось, то берёт от туда прописанные настройки. А если у меня два места ? А если у меня три места и везде статика ?

В Кубунте с 3.5. кедами вроде были настройки профилей для сети, а вот в последнем вроде нет ?

P.s. если вы не о прописывание адреса и параметров, а вообще о шаманстве с настройке драйверов,то сорри, что не туда вписался.

0
lord_i - 7 Октябрь, 2010 - 19:16
Изображение пользователя lord_i.

Я вообще-то про другое. Я про концепцию. Я знаю как что настраивать как в винде так и в кубунте. И скрипты писать умею. :) (не валом, но умею) Я только про глючность НМ сетую. Ведь настройка из гуи как в винде так и в кубунте одинаковая практически. Только в винде и убунте (гноме) все работает, а в кубунте (кде) глюки. Вот мечта у меня - неглючный НМ в кубунте. Кстати, на 9.10 такой херни не было на том же железе. Веселуха началась с 10.04. Нотик перестал иногда просыпаться, НМ пинками нужно поднимать ... Короче - что-то настраивают :)

0
Гость - 9 Октябрь, 2010 - 15:17

Да, разумеется, его нет, и быть не может, только непонятно, чем тогда я пользуюсь постоянно.
никаких wicd не стоит, и стоять не будет, то что стало с дистрибутивом, так и работает.
последний глюк был в 9.10, и тот был исправлен.
В 10.04 ни одной проблемы не было.

0
lord_i - 11 Октябрь, 2010 - 17:17
Изображение пользователя lord_i.

Мог бы с Вами согласится по поводу кривизны моих рук, но только при условии что железо у нас одинаковое. В чем сомневаюсь. Очень железозависимая тема.

0
senet - 25 Октябрь, 2010 - 13:46

ну незнаю, мне он, НМ, оч даже нравиться, особенно в 10.10, сеть настроилась в два клика)
10.04 чуть пришлось поквоыряться, но в итоге тоже все ок, гораздо проще чем в винде)

0
lord_i - 8 Октябрь, 2010 - 20:00
Изображение пользователя lord_i.

Если я правильно понял - наши молитвы услышаны. Глючный нетворк менеджер в новом КДЕ заменили вот этим:
http://www.kde.org/applications/internet/kwlan/ интересно, будет такое же глюкалово... ?

0
Voyageur - 11 Октябрь, 2010 - 17:39
Изображение пользователя Voyageur.

На той странице, которая расположена по ссылке есть ссылка на страницу приложения на kde-apps.org. Судя по этой ссылке, kwlan написан для третьих кед.
А вот мы сегодня выяснили в конфе, что по ходу пакет network-manager-kde теперь заменен пакетом plasma-widget-networkmanagement, который вроде как допилили до съедобного состояния. Вот так это дело выглядит у SmartByte'а.

0
lord_i - 11 Октябрь, 2010 - 18:11
Изображение пользователя lord_i.

Я тоже как то напрягся, когда почитал про kwlan ... Теперь понятно. Кстати, я высадился когда после установки 10.10 networkmanager пропал совсем. Я его и поставил ручками. Сейчас снесу и плазмоид установлю. О результатах отпишусь. Если связь будет :)

0
DarkneSS - 11 Октябрь, 2010 - 19:35
Изображение пользователя DarkneSS.

Заменён точно, но работает всё равно плохо.

0
lord_i - 12 Октябрь, 2010 - 07:56
Изображение пользователя lord_i.

Таки да... После сна без такого пинка:
#!/bin/sh

rm /var/lib/NetworkManager/NetworkManager.state
service network-manager stop
service network-manager start

вайфай не подымается ...
Видимо дело не в плазмоиде а в сервисе...

0
senet - 25 Октябрь, 2010 - 13:55

м? заменен? может быть, мне показалось что енто то же самоео ток лучше)
а если не нет.монагер то чем можно восползоваться для потключения того же вайфая?
c pppoe разобрался, кстати да, не через НМ) а вот вай фай, как настроить вслучае чаго?)

+1
dyug - 25 Октябрь, 2010 - 14:07

wpa_suppliant, /etc/network/interfaces, guessnet
ключевые слова для поиска.

последнее, вкупе с первыми двумя ключевыми словами мне помогли.
Сейчас пользуюсь нетворк-манагером по причине того, что он таки работает без проблем.
Опять таки у меня. :-)
на 3 разных ноутах.
http://kubuntu.ru/node/5283 описание/ссылки я показывал у себя...

собственно - добавляю howto-configuring-linux-laptop
http://wiki.clug.org.za/wiki/Wireless_Roaming

Ну и вкратце по русски http://www.opennet.ru/base/sys/debian_laptop.txt.html

0
lord_i - 11 Октябрь, 2010 - 19:07
Изображение пользователя lord_i.

Мда ... Неплохо выглядит этот plasma-widget-networkmanagement... Трафик считает, графики рисует ... Посмотрим как свою основную функцию будет выполнять. :) Вот только непонятно назначение кнопки "дополнительно" которая при нажатии на нее превращается в кнопку "скрыть" и ничего не происходит ... Только размер окна менеджера как то подозрительно увеличивается при этом и меньше его не сделаешь ...

+1
Voyageur - 12 Октябрь, 2010 - 08:00
Изображение пользователя Voyageur.

Для беспроводных интерфейсов эта кнопка показывает доступные сети.

0
Filkt - 13 Октябрь, 2010 - 09:01
Изображение пользователя Filkt.

хм, у меня вот этот новоый НМ из 10.10 работает более менее со всем кроме ethernet, 3G момед без проблем (почти), вайфайка тож а вот pppoe как через pppoeconf настраивал так и настраиваю, и тож самое с vpn всё через консоль

0
rlepish - 14 Октябрь, 2010 - 22:22

А как plasma-widget-networkmanagement заставить появиться в системном лотке? Обновился на ноуте до 10.10, а его нет, при установке на другой ноут с нуля, он виден.
Network-manager-kde после установки в системном лотке есть, но он сносит plasma-widget-networkmanagement и наоборот

+1
DarkneSS - 14 Октябрь, 2010 - 22:45
Изображение пользователя DarkneSS.

Правой клавишей мыши по лотку, настроить, вид - ставим галку.

0
rlepish - 14 Октябрь, 2010 - 23:12

Ку) Спасибо!

+1
DarkneSS - 14 Октябрь, 2010 - 23:15
Изображение пользователя DarkneSS.

Заныкали так заныкали :-)

+1
lord_i - 15 Октябрь, 2010 - 08:54
Изображение пользователя lord_i.

Нашел причину гадского глюка. По пути ~/.kde/share/apps/networkmanagement/connections оказалось две записи для одной точки доступа, причем в одной autoconnect=true а в другой autoconnect=false.
А я пинками поднимаю после каждого слипа и ресета ... Теперь вроде все нормально ... Может кто тоже мучается с такими симтомами...

0
lord_i - 25 Октябрь, 2010 - 08:31
Изображение пользователя lord_i.

Обратил внимание на такую особенность. НМ начинает козлить если у точки доступа скрытый SSID. Козление проявляется в совершенном нежелании подключаться к точке. Подключается после множественных пинков типа останова\старта НМ. Если открыть SSID на точке - подключение происходит стабильно и без пинков. Кто-то сталкивался? Какие-то пути решения? Открыть SSID не предлагайте - это и так очевидно. Хотелось бы стабильной работы с закрытым.

0
dyug - 25 Октябрь, 2010 - 10:10

Не проверял.
смотри что в логах при этом пишется.
поподробнее, желательно...
Заодно, разу чтоб проверить, поставить нм-апплет от гнома, и проверить, как он будет себя вести...
Просто было на бете 10.04, когда нетворк манагер просто перестал понимать нешифрованные сети.
Открыл багу - признали исправили. :-)

0
lord_i - 26 Октябрь, 2010 - 08:32
Изображение пользователя lord_i.

Будешь смеятся - со вчера ни разу не глюканул ... Боится наверное ... :)

0
dyug - 26 Октябрь, 2010 - 12:05

принципиально не буду. :-)
Так, улыбнуло.. :-)
впрочем, я уже неоднократно говорил, что я использую нетворк манагер(плазмоид в качестве отображения) исключительно из за того, что он работает, и не глючит в моих условиях.

а это - штук 15 статик сетей(разные точки конторы), пару дхцп сетей (ну с ними проще :-) )
штук 5 разный ви фи сетей, правда все дхцп, модем имени нокия, модем имени тошибаГ900(винмобиле 6), модем имени Андроид(НТС)....

Вот единственное что я еще не поборол(точнее, не разбирался) как с андроида взять гпс и отдать его гпсд на нетбуке. :-)

0
lord_i - 28 Октябрь, 2010 - 08:30
Изображение пользователя lord_i.

Поймал. Это когда после сна ничего не происходит.

</code>2010-10-28 08:04:58 Winter-laptop NetworkManager[1036] <info> wake requested (sleeping: yes  enabled: yes)
2010-10-28 08:04:58 *** NetworkManager[1036] <info> waking up and re-enabling...
2010-10-28 08:04:58 *** NetworkManager[1036] <info> (wlan0): now managed
2010-10-28 08:04:58 *** NetworkManager[1036] <info> (wlan0): device state change: 1 -> 2 (reason 2)
2010-10-28 08:04:58 *** NetworkManager[1036] <info> (wlan0): bringing up device.
2010-10-28 08:04:58 *** bluetoothd[1296] HCI dev 0 down
2010-10-28 08:04:58 *** NetworkManager[1036] <info> (wlan0): preparing device.
2010-10-28 08:04:58 *** NetworkManager[1036] <info> (wlan0): deactivating device (reason: 2).
2010-10-28 08:04:58 *** NetworkManager[1036] <info> Unmanaged Device found; state CONNECTED forced. (see http://bugs.launchpad.net/bugs/191889)
2010-10-28 08:04:58 *** NetworkManager[1036] <info> Unmanaged Device found; state CONNECTED forced. (see http://bugs.launchpad.net/bugs/191889)
2010-10-28 08:04:58 *** NetworkManager[1036] <info> (eth0): now managed
2010-10-28 08:04:58 *** NetworkManager[1036] <info> (eth0): device state change: 1 -> 2 (reason 2)
2010-10-28 08:04:58 *** NetworkManager[1036] <info> (eth0): bringing up device.
2010-10-28 08:04:58 *** NetworkManager[1036] <info> (eth0): preparing device.
2010-10-28 08:04:58 *** NetworkManager[1036] <info> (eth0): deactivating device (reason: 2).
2010-10-28 08:04:58 *** kernel [19434.441327] ADDRCONF(NETDEV_UP): wlan0: link is not ready
2010-10-28 08:04:58 *** kernel [19434.441339] device wlan0 entered promiscuous mode
2010-10-28 08:04:58 *** kernel [19434.446734] sky2 0000:85:00.0: eth0: enabling interface
2010-10-28 08:04:58 *** kernel [19434.447542] ADDRCONF(NETDEV_UP): eth0: link is not ready
2010-10-28 08:04:58 *** bluetoothd[1296] Adapter /org/bluez/1294/hci0 has been disabled
2010-10-28 08:04:58 *** bluetoothd[1296] Stopping security manager 0
2010-10-28 08:04:58 *** bluetoothd[1296] HCI dev 0 unregistered
2010-10-28 08:04:58 *** bluetoothd[1296] Unregister path: /org/bluez/1294/hci0
2010-10-28 08:04:58 *** NetworkManager[1036] <info> BT device 00:22:A5:E4:D3:E9 removed
2010-10-28 08:04:58 *** bluetoothd[1296] HCI dev 0 registered
2010-10-28 08:04:58 *** bluetoothd[1296] HCI dev 0 up
2010-10-28 08:04:58 *** bluetoothd[1296] Starting security manager 0
2010-10-28 08:04:58 *** NetworkManager[1036] <info> (wlan0): supplicant interface state:  starting -> ready
2010-10-28 08:04:58 *** NetworkManager[1036] <info> (wlan0): device state change: 2 -> 3 (reason 42)
2010-10-28 08:04:58 *** bluetoothd[1296] ioctl(HCIUNBLOCKADDR): Invalid argument (22)
2010-10-28 08:04:58 *** bluetoothd[1296] probe failed with driver input-headset for device /org/bluez/1294/hci0/dev_00_22_A5_E4_D3_E9
2010-10-28 08:04:58 *** bluetoothd[1296] Adapter /org/bluez/1294/hci0 has been enabled
2010-10-28 08:05:00 *** kernel [19435.903868] EXT4-fs (sda4): re-mounted. Opts: errors=remount-ro,commit=0
2010-10-28 08:05:22 *** acpid client connected from 1079[0:0]
2010-10-28 08:05:22 *** acpid 1 client rule loaded
2010-10-28 08:05:54 *** kernel [19490.180245] Skipping EDID probe due to cached edid

Выключаю беспроводную сеть из плазмоида, затем сразу включаю и - вуаля:
2010-10-28 08:08:07 *** NetworkManager[1036] <info> (wlan0): device state change: 3 -> 2 (reason 0)
2010-10-28 08:08:07 *** NetworkManager[1036] <info> (wlan0): deactivating device (reason: 0).
2010-10-28 08:08:07 *** NetworkManager[1036] <info> (wlan0): taking down device.
2010-10-28 08:08:07 *** kernel [19623.742935] device wlan0 left promiscuous mode
2010-10-28 08:08:07 *** NetworkManager[1036] <info> (wlan0): device state change: 3 -> 2 (reason 0)
2010-10-28 08:08:07 *** NetworkManager[1036] <info> (wlan0): deactivating device (reason: 0).
2010-10-28 08:08:07 *** NetworkManager[1036] <info> (wlan0): taking down device.
2010-10-28 08:08:07 *** kernel [19623.742935] device wlan0 left promiscuous mode
2010-10-28 08:08:15 *** NetworkManager[1036] <info> (wlan0): bringing up device.
2010-10-28 08:08:15 *** kernel [19631.051000] ADDRCONF(NETDEV_UP): wlan0: link is not ready
2010-10-28 08:08:15 *** kernel [19631.051010] device wlan0 entered promiscuous mode
2010-10-28 08:08:15 *** NetworkManager[1036] <info> (wlan0): supplicant interface state:  starting -> ready
2010-10-28 08:08:15 *** NetworkManager[1036] <info> (wlan0): device state change: 2 -> 3 (reason 42)
2010-10-28 08:08:15 *** NetworkManager[1036] <info> (wlan0): bringing up device.
2010-10-28 08:08:15 *** kernel [19631.051000] ADDRCONF(NETDEV_UP): wlan0: link is not ready
2010-10-28 08:08:15 *** kernel [19631.051010] device wlan0 entered promiscuous mode
2010-10-28 08:08:15 *** NetworkManager[1036] <info> (wlan0): supplicant interface state:  starting -> ready
2010-10-28 08:08:15 *** NetworkManager[1036] <info> (wlan0): device state change: 2 -> 3 (reason 42)
2010-10-28 08:08:18 *** NetworkManager[1036] <info> Activation (wlan0) starting connection '***'
2010-10-28 08:08:18 *** NetworkManager[1036] <info> (wlan0): device state change: 3 -> 4 (reason 0)
2010-10-28 08:08:18 *** NetworkManager[1036] <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
2010-10-28 08:08:18 *** NetworkManager[1036] <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
2010-10-28 08:08:18 *** NetworkManager[1036] <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
2010-10-28 08:08:18 *** NetworkManager[1036] <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.

Ну и далее все хорошо ...
Как видно в первом случае вылазит ссылка на баг, я его почитал немного и "ниасилил" :) Там что-то все в кучу ...

0
dyug - 28 Октябрь, 2010 - 11:30

под кат бы... :-)
Но у меня такая бага была, на 10.04. Я вылечил ее методом добавления модуля вирелеес в список выгружаемых при спячке...

вполне возможно, что у тебя та же проблема
и вполне возможно, что это тебе поможет..
На 10.10 такой проблемы нет. У меня на ноуте и на нетбуке.

0
lord_i - 29 Октябрь, 2010 - 08:29
Изображение пользователя lord_i.

Попробовал. После просыпания потребовалось значительно больше пинков. Привел к начальному состоянию. Стало как было. Решил не трогать больше в духе старой армейской поговорки - "не трогай технику и она не подведет" :)

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры