Google Earth проблемы (старые лекарства не помогают).

Изображение пользователя kanzo.

Google Earth
Ну очень нужна мне эта программа....
Установка
Вариант первый вроде бы как самый очевидный.
Ставлю пакет googleearth-package
Формирую с его помощью GoogleEarthLinux.bin
Пытаюсь установить... ошибка
Гуглю нахожу как решить
Установил
Запускаю. Несколько секунд и все программа закрывается.
Гуглю. Пробую все что нашел. Не помогает.
Качаю GoogleEarthLinux.bin с сайта гугл
Устанавливаю.
Все тоже самое. Программа закрывается через несколько секунд.
Оба варианта проверяю запуская в английской локализации. Смена происходит (это видно по англоязычному меню), но эффект тот же.

Захожу по другому.
Качаю с http://packages.medibuntu.org/lucid/googleearth.html DEB пакет.
Устанавливаю. Работает. По русски!!!
Рано радуюсь. При попытке сохранить данные (например точку на карте) программа «вылетает)
Проверяю с английской локализацией. Тоже самое.

Далее моих скромных познаний не хватает. А варианты в гугле «кончились»....
Может быть специалистам что то скажет далее приведенная информация.
оочень нужна она мне...

Ниже то что было в терминале и файлах баг-репорта

При варианте установки из BIN файла

kanzo@fantom:~$ /home/kanzo/google-earth/googleearth %f

(process:3859): GLib-GObject-CRITICAL **: /build/buildd/glib2.0-2.26.0/gobject/gtype.c:2710: You forgot to call g_type_init()

(process:3859): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(process:3859): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed
Google Earth has caught signal 11.

We apologize for the inconvenience, but Google Earth has crashed.
This is a bug in the program, and should never happen under normal
circumstances. A bug report and debugging data have been written
to this text file:

/home/kanzo/.googleearth/crashlogs/crashlog-4caef459.txt

Please include this file if you submit a bug report to Google.
kanzo@fantom:~$

#############################
файл баг репорта
#############################

Major Version 5
Minor Version 2
Build Number 0001
Build Date Sep 1 2010
Build Time 11:25:42
OS Type 3
OS Major Version 2
OS Minor Version 6
OS Build Version 35
OS Patch Version 0
Crash Signal 11
Crash Time 1286534233
Up Time 3,49858

Stacktrace from glibc:
./libgoogleearth_free.so(+0xd090b)[0x1e090b]
[0xbce400]
/usr/lib/libgdk_pixbuf-2.0.so.0(gdk_pixbuf_from_pixdata+0x13f)[0x73d1baf]
/usr/lib/libgdk_pixbuf-2.0.so.0(gdk_pixbuf_new_from_inline+0x63)[0x73d1e73]
/usr/lib/flashplugin-installer/libflashplayer.so(+0x4d395)[0xa7632395]
/usr/lib/flashplugin-installer/libflashplayer.so(+0x4bdee)[0xa7630dee]
/usr/lib/flashplugin-installer/libflashplayer.so(NP_Initialize+0x1ae)[0xa763528e]
./libQtWebKit.so.4(+0x747b22)[0x2f47b22]
./libQtWebKit.so.4(+0x747c0c)[0x2f47c0c]
./libQtWebKit.so.4(+0x6062ff)[0x2e062ff]
./libQtWebKit.so.4(+0x604516)[0x2e04516]
./libQtWebKit.so.4(+0x60476a)[0x2e0476a]
./libQtWebKit.so.4(+0x712beb)[0x2f12beb]
./libQtWebKit.so.4(+0x5b1595)[0x2db1595]
./libQtWebKit.so.4(+0x5a185c)[0x2da185c]
./libQtWebKit.so.4(+0x5b1981)[0x2db1981]
./libQtWebKit.so.4(+0x5b199a)[0x2db199a]
./libQtWebKit.so.4(+0xaa2c4b)[0x32a2c4b]
./libQtWebKit.so.4(+0x16ad57)[0x296ad57]
./libQtWebKit.so.4(+0x1749d5)[0x29749d5]
./libQtWebKit.so.4(+0x183282)[0x2983282]
./libQtWebKit.so.4(+0x1bc22d)[0x29bc22d]
./libQtWebKit.so.4(+0x29ac5d)[0x2a9ac5d]
./libQtWebKit.so.4(+0x2a9410)[0x2aa9410]
./libQtWebKit.so.4(+0x2a9f72)[0x2aa9f72]
./libQtWebKit.so.4(+0x2b7fea)[0x2ab7fea]
./libQtWebKit.so.4(+0x4be45a)[0x2cbe45a]
./libQtWebKit.so.4(+0x4bf243)[0x2cbf243]
./libQtWebKit.so.4(+0x4c0449)[0x2cc0449]
./libQtWebKit.so.4(+0x4c2a75)[0x2cc2a75]
./libQtWebKit.so.4(+0x4c36b8)[0x2cc36b8]
./libQtWebKit.so.4(+0x4c6773)[0x2cc6773]
./libQtWebKit.so.4(+0x501706)[0x2d01706]
./libQtWebKit.so.4(+0x5017fb)[0x2d017fb]
./libQtWebKit.so.4(+0x539f0b)[0x2d39f0b]
./libQtWebKit.so.4(+0x54c290)[0x2d4c290]
./libQtWebKit.so.4(+0x547cc3)[0x2d47cc3]
./libQtWebKit.so.4(+0x6fd155)[0x2efd155]
./libQtWebKit.so.4(+0x6fd83e)[0x2efd83e]
./libQtCore.so.4(_ZN11QMetaObject8metacallEP7QObjectNS_4CallEiPPv+0x3f)[0x3755a7]
./libQtCore.so.4(_ZN14QMetaCallEvent13placeMetaCallEP7QObject+0x24)[0x37d5ec]
./libQtCore.so.4(_ZN7QObject5eventEP6QEvent+0x185)[0x37e03d]
./libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0xa0)[0xee7e20]
./libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x22e)[0xef1962]
./libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x70)[0x36fd50]
./libQtCore.so.4(_ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData+0x22d)[0x370989]
./libQtCore.so.4(_ZN20QEventDispatcherUNIX13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x37)[0x39594b]
./libQtGui.so.4(+0x1d3ca4)[0xf7cca4]
./libQtCore.so.4(_ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE+0x47)[0x36efbf]
./libQtCore.so.4(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0xff)[0x36f223]
./libQtCore.so.4(_ZN16QCoreApplication4execEv+0x9d)[0x370c05]
./libQtGui.so.4(_ZN12QApplication4execEv+0x25)[0xee77a1]
./libgoogleearth_free.so(_ZN5earth6client11Application3runEv+0x4bc)[0x1ebb0c]
./libgoogleearth_free.so(earthmain+0x27d)[0x1dfd3d]
./googleearth-bin(_init+0x12e)[0x80486d2]
/lib/libc.so.6(__libc_start_main+0xe7)[0x4e6ce7]
./googleearth-bin(_init+0x9d)[0x8048641]


Вариант установки из DEB файла

kanzo@fantom:~$ googleearth %f
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: Нет такого файла или каталога
Google Earth has caught signal 11.

We apologize for the inconvenience, but Google Earth has crashed.
This is a bug in the program, and should never happen under normal
circumstances. A bug report and debugging data have been written
to this text file:

/home/kanzo/.googleearth/crashlogs/crashlog-4caef7dd.txt

Please include this file if you submit a bug report will to Google.
kanzo@fantom:~$

**************************
файл баг репорта
**************************

Major Version 5
Minor Version 1
Build Number 3533
Build Date Nov 11 2009
Build Time 16:41:31
OS Type 11
OS Major Version 2
OS Minor Version 6
OS Build Version 35
OS Patch Version 0
Crash Signal 11
Crash Time 1286535133
Up Time 21.3804

Stacktrace from glibc:
/usr/lib/googleearth/googleearth-bin[0x805caa6]
[0x2e7400]
/usr/lib/libQtGui.so.4(_ZN6QLabel7setTextERK7QString+0x41)[0xe91c71]
/usr/lib/googleearth/libgoogleearth_lib.so(_ZN16PreferenceWidget14languageChangeEv+0xa7)[0x38cb97]
/usr/lib/libQtGui.so.4(_ZN7QWidget5eventEP6QEvent+0xc9e)[0xa6957e]
/usr/lib/libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0xac)[0xa0afdc]
/usr/lib/libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x219)[0xa110e9]
/usr/lib/libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x7b)[0x7aab3b]
/usr/lib/libQtCore.so.4(_ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData+0x2cb)[0x7add8b]
/usr/lib/libQtCore.so.4(_ZN16QCoreApplication16sendPostedEventsEP7QObjecti+0x2d)[0x7adf4d]
/usr/lib/libQtCore.so.4(+0x192a74)[0x7d9a74]
/lib/libglib-2.0.so.0(g_main_context_dispatch+0x1d5)[0x7051855]
/lib/libglib-2.0.so.0(+0x41668)[0x7055668]
/lib/libglib-2.0.so.0(g_main_context_iteration+0x68)[0x7055848]
/usr/lib/libQtCore.so.4(_ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x65)[0x7d9565]
/usr/lib/libQtGui.so.4(+0x1edbe5)[0xaccbe5]
/usr/lib/libQtCore.so.4(_ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE+0x49)[0x7a9609]
/usr/lib/libQtCore.so.4(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0xfa)[0x7a9a8a]
/usr/lib/libkio.so.5(_ZN3KIO9NetAccess10enter_loopEv+0x6b)[0x332bb3b]
/usr/lib/libkio.so.5(_ZN3KIO9NetAccess22synchronousRunInternalEPNS_3JobEP7QWidgetP10QByteArrayP4KUrlP4QMapI7QStringSA_E+0x1c6)[0x332c216]
/usr/lib/libkio.so.5(_ZN3KIO9NetAccess14synchronousRunEPNS_3JobEP7QWidgetP10QByteArrayP4KUrlP4QMapI7QStringSA_E+0x6b)[0x332c9cb]
/usr/lib/libkfile.so.4(_ZN11KFileWidgetC1ERK4KUrlP7QWidget+0x2b66)[0x7ae90d6]
/usr/lib/kde4/kfilemodule.so(+0x16fb)[0x373b6fb]
/usr/lib/libkio.so.5(_ZN11KFileDialogC1ERK4KUrlRK7QStringP7QWidgetS7_+0x202)[0x33aa0c2]
/usr/lib/libkio.so.5(+0x1caa12)[0x33aea12]
/usr/lib/libQtGui.so.4(_ZN11QFileDialog15getSaveFileNameEP7QWidgetRK7QStringS4_S4_PS2_6QFlagsINS_6OptionEE+0x22f)[0xf8b67f]
/usr/lib/googleearth/libcommon.so(_ZN5earth6common14SaveFileDialogERK7QStringP7QWidgetS3_PS1_S3_+0x15a)[0x16a6aaa]
/usr/lib/googleearth/liblayer.so(_ZN5earth5layer11LayerWindow9SaveAsKmlERKNS_7geobase15AbstractFeatureEP7QWidget+0x16d)[0x57bf95d]
/usr/lib/googleearth/liblayer.so(_ZN5earth5layer11LayerWindow8DoSaveAsERNS_6common4ItemE+0x48)[0x57bfd38]
/usr/lib/googleearth/liblayer.so(_ZN5earth5layer11FeatureMenu17ProcessMenuActionENS1_10MenuItemIdERK7QStringRK6QPoint+0x21c)[0x57a124c]
/usr/lib/googleearth/liblayer.so(_ZN5earth5layer11FeatureMenu10CreateMenuEPNS_6client12IMenuContextEbRK6QPoint+0x8af)[0x57ab9cf]
/usr/lib/googleearth/liblayer.so(_ZN5earth5layer11FeatureMenuC1EPNS0_18ILayerWindowActionEPNS_6client12IMenuContextERNS_7geobase15AbstractFeatureEPNS_6common4ItemEP7QWidgetRK6QPointb+0xcb)[0x57ac62b]
/usr/lib/googleearth/liblayer.so(_ZN5earth5layer11LayerWindow15ShowFeatureMenuEPNS_7geobase15AbstractFeatureEP7QWidgetRK6QPointb+0x89)[0x57b42b9]
/usr/lib/googleearth/liblayer.so(_ZN5earth5layer11LayerWindow13OnContextMenuERKNS_6common12ItemObserver16ContextMenuEventE+0x4f)[0x57b434f]
/usr/lib/googleearth/libcommon.so(_ZN5earth6common8ItemTree16contextMenuEventEP17QContextMenuEvent+0xdb)[0x168244b]
/usr/lib/libQtGui.so.4(_ZN7QWidget5eventEP6QEvent+0xc48)[0xa69528]
/usr/lib/libQtGui.so.4(_ZN6QFrame5eventEP6QEvent+0x33)[0xe8a763]
/usr/lib/libQtGui.so.4(_ZN19QAbstractScrollArea13viewportEventEP6QEvent+0x32)[0xf27a82]
/usr/lib/libQtGui.so.4(_ZN17QAbstractItemView13viewportEventEP6QEvent+0x307)[0xfe40f7]
/usr/lib/libQtGui.so.4(_ZN9QTreeView13viewportEventEP6QEvent+0x153)[0x1026883]
/usr/lib/libQtGui.so.4(+0x64b4d5)[0xf2a4d5]
/usr/lib/libQtCore.so.4(_ZN23QCoreApplicationPrivate29sendThroughObjectEventFiltersEP7QObjectP6QEvent+0x9a)[0x7aa29a]
/usr/lib/libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0x89)[0xa0afb9]
/usr/lib/libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x588)[0xa11458]
/usr/lib/libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x7b)[0x7aab3b]
/usr/lib/libQtGui.so.4(_ZN16QCoreApplication20sendSpontaneousEventEP7QObjectP6QEvent+0x3e)[0xaa362e]
/usr/lib/libQtGui.so.4(+0x1bfd7c)[0xa9ed7c]
/usr/lib/libQtGui.so.4(_ZN12QApplication15x11ProcessEventEP7_XEvent+0x1791)[0xa9e151]
/usr/lib/libQtGui.so.4(+0x1ee36a)[0xacd36a]
/lib/libglib-2.0.so.0(g_main_context_dispatch+0x1d5)[0x7051855]
/lib/libglib-2.0.so.0(+0x41668)[0x7055668]
/lib/libglib-2.0.so.0(g_main_context_iteration+0x68)[0x7055848]
/usr/lib/libQtCore.so.4(_ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x65)[0x7d9565]
/usr/lib/libQtGui.so.4(+0x1edbe5)[0xaccbe5]
/usr/lib/libQtCore.so.4(_ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE+0x49)[0x7a9609]
/usr/lib/libQtCore.so.4(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0xfa)[0x7a9a8a]
/usr/lib/libQtCore.so.4(_ZN16QCoreApplication4execEv+0xaf)[0x7ae00f]
/usr/lib/libQtGui.so.4(_ZN12QApplication4execEv+0x27)[0xa09e07]
/usr/lib/googleearth/libgoogleearth_lib.so(_ZN5earth6client11Application3runEv+0x436)[0x3e6e86]
/usr/lib/googleearth/googleearth-bin[0x805c77a]
/lib/libc.so.6(__libc_start_main+0xe7)[0x41d2ce7]
/usr/lib/googleearth/googleearth-bin[0x805be71]

Комментарии (8)

0
knuckles - 8 Октябрь, 2010 - 17:35
Изображение пользователя knuckles.

Про варинат установки из BIN-файла могу сказать, что версия glib, установленная в системе старее той, что требуется для Google Earth. На 10.10 должно пойти (если не будет падать по другой причине).
Про вариант из DEB-пакета. Смысл ошибки Нет такого файла или каталога понятен, но непонятно о каком именно файле идет речь. Возможно, не хватает каких-то пакетов и стоит попробовать добавить Medibuntu как репозиторий, после чего установить пакет с помощью aptitude.

0
DarkneSS - 12 Октябрь, 2010 - 18:45
+1
kanzo - 23 Октябрь, 2010 - 10:02
Изображение пользователя kanzo.

Повозился я повозился. Не сумел победить. Отложил на некоторое время.
А тут наводя порядок в файловом хранилище наткнулся на когда то скаченный деб пакет Google Earth.
Решил его попробовать. Он установился и работает!
Изначально поставил на виртуальную машину, потом на "честную" систему kubuntu 10.10 , на которой до этого попыток установки Google Earth не было.
Версия не самая новая, но и не старье. Лучше такая чем никакой (я так думаю).

выложил файл сюда
http://files.mail.ru/RP1033

пролежит он там не долго, 30 дней...
если после этого кому то понадобится, напишите выложу по новой.
ну или если кто знает куда можно положить "навечно" положите а сюда ссылку.

0
_victor_ - 23 Октябрь, 2010 - 21:18
Изображение пользователя _victor_.

Были подобные проблемы до смены видеокарты. ИМХО старые видеокарты (особенно Radeon) не поддерживают OpenGL в последних версиях GoogleEarth.

0
sergejj60 - 1 Ноябрь, 2010 - 14:25

Установил googleearth вот этим способом:
http://www.liberiangeek.net/2010/09/install-google-earth-ubuntu-10-10-maverick-meerkat/

После установки не отображались русские буквы и меню!!!
Установил Ubuntu software-center и зависимости,
(А также зашёл в параметры системы/локаль и выбрал язык системы Русский и загрузил то что требовалось.)
Заново установил googleearth
http://www.liberiangeek.net/2010/09/install-google-earth-ubuntu-10-10-maverick-meerkat/ и всё заработало просто отлично!!!
Kubuntu 10.10x64

0
Гость - 7 Май, 2012 - 06:56

На 12.04 не катит :(

+1
Гость - 7 Май, 2012 - 07:06

О как, sudo apt-get install xfonts-cyrillic
Помогло для Kubuntu 12.04 (amd64)

0
gThumb - 9 Май, 2012 - 11:55
Изображение пользователя gThumb.

Подтверждаю.
Kubuntu 12.04 (32 bit)
1. Качаем .deb - пакет с http://www.google.com/intl/ru/earth/download/ge/agree.html и устанавливаем его из домашней директории ( из папок с рус-яз названиями установщик не запустится).
2. В терминале sudo apt-get install xfonts-cyrillic
3. В терминале sudo reboot (Перезагрузка.)
У меня все рус-яз шрифты показались и все работает.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры