amdcccle ругается (((

Изображение пользователя palyanich.

Сообщение следующего содержание вылазит при запуске amdcccle (Catalyst) в терминале:
palyanich@HyperFast:~$ sudo amdcccle
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/palyanich/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon

Скажите пожалуйста, что оно означает и как лечится?!

*ATi linux driver 10.9

0
Lang - 12 Октябрь, 2010 - 01:26
Изображение пользователя Lang.

Оно хочет от тебя ibus. Зачем вот только?

0
palyanich - 12 Октябрь, 2010 - 01:37
Изображение пользователя palyanich.

Я заинтригован) ) )

0
Lang - 12 Октябрь, 2010 - 01:40
Изображение пользователя Lang.

Установи его и проверь ещё раз)

0
palyanich - 12 Октябрь, 2010 - 01:43
Изображение пользователя palyanich.

дык он установлен.... который qt4!

0
knuckles - 12 Октябрь, 2010 - 07:09
Изображение пользователя knuckles.

Не, не, не qt4 :-) aptitude search ibus

0
palyanich - 12 Октябрь, 2010 - 12:29
Изображение пользователя palyanich.

Вот так:

0
knuckles - 12 Октябрь, 2010 - 12:36
Изображение пользователя knuckles.

Ммм... а вот так: ps -A | grep -i ibus?
И еще вот это можно попробовать: mkdir ~/.config/ibus/bus или touch ~/.config/ibus/bus (я даже не уверен, папка это или просто файл :-) ).

0
palyanich - 12 Октябрь, 2010 - 23:21
Изображение пользователя palyanich.

Забавно... после ps -A | grep -i ibus amdcccle выдал: palyanich@HyperFast:~$ sudo amdcccle
Parse error on line 63 of section Screen in file /etc/X11/xorg.conf
        Unexpected EOF. Missing EndSection keyword?
Parse error on line 63 of section Screen in file /etc/X11/xorg.conf
        Unexpected EOF. Missing EndSection keyword?

залез в xorg.conf, линия 63 - EndSection присутствует! посмотрел на предмет не-пресудствующих... все нормально xorg.conf как xorg.conf! кстати вот-он, если что:

обе команды
mkdir ~/.config/ibus/bus
и
touch ~/.config/ibus/bus

выдали одно и тоже:mkdir: cannot create directory `/home/palyanich/.config/ibus/bus': No such file or directory
и
touch: cannot touch `/home/palyanich/.config/ibus/bus': No such file or directory

--------------------------
в общем теперь amdcccle вообще не стартует, ругаясь на неправильные "линии" в xorg.conf (((

0
knuckles - 13 Октябрь, 2010 - 10:39
Изображение пользователя knuckles.

1. Я правильно понимаю, что ps -A | grep -i ibus ничего не выдал?
2. Скорее всего в xorg.conf не хватает пустой строки в конце файла, т.е. нужно открыть его в редакторе, нажать Ctrl+End, затем Enter и сохранить.
3. Не учел, что родительской папки может не быть. Попробуй так: mkdir -p ~/.config/ibus/bus

0
palyanich - 13 Октябрь, 2010 - 11:42
Изображение пользователя palyanich.

1. Ты ПРАВИЛЬНО понимаешь - ничего не выдал!
palyanich@HyperFast:~$ ps -A | grep -i ibus
palyanich@HyperFast:~$

2. Спасибо! Теперь буду знать) ) )
3. Папочку создал, но все равно жалуется на отсутствие ibus:
palyanich@HyperFast:~$ mkdir -p ~/.config/ibus/bus
palyanich@HyperFast:~$ sudo amdcccle
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon

0
knuckles - 13 Октябрь, 2010 - 11:46
Изображение пользователя knuckles.

Давай дальше копать. Хотелось бы посмотреть результаты выполнения следующих команд: ls -l /etc/init.d | grep -i ibus и ls -l /etc/init | grep -i ibus.

0
palyanich - 13 Октябрь, 2010 - 12:31
Изображение пользователя palyanich.

мистика! ты не поверишь, но нихрена (((

palyanich@HyperFast:~$ ls -l /etc/init.d | grep -i ibus
palyanich@HyperFast:~$ ls -l /etc/init | grep -i ibus
palyanich@HyperFast:~$

0
knuckles - 13 Октябрь, 2010 - 13:05
Изображение пользователя knuckles.

Ну, почему, верю :-)
Очевидно, демон ibus не установлен в системе. Надо какой-то пакет доставить - я не знаю какой. Может быть переустановить те из списка выше, что уже стоят.

0
palyanich - 14 Октябрь, 2010 - 14:03
Изображение пользователя palyanich.

Спасибо knuckles за то, что мучаешься со мной)))

В общем снес систему - поставил заново, обновился до КДЕ 4.5.2!
вопрос первый - можно ли как-нибудь установить ATi драйвер НЕ через jockey? Ибо в прошлый раз, ставя через Additional Drivers наблюдалось довольно-таки большое падение производительности с включенными эффектами (на 9.10 все летало успевай ловить). Попытка запуска *.run в консоле (ессесно не без sudo) выдает вот такую шнягу:
=====================================================================
ATI Technologies Catalyst(TM) Proprietary Driver Installer/Packager
=====================================================================

Error: ./default_policy.sh does not support version
default:v2:i686:lib::none:2.6.35-22-generic:; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.wRVLsj

генерировал пакеты, ставил "dpkg -i *.deb" - получал черный экран, или, в лучшем случаи текстовый логин...((( драйвера последние, с сайта AMD за номером 10.9

вопрос второй - по дефолту, после чистой установки Kubuntu, не ставя драйвер ATi эффекты работают на ура, соответственно они чем-то ускоряются. Mesa? Vesa? - или что это? xorg.conf в /etc/X11/ не наблюдается... glxgears выдает ~20000 вреймов за 5 сек - то есть очень даже нормальный для меня результат! правда тоже ругается на какие-то там прирывания:
palyanich@HyperFast:~$ glxgears
IRQ's not enabled, falling back to busy waits: 2 0

помоги мне, добрый knuckles)))

0
knuckles - 14 Октябрь, 2010 - 14:09
Изображение пользователя knuckles.

ответ первый: драйвер 10.9 с сайта не поддерживает ядро 2.6.35 - жди 10.10 (ох уж это магическое число :-) )
ответ второй: sudo Xorg -configure тебе все расскажет.