Маверик - не все можно установить из репоизариев... Не перекомпилили, что ли? [ЗАКРЫТО]

Здравствуйте еще раз!
Маверика поставил на чистую систему, не апгрейдом. С Альтернатив-ЦД.
На удивление встал на мой ноут (ASUS K40IN) без нареканий и плясок с бубнами в виде nomodeset при загрузке. Даже порадовало. А дровишки-то на НВИДИЮ мою не те - nouveau которые, не нравятся они. подтармаживают и в ХД качестве фильмы не посмотришь нормально... Решил пойти стандартным путем.
Подключаю репу x-swat/x-update - делаю раз и....:
------------------------------------------------
sudo apt-get install nvidia-current
[sudo] password for fox:
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
nvidia-current : Зависит: dkms но он не будет установлен
E: Сломанные пакеты
------------------------------------------------
оппа... поставил с репы медубунты кодеки - прошло нормально... и с медубунты, и с локальной репы прицепом (зависимостями)... ладно, думаю, может косяк на репе, ну не подкомпилили еще. поставлю дровишки от производителя, благо лежат про запас.... бац и
------------------------------------------------
[email protected]:~$ sudo apt-get install build-essential
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
build-essential : Зависит: gcc (>= 4:4.4.3) но он не будет установлен
Зависит: g++ (>= 4:4.4.3) но он не будет установлен
E: Сломанные пакеты
-------------------------------------------------
это он за что меня так? как жить?

0
DarkneSS - 14 Октябрь, 2010 - 16:05
Изображение пользователя DarkneSS.

Подождать, выполнитьsudo apt-get update
sudo apt-get install -f

Попробовать установить то, что пробовали.
И ваш sources.list в студию!

0
EvFox72 - 14 Октябрь, 2010 - 17:29

упдате делал раз пять
с ключиком -f еще не пробывал...
сейчас попробую. на всякий случай:
-------------------------------------------------
cat /etc/apt/sources.list
deb http://mirrors.irk.ru/ubuntu/ maverick main universe restricted multiverse
deb-src http://mirrors.irk.ru/ubuntu/ maverick main universe restricted multiverse
deb http://mirrors.irk.ru/ubuntu/ maverick-updates main universe restricted multiverse
deb-src http://mirrors.irk.ru/ubuntu/ maverick-updates main universe restricted multiverse
deb http://archive.canonical.com/ubuntu maverick partner
deb-src http://archive.canonical.com/ubuntu maverick partner

[email protected]:~$ ls /etc/apt/sources.list.d/
gezakovacs-ppa-maverick.list medibuntu.list ubuntu-x-swat-x-updates-maverick.list
gezakovacs-ppa-maverick.list.save medibuntu.list.save ubuntu-x-swat-x-updates-maverick.list.save
----------------------------------------------------
стоят наши локальные репозитарии. пробовал стандартный - не помогает...

ну и что и требовалось доказать :

[email protected]:~$ sudo apt-get install -f nvidia-current
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
nvidia-current : Зависит: dkms но он не будет установлен
E: Сломанные пакеты

0
Жюстина - 14 Октябрь, 2010 - 17:45
Изображение пользователя Жюстина.

Ога ркуцкие репозитории, то жа мне, доверия много вызывают... )))) К тому же не все тут.

И вообще, надо настоящие, и желательно не яндексовые, и вообще чтоб не ру!

Так что пробуем нормальные репозитории, и разбираемся, что именно не получается с ними.

А подкомпилили всё ещё на стадии альфы, я думаю.

0
EvFox72 - 15 Октябрь, 2010 - 02:29

я ж грю, пробывал и офифициальные.

0
Samath - 14 Октябрь, 2010 - 18:55

у сестры моей тоже бывает проблема "Сломанные пакеты". только у нее 9.04. Надо ей тоже предложить параметр -f.

0
DarkneSS - 14 Октябрь, 2010 - 19:16
Изображение пользователя DarkneSS.

Не

>sudo apt-get install -f nvidia-current>

а сначала

sudo apt-get install -f

а потом уже

apt-get install nvidia-current

0
EvFox72 - 15 Октябрь, 2010 - 02:49

[email protected]:~$ sudo apt-get install -f
[sudo] password for fox:
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
[email protected]:~$ sudo apt-get check -f
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
[email protected]:~$ sudo apt-get install nvidia-current
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
nvidia-current : Зависит: dkms но он не будет установлен
E: Сломанные пакеты

0
DarkneSS - 14 Октябрь, 2010 - 19:17
Изображение пользователя DarkneSS.

Подождать это значит пару часов хотя бы, пока ваше локальное зеркало синхронизируется с официальным, а лучше полдня!

0
EvFox72 - 15 Октябрь, 2010 - 03:58

вот жешь как бывает....
с Надцатой попытки apt-get update && apt-get install nvidia-current все заработало... скачались и поставились зависимости, но только с ОФИЦИАЛЬНОГО (http://archive.ubuntu.com) зеркала. даже ru.archive.ubuntu.com что-то не работал.
вот так...
тема закрыта, решения не понятно... что было? :)

0
DarkneSS - 15 Октябрь, 2010 - 07:35
Изображение пользователя DarkneSS.

Ваши зеркала синхронизировались с официальным. Из-за этого на них были разные пакеты. Назовём их условно сегодняшние и вчерашние. Так вот у них разные зависимости, поэтому apt и сходит с ума.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры