виснет винда в virtualbox

Виснет winxp в virtualbox. не сразу.. через несколько часов. Намертво. Думал, что дело в винде, пробовал восстановить из ранних состояний средством восстановления из винды.. ничего. Переустановить винду не представляется возможности.
Может продебажить с dbg версией virtualbox? Только это свободная версия и в ней нету USB, что для меня плохо.
Вопрос, для начала, состоит в том, чтобы выяснить что вешает систему: win or virtualbox
Что посоветуете?

0
DarkneSS - 5 Ноябрь, 2010 - 10:11
Изображение пользователя DarkneSS.

Обновите до несвободной, и будет вам USB.

0
Draco - 5 Ноябрь, 2010 - 11:06

Спасибо, это я знаю, использую проприентарную с USB, я про то, что dbg нету в несвободной..

0
DarkneSS - 5 Ноябрь, 2010 - 12:15
Изображение пользователя DarkneSS.
  • Поставьте свободную с dbg
  • отловите баг
  • поставьте закрытую
  • ?????
  • PROFIT!
0
SEVA - 5 Ноябрь, 2010 - 12:44
Изображение пользователя SEVA.

пфффф, что за вопрос? и чего еще ожидать от винды, кроме зависона? А какая винда-то хоть, не семерка случайно? Полагаю в восьмерке баг будет исправлен))). А так, может памяти на нее накинуть?

0
salt - 5 Ноябрь, 2010 - 12:56
Изображение пользователя salt.

Винда виснет везде и всегда, это одно из её свойств :)

0
knuckles - 10 Ноябрь, 2010 - 16:32
Изображение пользователя knuckles.

Живет на виртуалбоксе уже очень давно. Не зависла ни разу)

0
lord_i - 5 Ноябрь, 2010 - 21:55
Изображение пользователя lord_i.

Версию виртуалбокс в студию. И еще какое железо у Вас. Очень принципиально - есть ли поддержка аппаратной виртуализации в процессоре. Если ее нет - возможны нерешаемые глюки типа Вашего. И еще - про USB что-то несовсем я понял ... У меня 3.2.10. r66523 (версия вроде как свободная) и с УСБ никаких проблем в гостевой системе ... Все прекасно включается/отключается и рабротает тоже без вопросов.

0
Draco - 10 Ноябрь, 2010 - 00:46

VirtualBox 3.2.10. r66523
Kubuntu 10.10 Maverick
Аппаратная поддержка виртуализации есть, включена.

А USB раньше osd версия virtualbox'a не поддерживала, тем и отличалась..
Пока курю логи VirtualBox..

0
Draco - 10 Ноябрь, 2010 - 01:13

Вот лог винды в виртуалбоксе..
Вроде ничего интересного..

0
lord_i - 10 Ноябрь, 2010 - 23:01
Изображение пользователя lord_i.

Очень даже есть чего интересного:
Guest Log: VBoxTray: 3.2.8 r64453 started.
Попробуйте обновить Guest addition чтоб он соответствовал версии виртуалбокса. Должно помочь.

0
Draco - 11 Ноябрь, 2010 - 08:29

Точно, а я сразу и не заметил..

0
lord_i - 11 Ноябрь, 2010 - 09:28
Изображение пользователя lord_i.

Что-то поменялось? Виснет после обновления?

0
Draco - 11 Ноябрь, 2010 - 10:10

виснет всёравно...

0
knuckles - 10 Ноябрь, 2010 - 16:35
Изображение пользователя knuckles.

виснет винда в virtualbox
А сам виртуалбокс при этом виснет? Если нет, то что-то с Виндой - вам в службу поддержки Windows.

0
Draco - 11 Ноябрь, 2010 - 10:26

Что можно сделать в винде?
Включил аудит, только информация всёравно бесполезная.

0
Draco - 11 Ноябрь, 2010 - 10:20

Ещё когда зависшую винду выключаю в логе появляется
00:55:08.737 Changing the VM state from 'DESTROYING' to 'TERMINATED'.

0
lord_i - 11 Ноябрь, 2010 - 10:49
Изображение пользователя lord_i.

Все таки по поводу железа. Какой процессор (точно со всеми буквами и цифрами)? и сколько физической памяти в машине?

0
Draco - 11 Ноябрь, 2010 - 12:40

AMD Athlon(tm) 64 X2 Dual Core Processor 4600+
памяти 6 Гб

Флага "svm" нету, но процессор вроде иемеет виртуализацию, я когда-то для этого биос обновлял даже..

VT-x/AMD-V: Включены

0
lord_i - 11 Ноябрь, 2010 - 15:05
Изображение пользователя lord_i.

Насколько я понял (смотрел весьма бегло) этот процессор не поддерживает AMD-V. Может имеет смысл отключить VT-x/AMD-V в виртуалбоксе?

0
Draco - 11 Ноябрь, 2010 - 23:48

Я попробую, только почему в биосе есть virtualization = enabled?

0
lord_i - 15 Ноябрь, 2010 - 15:30
Изображение пользователя lord_i.

Чем закончилась (если закончлась) Ваша борьба?

0
lord_i - 12 Ноябрь, 2010 - 11:26
Изображение пользователя lord_i.

Если процессор не поддерживает или поддерживает криво - лучше попробовать без этого... По крайней мере будет понятно что в этом причина в случае если глюк уйдет.

0
Draco - 16 Ноябрь, 2010 - 13:00

Спасибо большое lord_i за помощь.
Дело не в виртуализации было, но отключив аппаратную виртуализацию виртуалбокс ругнулся на то, что не может без аппаратной вирт. 2 процессора эмулировать.. и тут я вспомнил, что ставилась винда когда-то давно на один процессор.. потом я поставил в конфигурации 2. И вот работало оно до поры до времени нормально, пока не запускалось приложение активно использовавшее распараллеливание потоков.. и тут всё начинало падать.
Поставил использование одного процессора- несколько дней работает нормально. Думаю проблема решена.

0
Draco - 16 Ноябрь, 2010 - 16:22

Поставил касперского последнего, зависла сразу же :)
Хотя бы понятно, что это в винде дело.. хотя..

0
lord_i - 16 Ноябрь, 2010 - 21:45
Изображение пользователя lord_i.

Касперский - суксь и скверна!!! :) Сносите немедленно :)

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры